Subject: Re: [siprec] #17: Deliver Metadata in Recording Session dialog possibly using INVITE

From: "siprec issue tracker" <[email-masked]>
Date: Mon, 27 Sep 2010 13:08:59 -0000

#17: Deliver Metadata in Recording Session dialog possibly using INVITE
--------------------------------+-------------------------------------------
 Reporter:  rmohanr@…           |       Owner:  andrew.hutton@…                     
     Type:  enhancement         |      Status:  assigned                            
 Priority:  minor               |   Milestone:                                      
Component:  Architecture        |     Version:  1.0                                 
 Severity:  Active WG Document  |    Keywords:  Metadata                            
--------------------------------+-------------------------------------------

Comment(by andrew.hutton@…):

 I proposed to add the following text as a bullet in section 4.3.2. of the
 siprec architecture draft. See http://tools.ietf.org/html/draft-ietf-
 siprec-architecture-00#section-4.3.2

 “As a body during RS establishment: The recording metadata may be conveyed
 as a body to the SIP INVITE request used to initiate the RS. In this case
 the body of the INVITE would be a multipart body containing both SDP and
 recording metadata”.

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/17#comment:4>
siprec <http://tools.ietf.org/siprec/>

---

From: Leon Portman <[email-masked]>
Date: Mon, 27 Sep 2010 15:58:18 +0200

I agree, we need this one and it was also was agreed during previous interim call.

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of siprec issue tracker
Sent: Monday, September 27, 2010 3:09 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [siprec] #17: Deliver Metadata in Recording Session dialog possibly using INVITE

_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 27 Sep 2010 12:48:24 -0400

I find such a statement overly simplistic, and also more appropriate as 
part of the mechanism than the architecture.

Part of the problem is with the phrase "*the* recording metadata", as if 
it were a single entity.

I fully expect that *some* recording metadata will be conveyed with the 
INVITE of the RS. But not all of it. And I expect that some of it is 
likely to be in a body for that purpose, but again not all of it. (I 
expect some will be obtained from the offer/answer exchange.

	Thanks,
	Paul

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Mon, 27 Sep 2010 22:22:08 +0530

Andrew,

The proposed text looks good to me

Thanks,
Ram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Leon Portman
Sent: Monday, September 27, 2010 7:28 PM
To: siprec issue tracker; [email-masked]
Cc: [email-masked]
Subject: Re: [siprec] #17: Deliver Metadata in Recording Session dialog possibly using INVITE

Leon

---

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 28 Sep 2010 10:29:57 +0200

Hi Paul,

I see your point and think maybe there is a wider problem with section 4.3.2 of the architecture draft which in the first paragraph states "The recording metadata definition will be described through an XML schema". 

It is clear to me that the SRS will obtain all kinds of information from SIP headers and SDP bodies which I might store with the recorded media as metadata. What I think this section is talking about possible ways of transporting metadata which is not already available in SIP/SDP. 

I agree with your point that there are multiple mechanisms might be used for a single session and will have to modify the section to take this in to account.

Regards
Andy

> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: 27 September 2010 17:48
> To: siprec issue tracker
> Cc: Hutton, Andrew; [email-masked]
> >   Reporter:  rmohanr@...           |       Owner:  andrew.hutton@...
> > Comment(by andrew.hutton@...):
> >
> >   "As a body during RS establishment: The recording 
> metadata may be conveyed
> >   recording metadata".

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 28 Sep 2010 09:37:55 -0400

OK, I've succeeded in making my point! :-)

	Thanks,
	Paul