Subject: Re: [siprec] #4: Media coding negotiation

From: "siprec issue tracker" <[email-masked]>
Date: Thu, 09 Sep 2010 07:49:26 -0000

#4: Media coding negotiation
------------------------------------------------+---------------------------
 Reporter:  john.elwell@…                       |       Owner:  krehor@…        
     Type:  enhancement                         |      Status:  new             
 Priority:  major                               |   Milestone:  milestone1      
Component:  Requirements                        |     Version:                  
 Severity:  Candidate WG Document               |    Keywords:                  
------------------------------------------------+---------------------------

Comment(by krehor@…):

 > I suggest we add a requirement:
 > "The mechanism MUST provide a means for the SRC and SRS to agree
 > on media to be recorded and on formats and bandwidths for transporting
 > those media to the SRS."

 That covers codec negotiation at setup time, but what about during the
 recording session or during a pause/resume?

 > This does not address Leon's additional point about other entities
 > providing transcoding, which, if this is to be pursued, should have
 > a separate issue raised.

 I think this is out of scope for SIPREC, since it would not be controlled
 by the SRS. In fact the SRS should never know if a transcoder were
 inserted in the media stream between SRC and SRS.

 Ken

-- 
Ticket URL: <https://trac.tools.ietf.org/wg/siprec/trac/ticket/4#comment:3>
siprec <http://tools.ietf.org/siprec/>

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 9 Sep 2010 10:15:24 +0200

> -----Original Message-----
> From: siprec issue tracker [mailto:[email-masked]] 
> Sent: 09 September 2010 08:49
> To: [email-masked]; Elwell, John; [email-masked]
> Cc: [email-masked]
> Subject: Re: [siprec] #4: Media coding negotiation
> 
>  Reporter:  john.elwell@...                       |       
> Owner:  krehor@...        
>      Type:  enhancement                         |      
> Status:  new             
>  Priority:  major                               |   
> Milestone:  milestone1      
> Comment(by krehor@...):
[JRE] I think the existing requirement for pause/resume is sufficient for that purpose. For code re-negotiation in general, we could add ", including any changes during the lifetime of the RS".

>  inserted in the media stream between SRC and SRS.
[JRE] I agree.

John (as individual)

> 
>  Ken
> 
> -- 
> Ticket URL: 
> <https://trac.tools.ietf.org/wg/siprec/trac/ticket/4#comment:3>

---

From: "siprec issue tracker" <[email-masked]>
Date: Thu, 16 Sep 2010 01:06:43 -0000

Comment(by dave.smith@…):

 Regarding this part:
 ''  I suggest we add a requirement:
    "The mechanism MUST provide a means for the SRC and SRS to agree
 on media to be recorded and on formats and bandwidths for transporting
 those media to the SRS."''

 My comments are:
 Can we get a couple of use cases that highlight the importance of this?
 Isn't codec negotiation already part of SIP?
 Also, why would anything be different during RS or for Pause/Resume?

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/4#comment:4>
siprec <http://tools.ietf.org/siprec/>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 16 Sep 2010 09:17:25 -0400

Its not apparent to me what the expectations are here.

We have a CS that is already established, or being established. A 
negotiation of codecs takes place for that, finding something mutually 
agreeable.

Then we introduce the RS into the picture. Potentially the SRS has its 
own capabilities and constraints on codecs.

Is the goal to constrain the CS establishment to codecs that are 
mutually agreeable to all three parties? Or is it to force the SRC to 
handle the negotiations independently, and do transcoding when required?

ISTM that typically the CS establishment should proceed without regard 
to the limitations of the RS. Then it would typically be the 
responsibility of the SRC to offer the SRS whatever has been negotiated, 
and of the SRS to be capable of dealing with whatever the CS chooses to use.

	Thanks,
	Paul

---

From: Deepanshu <[email-masked]>
Date: Fri, 17 Sep 2010 12:04:45 +0800

According to me it is not at all feasible to change/modify codecs which were
agreed for CS due to RS establishment. Moreover its not needed also. Today's
SRS is capable enough to handle whatever CS is using. In case, not, than
transcoding will be done (which will for sure out-of-scope)

So I don't see a need of any requirement here.

Deepanshu Gautam
Tel: +86 25 56620008, Mob: +86 13585147627
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Paul Kyzivat
Sent: 2010年9月16日 21:17
To: siprec issue tracker
Cc: [email-masked]; [email-masked]
Subject: Re: [siprec] #4: Media coding negotiation

	Thanks,
	Paul

>   Also, why would anything be different during RS or for Pause/Resume?
_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec

---

From: "siprec issue tracker" <[email-masked]>
Date: Tue, 28 Sep 2010 07:49:52 -0000

Type:  enhancement                         |      Status:  assigned        
Changes (by krehor@…):

  * status:  new => assigned

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/4#comment:5>
siprec <http://tools.ietf.org/siprec/>