Subject: Re: [siprec] #14: Terminology: pause/resume

From: "siprec issue tracker" <[email-masked]>
Date: Thu, 09 Sep 2010 08:19:22 -0000

#14: Terminology: pause/resume
------------------------------------------------+---------------------------
 Reporter:  john.elwell@…                       |       Owner:  krehor@…        
     Type:  defect                              |      Status:  new             
 Priority:  minor                               |   Milestone:  milestone1      
Component:  Requirements                        |     Version:                  
 Severity:  Candidate WG Document               |    Keywords:                  
------------------------------------------------+---------------------------

Comment(by krehor@…):

 Proposed definitions:

 Start: Begin storing the incoming media stream.
 Stop:  Media capture is permanently terminated for this session; the
 recording is closed and cannot be reopened.

 Pause: Temporarily discontinue storing of the incoming media stream. The
 recording remains open; recording may continue via the Resume command.

 Resume: Continue storing the incoming media stream, appended onto the same
 recording.

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/14#comment:2>
siprec <http://tools.ietf.org/siprec/>

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 9 Sep 2010 10:59:18 +0200

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of siprec issue tracker
> Sent: 09 September 2010 09:19
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [siprec] #14: Terminology: pause/resume
> 
>  Reporter:  john.elwell@...                       |       
> Owner:  krehor@...        
>      Type:  defect                              |      
> Status:  new             
>  Priority:  minor                               |   
> Milestone:  milestone1      
> Comment(by krehor@...):
[JRE] The original comment did not cover the concept of start/stop. If we feel we need such terms, I have no objection.

>  Resume: Continue storing the incoming media stream, appended 
[JRE] This does not address the original concern that pause seems to have some potential for confusion with pause during playback. If people are comfortable using pause, I have no objection.

John (as individual)

> 
> -- 
> Ticket URL: 
> <http://trac.tools.ietf.org/wg/siprec/trac/ticket/14#comment:2>
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: "siprec issue tracker" <[email-masked]>
Date: Thu, 16 Sep 2010 01:27:56 -0000

Comment(by dave.smith@…):

 I don't see a problem with Pause/Resume.  I prefer Pause/Resume.

 Although those definitions above (for Start/Stop/Pause/Resume) offer an
 easy way to understand the terms, i don't prefer those definitions because
 they are SRS centric.  The implementation of S/S/P/R could be via the SRC,
 or SRS.

 Pause/Resume in the context of Playback means to pause or resume playback,
 i.e., you are stopping your playback intermittently (for a short period of
 time) but then plan to continue playback later.

 Pause/Resume in the context of Recording means to pause or resume
 recording, i.e., you are stopping Recording of a conversation (even though
 the conversation continues) intermittently but then plan to continue
 recording the ongoing conversation later.

 I don't see a problem with Pause/Resume...as i see it, it works well for
 each separate case.  I highly recommend to keep the terms
 Pause/Resume...it has always been easily been understood by all colleagues
 i have ever personally mentioned it to, including all members of the
 SIPREC WG.

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/14#comment:3>
siprec <http://tools.ietf.org/siprec/>

---

From: Leon Portman <[email-masked]>
Date: Thu, 16 Sep 2010 15:40:17 +0200

I agree, these are the common terms in the industry.

Leon

---

From: "siprec issue tracker" <[email-masked]>
Date: Mon, 20 Sep 2010 10:57:27 -0000

#14: Terminology: pause/resume
------------------------------------------------+---------------------------
 Reporter:  john.elwell@…                       |        Owner:  krehor@…        
     Type:  defect                              |       Status:  closed          
 Priority:  minor                               |    Milestone:  milestone1      
Component:  Requirements                        |      Version:                  
 Severity:  Candidate WG Document               |   Resolution:  wontfix         
 Keywords:                                      |  
------------------------------------------------+---------------------------
Changes (by john.elwell@…):

  * status:  new => closed
  * resolution:  => wontfix

Comment:

 The consensus seems to be to stick to pause/resume, and therefore I am
 happy to withdraw my original comment.

 John (as individual)

-- 
Ticket URL: <https://wiki.tools.ietf.org/wg/siprec/trac/ticket/14#comment:4>
siprec <http://tools.ietf.org/siprec/>