Subject: [siprec] Comments on draft-ietf-siprec-req-02

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 28 Sep 2010 15:18:29 +0200

Hi,
 
I have a couple of minor comments on the updated requirements draft.
 
1. Introduction - States " (The requirements for session metadata delivery are specified separately [draft-ram-siprec-metadata-00]". However this draft does not provide requirements for metadata delivery it describes the metadata model.

2. Section 4, Example Deployment Architecture. I think we should change "Recording Control" to "Recording Session" which is defined in the definitions. Note the architecture draft does not refer to recording control at all and it sound like something from MediaCtrl. Sorry for not spotting this earlier.

Regards
Andy

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 28 Sep 2010 10:06:05 -0400

> 1. Introduction - States " (The requirements for session metadata delivery are specified separately [draft-ram-siprec-metadata-00]". However this draft does not provide requirements for metadata de…

Hmm. Yes, that is an issue.

It has not been an aspiration of mine for the metadata model to say 
anything about delivery requirements. Its really intended to be a 
synthesis of some of the requirements - an interim step to a mechanism.

But then we do have to decide where to put metadata delivery 
requirements. There is sort of a chicken/egg issue here:
- we need some requirements nailed down to make the metamodel
- we need the metamodel before nailing down delivery requirements.

I can see a few ways out of that:

- create a 2nd requirements doc based on metamodel doc
- suspend completion of requirements doc until metamodel is
   agreed. Then finalize requirements for metadata delivery
   based on the metamodel
- plan to add requirements for delivery to the metamodel doc

I don't much like creating a 2nd independent requirements doc. But 
either of the others is acceptable to me. I think I slightly prefer 
keeping all the requirements in the one requirements document.

	Thanks,
	Paul

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 30 Sep 2010 10:19:48 +0200

Can we keep requirements for metadata delivery generic enough in the -req, so that the document can be finished and metadata delivery can be pursued in the context of architecture and solution when the metadata model work matures?

John 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Paul Kyzivat
> Sent: 28 September 2010 15:06
> To: [email-masked]
> Subject: Re: [siprec] Comments on draft-ietf-siprec-req-02
> 
> 
> 
> > 1. Introduction - States " (The requirements for session 
> metadata delivery are specified separately 
> [draft-ram-siprec-metadata-00]". However this draft does not 
> provide requirements for metadata delivery it describes the 
> metadata model.
> 
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 30 Sep 2010 10:41:27 -0400

> Can we keep requirements for metadata delivery generic enough in the -req, so that the document can be finished and metadata delivery can be pursued in the context of architecture and solution when…

Perhaps. If the requirement were something vague. E.g. that the 
mechanism must provide a way for the SRC to convey any/all of the 
metadata to the SRS incrementally as it becomes known to the SRC over 
the course of the RS, and defer the definition of exactly what the 
metadata consists of.

	Thanks,
	Paul

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 30 Sep 2010 18:14:28 +0200

Yes, I would hope something along those lines would suffice. Could you propose some words to Ken?

Thanks,

John 

> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: 30 September 2010 15:41
> To: Elwell, John
> Cc: [email-masked]
> > Can we keep requirements for metadata delivery generic 
> enough in the -req, so that the document can be finished and 
> metadata delivery can be pursued in the context of 
> architecture and solution when the metadata model work matures?
>