Subject: [siprec] SIP Recording Metadata Open item : Communication Session -Summary so far

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Fri, 22 Oct 2010 18:50:55 +0530

Hi Team,

As we had several mail threads with lot of inputs, I am summarizing the
comments received on CS attributes. Please use this thread going forward
to close each attribute.

1) Do we need a CS Group ?

This inturn emphasis on the need for a proper definition of CS. I am
taking Paul's example here:

 - customer in call with agent

 - agent puts customer on hold

 - agent makes consultation call with expert

 - consultation call ends

 - agent resumes call with customer

Question is whether above is one CS or two ? Currently we have RS that
can tie multiple CS together. We can have multiple CS's per RS and so we
may explicitly need a CS group

2) Also I hear from the discussions that we need Participant to CS
mapping ?Currently the model has Received Media Stream to Participant
mapping only. 

Should we add CS to Participant mapping in model ?

Please use this thread to close on these two items

Regards,

Ram

---

From: "Elwell, John" <[email-masked]>
Date: Fri, 22 Oct 2010 15:55:42 +0200

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Ram Mohan R (rmohanr)
> Sent: 22 October 2010 14:21
> To: [email-masked]
> Subject: [siprec] SIP Recording Metadata Open item : 
> Communication Session -Summary so far
> 
> Hi Team,
> 
> As we had several mail threads with lot of inputs, I am 
> summarizing the comments received on CS attributes. Please 
> use this thread going forward to close each attribute.
> 
>  
> 
> This inturn emphasis on the need for a proper definition of 
> CS. I am taking Paul's example here:
> 
> Question is whether above is one CS or two ? Currently we 
> have RS that can tie multiple CS together. We can have 
> multiple CS's per RS and so we may explicitly need a CS group
> 
>  
> 
>  
> 
> 2) Also I hear from the discussions that we need Participant 
> to CS mapping ?Currently the model has Received Media Stream 
> to Participant mapping only. 
> 
[JRE] Another way of doing it would be that a CS has a number of participants and a participant has a number of media that it transmits (e.g., audio, video 1, video 2). I don't know whether this works better.

John (as individual)

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 22 Oct 2010 10:52:53 -0400

> [JRE] Another way of doing it would be that a CS has a number of participants and a participant has a number of media that it transmits (e.g., audio, video 1, video 2). I don't know whether this wo…

That *might* work. We could associate the participant with each stream 
it sends, and each that it receives, and then associate the participant 
with one or more CSs. That could potentially be an alternative to 
CS-groups for the cases where we need those.

I think there are things to work out on that for pre-mixed media 
streams. Perhaps instead of "sends" the relationship should be 
"contributes to", and there could be several such for a given stream. 
(And of course there can be multiple participants that "receive" a media 
stream too.)

This does seem promising.

	Thanks,
	Paul

---

From: "Elwell, John" <[email-masked]>
Date: Fri, 22 Oct 2010 17:10:55 +0200

> [mailto:[email-masked]] On Behalf Of Paul Kyzivat
> Sent: 22 October 2010 15:53
> To: [email-masked]
> Subject: Re: [siprec] SIP Recording Metadata Open item : 
> > [JRE] Another way of doing it would be that a CS has a 
> number of participants and a participant has a number of 
> media that it transmits (e.g., audio, video 1, video 2). I 
> don't know whether this works better.
> 
[JRE] I hadn't seen this as an alternative to CS groups. A saw a participant as being involved only in a single CS, and if a given user or device participates in multiple CSs, they would be different participants. But I am open to different ways of modelling it.

> (And of course there can be multiple participants that 
[JRE] Yes, for a given stream that is sent, not all participants will receive it, so I was over-simplifying it. To some extent it might depend whether recording is focus-centric or participant centric - in the latter case the participant might only know that a given stream is sent to the mixer and will not know who receives it. But that is probably true for the media the participant receives too.

John

> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>