Subject: Re: [siprec] #45: Lack of requirements on types of media to becovered

From: "Ken Rehor (krehor)" <[email-masked]>
Date: Thu, 28 Oct 2010 01:04:19 -0700

Updated REQ-008 in draft-ietf-siprec-req-04 to include DTMF (as defined
by [RFC4733]).

This makes voice, DTMF (as defined by [RFC4733]), video, and text (as
defined by [RFC4103]) in scope. I suggest we define the scope to address
anything else, including XMPP and MESSAGE, in a later release.

Ken

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf Of
> Paul Kyzivat (pkyzivat)
> Sent: Thursday, September 30, 2010 7:55 AM
> To: [email-masked]
> Subject: Re: [siprec] #45: Lack of requirements on types of media to
becovered
> 
> 
> 
> On 9/30/2010 5:37 AM, Elwell, John wrote:
> > At the interim meeting this week, it was suggested we should cover
session
> mode MESSAGE and XMPP, but not MSRP. We should also cover DTMF (at
least in
> RTP, question over SIP-based mechanisms). And obviously audio and
video.
> Things like slides, whiteboard, etc. would be out of scope. Please
indicate
> whether you are in broad agreement with this and refine where
necessary.
> 
> I just sent another message on this subject.
> 
> ISTM that any media that can be negotiated via o/a can be considered
> covered by default. That includes DTMF in RTP, and MSRP.
> 
> MESSAGE and XMPP don't fit that category, and so require some special
> treatment.
> 
> I think it makes sense to do something about MESSAGE.
> 
> I don't know what to do about XMPP, since it isn't part of a *sip* CS.
> ISTM that may be an entirely separate piece of work.
> 
> 	Thanks,
> 	Paul
> 
> > John (as chair)
> >
> >> -----Original Message-----
> >> From: siprec issue tracker [mailto:[email-masked]]
> >> Sent: 30 September 2010 10:14
> >> To: Elwell, John
> >> Cc: [email-masked]
> >> Subject: [siprec] #45: Lack of requirements on types of media
> >> to be covered
> >>
> >> #45: Lack of requirements on types of media to be covered
> >> ------------------------------------------------+-------------
> >> --------------
> >>   Reporter:  john.elwell@...                       |
> >> Owner:  Ken Rehor
> >>       Type:  defect                              |
> >> Status:  new
> >>   Priority:  major                               |
> >> Milestone:
> >> Component:  Requirements                        |
> >> Version:
> >>   Severity:  Active WG Document                  |
> >> Keywords:
> >> ------------------------------------------------+-------------
> >> --------------
> >>   Although there is some mention of media types in earlier parts of
the
> >>   document (e.g., video, instant message, text), the requirements
lack
> >>   anything do with media types, apart from some specific
> >> requirements to do
> >>   with audio. We should make it clear which media types the
> >> initial solution
> >>   is required to support, taking into consideration at least
> >> audio, video,
> >>   DTMF, fax, real-time text, instant messaging, slides,
> >> whiteboard, etc..
> >>   Some of these will surely be left outside the scope of the
initial
> >>   solution, but we should make it clear what is within scope.
> >>
> >>   John
> >>
> >> --
> >> Ticket URL:<http://trac.tools.ietf.org/wg/siprec/trac/ticket/45>
> >> siprec<http://tools.ietf.org/siprec/>
> >>
> >>
> > _______________________________________________
> > siprec mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/siprec
> >
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

---

From: "siprec issue tracker" <[email-masked]>
Date: Thu, 28 Oct 2010 08:04:44 -0000

Changes (by krehor@…):

  * status:  new => closed
  * resolution:  => fixed

Comment:

 Updated REQ-008 in draft-ietf-siprec-req-04 to include DTMF (as defined by
 [RFC4733]).

-- 
------------------------------------------------+---------------------------
 Reporter:  john.elwell@…                       |        Owner:  Ken Rehor
     Type:  defect                              |       Status:  closed   
 Priority:  major                               |    Milestone:           
Component:  Requirements                        |      Version:           
 Severity:  Active WG Document                  |   Resolution:  fixed    
 Keywords:                                      |  
------------------------------------------------+---------------------------

Ticket URL: <https://wiki.tools.ietf.org/wg/siprec/trac/ticket/45#comment:1>
siprec <http://tools.ietf.org/siprec/>