Subject: [siprec] SIPREC WG Mtg Min's - ITEF 78.2 Interim Virtual Mtg_101210

From: "Dave Smith" <[email-masked]>
Date: Wed, 13 Oct 2010 11:45:32 -0700

Thanks for your participation in the subject mtg yesterday.  

Here are the mtg min's for this mtg held virtually on Oct 12, 2010.  

Participants:

John Elwell - Chair  

Brian Rosen - Chair

Ken Rehor 

Paul Kyzivat 

Ram Parthasarathi 

Henry Lum

Dave Smith - Note Taker

Agenda:

I.  Requirements Draft - Review of Draft-03

 https://datatracker.ietf.org/doc/draft-ietf-siprec-req/ 

 75 min -  Ken Rehor

II.  Metadata Draft - Review of Draft-01

 https://datatracker.ietf.org/doc/draft-ram-siprec-metadata/ 

 30 min

 Paul Kyzivat / Ram

Meeting Minutes:

Part I - Requirements Draft

1.  DTMF 

a.  Do we need to capture DTMF as Metadata and/or as Data?

            b.  Include KPML in the discussion

            c.  Change wording of REQ-007bis2 (it is not "out-of-band")

            d.  Make REQ-007 into only one requirement for recording
DTMF (leave for Arch Draft/Doc to address how it is done)

            e.  Post to List for discussion

2.  REQ-023

            a.  Change wording from "a SIP UA" to "an authorized
participant in the CS" 

            b.  Post to List for discussion

3.  REQ-024

            a.  Change wording from "end users" to "participants"

            b.  Post to List for discussion

4.  Tracker Ticket # 43

            a.  Tracker Ticket # 43:  "What special requirements do we
need concerning conferences? I suspect we at least need something to do
with recording the view of a single  participant versus recording the
entire conference (including aspects that  a given participant might not
see)."

            b.  Consider to add use cases to describe (1) single
participant, versus (2) recording the entire conference 

            c.  We probably need to identify in metadata participant
participation, if available

            d.  SRC may not know participants, for example, where there
is separation between SRC & Mixer - this is to be handled at a later
Draft phase

5.  Tracker Ticket #46

            a.  New wording for REQ-025 was accepted

6.  Use Case #12

            a.  The SRC to control the timing required (max delay, e.g.,
1 to 3 seconds max delay proposed for Speech Analytics use case) to
provide CS media to SRS

            b.  Post to List for discussion

7.  Tracker Ticket #35

            a.  Identified 3 areas to consider:

                        (1)  Who SRS exposes recordings to

                        (2)  How SRC handles participants

                        (3)  SRC to SRS relationship - this is probably
our primary focus

            b.  Probably SRC needs to filter its media/metadata to SRS

            c.  Consider to leverage other Security specifications:

                        GEOPRIV (how a user specifies his preferences
for private information)

                        Telepresence (multiple streams, participant
info)

                        SIP standards for security

            d.  We should be able to use standard SIP for Integrity and
Confidentiality, but probably need more for Authentication and Privacy.

            e.  We need a Draft of Security Requirements.  We need to
recruit a security SME (Subject Matter Expert) to assist.  

8.  Action Items:

            a.  Set deadline of Thurs PM, Oct 14 for inputs on Draft-03
and this mtg.

            b.  Provide Draft-04 by Monday, Oct 18 (final due Oct 25)

            c.  See individual action items above; note that Security
Draft needs to be addressed (it is the most difficult part and may
impact our progress)

            d.  Authors to initiate the List discussions       

Part II - Metadata Draft

1.  "Received" versus "Recorded" media streams

            a.  Post questions to List for discussion          

2.  What metadata is needed, what is not needed?

            a.  We want metrics about the recording:  End points, if
something was not recorded, identify speaker, identify participants,
identify when someone went on hold, who initiated the call, who
terminated the call, etc....if available

            b.  Post to List for discussion

3.  Relating participants to (1) Media is reasonable and doable, to (2)
Signaling is more difficult, excessive, and may not be needed

            a.  Post to List for discussion

4.  Action Items:

            a.  Authors to initiate the List discussions

            b.  Use a unique title for each thread

            c.  More List discussions requested

Let me know if you have any additions, corrections, or remarks.  

Regards,

Dave

-------------------------------------------------------------------------------------------------------------------
CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential and proprietary information of Alcatel-Lucent and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Alcatel-Lucent and/or its affiliated entities.

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Thu, 14 Oct 2010 07:22:09 +0530

Added Ram Mohan R and Leon Portman in the participant list

________________________________

From: Dave Smith [mailto:[email-masked]]
Sent: Thu 10/14/2010 12:15 AM
To: [email-masked]
Cc: Parthasarathi R (partr); Paul Kyzivat (pkyzivat); [email-masked]; Henry Lum; Leon Portman; Elwell, John; Ken Rehor (krehor); Dave Smith
Subject: SIPREC WG Mtg Min's - ITEF 78.2 Interim Virtual Mtg_101210

Participants:

John Elwell - Chair  

Brian Rosen - Chair

Ken Rehor 

Paul Kyzivat 

Parthasarathi R

Ram Mohan R

Leon Portman

Henry Lum

Dave Smith - Note Taker

Agenda:

 75 min -  Ken Rehor

 30 min

 Paul Kyzivat / Ram

Meeting Minutes:

1.  DTMF 

            d.  Make REQ-007 into only one requirement for recording DTMF (leave for Arch Draft/Doc to address how it is done)

2.  REQ-023

            a.  Change wording from "a SIP UA" to "an authorized participant in the CS" 

3.  REQ-024

4.  Tracker Ticket # 43

            a.  Tracker Ticket # 43:  "What special requirements do we need concerning conferences? I suspect we at least need something to do with recording the view of a single  participant versus recording the entire conference (including aspects that  a given participant might not see)."

            b.  Consider to add use cases to describe (1) single participant, versus (2) recording the entire conference 

            c.  We probably need to identify in metadata participant participation, if available

            d.  SRC may not know participants, for example, where there is separation between SRC & Mixer - this is to be handled at a later Draft phase

5.  Tracker Ticket #46

6.  Use Case #12

            a.  The SRC to control the timing required (max delay, e.g., 1 to 3 seconds max delay proposed for Speech Analytics use case) to provide CS media to SRS

7.  Tracker Ticket #35

                        (3)  SRC to SRS relationship - this is probably our primary focus

                        GEOPRIV (how a user specifies his preferences for private information)

                        Telepresence (multiple streams, participant info)

            d.  We should be able to use standard SIP for Integrity and Confidentiality, but probably need more for Authentication and Privacy.

            e.  We need a Draft of Security Requirements.  We need to recruit a security SME (Subject Matter Expert) to assist.  

8.  Action Items:

            a.  Set deadline of Thurs PM, Oct 14 for inputs on Draft-03 and this mtg.

            c.  See individual action items above; note that Security Draft needs to be addressed (it is the most difficult part and may impact our progress)

 

Part II - Metadata Draft

            a.  We want metrics about the recording:  End points, if something was not recorded, identify speaker, identify participants, identify when someone went on hold, who initiated the call, who terminated the call, etc....if available

3.  Relating participants to (1) Media is reasonable and doable, to (2) Signaling is more difficult, excessive, and may not be needed

4.  Action Items:

 

Regards,

Dave

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 14 Oct 2010 12:25:06 +0200

Dave,

Thanks for your notes. I have merged them with my own notes and I will send them out as official draft minutes in a separate mail.

John

________________________________
From: Dave Smith [mailto:[email-masked]]
Sent: 13 October 2010 19:46
To: [email-masked]
Cc: Parthasarathi R (partr); Paul Kyzivat (pkyzivat); [email-masked]; Henry Lum; Leon Portman; Elwell, John; [email-masked]; Dave Smith
Subject: SIPREC WG Mtg Min's - ITEF 78.2 Interim Virtual Mtg_101210

Participants:

John Elwell - Chair

Brian Rosen - Chair
Ken Rehor
Paul Kyzivat
Ram Parthasarathi
Henry Lum
Dave Smith - Note Taker

Agenda:

 75 min -  Ken Rehor

 30 min

 Paul Kyzivat / Ram

Meeting Minutes:

2.  REQ-023

3.  REQ-024

4.  Tracker Ticket # 43

5.  Tracker Ticket #46

6.  Use Case #12

7.  Tracker Ticket #35

8.  Action Items:

Part II - Metadata Draft

4.  Action Items:

Regards,
Dave