Subject: [siprec] Comments on draft-ietf-siprec-architecture

From: Cullen Jennings <[email-masked]>
Date: Sun, 7 Nov 2010 15:53:33 -0700

Of the approaches in section 4.3.2, I think the Even Package will work best for deliver of metadata.

Have you thought about what sort of response latency is acceptable on the Pause/Resume. For video conferencing types applications people some times find that the signaling path is too slow for this control and instead use the media path. I don't have any opinion on which would be best here but it's worth thinking about. 

What approaches are you considering to detect that a UA is recording aware and then to alert it that media is being recorded?

---

From: Leon Portman <[email-masked]>
Date: Mon, 8 Nov 2010 03:33:26 +0200

Cullen, Hi

The problem with event package that it is require separate SIP dialog. And also some basic mandatory information is required to be in initial RS INVITE (like participants) because it can influence how do we want to record this CS,

Regarding Pause/Resume specially for video. The latency is very important here. Specially in a case where SRS will need to wait until next Key Frame and it can take tens of seconds. So if the control over signaling or over media is less important, because we have a bigger problem here. I prefer to do it over SDP - media inactive approach.

Regards

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Cullen Jennings
Sent: Monday, November 08, 2010 12:54 AM
To: [email-masked]
Subject: [siprec] Comments on draft-ietf-siprec-architecture

_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec

---

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 8 Nov 2010 04:05:56 +0100

Hi,

See below.

Regards
Andy

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Leon Portman
> Sent: 08 November 2010 09:33
> To: Cullen Jennings; [email-masked]
> Subject: Re: [siprec] Comments on draft-ietf-siprec-architecture
> 
> Cullen, Hi
> 
> The problem with event package that it is require separate 
> SIP dialog. And also some basic mandatory information is 
> required to be in initial RS INVITE (like participants) 
> because it can influence how do we want to record this CS,

[AndyH] - The fact that the event package mechanism requires a separate dialog is also a benefit in that metadata updates may be needed outside of the RS dialog, for example after the RS is terminated. So although I understand the desire to include metadata in the RS INVITE this I don't think reduces the need for an event package.

> 
> Regarding Pause/Resume specially for video. The latency is 
> very important here. Specially in a case where SRS will need 
> to wait until next Key Frame and it can take tens of seconds. 
> So if the control over signaling or over media is less 
> important, because we have a bigger problem here. I prefer to 
> do it over SDP - media inactive approach.
> 
> Regards
> 
> Leon
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Cullen Jennings
> Have you thought about what sort of response latency is 
> acceptable on the Pause/Resume. For video conferencing types 
> applications people some times find that the signaling path 
> is too slow for this control and instead use the media path. 
> I don't have any opinion on which would be best here but it's 
> worth thinking about. 
> 
> What approaches are you considering to detect that a UA is 
> recording aware and then to alert it that media is being recorded?
> 
>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 8 Nov 2010 04:11:18 +0100

Hi Cullen,

With regard to the approaches for detecting recording aware UA's and alerting UA's of recording we started some work on this in http://tools.ietf.org/html/draft-johnston-siprec-cc-rec-00.

However we made a decision at Maastricht to not progress this until the requirements were clearer so it is probably about time we started work on mechanism again.

Regards
Andy

> Sent: 08 November 2010 06:54
> To: [email-masked]

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 9 Nov 2010 20:58:16 -0700

> However we made a decision at Maastricht to not progress this until the requirements were clearer so it is probably about time we started work on mechanism again.

Thanks - Good to hear that draft is not dead.

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Thu, 11 Nov 2010 14:09:13 +0530

Andy,

I agree that XML sort of document will be required to pass metadata
between SRS and SRC. 
In the current metadata model, we could not see the requirement to
update outside RS dialog. Could you please elaborate if any.

Thanks
Partha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Hutton, Andrew
Sent: Monday, November 08, 2010 8:36 AM
To: Leon Portman; Cullen Jennings (fluffy); [email-masked]
Subject: Re: [siprec] Comments on draft-ietf-siprec-architecture

Hi,

See below.

Regards
Andy

> The problem with event package that it is require separate SIP dialog.

> And also some basic mandatory information is required to be in initial

> RS INVITE (like participants) because it can influence how do we want 
> to record this CS,

[AndyH] - The fact that the event package mechanism requires a separate
dialog is also a benefit in that metadata updates may be needed outside
of the RS dialog, for example after the RS is terminated. So although I
understand the desire to include metadata in the RS INVITE this I don't
think reduces the need for an event package.

> 
> Regarding Pause/Resume specially for video. The latency is very 
> important here. Specially in a case where SRS will need to wait until 
> next Key Frame and it can take tens of seconds.
> So if the control over signaling or over media is less important, 
> because we have a bigger problem here. I prefer to do it over SDP - 
> media inactive approach.
> 
> Regards
> 
> Leon
> 
> Of the approaches in section 4.3.2, I think the Even Package will work

> best for deliver of metadata.
> 
> Have you thought about what sort of response latency is acceptable on 
> the Pause/Resume. For video conferencing types applications people 
> some times find that the signaling path is too slow for this control 
> and instead use the media path.
> I don't have any opinion on which would be best here but it's worth 
> thinking about.
> 
> What approaches are you considering to detect that a UA is recording 
> aware and then to alert it that media is being recorded?
> 
>