Subject: Re: [siprec] comments on draft-ietf-siprec-req-02 REQ-021

From: Leon Portman <[email-masked]>
Date: Tue, 2 Nov 2010 19:29:29 +0200

I prefer not to dump all CS SIP to SRS because it will require very complex state machine from SRS in order to understand call state. We are doing it today for some implementation and it is very messy. Some SRCs can provide much higher level of metadata

Leon

----- Original Message -----
From: Paul Kyzivat <[email-masked]>
To: Leon Portman
Cc: [email-masked] <[email-masked]>
Sent: Tue Nov 02 19:24:30 2010
Subject: Re: [siprec] comments on draft-ietf-siprec-req-02 REQ-021

If there is need to convey a lot of the CS signalnig info to the SRS, we 
might want to consider tunneling pretty much all of the CS sip signaling 
down to the SRS, perhaps in its native form.

On 11/2/2010 11:47 AM, Leon Portman wrote:
> Just one additional comment:
>
> Codec info that will be available in SDP between SRC and SRS not always will represent the codec in CS because of mixing and transcoding.
> So we still need to define way to convey via the metadata.

Do you think they will differ often enough that this should always be 
sent as explicit metadata? Or is this the exception rather than the 
rule, so that we might plan to use the info passed directly in SDP 
between SRC and SRS, with exceptions when needed?

> Same is for SIP header parameters : to, from ,contact, via etc.

Clearly we need to convey participant information that won't be there 
naturally in the RS.

	Thanks,
	Paul

> Leon
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Leon Portman
> Sent: Tuesday, November 02, 2010 5:42 PM
> To: Paul Kyzivat
> Cc: [email-masked]
> Subject: Re: [siprec] comments on draft-ietf-siprec-req-02 REQ-021
>
> Paul, Hi
>
> I agree that metadata is transport specific in relation to the transport layer of CS like the codec example.
> But I am still missing the point why the actual format of metadata should be dependent on over which transport protocol we will send it?
>
> Leon
>
> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: Tuesday, November 02, 2010 5:37 PM
> To: Leon Portman
> Cc: Elwell, John; [email-masked]
> Subject: Re: [siprec] comments on draft-ietf-siprec-req-02 REQ-021
>
> Leon,
>
> Your response is still not to the point. Specifically, if there is some
> information that we want to retain as metadata, which is "naturally"
> available via sip signaling between SRC and SRS, but which then is
> "transport specific", do we need to define some other transport-agnostic
> way to send it?
>
> Consider the codec info that is naturally available in the SDP between
> SRC and SRS. Do we need to define some other way to send that, which is
> transport agnostic? And if so, do we need to use that way?
>
> ISTM that we only need to be transport agnostic while we are gathering
> the detailed requirements on what needs to be conveyed. Once we get down
> to selecting the transport mechanism for each bit of the metadata, I
> think we no longer need to be transport agnostic.
>
> The situation may be different for *retrieving* metadata. But that is
> out of scope for now.
>
> 	Thanks,
> 	Paul
>
> On 11/2/2010 10:59 AM, Leon Portman wrote:
>> Actually the drive for this requirement was that metadata can be delivered via different transport protocols: SIP INVITE, Subscribe/notify, Info, HTTP, etc. It does not relates to actual transport protocol of CS.
>>
>> And we wanted that metadata definition (xml schema) will be agnostic to Metadata transport and not CS or RS transport
>> May be we should phrase it like this:
>>
>> REQ-021 Metadata format must be agnostic of the metadata transport protocol
>>
>> Leon
>>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf Of Elwell, John
>> Sent: Tuesday, November 02, 2010 4:47 PM
>> To: Paul Kyzivat; [email-masked]
>> Subject: Re: [siprec] comments on draft-ietf-siprec-req-02 REQ-021
>>
>> I didn't see any response to this, and the requirement still exists in -04. Can we delete REQ-021?
>>
>> John
>>
>>> -----Original Message-----
>>> From: [email-masked]
>>> [mailto:[email-masked]] On Behalf Of Paul Kyzivat
>>> Sent: 28 September 2010 14:34
>>> To: [email-masked]
>>> Subject: [siprec] comments on draft-ietf-siprec-req-02 REQ-021
>>>
>>>> REQ-021 Metadata format must be agnostic of the transport protocol.
>>>
>>>
>>> IMO this requirement is dubious or at least requires clarification.
>>>
>>> Is the goal that the metadata *as stored* by the SRS must be
>>> agnostic to
>>> transport? Or is it that that encoding of the metadata *when
>>> transmitted* to the SRS must be encoded in a transport agnostic way?
>>>
>>> Some of the metadata will be most naturally gathered
>>> opportunistically
>>> from the transport. For instance codec information. That
>>> would make it
>>> non-agnostic to the transport.
>>>
>>> 	Thanks,
>>> 	Paul
>>> _______________________________________________
>>> siprec mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/siprec
>>>
>> _______________________________________________
>> siprec mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/siprec
>>
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 02 Nov 2010 18:15:26 -0400

Fair enough. This is a tradeoff between SRC complexity and SRS complexity.

	Thanks,
	Paul

On 11/2/2010 1:29 PM, Leon Portman wrote:
> From: Paul Kyzivat<[email-masked]>
> To: Leon Portman
> Cc: [email-masked]<[email-masked]>