Subject: [siprec] SIPREC Metadata model: Is it required to model streams that are not recorded ?

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Tue, 21 Dec 2010 18:59:16 +0530

Hi all,

During the SIPREC IETF dec 16th 2010 virtual interim we discussed in
brief about the need to model stream that are not recorded ( there were
people like Leon who have suggested on having this in the model).

e.g. SRC offered certain media types (like audio, video) but SRS choose
to accept only subset of them ( say only audio).

The other possibility could be a CS might have multiple media
types(audio, video) but an SRC may record only one type (say audio) due
to its limitations. However an SRS might want to know all the streams of
CS.

If its required  to  model these information in metadata, how do we do
them ?

I would like to get some thoughts/ inputs from interested people in the
mailing list on whether there is a value add / need  in storing
information about streams that are not recorded.

Regards,

Ram

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 21 Dec 2010 14:47:03 +0100

If additional media streams are offered to the SRS but declined, clearly the SRS knows of the existence of those streams. So I think the point behind the question is whether the SRS needs to know the subsequent fate of those additional streams in the CS, e.g., if they are held, resumed, disabled, etc..

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Ram Mohan R (rmohanr)
> Sent: 21 December 2010 13:29
> To: [email-masked]
> Subject: [siprec] SIPREC Metadata model: Is it required to 
> model streams that are not recorded ?
> 
> Hi all,
> 
>  
> 
> During the SIPREC IETF dec 16th 2010 virtual interim we 
> discussed in brief about the need to model stream that are 
> not recorded ( there were people like Leon who have suggested 
> on having this in the model).
> 
>  
> 
> e.g. SRC offered certain media types (like audio, video) but 
> SRS choose to accept only subset of them ( say only audio).
> 
> types(audio, video) but an SRC may record only one type (say 
> audio) due to its limitations. However an SRS might want to 
> know all the streams of CS.
> 
>  
> 
> If its required  to  model these information in metadata, how 
> do we do them ?
> 
>  
> 
> I would like to get some thoughts/ inputs from interested 
> people in the mailing list on whether there is a value add / 
> need  in storing information about streams that are not recorded.
> 
>  
> 
> Regards,
> 
> Ram
> 
>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 21 Dec 2010 10:17:23 -0500

> If additional media streams are offered to the SRS but declined, clearly the SRS knows of the existence of those streams. So I think the point behind the question is whether the SRS needs to know t…

One possibility is for the SRC to continue offering them even though 
they have been previously declined. However there is some cost to doing 
this, in maintaining media ports, possibly using ICE, etc.

An alternative might be to send metadata about these hypothetical 
streams without any cross reference to the SDP. But that will require 
being careful that sufficient info is in the metadata without the SDP in 
the RS.

	Thanks,
	Paul

> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 22 Dec 2010 14:22:43 -0800

How about leaving this up to the RS implementation. If it cannot record
something but wants to know of its existence and state, it can accept
the stream and throw it away. Not the most efficient thing to do, but
this way it does stay in the loop if that is important to it.

Cheers,
Charles

> From: [email-masked] [mailto:[email-masked]] On
Behalf Of Paul Kyzivat (pkyzivat)
> Sent: Tuesday, December 21, 2010 7:17 AM
> To: [email-masked]
> Subject: Re: [siprec] SIPREC Metadata model: Is it required to model
streams that are not recorded ?
> > If additional media streams are offered to the SRS but declined,
clearly the SRS knows of the
> existence of those streams. So I think the point behind the question
is whether the SRS needs to know
> the subsequent fate of those additional streams in the CS, e.g., if
they are held, resumed, disabled,
> etc..