Subject: [siprec] Use of normative language when defining the SIPREC protocol

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 16 Dec 2010 15:38:10 +0200

Hi,

when writing the protocol draft, you are going to be referencing
existing specifications such as SIP, the offer/answer model, the SDP
label attribute, etc. Those specifications already contain a number of
normative statements that define what implementations should do.

In the SIPREC protocol draft, you may want to point to some of the
behavior defined in those documents. When doing so, please do not use
normative language. For example, stating that per RFC 3264, an answer
has the same number of media lines as its associated offer is OK.
However, stating that an answer MUST have the same number of media lines
as the offer is not OK because this behavior is already defined in RFC 3264.

I am making this comment now so that the protocol document gets it right
from the beginning. At this point, the few issues present in the current
draft are easily fixed.

Thanks,

Gonzalo

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 16 Dec 2010 14:50:39 +0100

Well, we haven't even adopted a draft as a WG document yet, but it would help if authors could consider such issues right from the start. Thanks, Gonzalo, for raising this.

John 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Gonzalo Camarillo
> Sent: 16 December 2010 13:38
> To: [email-masked]
> Subject: [siprec] Use of normative language when defining the 
> SIPREC protocol
> 
> Hi,
> 
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 16 Dec 2010 15:52:33 +0200

Hi John,

yes, I know it is not a WG item... but as part of my preparation for the
virtual interim, I read all the siprec drafts, WG items and non-WG items ;o)

Cheers,

Gonzalo

---

From: "Henry Lum" <[email-masked]>
Date: Thu, 16 Dec 2010 08:33:12 -0800

Thanks for pointing this out. We'll fix this in the next revision.

Henry

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Gonzalo Camarillo
> Sent: Thursday, December 16, 2010 8:38 AM
> To: [email-masked]
> Subject: [siprec] Use of normative language when defining the SIPREC
> protocol
> 
> Hi,
> 

-------------------------------------------------------------------------------------------------------------------
CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential and proprietary information of Alcatel-Lucent and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Alcatel-Lucent and/or its affiliated entities.