Subject: [siprec] FW: Requirements #61 (new): Do we need REQ-010 (multpleRSs per CS)?

From: "Dave Smith" <[email-masked]>
Date: Thu, 23 Dec 2010 12:27:41 -0800

I agree as well...this is a much better req't.

Regards,
Dave

-----Original Message-----
From: Hutton, Andrew [mailto:[email-masked]] 
Sent: Thursday, December 23, 2010 5:58 AM
To: Parthasarathi R (partr); Leon Portman; Elwell, John; Dave Smith;
[email-masked]
Subject: RE: [siprec] Requirements #61 (new): Do we need REQ-010
(multpleRSs per CS)?

I also like John's suggestion to replace REQ-10 and 11 with the single
statement which does not prejudice the solution.

Regards
Andy 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Parthasarathi R (partr)
Sent: 23 December 2010 12:00
To: Leon Portman; Elwell, John; Dave Smith; [email-masked]
Subject: Re: [siprec] Requirements #61 (new): Do we need REQ-010
(multple RSs per CS)?

The requirement approach looks good for me

Partha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Leon Portman
Sent: Thursday, December 23, 2010 2:54 PM
To: Elwell, John; Dave Smith; [email-masked]
Subject: Re: [siprec] Requirements #61 (new): Do we need REQ-010
(multple RSs per CS)?

I agree with such wording

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Elwell, John
Sent: Thursday, December 23, 2010 11:01 AM
To: Dave Smith; [email-masked]
Subject: Re: [siprec] Requirements #61 (new): Do we need REQ-010
(multple RSs per CS)?

> -----Original Message-----
> From: Dave Smith [mailto:[email-masked]]
> Sent: 22 December 2010 18:56
> To: Elwell, John; [email-masked]
> Subject: RE: [siprec] Requirements #61 (new): Do we need REQ-010 
> (multple RSs per CS)?
> 
> Regarding this subject, I'd first like to investigate/ask:
> 
> 1.  Is there a use case for REQ-010 associated with Speech Analytics 
> needs?
> 
> 2.  If REQ-010 is not needed, then why is REQ-011 needed?
[JRE] Good question. In my opinion, if there are multiple media to be
delivered, it certainly makes sense to deliver them as a single RS, so
that the metadata for that RS can easily link to the media. Whether that
needs to be stated as a requirement or left for the solution, I am not
sure. However, I certainly think we need some sort of requirement for
delivering multiple media and for the SRS to be able to identify them as
belonging to the same CS. REQ-007 identifies media types that have to be
supported, but there is nothing in that requirement to talk about
multiple media from the same session. Perhaps REQ-010 and REQ-011 can be
replaced by a single requirement along the lines of "The mechanism MUST
support the ability to deliver to the SRS multiple media streams for a
given CS."

John (as individual)

> 
> Regards,
> Dave
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Elwell, John
> Sent: Wednesday, December 22, 2010 2:21 AM
> To: [email-masked]
> Subject: Re: [siprec] Requirements #61 (new): Do we need REQ-010 
> (multple RSs per CS)?
> 
> Let me try to summarize where we are.
> 
> 1. I think we are agreed that we are not considering the case of 
> multiple SRCs (on behalf of multiple parties in the CS) each having an

> RS to the SRS. This can happen, but doesn't need to be in the 
> requirements.
> 
> 2. I think we are agreed that we are not considering the case where a 
> single SRC has multiple RSs to different SRSs, the multiple SRSs being

> for resilience purposes, say. Again, it can be deployed like this, but

> we don't need a specific requirement.
> 
> 3. So we are talking about whether we need multiple RSs between the 
> same SRC/SRS for a given CS.
> 
> 4. REQ-010 talks about multiple media streams - it is unclear whether 
> it means multiple media types (e.g., audio and video), multiple 
> parties of the same medium (e.g., the two directions of audio in a 
> 2-party audio call), or both.
> 
> 5. I have heard no motivation for different RSs for different media 
> types.
> 
> 6. I have heard some motivation for different RSs for different 
> parties engaged in the same media type. The motivation seems to be 
> along the lines of what is currently deployed and the inability of 
> SIP/SDP stacks to handle multiple m-lines of the same type. There has 
> been a suggestion this is perhaps a problem that the solution should 
> address somehow, but there does not need to be a requirement (the 
> requirement would prejudice the solution).
> 
> John
>  
> 
> > -----Original Message-----
> > From: siprec issue tracker [mailto:[email-masked]]
> > Sent: 22 December 2010 10:14
> > To: [email-masked]; Elwell, John
> > Cc: [email-masked]
> > Subject: [siprec] Requirements #61 (new): Do we need REQ-010 
> > (multple RSs per CS)?
> > 
> > #61: Do we need REQ-010 (multple RSs per CS)?
> > 
> >  Thread starting at:
> >  http://www.ietf.org/mail-archive/web/siprec/current/msg01219.html
> > 
> > --
> > ------------------------------------------------+-------------
> > --------------
> >  Reporter:  john.elwell@...                       |       
> > Owner:  leon.portman@...       
> >      Type:  defect                              |      
> > Status:  new                  
> >  Priority:  major                               |   
> > Milestone:                       
> > Component:  Requirements                        |     
> > Version:                       
> >  Severity:  Active WG Document                  |    
> > Keywords:                       
> > ------------------------------------------------+-------------
> > --------------
> > 
> > Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/61>
> > siprec <http://tools.ietf.org/siprec/>
> > 
> > 
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
> 
> 					
> --------------------------------------------------------------
> -----------------------------------------------------
> CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain

> confidential and proprietary information of Alcatel-Lucent and/or its 
> affiliated entities. Access by the intended recipient only is 
> authorized. Any liability arising from any party acting, or refraining

> from acting, on any information contained in this e-mail is hereby 
> excluded. If you are not the intended recipient, please notify the 
> sender immediately, destroy the original transmission and its 
> attachments and do not disclose the contents to any other person, use 
> it for any purpose, or store or copy the information in any medium. 
> Copyright in this e-mail and any attachments belongs to Alcatel-Lucent

> and/or its affiliated entities.
> 					
> 
_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec
_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec
_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec

-------------------------------------------------------------------------------------------------------------------
CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential and proprietary information of Alcatel-Lucent and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Alcatel-Lucent and/or its affiliated entities.

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 28 Dec 2010 17:15:42 +0100

I haven't heard any opposition to the reworded requirement to replace REQ-10/REQ-11, so I would suggest the editors post req-06 with this change (plus other previously-agreed changes), ready for WGLC.

John

> [mailto:[email-masked]] On Behalf Of Dave Smith
> Sent: 23 December 2010 20:28
> To: [email-masked]
> Subject: [siprec] FW: Requirements #61 (new): Do we need 
> REQ-010 (multpleRSs per CS)?
> 
> 
> [mailto:[email-masked]] On Behalf
> [mailto:[email-masked]] On Behalf
> Of Leon Portman
> CONFIDENTIALITY NOTICE: This e-mail and any files attached 
> may contain confidential and proprietary information of 
> Alcatel-Lucent and/or its affiliated entities. Access by the 
> intended recipient only is authorized. Any liability arising 
> from any party acting, or refraining from acting, on any 
> information contained in this e-mail is hereby excluded. If 
> you are not the intended recipient, please notify the sender 
> immediately, destroy the original transmission and its 
> attachments and do not disclose the contents to any other 
> person, use it for any purpose, or store or copy the 
> information in any medium. Copyright in this e-mail and any 
> attachments belongs to Alcatel-Lucent and/or its affiliated entities.
>