Subject: [siprec] Requirements #61 (new): Do we need REQ-010 (multple RSs per CS)?

From: "siprec issue tracker" <[email-masked]>
Date: Wed, 22 Dec 2010 10:13:32 -0000

#61: Do we need REQ-010 (multple RSs per CS)?

 Thread starting at:
 http://www.ietf.org/mail-archive/web/siprec/current/msg01219.html

-- 
------------------------------------------------+---------------------------
 Reporter:  john.elwell@…                       |       Owner:  leon.portman@…       
     Type:  defect                              |      Status:  new                  
 Priority:  major                               |   Milestone:                       
Component:  Requirements                        |     Version:                       
 Severity:  Active WG Document                  |    Keywords:                       
------------------------------------------------+---------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/siprec/trac/ticket/61>
siprec <http://tools.ietf.org/siprec/>

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 22 Dec 2010 11:20:46 +0100

Let me try to summarize where we are.

1. I think we are agreed that we are not considering the case of multiple SRCs (on behalf of multiple parties in the CS) each having an RS to the SRS. This can happen, but doesn't need to be in the requirements. 

2. I think we are agreed that we are not considering the case where a single SRC has multiple RSs to different SRSs, the multiple SRSs being for resilience purposes, say. Again, it can be deployed like this, but we don't need a specific requirement.

3. So we are talking about whether we need multiple RSs between the same SRC/SRS for a given CS.

4. REQ-010 talks about multiple media streams - it is unclear whether it means multiple media types (e.g., audio and video), multiple parties of the same medium (e.g., the two directions of audio in a 2-party audio call), or both.

5. I have heard no motivation for different RSs for different media types.

6. I have heard some motivation for different RSs for different parties engaged in the same media type. The motivation seems to be along the lines of what is currently deployed and the inability of SIP/SDP stacks to handle multiple m-lines of the same type. There has been a suggestion this is perhaps a problem that the solution should address somehow, but there does not need to be a requirement (the requirement would prejudice the solution).

John

> -----Original Message-----
> From: siprec issue tracker [mailto:[email-masked]] 
> Sent: 22 December 2010 10:14
> To: [email-masked]; Elwell, John
> Cc: [email-masked]
> Subject: [siprec] Requirements #61 (new): Do we need REQ-010 
> (multple RSs per CS)?
> 
>  Reporter:  john.elwell@...                       |       
> Owner:  leon.portman@...       
>      Type:  defect                              |      
> Status:  new                  
>  Priority:  major                               |   
> Milestone:

---

From: Leon Portman <[email-masked]>
Date: Wed, 22 Dec 2010 13:12:13 +0200

Yes, it is good summary and I agree with your last observation. 

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Elwell, John
Sent: Wednesday, December 22, 2010 12:21 PM
To: [email-masked]
Subject: Re: [siprec] Requirements #61 (new): Do we need REQ-010 (multple RSs per CS)?

John

>  http://www.ietf.org/mail-archive/web/siprec/current/msg01219.html
_______________________________________________
siprec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/siprec

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Wed, 22 Dec 2010 18:04:17 +0530

John,

IMO, Multiple m-line support has to be enhanced in the devices
(implementation) rather than tweak SIPREC solution to avoid this issue.
The support for multiple m-line will be required for video devices as
well. 

Thanks
Partha 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Leon Portman
Sent: Wednesday, December 22, 2010 4:42 PM
To: Elwell, John; [email-masked]
Subject: Re: [siprec] Requirements #61 (new): Do we need REQ-010
(multple RSs per CS)?

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Elwell, John
Sent: Wednesday, December 22, 2010 12:21 PM
To: [email-masked]
Subject: Re: [siprec] Requirements #61 (new): Do we need REQ-010
(multple RSs per CS)?

1. I think we are agreed that we are not considering the case of
multiple SRCs (on behalf of multiple parties in the CS) each having an
RS to the SRS. This can happen, but doesn't need to be in the
requirements. 

2. I think we are agreed that we are not considering the case where a
single SRC has multiple RSs to different SRSs, the multiple SRSs being
for resilience purposes, say. Again, it can be deployed like this, but
we don't need a specific requirement.

3. So we are talking about whether we need multiple RSs between the same
SRC/SRS for a given CS.

4. REQ-010 talks about multiple media streams - it is unclear whether it
means multiple media types (e.g., audio and video), multiple parties of
the same medium (e.g., the two directions of audio in a 2-party audio
call), or both.

5. I have heard no motivation for different RSs for different media
types.

6. I have heard some motivation for different RSs for different parties
engaged in the same media type. The motivation seems to be along the
lines of what is currently deployed and the inability of SIP/SDP stacks
to handle multiple m-lines of the same type. There has been a suggestion
this is perhaps a problem that the solution should address somehow, but
there does not need to be a requirement (the requirement would prejudice
the solution).

John

> Subject: [siprec] Requirements #61 (new): Do we need REQ-010 (multple 
> RSs per CS)?
>

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 22 Dec 2010 14:48:29 +0100

Partha,

Right. I just said that the solution should address the problem "somehow". That might be by specifying multiple m-line support in an unambiguous way, for example.

John

> From: Parthasarathi R (partr) [mailto:[email-masked]] 
> Sent: 22 December 2010 12:34
> To: Leon Portman; Elwell, John; [email-masked]
> Subject: RE: [siprec] Requirements #61 (new): Do we need 
> REQ-010 (multple RSs per CS)?
> 
> John,
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf
> Of Leon Portman
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf
> Of Elwell, John

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 22 Dec 2010 10:10:30 -0500

> Yes, it is good summary and I agree with your last observation.

OK. If this meets the perceived needs, then it certainly makes life 
simpler for constructing a mechanism.

	Thanks,
	Paul

>> Ticket URL:<http://trac.tools.ietf.org/wg/siprec/trac/ticket/61>
>> siprec<http://tools.ietf.org/siprec/>
>>
>>

---

From: "Dave Smith" <[email-masked]>
Date: Wed, 22 Dec 2010 10:55:56 -0800

Regarding this subject, I'd first like to investigate/ask:

1.  Is there a use case for REQ-010 associated with Speech Analytics
needs?

2.  If REQ-010 is not needed, then why is REQ-011 needed?

Regards,
Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Elwell, John
Sent: Wednesday, December 22, 2010 2:21 AM
To: [email-masked]
Subject: Re: [siprec] Requirements #61 (new): Do we need REQ-010
(multple RSs per CS)?

John

-------------------------------------------------------------------------------------------------------------------
CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential and proprietary information of Alcatel-Lucent and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Alcatel-Lucent and/or its affiliated entities.

---

From: Leon Portman <[email-masked]>
Date: Wed, 22 Dec 2010 21:55:21 +0200

Dave, hi

I don't think that req-10 related to analytics, recording of unsummed audio is related.

Leon

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 23 Dec 2010 10:01:08 +0100

> From: Dave Smith [mailto:[email-masked]] 
> Sent: 22 December 2010 18:56
[JRE] Good question. In my opinion, if there are multiple media to be delivered, it certainly makes sense to deliver them as a single RS, so that the metadata for that RS can easily link to the media. Whether that needs to be stated as a requirement or left for the solution, I am not sure. However, I certainly think we need some sort of requirement for delivering multiple media and for the SRS to be able to identify them as belonging to the same CS. REQ-007 identifies media types that have to be supported, but there is nothing in that requirement to talk about multiple media from the same session. Perhaps REQ-010 and REQ-011 can be replaced by a single requirement along the lines of "The mechanism MUST support the ability to deliver to the SRS multiple media streams for a given CS."

John (as individual)

> --------------------------------------------------------------
> -----------------------------------------------------
> CONFIDENTIALITY NOTICE: This e-mail and any files attached 
> may contain confidential and proprietary information of 
> Alcatel-Lucent and/or its affiliated entities. Access by the 
> intended recipient only is authorized. Any liability arising 
> from any party acting, or refraining from acting, on any 
> information contained in this e-mail is hereby excluded. If 
> you are not the intended recipient, please notify the sender 
> immediately, destroy the original transmission and its 
> attachments and do not disclose the contents to any other 
> person, use it for any purpose, or store or copy the 
> information in any medium. Copyright in this e-mail and any 
> attachments belongs to Alcatel-Lucent and/or its affiliated entities.
> 					
>

---

From: Leon Portman <[email-masked]>
Date: Thu, 23 Dec 2010 11:23:50 +0200

I agree with such wording

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Elwell, John
Sent: Thursday, December 23, 2010 11:01 AM
To: Dave Smith; [email-masked]
Subject: Re: [siprec] Requirements #61 (new): Do we need REQ-010 (multple RSs per CS)?

John (as individual)

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Thu, 23 Dec 2010 17:30:15 +0530

The requirement approach looks good for me

Partha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Leon Portman
Sent: Thursday, December 23, 2010 2:54 PM
To: Elwell, John; Dave Smith; [email-masked]
Subject: Re: [siprec] Requirements #61 (new): Do we need REQ-010
(multple RSs per CS)?

Leon

-----Original Message-----

> Subject: RE: [siprec] Requirements #61 (new): Do we need REQ-010 
> (multple RSs per CS)?
> 
[JRE] Good question. In my opinion, if there are multiple media to be
delivered, it certainly makes sense to deliver them as a single RS, so
that the metadata for that RS can easily link to the media. Whether that
needs to be stated as a requirement or left for the solution, I am not
sure. However, I certainly think we need some sort of requirement for
delivering multiple media and for the SRS to be able to identify them as
belonging to the same CS. REQ-007 identifies media types that have to be
supported, but there is nothing in that requirement to talk about
multiple media from the same session. Perhaps REQ-010 and REQ-011 can be
replaced by a single requirement along the lines of "The mechanism MUST
support the ability to deliver to the SRS multiple media streams for a
given CS."

John (as individual)

> [mailto:[email-masked]] On Behalf Of Elwell, John

> 4. REQ-010 talks about multiple media streams - it is unclear whether 
> it means multiple media types (e.g., audio and video), multiple 
> parties of the same medium (e.g., the two directions of audio in a 
> 2-party audio call), or both.
> 
> 6. I have heard some motivation for different RSs for different 
> parties engaged in the same media type. The motivation seems to be 
> along the lines of what is currently deployed and the inability of 
> SIP/SDP stacks to handle multiple m-lines of the same type. There has 
> been a suggestion this is perhaps a problem that the solution should 
> address somehow, but there does not need to be a requirement (the 
> requirement would prejudice the solution).
> 
> John
>  
> 
> CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain

> confidential and proprietary information of Alcatel-Lucent and/or its 
> affiliated entities. Access by the intended recipient only is 
> authorized. Any liability arising from any party acting, or refraining

> from acting, on any information contained in this e-mail is hereby 
> excluded. If you are not the intended recipient, please notify the 
> sender immediately, destroy the original transmission and its 
> attachments and do not disclose the contents to any other person, use 
> it for any purpose, or store or copy the information in any medium. 
> Copyright in this e-mail and any attachments belongs to Alcatel-Lucent

> and/or its affiliated entities.
> 					
>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 23 Dec 2010 14:57:53 +0100

I also like John's suggestion to replace REQ-10 and 11 with the single statement which does not prejudice the solution.

Regards
Andy 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Parthasarathi R (partr)
Sent: 23 December 2010 12:00
To: Leon Portman; Elwell, John; Dave Smith; [email-masked]
Subject: Re: [siprec] Requirements #61 (new): Do we need REQ-010 (multple RSs per CS)?

Partha

-----Original Message-----

Leon

-----Original Message-----

John (as individual)

---

From: Deepanshu Gautam <[email-masked]>
Date: Fri, 24 Dec 2010 09:09:40 +0800

As I remember, REQ-10 was the requirement which was advocated by speech
analytics use case. I think REQ-10 was aiming for unsummed audio. Is there a
requirement for unsummed audio apart form REQ-10?

Deepanshu Gautam
T: +86 25 5260008 M: +86 135 85147627

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Leon Portman
Sent: Thursday, December 23, 2010 3:55 AM
To: Dave Smith
Cc: <[email-masked]>
Subject: Re: [siprec] Requirements #61 (new): Do we need REQ-010 (multple
RSs per CS)?

Dave, hi

I don't think that req-10 related to analytics, recording of unsummed audio
is related.

Leon

>> http://www.ietf.org/mail-archive/web/siprec/current/msg01219.html
----------------------------------------------------------------------------
---------------------------------------
confidential and proprietary information of Alcatel-Lucent and/or its
affiliated entities. Access by the intended recipient only is authorized.
Any liability arising from any party acting, or refraining from acting, on
any information contained in this e-mail is hereby excluded. If you are not
the intended recipient, please notify the sender immediately, destroy the
original transmission and its attachments and do not disclose the contents
to any other person, use it for any purpose, or store or copy the
information in any medium. Copyright in this e-mail and any attachments
belongs to Alcatel-Lucent and/or its affiliated entities.

---

From: Leon Portman <[email-masked]>
Date: Fri, 24 Dec 2010 09:15:49 +0200

Deepanshu, Hi

Yes, you right. We only have dedicated requirements for mixing media
streams. However new John's wording for the REQ-10 and 11 covers unsummed
case as well in my opinion

regards

Leon

On Fri, Dec 24, 2010 at 3:09 AM, Deepanshu Gautam <[email-masked]>wrote:

> Of

---

From: Deepanshu Gautam <[email-masked]>
Date: Fri, 24 Dec 2010 15:26:13 +0800

Leon,

I'm fine with john's new requirement.

I was just trying to confirm that we still have a requirement for
transferring unsummed media,  although it is not explicitly mentioned in RD.

Regrads

Deepanshu Gautam

From: Leon Portman [mailto:[email-masked]] 
Sent: Friday, December 24, 2010 3:16 PM
To: Deepanshu Gautam
Cc: Dave Smith; [email-masked]
Subject: Re: [siprec] Requirements #61 (new): Do we need REQ-010 (multple
RSs per CS)?

Deepanshu, Hi

regards

Leon  

On Fri, Dec 24, 2010 at 3:09 AM, Deepanshu Gautam <[email-masked]>
wrote:

Deepanshu Gautam

-----Original Message-----

Leon Portman

Dave, hi

Leon

---

From: Leon Portman <[email-masked]>
Date: Fri, 24 Dec 2010 13:03:22 +0200

Deepanshu, Hi

I think we are ok, mixing is the special case that requires special treatment.

Leon

On Dec 24, 2010, at 9:26 AM, Deepanshu Gautam <[email-masked]> wrote:

> Leon,
> 
>  
> 
> I’m fine with john’s new requirement.
> 
> I was just trying to confirm that we still have a requirement for transferring unsummed media,  although it is not explicitly mentioned in RD.
> 
>  
> 
> Regrads
> 
>  
> 
> Deepanshu Gautam
> 
> Yes, you right. We only have dedicated requirements for mixing media streams. However new John's wording for the REQ-10 and 11 covers unsummed case as well in my opinion
> 
>  
> 
> regards
> 
>  
> 
> Leon  
> 
> On Fri, Dec 24, 2010 at 3:09 AM, Deepanshu Gautam <[email-masked]> wrote:
>