Subject: Re: [siprec] Can an MS object span several CSs in a CSG?

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 10 Jun 2011 10:26:39 -0700

Please excuse the delay. I am catching up after having been away on
vacation.
In light of this better understanding of the use case, I also prefer the
option favored by John and Leon to model as a separate MS. In this
specific case, I would expect the properties of the MS to change when A
is transferred to C, so I expect the overhead in creating a new MS vs.
reusing the same MS to be minimal and not worth the added complexity to
the model.

Cheers,
Charles

> -----Original Message-----
> From: Leon Portman [mailto:[email-masked]]
> Sent: Tuesday, May 31, 2011 6:19 AM
> To: Elwell, John; Parthasarathi R (partr); Charles Eckel (eckelcu);
Ram Mohan R (rmohanr);
> [email-masked]
> Subject: RE: [siprec] Can an MS object span several CSs in a CSG?
> 
> Hello
> 
> I also having a problem even without a quantification of number of
update messages that CS MS is
> remains same between different CS.  So I do prefer to keep it simple
and keep it per CS.
> 
> Leon
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf Of Elwell, John
> Sent: Friday, May 27, 2011 12:26 PM
> To: Parthasarathi R (partr); Charles Eckel (eckelcu); Ram Mohan R
(rmohanr); [email-masked]
> Subject: Re: [siprec] Can an MS object span several CSs in a CSG?
> 
> 
> 
> 
> > -----Original Message-----
> > From: Parthasarathi R (partr) [mailto:[email-masked]]
> > Sent: 26 May 2011 15:55
> > To: Elwell, John; Charles Eckel (eckelcu); Ram Mohan R (rmohanr);
> > [email-masked]
> > Subject: RE: [siprec] Can an MS object span several CSs in a CSG?
> >
> > John,
> >
> > The callflow mentioned by me is the basic primitive in the call
center
> > scenario wherein customer (participant) is same throughout the
session
> > and agents are changed using transfer service and B2BUA acts as SRC.
> > IMO, it is one of key requirement to be considered in case we
support
> > for partial-update.
> [JRE] Agreed the Participant remains the same, but we are discussing
MS.
> 
> > This may not be the only callflow where MS partial-update is
required
> > in this fashion. During -00 format draft, I thought that the
> > partial-update is not required but lot of folks raised the concern
> > that partial update is important. Current, -01 format draft is
> > designed to support partial-update. Now, You propose to restrict MS
> > partial-update across CS. IMO, it is a not good idea to restrict in
> > the protocol level. Anyway, I think that we need others opinion
before
> > conclude here.
> [JRE] I am not opposed to partial update, but I would like to avoid
distorting the model just to gain
> some efficiency improvements in certain cases. To me it is not
intuitive that a MS on one CS and an MS
> on another CS are the same object, just because one of the
Participants is common to both CSs. In the
> transfer-between-agents example, although one of the Participants is
common to the two CSs, this is
> not true for the other Participants.
> 
> Let's try to quantify the efficiency improvement. In the blind
transfer case, the partial updates
> would at least have to include:
> - the removal of P1 from CS1 (where P1 is the first agent and CS1 is
the first CS);
> - the removal of P2 from CS1 (where P2 is the transferred
participant);
> - the termination of CS1;
> - the removal of CS1 from CSG1;
> - the creation of CS2 (the CS that results from transfer);
> - the addition to of CS2 to CSG1;
> - the addition of P2 to CSG1;
> - the addition of P3 to CS2 (where P3 is the second agent);
> - the removal of P1 as a sender of MS1 (MS1 is from P1 to P2);
> - the removal of P2 as a recipient of MS1;
> - the termination of MS1;
> - the creation of MS3;
> - the addition of P3 as a sender of MS3;
> - the addition of P2 as a recipient of MS3.
> 
> So all we are arguing about is whether we also include in the partial
updates EITHER (this I think is
> your proposal):
> - the removal of P1 as a recipient of MS2;
> - the addition of P3 as a recipient of MS2;
> 
> OR
> - the removal of P1 as recipient of MS2;
> - the removal of P2 as a sender of MS2;
> - the termination MS2;
> - the creation of MS4;
> - the addition of P3 as a recipient of MS4;
> - the addition of P2 as a sender of MS4.
> 
> So with the first option the total number of deltas is 14+2=16.
> For the second option the total number of deltas is 14+6=20.
> 
> Some of the details might be wrong, but I hope you can see the point I
am getting at. Looked at this
> way, the efficiency saving by recycling MS2 for use in consecutive CSs
is relatively small. Or perhaps
> your intention is also to recycle MS1 (this time, the recipient
remaining the same but the sender
> changing). That would reduce the number of deltas slightly further.
The impact on XML size might not
> be quite in proportion to the reduction in the number of deltas, since
by recycling MS2 it has to have
> a global identifier, not an identifier local to a CS. Or perhaps it
could have an identifier local to
> a CSG.
> 
> I also see that with your proposal it doesn't force the MS to be
recycled - an SRC could still choose
> to model it as separate MSs. However, in that case it would still need
to use global identifiers for
> MSs.
> 
> I am not necessarily opposed to your proposal for recycling MS objects
outside the context of a single
> CS - I can see advantages and disadvantages. I just want to make sure
the group makes an informed
> decision.
> 
> John (as individual)
> 
> 
> >
> > Enhancing label attribute across the multiple SIP message to tie
> > between Metadata XML and RS SDP m-line is possible. SRC has to
ensure
> > that label for the given RS SDP m-line should have same label
> > throughout single CSG even though it span across multiple CS and
> > multiple RS. Even then, it will not meet partial-update requirement
as
> > mentioned below in this mail thread. At this moment, I'm favoring
URN
> > UUID and not label attribute
> > enhancement.
> >
> > Please read inline
> >
> > Thanks
> > Partha
> >
> > -----Original Message-----
> > From: Elwell, John [mailto:[email-masked]]
> > Sent: Wednesday, May 25, 2011 7:17 PM
> > To: Parthasarathi R (partr); Charles Eckel (eckelcu); Ram Mohan R
> > (rmohanr); [email-masked]
> > Subject: RE: [siprec] Can an MS object span several CSs in a CSG?
> >
> >
> >
> > > -----Original Message-----
> > > From: Parthasarathi R (partr) [mailto:[email-masked]]
> > > Sent: 25 May 2011 08:48
> > > To: Elwell, John; Charles Eckel (eckelcu); Ram Mohan R (rmohanr);
> > > [email-masked]
> > > Subject: RE: [siprec] Can an MS object span several CSs in a CSG?
> > >
> > > John,
> > >
> > >
===================================================================
> > > > 3) B transfer the call of A & B to C using REFER, B2BUA
> > > converts REFER
> > >
> > > > to RE-INVITE towards A & C and A & C are connected. B2BUA
> > > updates RS
> > > > with CS2, Participant1 as A & participant2 as C, MS1(A's media
> > > > stream), MS2(C's media stream). There is no update on RS1,
> > > CSG1, MS1,
> > > > MS2. MS2 will become MS2 with the new association and in terms
of
> > > > format, it will associate with <send> tag
> > > [JRE] What harm is done (what do we lose) if, following
> > transfer, A's
> > > media stream is called MS3 and C's media stream is called MS4?
> > >
> >
=====================================================================
> > > <Partha> To indicate MS1 as MS3, MS1 media block has to be
> > stopped in
> > > the partial-update and start MS3 separate which is not required in
> > > case there is a means to have common MS1. </Partha>
> > [JRE] It seems this distorts the model in order to give some minor
> > efficiency improvement during metadata updates. I doubt that this
> > alone is sufficient justification for having the MS persist from one
> > CS to another CS.
> >
> > >
> > > ==============================================================
> > > ==========
> > > =======================
> > > MS3 can reference the same SDP m-line (through a=label) as MS1,
and
> > > likewise MS4 could reference the same SDP m-line as MS2, if we are
> > > concerned about recycling media descriptions in RS SDP.
> > > ==============================================================
> > > ==========
> > > ==================
> > > <Partha> As you mentioned, we will lose recycling of media
> > description
> > > in RS SDP without common value in media stream object for this
> > > scenario.
> > [JRE] I don't understand your point. With my proposal we can still
> > recycle RS SDP m-lines.
> >
> > <Partha> Agreed that Recycle is possible with your proposal.
> > I indicated
> > the need for unique-id in this  requirement </Partha>
> >
> > > AFAIK, Your proposal needs enhancement in RFC 4574 as label
> > attribute
> > > scope is within single SIP message and not required to be unique
in
> > > all SIP messages of a given dialog. </Partha>
> > [JRE] But I think we could nail that down as a requirement of the
> > SIPREC protocol.
> >
> > John (as individual)
> >
> > >
> > > Thanks
> > > Partha
> > >
> > > John (as individual)
> > >
> > > >
> > > > Thanks
> > > > Partha
> > > >
> > > > -----Original Message-----
> > > > From: Charles Eckel (eckelcu)
> > > > Sent: Wednesday, May 25, 2011 1:39 AM
> > > > To: Ram Mohan R (rmohanr); Parthasarathi R (partr);
> > 'Elwell, John';
> > > > [email-masked]'
> > > > Subject: RE: [siprec] Can an MS object span several CSs in a
CSG?
> > > >
> > > > Hi Ram,
> > > >
> > > > I think that is many cases, they will be treated as separate MSs
> > > > due to the complexities you mention. However, I am trying to
> > understand if
> > > > Partha feels allowing an SRC to treat them as a single MS is
still
> > > > required. If not, then what is a use case? A concrete example
> > > > would help me, and potentially others, to better understand the
> > > motivation behind
> > > > Partha's requirement for modeling media from multiple CSs
> > > as a single
> > > > MS.
> > > >
> > > > Cheers,
> > > > Charles
> > > >
> > > > > -----Original Message-----
> > > > > From: Ram Mohan R (rmohanr)
> > > > > Sent: Tuesday, May 24, 2011 9:36 AM
> > > > > To: Charles Eckel (eckelcu); Parthasarathi R (partr);
> > > Elwell, John;
> > > > > [email-masked]
> > > > > Subject: RE: [siprec] Can an MS object span several CSs
> > in a CSG?
> > > > >
> > > > > Charles,
> > > > >
> > > > > I did bring about this specific usecase of MMOH/MOH
> > stream being
> > > > > played to different participants earlier and suggested that
> > > > they have
> > > > > to treated as a same MS across multiple CSs
> > (potentially recorded
> > > > using multiple RSs).
> > > > > Refer
> > > > >
> > http://www.ietf.org/mail-archive/web/siprec/current/msg01886.html
> > > > >
> > > > > We had several discussions on it and it and several
> > folks were in
> > > > > favor of treating it as separate MS as there would be
> > > > complexity in DB
> > > > design.
> > > > >
> > > > > Regards,
> > > > > Ram
> > > > >
> > > > >
> > > > > > -----Original Message-----
> > > > > > From: [email-masked]
> > > [mailto:[email-masked]] On
> > > > > > Behalf Of Charles Eckel (eckelcu)
> > > > > > Sent: Tuesday, May 24, 2011 9:11 PM
> > > > > > To: Parthasarathi R (partr); Elwell, John; [email-masked]
> > > > > > Subject: Re: [siprec] Can an MS object span several CSs
> > > in a CSG?
> > > > > >
> > > > > > Hi Partha,
> > > > > >
> > > > > > Is an example of this the same music on hold audio stream
> > > > existing
> > > > > > as the same MS within multiple CSs? If so, then I
> > > understand your
> > > > > > requirement to be that the SRC be able to indicate multiple
> > > > > > instances of this audio stream within several CSs as
> > > > being the same
> > > > > > MS. Is that correct?
> > > > > >
> > > > > > Thanks,
> > > > > > Charles
> > > > > >
> > > > > > > -----Original Message-----
> > > > > > > From: [email-masked]
> > > > [mailto:[email-masked]] On
> > > > > > Behalf Of Parthasarathi R (partr)
> > > > > > > Sent: Tuesday, May 24, 2011 4:26 AM
> > > > > > > To: Elwell, John; [email-masked]
> > > > > > > Subject: Re: [siprec] Can an MS object span several CSs
> > > > in a CSG?
> > > > > > >
> > > > > > > John,
> > > > > > >
> > > > > > > I agree that it is not mandatory to consider recorded
> > > > stream of a
> > > > > > > specific participant in several CS within the same
> > CSG as one
> > > > > > recorded
> > > > > > > stream but SIPREC protocol design MUST NOT restrict a
> > > > SRC in case
> > > > > > > it wishes to design in such a way.
> > > > > > >
> > > > > > > Thanks
> > > > > > > Partha
> > > > > > >
> > > > > > > -----Original Message-----
> > > > > > > From: [email-masked]
> > > > [mailto:[email-masked]] On
> > > > > > Behalf
> > > > > > > Of Elwell, John
> > > > > > > Sent: Tuesday, May 24, 2011 1:06 PM
> > > > > > > To: [email-masked]
> > > > > > > Subject: [siprec] Can an MS object span several CSs
> > in a CSG?
> > > > > > >
> > > > > > > We seem to have consensus that a Media Stream object
> > > > represents a
> > > > > > > recorded media stream, contributed to by one,
> > several or all
> > > > > > > Participants. However, Partha also wrote:
> > > > > > >
> > > > > > > "2) Each MS lifetime related to CSG because participant
> > > > may move
> > > > > > > from one CS to another CS within single CSG and also
> > > > CSG will span
> > > >
> > > > > > > across multiple RS."
> > > > > > >
> > > > > > > I am not sure we had resolved this during earlier
> > > > discussions on
> > > > > > > the scope of an MS object. Although the same
> > Participant can
> > > > > > > participate
> > > > > > in
> > > > > > > several CSs within the same CSG, I don't think the
> > > > recorded media
> > > > > > > streams need to be considered the same. Any other views?
> > > > > > >
> > > > > > > John (as individual)
> > > > > > > _______________________________________________
> > > > > > > siprec mailing list
> > > > > > > [email-masked]
> > > > > > > https://www.ietf.org/mailman/listinfo/siprec
> > > > > > > _______________________________________________
> > > > > > > siprec mailing list
> > > > > > > [email-masked]
> > > > > > > https://www.ietf.org/mailman/listinfo/siprec
> > > > > > _______________________________________________
> > > > > > siprec mailing list
> > > > > > [email-masked]
> > > > > > https://www.ietf.org/mailman/listinfo/siprec
> > > >
> > >
> >
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Tue, 14 Jun 2011 17:45:15 +0530

Hi all,

Sorry for the delay. Just to double confirm everybody understanding with
SIP message example, I added the example with creating new MS and
reusing the same MS as an attachment with this mail. 

Please note that creating new MS is putting SRS implementers to guess
how old MS and new MS are related. Also, few scenario like  Even after
looking into the example, the intention is to use local variable, I'm
ok.

Thanks
Partha

-----Original Message-----
From: Charles Eckel (eckelcu) 
Sent: Friday, June 10, 2011 10:57 PM
To: Leon Portman; Elwell, John; Parthasarathi R (partr); Ram Mohan R

Cheers,
Charles

> Ram Mohan R (rmohanr); [email-masked]
> update messages that CS MS is remains same between different CS.  So I
do prefer to keep it simple and keep it per CS.
> > center scenario wherein customer (participant) is same throughout 
> > the session and agents are changed using transfer service and B2BUA
acts as SRC.
> > support for partial-update.
MS.
> > required in this fashion. During -00 format draft, I thought that 
> > the partial-update is not required but lot of folks raised the 
> > concern that partial update is important. Current, -01 format draft 
> > is designed to support partial-update. Now, You propose to restrict 
> > MS partial-update across CS. IMO, it is a not good idea to restrict 
> > in the protocol level. Anyway, I think that we need others opinion 
> > before conclude here.
> distorting the model just to gain some efficiency improvements in 
> certain cases. To me it is not intuitive that a MS on one CS and an MS

> Participants is common to both CSs. In the transfer-between-agents
example, although one of the Participants is common to the two CSs, this
is not true for the other Participants.
> transfer case, the partial updates would at least have to include:
> updates EITHER (this I think is your proposal):

> am getting at. Looked at this way, the efficiency saving by recycling 
> MS2 for use in consecutive CSs is relatively small. Or perhaps your 
> intention is also to recycle MS1 (this time, the recipient remaining 
> the same but the sender changing). That would reduce the number of 
> deltas slightly further. The impact on XML size might not be quite in 
> proportion to the reduction in the number of deltas, since by
recycling MS2 it has to have a global identifier, not an identifier
local to a CS. Or perhaps it could have an identifier local to a CSG.
> recycled - an SRC could still choose to model it as separate MSs. 
> However, in that case it would still need to use global identifiers
for MSs.

> outside the context of a single CS - I can see advantages and 
> disadvantages. I just want to make sure the group makes an informed
decision.
> > ensure that label for the given RS SDP m-line should have same label

> > as mentioned below in this mail thread. At this moment, I'm favoring

> > URN UUID and not label attribute enhancement.
> >
> > Please read inline
> >
> > Thanks
> > Partha
> >
> > > > of format, it will associate with <send> tag

> > > and likewise MS4 could reference the same SDP m-line as MS2, if we

> > > are concerned about recycling media descriptions in RS SDP.
> > > in all SIP messages of a given dialog. </Partha>
CSG?

> > > > still required. If not, then what is a use case? A concrete 
> > > > example would help me, and potentially others, to better 
> > > > understand the
> > > motivation behind

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 14 Jun 2011 17:03:53 +0200

Partha,

Thanks for the examples. The character count for the delta is about 2500 when a new MS is created compared to about 2100 when the MS is retained. This seems to be in line with my previous gut feeling.

Concerning the need for "SRS implementers to guess how old MS and new MS are related", I don't think they are related, except by having other things in common like a common participant or a common CSG.

John (as individual)

> Sent: 14 June 2011 13:15
> To: Charles Eckel (eckelcu); Leon Portman; Elwell, John; Ram
> Mohan R (rmohanr); [email-masked]

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 14 Jun 2011 11:31:01 -0400

John,

Consider another case: two SRCs in the same CS (perhaps one at each 
"end".) They are both sending metadata about the same CS and MSs.

Suppose they want to cooperate with each other. They have the potential 
to use the same ID to reference the CS, so that the SRS will know they 
are talking about the same one. But with RS-specific MS ids there is no 
way for them to indicate that they are talking about the same MSs. With 
global MS ids, they could accomplish this.

	Thanks,
	Paul

On 6/14/2011 11:03 AM, Elwell, John wrote:
>>>>>> 3) B transfer the call of A&  B to C using REFER, B2BUA
>>>>> converts REFER
>>>>>
>>>>>> to RE-INVITE towards A&  C and A&  C are connected. B2BUA
>>>>> updates RS
>>>>>> with CS2, Participant1 as A&  participant2 as C,
>> MS1(A's media
>>>>>> of format, it will associate with<send>  tag
>>>>> case there is a means to have common MS1.</Partha>
>>>> the need for unique-id in this  requirement</Partha>
>>>>
>>>>> in all SIP messages of a given dialog.</Partha>

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 15 Jun 2011 15:55:12 +0200

Paul,

But if the two SRCs are somehow cooperating to the extent that they can share the same global ID for the CS, could they not also share the same local ID for the MS? Why does it need to be a global ID?

John

> [mailto:[email-masked]] On Behalf Of Paul Kyzivat
> Sent: 14 June 2011 16:31
> To: [email-masked]
> > Thanks for the examples. The character count for the delta
> is about 2500 when a new MS is created compared to about 2100
> when the MS is retained. This seems to be in line with my
> previous gut feeling.
> >
> > Concerning the need for "SRS implementers to guess how old
> MS and new MS are related", I don't think they are related,
> except by having other things in common like a common
> participant or a common CSG.
> >
> > John (as individual)
> >

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 15 Jun 2011 10:42:40 -0400

> But if the two SRCs are somehow cooperating to the extent that they can share the same global ID for the CS, could they not also share the same local ID for the MS? Why does it need to be a global…

They could *know* each other's local id for the MS.
They might even agree to use the *same* value for the local id.

E.g. we have SRC#1 and SRC#2, each using 123 as the local id for the 
"same" stream.

But to the SRS, there is one MS with id SRC#1:123, and another MS with 
SRC#2:123. It does not know they are the same. (That is the point of 
local scoping.)

So even though the two SRCs know they are talking about the same MS they 
have no way to tell that to the SRS.

	Thanks,
	Paul

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 15 Jun 2011 17:53:38 +0200

OK, I understand. So I will go along with the majority. Any other opinions whether we need global ID or local ID for MS?

John

> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: 15 June 2011 15:43
> To: Elwell, John
> Cc: [email-masked]
> > But if the two SRCs are somehow cooperating to the extent
> that they can share the same global ID for the CS, could they
> not also share the same local ID for the MS? Why does it need
> to be a global ID?
>
> transfer-between-agents

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 15 Jun 2011 13:40:29 -0400

There are many ways to skin the unique id cat, depending on what 
problems we most want to optimize:

- the uuid urn we are currently specifying.
   it takes 45 bytes on the wire, but only 16 bytes to store in binary.
   New values can be computed with the cost of an SHA-1 computation
   over something locally unique that need not be large.

- we could invent a way to encode the same kinds of values more
   compactly if on-the-wire size is the concern. For instance,
   with radix 64 the same value could be represented in 22 bytes
   rather than 45.

- if cost of computation is an issue, we could use two-part uuids,
   where one part is as above, and the other part is a simple integer.
   This would take more bytes to transmit and store, but (arguably)
   less computation to generate.

- we could use two-part ids as above, but where one part is
   optional to supply, defaulting to a per-RS value. Normally you
   would only supply one part, but could supply both parts if you
   want to reference an id that doesn't include the RS-default.
   Two-part ids would be large, while one-part ones could be small.
   The overall average would depend on locality - if most ids are
   per-RS then the average would be small. The SRS would still
   have to store both parts, but it could also use optimization
   tricks if it wishes.

IMO the simplest thing is just to go with uuid urns. But the last option 
above would also work for me if people feel the added complexity is 
justified.

	Thanks,
	Paul

---

From: "Henry Lum" <[email-masked]>
Date: Fri, 17 Jun 2011 13:44:21 -0700

I thought the local ID is relative to the CS and not the SRC, meaning
two cooperative SRCs should both refer to a MS as CS#1:1. That said, I
am not objecting to the use of uuid for an MS if this makes
synchronization between SRCs simpler.

However, I still find it confusing to allow an MS to be moved across CS
and participants. I worry that we can abuse the MS semantics to reuse MS
as if it is a physical port of media since an MS is no longer tied to
the lifetime of a CS. Keeping an MS to within a CS makes it clear about
segments of a call when it gets transferred from person to person. It
will be up to the SRS to stitch the segments of a call (multiple MS)
together.

Regards,
Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Paul Kyzivat
Sent: Wednesday, June 15, 2011 10:43 AM
To: Elwell, John
Cc: [email-masked]
Subject: Re: [siprec] Can an MS object span several CSs in a CSG?

On 6/15/2011 9:55 AM, Elwell, John wrote:
> Paul,
>
> But if the two SRCs are somehow cooperating to the extent that they
can share the same global ID for the CS, could they not also share the
same local ID for the MS? Why does it need to be a global ID?

	Thanks,
	Paul

-------------------------------------------------------------------------------------------------------------------
CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain confidential and proprietary information of Alcatel-Lucent and/or its affiliated entities. Access by the intended recipient only is authorized. Any liability arising from any party acting, or refraining from acting, on any information contained in this e-mail is hereby excluded. If you are not the intended recipient, please notify the sender immediately, destroy the original transmission and its attachments and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Copyright in this e-mail and any attachments belongs to Alcatel-Lucent and/or its affiliated entities.

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 17 Jun 2011 17:11:21 -0400

On 6/17/2011 4:44 PM, Henry Lum wrote:
> two cooperative SRCs should both refer to a MS as CS#1:1.

Hmm. I didn't think that is what was proposed.
But it would work as long as the same MS cannot be in two CSs.
(And I have so far been studiously staying out of that discussion.)

	Thanks,
	Paul

> That said, I

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Sat, 18 Jun 2011 02:52:55 +0530

Henry,

<snip> 
</snip>

The clear demarcation exists for transfer from person to person exists
using different CS-id after the transfer.

I'm worried about stitching the segments of a call (session) in case
same media type with multiple MS exists between CS. Say media stream of
same media type MS1 & MS2 in CS1 of participant1 corresponds to MS3 &
MS4 in CS2 of participant2 in single CSG, how to identify MS1
corresponds to MS3 or MS4 in CS2. I agree that it is possible to say
that SRS should have some extended metadata mechanism to achieve to this
but I preferred in case it is handled as part of metadata itself.

As John mentioned below, the local-id is not going to save the bandwidth
in the transfer scenario. Even I tried to see the example with full
metadata XML update (instead of partial update) wherein the size of full
message is less that local-id MS with partial update. I attached the
message for your reference.

Also, global id (URN UUID) will be able to achieve all the functionality
of local-id (XML:id) but not the other way around. Say, SRS does not
want to see the relation between MS1 to MS3 or MS4 in the above
scenario, global id is not going to stop anything.

Regards,
Henry

-----Original Message-----

	Thanks,
	Paul

>> Suppose they want to cooperate with each other. They have the 
>> potential to use the same ID to reference the CS, so that the SRS 
>> will know they are talking about the same one. But with RS-specific 
>> MS ids there is no way for them to indicate that they are talking 
>> about the same MSs. With global MS ids, they could accomplish this.
>>
>>        Thanks,
>>        Paul
>>
>> is about 2500 when a new MS is created compared to about 2100 when 
>> the MS is retained. This seems to be in line with my previous gut 
>> feeling.
>>>
>> MS and new MS are related", I don't think they are related, except by

>> having other things in common like a common participant or a common 
>> CSG.
>>>
>>> John (as individual)
>>>
>>>> To: Charles Eckel (eckelcu); Leon Portman; Elwell, John; Ram Mohan 
>>>> R (rmohanr); [email-masked]
>>>> Sorry for the delay. Just to double confirm everybody understanding

>>>> with SIP message example, I added the example with creating new MS 
>>>> and reusing the same MS as an attachment with this mail.
>>>>

>>>> vacation.
>>>> In light of this better understanding of the use case, I also 
>>>> prefer the option favored by John and Leon to model as a separate 
>>>> MS. In this specific case, I would expect the properties of the MS 
>>>> to change when A is transferred to C, so I expect the overhead in 
>>>> creating
>> a new MS vs.
>>>> reusing the same MS to be minimal and not worth the added 
>>>> complexity to the model.
>>>>
>>>> Cheers,
>>>> Charles
>>>>

>>>> example, although one of the Participants is common to the two CSs,

>>>> this is not true for the other Participants.
>>>>>

------------------------------------------------------------------------
-------------------------------------------
CONFIDENTIALITY NOTICE: This e-mail and any files attached may contain
confidential and proprietary information of Alcatel-Lucent and/or its
affiliated entities. Access by the intended recipient only is
authorized. Any liability arising from any party acting, or refraining
from acting, on any information contained in this e-mail is hereby
excluded. If you are not the intended recipient, please notify the
sender immediately, destroy the original transmission and its
attachments and do not disclose the contents to any other person, use it
for any purpose, or store or copy the information in any medium.
Copyright in this e-mail and any attachments belongs to Alcatel-Lucent
and/or its affiliated entities.

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 20 Jun 2011 12:53:21 +0200

> Sent: 17 June 2011 22:23
> To: Henry Lum; Paul Kyzivat (pkyzivat); Elwell, John
> Cc: [email-masked]
[JRE] What is meant by "MS1 corresponds to MS3 or MS4"? What exactly is this correspondence? I can understand how the two MS are both part of  CSs from the same CSG. I can also understand how they can both be transmitted by the same Participant. I can also understand that they might be for the same media type (e.g., video) and have same content (e.g., slides, current speaker). All this is visible from the metadata. What other aspect of correspondence requires the two MSs to have the same identifier? Or putting the question another way, what harm is done if the two MSs have different identifiers?

John

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Mon, 20 Jun 2011 17:19:27 +0530

John,

<snip>
[JRE] What is meant by "MS1 corresponds to MS3 or MS4"? What exactly is
this correspondence? 
<Partha> For example, Two audio stream (MS1, MS2) without content type
in CS1 by participant1 has to be correspond to an another two audio
stream (MS3, MS4) without content type in CS2 by participant1 under
single CSG1. Here is the question how to identify MS1 to MS3 or MS4?
</Partha>

[JRE] I can understand how the two MS are both part of  CSs from the
same CSG. I can also understand how they can both be transmitted by the
same Participant. I can also understand that they might be for the same
media type (e.g., video) and have same content (e.g., slides, current
speaker). All this is visible from the metadata. 
<Partha> We are in the same page till here. The missing piece is the
relationship for same multiple media types across CS if exist without
content type. Here, I may have concern about some specific case which I
could think of. I'm fine with local MS id in case folks feel that the
above scenario is just one of the corner case for the solution.

I could think of slightly modified proposal in your label attribute
extension. Say CSG1:MSid as the unique-id wherein CSG1 is the globally
unique-id and MSid is the extension of label attribute wherein label
attribute for the given MS is same throughout the given CSG. </Partha>

[JRE]What other aspect of correspondence requires the two MSs to have
the same identifier? 
<Partha> Ram mentioned about multicast scenario in another mail thread
wherein correspondence is required between two MSs. </Partha>

 Or putting the question another way, what harm is done if the two MSs
have different identifiers?

</snip>

Thanks
Partha

-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: Monday, June 20, 2011 4:23 PM
To: Parthasarathi R (partr); Henry Lum; Paul Kyzivat (pkyzivat)
Cc: [email-masked]
Subject: RE: [siprec] Can an MS object span several CSs in a CSG?

> However, I still find it confusing to allow an MS to be moved across 
> CS and participants. I worry that we can abuse the MS semantics to 
> reuse MS as if it is a physical port of media since an MS is no longer

> tied to the lifetime of a CS. Keeping an MS to within a CS makes it 
> clear about segments of a call when it gets transferred from person to

> person. It will be up to the SRS to stitch the segments of a call 
> (multiple MS) together.
> </snip>
>

> same media type with multiple MS exists between CS. Say media stream 
> of same media type MS1 & MS2 in CS1 of participant1 corresponds to MS3

> &
> that SRS should have some extended metadata mechanism to achieve to 
> this but I preferred in case it is handled as part of metadata itself.
[JRE] What is meant by "MS1 corresponds to MS3 or MS4"? What exactly is
this correspondence? I can understand how the two MS are both part of
CSs from the same CSG. I can also understand how they can both be
transmitted by the same Participant. I can also understand that they
might be for the same media type (e.g., video) and have same content
(e.g., slides, current speaker). All this is visible from the metadata.
What other aspect of correspondence requires the two MSs to have the
same identifier? Or putting the question another way, what harm is done
if the two MSs have different identifiers?

John

>
> As John mentioned below, the local-id is not going to save the 
> bandwidth in the transfer scenario. Even I tried to see the example 
> with full metadata XML update (instead of partial update) wherein the 
> size of full message is less that local-id MS with partial update. I 
> attached the message for your reference.
>
> Also, global id (URN UUID) will be able to achieve all the 
> functionality of local-id (XML:id) but not the other way around. Say, 
> SRS does not want to see the relation between MS1 to MS3 or MS4 in the

> above scenario, global id is not going to stop anything.
>
> Regards,
> Henry
>

---

From: "Henry Lum" <[email-masked]>
Date: Tue, 21 Jun 2011 08:42:11 -0700

> Sent: Monday, June 20, 2011 7:49 AM
> To: Elwell, John; Henry Lum; Paul Kyzivat (pkyzivat)
> Cc: [email-masked]
> could think of. 
>I'm fine with local MS id in case folks feel that the

[hlum] I couldn't find the email reference, but is the only
correspondence to require the same identifier is that a CS sends two
media streams with the same media type? Is there a way to further
qualify the media stream beyond media type? 

> > >> is about 2500 when a new MS is created compared to about 2100
when
> > >>>>>> From: Elwell, John
[mailto:[email-masked]]

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Tue, 21 Jun 2011 22:46:56 +0530

Henry,

The mail thread reference for multicast usecase is available at
http://www.ietf.org/mail-archive/web/siprec/current/msg02051.html

Thanks
Partha 

-----Original Message-----
From: Henry Lum [mailto:[email-masked]] 
Sent: Tuesday, June 21, 2011 9:12 PM
To: Parthasarathi R (partr); Elwell, John; Paul Kyzivat (pkyzivat)
Cc: [email-masked]
Subject: RE: [siprec] Can an MS object span several CSs in a CSG?

>I'm fine with local MS id in case folks feel that the  above scenario 
>is just one of the corner case for the solution.
> 

when

> > attachments and do not disclose the contents to any other person, 
> > use it for any purpose, or store or copy the information in any 
> > medium.