Subject: Re: [siprec] Use of RFC 2119 language in the metadata model

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Sun, 19 Jun 2011 09:10:37 +0530

Hi John / All,

I have not seen any views / discussion on this thread.

I am planning to publish draft-ietf-siprec-metadata-01. Before I go
ahead would like to get the opinion on how to go about for this issue. 
Do we want to leave the current language ( use of RFC 2119) as it is for
ver 01 and re-visit later when we merge format in to model ?
OR
Do we want to remove all the normative statements right now(for 01) and
have them (around the format portions) when we merge format and model ?

Let me know your opinions soon. I plan to publish the draft by Monday
evening or Tuesday morning(at the most).

Regards,
Ram

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Elwell, John
> Sent: Thursday, May 12, 2011 12:58 PM
> To: [email-masked]
> Subject: [siprec] Use of RFC 2119 language in the metadata model
> 
> Draft-ietf-metadata-00 makes extensive use of RFC 2119 language. At
> present this is an Informational document (although that does not
> necessarily prevent the use of RFC 2119 language), but eventually we
> anticipate incorporating the format material, and as a result the
> document would target a Proposed Standard. The format stuff clearly
has
> to be implemented by SRCs and SRSs, so I would expect normative
> language around those aspects. However, to draw a clear distinction
> between what has to be implemented and what is just abstract we
> probably need to refrain from RFC 2119 language when just describing
> the abstract model. Views?
> 
> John
> 
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 20 Jun 2011 13:00:50 +0200

Ram,

As there has been no list discussion on this, in follow-up to my question, I suggest you keep the RFC 2119 language as is in -01 and revisit when we merge the format stuff into the draft (see my separate email on that topic). You may wish to add it to your slides as an open issue for discussion at the meeting (put it at the end).

John

> From: Ram Mohan R (rmohanr) [mailto:[email-masked]] 
> Sent: 19 June 2011 04:41
> To: Elwell, John; [email-masked]
> Subject: RE: [siprec] Use of RFC 2119 language in the metadata model
> 
> Hi John / All,
>

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Mon, 20 Jun 2011 16:59:39 +0530

John,

Thanks for response. I kept the language as it is and posted the draft.
Also I have added a point in slides(of June 23 interim) to track this
item.

Regards,
Ram

> From: Elwell, John [mailto:[email-masked]]
> Sent: Monday, June 20, 2011 4:31 PM
> To: Ram Mohan R (rmohanr); [email-masked]
> As there has been no list discussion on this, in follow-up to my
> question, I suggest you keep the RFC 2119 language as is in -01 and
> revisit when we merge the format stuff into the draft (see my separate
> email on that topic). You may wish to add it to your slides as an open
> issue for discussion at the meeting (put it at the end).
> 
> John
> 
>