Subject: [siprec] Draft-portman-siprec-protocol-04 - comment on option tag usage

From: "Elwell, John" <[email-masked]>
Date: Mon, 20 Jun 2011 15:17:41 +0200

"When a user agent inserts a Require header field with the option tag
   record-aware, the UAS MUST only provide recording indications through
   the media level SDP."
Can we have some discussion on whether we really need this? Putting an option tag in a Require header field is normally only done when absolutely essential, since it will result in request rejection (or call rejection in the case of an initial INVITE request) if the option concerned is not supported. I rather doubt we would want a CS to fail just because one of the UAs is not recording-aware.

John

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 20 Jun 2011 11:30:35 -0400

> Can we have some discussion on whether we really need this? Putting an option tag in a Require header field is normally only done when absolutely essential, since it will result in request rejectio…

Are you asking whether we need the option? Or whether we need this 
statement about behavior when the option is mentioned in a Require header?

AFAIK we are agreed on having the option.

Once it exists, there is the potential to put it in a Require header, 
whether this is a good idea or not.

3261 already says what should happen if an option is present in a 
Require header. I don't think we need to talk about that.

But mentioning an option in Require, or Supported, *does not* ensure 
that the behavior associated with the option will be *used*. If we 
wanted to have a way to do that we would have to add some additional 
syntax some place.

I will also note that technically, mentioning an option in Require does 
not imply that it is also supported by the UA sending the message with 
the Require header.

What we get with an option, and placement of it in Supported, is that 
then the SRC *MAY* send the indication of recording in the signaling. 
That is the part we care about. If we have a need to *REQURE* that the 
indication be sent in signaling, we need more mechanism than simply options.

	Thanks,
	Paul

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 20 Jun 2011 17:37:44 +0200

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Paul Kyzivat
> Sent: 20 June 2011 16:31
> To: [email-masked]
> Subject: Re: [siprec] Draft-portman-siprec-protocol-04 - 
> comment on option tag usage
> 
> 
> 
> > Can we have some discussion on whether we really need this? 
> Putting an option tag in a Require header field is normally 
> only done when absolutely essential, since it will result in 
> request rejection (or call rejection in the case of an 
> initial INVITE request) if the option concerned is not 
> supported. I rather doubt we would want a CS to fail just 
> because one of the UAs is not recording-aware.
> 
[JRE] I am only asking about Require.

> AFAIK we are agreed on having the option.
[JRE] Quite so.

> wanted to have a way to do that we would have to add some additional 
[JRE] I think there might be precedents for specifications that define option tags to say they MUST NOT or SHOULD NOT be used in Require, although I don't have examples to hand. I wondered whether we needed to do something similar.

John

> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 20 Jun 2011 12:10:15 -0400

> [JRE] I think there might be precedents for specifications that define option tags to say they MUST NOT or SHOULD NOT be used in Require, although I don't have examples to hand. I wondered whether…

I see little point to that. It simply provides another potential error.
Using the option in Require is a stupid thing to do in any case that I 
can think of. But you can't legislate against stupidity. There is no 
incremental cost to a UA for handling the receipt of this option in a 
Require, so why worry about it?

If anything, perhaps we could just include a *note* on the futility of 
using it in Require, and just leave it at that.

	Thanks,
	Paul

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 20 Jun 2011 20:38:04 +0200

> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: 20 June 2011 17:10
> To: Elwell, John
> Cc: [email-masked]
> > [JRE] I think there might be precedents for specifications 
> that define option tags to say they MUST NOT or SHOULD NOT be 
> used in Require, although I don't have examples to hand. I 
> wondered whether we needed to do something similar.
> 
[JRE] Yes, that would make sense.

John