Subject: [siprec] Codec parameter in stream element

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Sat, 18 Jun 2011 03:17:45 +0530

Hi all,
 
Codec parameter in stream element is an open issue. It was discussed
during IETF-80 and minutes of IETF-80 about this discussion is mentioned
as a note of this mail. 
 
As per the recent conclusion in metadata, "recording" metadata
information is retrieved from RS SIP headers. In the same way, it is
possible to fetch codec parameter from RS SDP in SRS for codec parameter
related to stream element in metadata as there is a linkage between
stream element and RS SDP using label attribute. Please let me know any
specific issue in fetching from RS SDP in SRS. 
 
Including John, Paul, Hadriel in this mail thread for aiming at the
closure atleast during this interim meeting.
 
Thanks
Partha
 
Note: IETF-80 Minutes:
 
Slide 18: Open issue: Codec parameter in stream element. John Elwell
(from 
floor) disliked duplication, but thought there was a need to consider
what 
information needs to be passed up to the application at the SRS, e.g.,
the media 
type would be needed. So this could result in a small amount of
duplication to 
provide this in the XML for the application.  Paul Kyzivat was most
concerned 
about the direction attribute, since it is hard to figure out from the
RS SDP 
the direction of the CS media. Paul also felt that the SRS could pass 
information from the RS SDP up to the application if needed, without
necessarily 
requiring that information in XML. Hadriel Kaplan disliked duplication,
although 
the need for information in XML might depend on the RTP model. Will
continue 
discussion on relationship between information in XML and information in
SDP on 
the mailing list.

---

From: Paul Kyzivat <[email-masked]>
Date: Sat, 18 Jun 2011 12:38:04 -0400

Yes, AFAIK we agreed that the codec info in the RS is sufficient - it 
describes the media as it is available to the SRS. It may not be the 
same as what was in the CS, but people were not concerned with knowning 
that.

	Thanks,
	Paul

On 6/17/2011 5:47 PM, Parthasarathi R (partr) wrote:
> Slide 18: Open issue: Codec parameter in stream element. John Elwell (from
> floor) disliked duplication, but thought there was a need to consider what

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 20 Jun 2011 12:57:12 +0200

Yes, I think Paul's summary of where we are is correct.

John 

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: 18 June 2011 17:38
> To: Parthasarathi R (partr)
> Cc: [email-masked]; Elwell, John; [email-masked]
> Subject: Re: Codec parameter in stream element
>

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Mon, 20 Jun 2011 16:33:25 +0530

Paul/John,

Thanks for the confirmation. Based on the below mail thread discussion,
I'm considering "codec parameter in stream element" open item in
metadata format as closed. I'll update the slide for interim meeting
accordingly.

Thanks
Partha 

-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: Monday, June 20, 2011 4:27 PM
To: Paul Kyzivat (pkyzivat); Parthasarathi R (partr)
Cc: [email-masked]; [email-masked]
Subject: RE: Codec parameter in stream element

John 

> same as what was in the CS, but people were not concerned with 
> knowning that.
> 
> 	Thanks,
> 	Paul
> 

> > duplication to provide this in the XML for the application. Paul 
> > Kyzivat was most concerned about the direction attribute, since it 
> > is hard to figure
> out from the
> > RS SDP

> > necessarily requiring that information in XML. Hadriel Kaplan 
> > disliked
> duplication,
> > although
> > continue discussion on relationship between information in XML and
> information in
> > SDP on
> > the mailing list.
>