Subject: Re: [siprec] I-D Action: draft-eckel-siprec-rtp-rec-01.txt

From: "Elwell, John" <[email-masked]>
Date: Fri, 17 Jun 2011 18:35:00 +0200

Charles,

I still have a concern on the wording in section 13. It says:
"If an SRC or SRS is sending RTP, it is RECOMMENDED to use symmetric  
       RTP."
Why would an SRS send RTP (as opposed to RTCP)?

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: 16 June 2011 22:03
> To: [email-masked]
> Subject: I-D Action: draft-eckel-siprec-rtp-rec-01.txt
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> 
> 	Title           : Real-time Transport Protocol (RTP) 
> Recommendations for SIPREC
> 	Author(s)       : Charles Eckel
> 	Filename        : draft-eckel-siprec-rtp-rec-01.txt
> 	Pages           : 11
> 	Date            : 2011-06-16
> 
>    This document provides recommendations and guidelines for RTP and
>    RTCP in the context of SIPREC.  This document exists as a 
> standalone
>    document to facilitate discussion of the RTP 
> recommendations, and it
>    is anticipated that portions of this document will be incorporated
>    into [I-D.portman-siprec-protocol] rather than this document itself
>    being adopted as a working group document.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-eckel-siprec-rtp-rec-01.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> This Internet-Draft can be retrieved at:
> ftp://ftp.ietf.org/internet-drafts/draft-eckel-siprec-rtp-rec-01.txt
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 17 Jun 2011 11:55:59 -0700

Hi John,

I tried to address this concern by handling RTP and RTCP separately:

   If an SRC or SRS is sending RTP, it is RECOMMENDED to use symmetric
   RTP.  If an SRC or SRS is sending RTCP, it is RECOMMENDED to use
   symmetric RTCP.

I agree that the SRS will generally not need to send RTP, and that only
the RTCP recommendation will apply to the SRS, but I did not want to
exclude it and did not see the harm in including the SRS in the
considerations for RTP. I you think it is better to change to:

   If an SRC is sending RTP, it is RECOMMENDED to use symmetric
   RTP.  If an SRC or SRS is sending RTCP, it is RECOMMENDED to use
   symmetric RTCP.

Cheers,
Charles

> From: Elwell, John [mailto:[email-masked]]
> Sent: Friday, June 17, 2011 9:35 AM
> To: [email-masked]; Charles Eckel (eckelcu)
> Subject: RE: I-D Action: draft-eckel-siprec-rtp-rec-01.txt
> 
> Charles,
>

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 20 Jun 2011 10:31:16 +0200

Charles,

What I had in mind was something along the following lines:
"It is RECOMMENDED to use symmetric RTP. Although an SRS will not normally transmit RTP, it will transmit RTCP as well as receiving RTP and RTCP. Likewise, although an SRC will not normally receive RTP, it will receive RTCP as well as transmitting RTP and RTCP."

Your latest proposal seems to suggest that sending RTCP is optional, and I am not sure we want to condone that.

John

> From: Charles Eckel (eckelcu) [mailto:[email-masked]] 
> Sent: 17 June 2011 19:56
> To: Elwell, John; [email-masked]

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 20 Jun 2011 08:56:36 -0700

Hi John,

Other comments I have received on this section have been to address RTP
and RTCP separately. In order to address your concern as well as these,
how about the following:

When sending RTP, it is RECOMMENDED to use symmetric RTP. When sending
RTCP, it is RECOMMENDED to use symmetric RTCP. Although an SRS will not
normally send RTP, it will send RTCP as well as receive RTP and RTCP.
Likewise, although an SRC will not normally receive RTP, it will receive
RTCP as well as send RTP and RTCP.

Cheers,
Charles

> Sent: Monday, June 20, 2011 1:31 AM
> To: Charles Eckel (eckelcu); [email-masked]
> "It is RECOMMENDED to use symmetric RTP. Although an SRS will not
normally transmit RTP, it will
> transmit RTCP as well as receiving RTP and RTCP. Likewise, although an
SRC will not normally receive
> RTP, it will receive RTCP as well as transmitting RTP and RTCP."
> 
> Your latest proposal seems to suggest that sending RTCP is optional,
and I am not sure we want to
> condone that.

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 20 Jun 2011 20:48:49 +0200

Might work, but is the term "symmetric RTCP" a well-established term?

John

> Sent: 20 June 2011 16:57
> > > > >    into [I-D.portman-siprec-protocol] rather than 
> this document
> > > itself

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 20 Jun 2011 13:19:27 -0700

Yes, both are defined in RFC 4961.

Cheers,
Charles

> Sent: Monday, June 20, 2011 11:49 AM

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 21 Jun 2011 08:16:17 +0200

Charles,

Sorry, I should have checked. In that case, I certainly like your words.

John 

> Sent: 20 June 2011 21:19
> > > > > > From: Elwell, John 
> [mailto:[email-masked]]

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 21 Jun 2011 08:27:14 -0700

No worries, and thank you for reviewing. I hope others can have a look
as well. So far I have not received any comments outside of yours from
SIPREC, nor have I received any from AVT.
Would it help if I put a few slides together for Thursday's interim
meeting?

Cheers,
Charles 

> Sent: Monday, June 20, 2011 11:16 PM
> > > > > > I agree that the SRS will generally not need to send RTP,
and
> > > > > > that only

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 21 Jun 2011 17:31:24 +0200

Charles,

I really wanted some list discussion, but we have some time at the end so by all means put some slides together and we will try to get discussion going at the meeting if not before.

Thanks,

John

> Sent: 21 June 2011 16:27
> > > > > normally send RTP, it will send RTCP as well as 
> receive RTP and
> > > RTCP.
> > > > > > >    If an SRC or SRS is sending RTP, it is 
> RECOMMENDED to use
> > > > > symmetric
> > > > > > > > "If an SRC or SRS is sending RTP, it is 
> RECOMMENDED to use
> > > > > symmetric
> > > > > > > >        RTP."
> > > > > > > > >    This document provides recommendations and 
> guidelines
> > > > > > > for RTP and
> > > > > > > > >    is anticipated that portions of this 
> document will be
> > > > > > > incorporated