Subject: Re: [siprec] What does an MS object represent? Can we pick one of theseoptions?

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 10 Jun 2011 10:36:07 -0700

Hi John,

Given that the syntax for the content attribute in RFC 4796 allows for
the assignment of additional extension values:

       content-attribute   = "a=content:" mediacnt-tag
       mediacnt-tag        = mediacnt *("," mediacnt)
       mediacnt            = "slides" / "speaker" / "sl" / "main"
                             / "alt" / mediacnt-ext
       mediacnt-ext        = token

do you still think it is not rich enough? It seems to be that given the
content and label attributes plus the grouping framework, we can express
pretty complex and detailed relationships. That said, it may be simpler
to express in metadata than in SDP. Is that the motivation?

Cheers,
Charles 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf Of Elwell, John
> Sent: Tuesday, May 24, 2011 11:15 PM
> To: Paul Kyzivat (pkyzivat); Ram Mohan R (rmohanr)
> Cc: [email-masked]
> Subject: Re: [siprec] What does an MS object represent? Can we pick
one of theseoptions?
> 
> Given that SDP's a=content might not be rich enough, I think we need
to define something new for
> metadata, independent of a=content. The SRC could choose to derive the
metadata content attribute from
> the a=content attributes of the contributing CS streams (that is an
SRC decision), but should not use
> the a=content label in the RS SDP.
> 
> John (as individual)
> 
> > -----Original Message-----
> > From: Paul Kyzivat [mailto:[email-masked]]
> > Sent: 24 May 2011 18:07
> > To: Ram Mohan R (rmohanr)
> > Cc: Elwell, John; [email-masked]
> > Subject: Re: [siprec] What does an MS object represent? Can
> > we pick one of theseoptions?
> >
> >
> >
> > On 5/24/2011 12:52 PM, Ram Mohan R (rmohanr) wrote:
> > > Paul/ John,
> > >
> > > I am ok to add attribute "content" in MS block of the model.
> > >
> > > The question is do we want to map this attribute in the model to
> > > 1) The Session Description Protocol (SDP) Content Attribute
> > defined in
> > > RFC 4796 OR
> > > 2)define our own content in the metadata XML which can take
> > values as
> > > "audio" / "main video" / "presentation video" / "current
> > speaker video"
> > > as suggested by John.
> >
> > Well...
> >
> > ISTM that if there is already an a=content in the CS SDP,
> > then we would
> > want to report that in the metadata.
> >
> > If there is a pair (one from offer, one from answer, same
> > m-line offset)
> > and there is *not* an a=content that pairs them, then we
> > would want to
> > report it anyway.
> >
> > But if we do that we have a problem with names and conflicts.
rfc4796
> > doesn't define a lot of names, nor does it say whether corresponding
> > streams in offer & answer must have the same names.
> >
> > So I think we have something similar but not quite the same,
> > and we need
> > to define something new. It must permit identifying streams
> > even though
> > we know nothing of their purpose.
> >
> > 	Thanks,
> > 	Paul
> >
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 14 Jun 2011 17:24:01 +0200

Charles,

I think it was Paul who first suggested that a=content might not be rich enough, and I was just discussing the consequences. So perhaps Paul should respond.

John

> From: Charles Eckel (eckelcu) [mailto:[email-masked]] 
> Sent: 10 June 2011 18:36
> To: Elwell, John; Paul Kyzivat (pkyzivat); Ram Mohan R (rmohanr)
> Cc: [email-masked]
> Subject: RE: [siprec] What does an MS object represent? Can

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 14 Jun 2011 11:46:09 -0400

> I think it was Paul who first suggested that a=content might not be rich enough, and I was just discussing the consequences. So perhaps Paul should respond.

Its all about namespaces, and being able to distinquish annotations 
supplied by the SRC from those already present in the CS. For instance, 
if the MS in the RS is a mix of multiple CS media streams that have 
differing a=content values, it would be difficult to represent that 
using a=content in the RS SDP using a=content.

There are probably lots of ways to skin that cat. We are just hand 
waving right now. I don't know how deep we want to go with that in the 
metamodel.

	Thanks,
	Paul

>>>> streams in offer&  answer must have the same names.
>>>>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 14 Jun 2011 08:58:03 -0700

Hi Paul,

My first thought is that mixing CS MSs with different a=content values
into a single RS MS is something that should probably be avoided. I do
not think reusing the a=content attribute for the RS MS complicates
this. If you wanted to mix CS1 MS1 and CS1 MS2 with different content
attributes into a single RS MS, you could include the following:

a:content=CS1-MS1-content-attribute-value
CS1-MS2-content-attribute-value

Cheers,
Charles

> From: Paul Kyzivat (pkyzivat)
> Sent: Tuesday, June 14, 2011 8:46 AM
> To: Elwell, John
> Cc: Charles Eckel (eckelcu); Ram Mohan R (rmohanr); [email-masked]
one of theseoptions?
> > I think it was Paul who first suggested that a=content might not be
rich enough, and I was just
> discussing the consequences. So perhaps Paul should respond.
>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 14 Jun 2011 12:18:27 -0400

On 6/14/2011 11:58 AM, Charles Eckel (eckelcu) wrote:
> into a single RS MS is something that should probably be avoided.

Yeah, certainly in cases of conflict. Not so clear if there is an 
a=content in one direction and none in the other.

We may eventually need some sort of BCP or informational document with 
guidelines on how to use all this stuff.

> I do

Do we then know (or care) which came from which participant?

Yes, I know I am getting really picky here, and it probably doesn't 
matter. Maybe we can somehow just leave the details of how to do this to 
the mechanism.

	Thanks,
	Paul

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 14 Jun 2011 14:09:12 -0700

I was thinking that in the metadata you would have the SDP for both CS1
MS1 and CS2 MS2, and then in the RS you would include the content
attribute in the example provided below.

Cheers,
Charles

> Sent: Tuesday, June 14, 2011 9:18 AM
> To: Charles Eckel (eckelcu)
> Cc: Elwell, John; Ram Mohan R (rmohanr); [email-masked]
one of theseoptions?
> >>>> Given that the syntax for the content attribute in RFC 4796
allows
> > for

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 14 Jun 2011 17:17:37 -0400

> attribute in the example provided below.

IIRC there was once some discussion in passing of whether we should 
include all the CS sdp in the metadata, and the decision was "no" - we 
would call out in the metamodel all the stuff that we wanted to carry.

Can somebody confirm/deny that?

	Thanks,
	Paul

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 15 Jun 2011 08:55:24 +0530

> Sent: Wednesday, June 15, 2011 2:48 AM
one
> of theseoptions?

Yes we agreed that there is no need/requirement to pass the entire CS
SDP in metadata. Here is one of the mail thread for the same from
archives
http://www.ietf.org/mail-archive/web/siprec/current/msg01581.html

Ram

> >> matter. Maybe we can somehow just leave the details of how to do
> this
> > to
> >> the mechanism.
> >>
> >> 	Thanks,
> >> 	Paul
> >>
> >>> Cheers,
> >>> Charles
> >>>
> >>>> waving right now. I don't know how deep we want to go with that
in
> > the
> >>>>>>> Given that SDP's a=content might not be rich enough, I think
we
> >>> need
> >>>>>>> the a=content attributes of the contributing CS streams (that
> is
> >>> an
> >>>>>>>>> The question is do we want to map this attribute in the
model
> > to

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 15 Jun 2011 08:55:37 +0200

I think Paul's recollection is correct.

John 

> Sent: 14 June 2011 22:18
> >> matter. Maybe we can somehow just leave the details of how 
> to do this
> > to
> >> the mechanism.
> >>
> >> 	Thanks,
> >> 	Paul
> >>
> >>> Cheers,
> >>> Charles
> >>>
> >>>> waving right now. I don't know how deep we want to go 
> with that in
> > the
> >>>> metamodel.
> >>>>
> >>>> 	Thanks,
> >>>> 	Paul
> >>>>
> >>>>> John
> >>>>>
> >>>>>
> >>>>>>> Given that SDP's a=content might not be rich enough, 
> I think we
> >>> need
> >>>>>>> the a=content attributes of the contributing CS 
> streams (that is
> >>> an
> >>>>>>>>> The question is do we want to map this attribute in 
> the model
> > to