Subject: [siprec] SIPREC Protocol draft and merge of draft-eckel-siprec-rtp-rec-03

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 1 Mar 2012 16:20:49 +0100

Hi All,

We still have a place holder in draft-ietf-siprec-protocol for including text from draft-eckel-siprec-rtp-rec-03.

What is holding is up with this do we need more review from AVT experts or is it something else?

I see from the Taipei minutes that "section 4.3 needs more text about various usages of RTP by mixers/translators".

Charles, can you initiate discussion on the list to move this forward or let me know what other action we need to take.

Regards
Andy (SIPREC Co-Chair).

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 2 Mar 2012 09:20:21 -0800

Hi Andy,

Based on the comments and discussion at IETF 83, I think the following
additions to the draft would be beneficial:

1) SSRC based multiplexing
Explicitly mention multiplexing using SSRC, not RTP session
multiplexing, and illustrate how a two party call may be recorded by a
B2BUA acting as an SRC, using either multiple m-lines or a single m-line
toward the SRS.

Note, there was some discussion regarding two separate calls being
recorded in a single RS with single m-line? I do not think we need to
dive into this, but we can if others think it is important to do so.

2) Split personality SRC
draft-eckel-siprec-rtp-rec-03 describes the RTP/RTCP handling expected
by SIPREC SRCs and SRSs, as well as SIPREC aware UAs and unaware UAs. In
addition to the models stated currently, there is also a model in which
the SRC acts as an RTP/RTCP translator toward the UAs within the CS(s),
and as an RTP/RTCP endpoint toward the SRS for the corresponding RS. I
have not gotten my head around this model completely, but I think it may
be a useful exercise to discuss and perhaps add corresponding text to
the draft.

Cheers,
Charles

> -----Original Message-----
> From: Hutton, Andrew [mailto:[email-masked]]
> Sent: Thursday, March 01, 2012 7:21 AM
> To: Charles Eckel (eckelcu); Henry Lum; [email-masked]
> Cc: [email-masked]
> Subject: SIPREC Protocol draft and merge of
draft-eckel-siprec-rtp-rec-
> 03
> 
> Hi All,
> 
> We still have a place holder in draft-ietf-siprec-protocol for
> including text from draft-eckel-siprec-rtp-rec-03.
> 
> What is holding is up with this do we need more review from AVT
experts
> or is it something else?
> 
> I see from the Taipei minutes that "section 4.3 needs more text about
> various usages of RTP by mixers/translators".
> 
> Charles, can you initiate discussion on the list to move this forward
> or let me know what other action we need to take.
> 
> Regards
> Andy (SIPREC Co-Chair).

---

From: "Hutton, Andrew" <[email-masked]>
Date: Fri, 9 Mar 2012 15:49:49 +0100

Hi Charles,

See below.

Regards
Andy

> From: Charles Eckel (eckelcu) [mailto:[email-masked]]
> Sent: 02 March 2012 17:20
> To: Hutton, Andrew; Henry Lum; [email-masked]
> Cc: [email-masked]
> Subject: RE: SIPREC Protocol draft and merge of draft-eckel-siprec-rtp-
> rec-03
> 
> Hi Andy,
> 

[AndyH] - Wow so you really can see the future.

> B2BUA acting as an SRC, using either multiple m-lines or a single m-

[AndyH] - Yes I think we need this but need to be careful about not replicated what is in the protocol draft especially if we decide to keep the RTP draft separate (See next e-mail).

> dive into this, but we can if others think it is important to do so.

[AndyH] - I am thinking we might need to say whether this is allowed or not especially if the metadata cannot support it. It relates to section 4.2 of your draft which we might need to add some clarification.

> be a useful exercise to discuss and perhaps add corresponding text to

[AndyH] - Maybe I also have not got me head around that yet.