Subject: [siprec] Draft Minutes from SIPREC session

From: "Stach, Thomas" <[email-masked]>
Date: Fri, 30 Mar 2012 11:07:45 +0200

Brian, Andy,

below are my minutes. 
Please scan through and correct if I got something wrong.

Kind Regards
Thomas

SIPREC WG - IETF 83. 

0905 - 0910    5 mins           Chairs                        WG Status Update 

WGLC closes on April 6th. Comments were solicited

0910 - 0925            15 mins              Leon Portman                    SIPREC Architecture draft                 http://tools.ietf.org/html/draft-ietf-siprec-architecture-04  

Honoring "Not record" preference of a UA. Editor wants input if this could be made mandatory?
Need for 3.1.3 proposals to either remove or to make clear that the items in the draft are not exhaustive.
On SRS initiated recording: Wording seems to imply that recording is mandatory, text needs clarification

0925 - 0955            30 mins              Henry Lum                        SIPREC Protocol    http://tools.ietf.org/html/draft-ietf-siprec-protocol-03  

Metadata mandatory to implement?
Difficulty to verify this, if no metadata is actually available to be sent. 
It was proposed that metadata is to be sent at the time of initial offer/answer. 
It is hard to mandate it for persistent recording. Metadata might not be available at the time of establishment of recording session, later on e.g. in snapshot requests it would have to be provided.
Text needs to be make the different scenarios as clear as possible.

Conclusion: Mandatory to implement, but only mandatory to be sent when available.

Does the draft need to mention the difference in recording a CS that uses SDES vs. DTLS-SRTP for security? This has no impact on the protocol, but probably needs to be mentioned elsewhere e.g. in RTP model. It was proposed the seek advice from security directorate/experts. Richard Barnes volunteered to do this.

0955 - 1020            25 mins              Partha Ravindran               SIPREC Metadata http://tools.ietf.org/html/draft-ietf-siprec-metadata-06  

Agreement on slides 1-6, 
Slide 7: Start/Stop time attributes will be added.
Slide 8 (BT use case for Trading/Touret system): 
Recording of several CSs mixed into a single RS.
Other example is recording of two way radio. 
The associated semantics will be documented, update of use cases draft necessary?
Further list discussion needs to happen to identify other potential use cases and their associated semantics.

Due to the involved complexity it was proposed to work on a document showing various examples of the whole picture.

WGLC premature, wait for outcome of ongoing list discussion.

1020 - 1050            25 mins              Charles Eckel                    RTP Recommendations for SIPREC                 http://tools.ietf.org/html/draft-eckel-siprec-rtp-rec-03  

Slide 7: RCTP support proposed to be at SHOULD strength in order to cover e.g. SIP UA without RTCP support.
Slide 8: Providing CNAME/SSRC/CSRC could be useful, but should be kept optional.
Slide 9: no objections
Slide 10: no decision on whether to include into protcol document or have separate document, took to the list

---

From: Brian Rosen <[email-masked]>
Date: Fri, 30 Mar 2012 05:24:06 -0400

Thanks!  Great work.

Brian