Subject: [siprec] I-D Action: draft-ietf-siprec-metadata-06.txt

From: [email-masked]
Date: Mon, 12 Mar 2012 09:59:12 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the SIP Recording Working Group of the IETF.

	Title           : Session Initiation Protocol (SIP) Recording Metadata
	Author(s)       : Ram Mohan Ravindranath
                          Parthasarathi Ravindran
                          Paul Kyzivat
	Filename        : draft-ietf-siprec-metadata-06.txt
	Pages           : 48
	Date            : 2012-03-12

   Session recording is a critical requirement in many communications
   environments such as call centers and financial trading.  In some of
   these environments, all calls must be recorded for regulatory,
   compliance, and consumer protection reasons.  Recording of a session
   is typically performed by sending a copy of a media stream to a
   recording device.  This document describes the metadata model as
   viewed by Session Recording Server(SRS) and the Recording metadata
   format.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-siprec-metadata-06.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-siprec-metadata-06.txt

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Tue, 13 Mar 2012 10:12:01 +0000

Hi all,

IETF-82 SIPREC meeting consensus and other SIPREC mailing consensus after -05 revision of metadata draft are updated in this revision. Summary of changes between -05 and -06 are as follows:

1) The association between participant and CS is changed as 0..* from 2..*
2) Associate-time and disassociate-time attributes in CS are moved to ParticipantCSAssociation
3) CSRSassociation metadata element creation to indicate the attributes related to CS and RS.
4) participantsessionassoc XML element is added to represent participant and session associated XML elements.
5) CSRC attribute is removed from participantstreamassociation object
6) ParticipantStreamAssoc XML element is introduced for association between participant and stream XML element.
7) Sec 7 and Appendix B Example update based on new updated metadata XML Schema
7) Proprietary unique-id usage is shown in Sec 7.1 example
8) XML schema update in Sec 8 based on metadata element changes

Editorial changes
1) Added reference for reason header, p-asserted-identity
2) Changed RFC reference of RFCxxxx[RFCxxxx] to RFCxxxx
3) Changed *MUST* to MUST in Sec 6.5.3

Could you please review the updated metadata draft at http://www.ietf.org/internet-drafts/draft-ietf-siprec-metadata-06.txt and provide your valuable comments.

Thanks
Partha

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of [email-masked]
>Sent: Monday, March 12, 2012 10:29 PM
>To: [email-masked]
>Cc: [email-masked]
>Subject: [siprec] I-D Action: draft-ietf-siprec-metadata-06.txt
>
>
>A New Internet-Draft is available from the on-line Internet-Drafts
>directories. This draft is a work item of the SIP Recording Working
>Group of the IETF.
>
>_______________________________________________
>siprec mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/siprec

---

From: <[email-masked]>
Date: Tue, 13 Mar 2012 17:22:45 +0000

Partha

Section 6.7.3 talks about media mode, but I cant find any such attribute in the xml schema or examples.

Rgds
John Stafford | Solution Architect 1 | BT Global Services 
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Ravindran, Parthasarathi [[email-masked]]
Sent: 13 March 2012 10:12
To: [email-masked]
Subject: [siprec] Change Summary & Review request: I-D Action: draft-ietf-siprec-metadata-06.txt

Hi all,

Editorial changes

Thanks
Partha

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Tue, 13 Mar 2012 17:45:02 +0000

Hi John,

Thanks for pointing to the text which was not removed as part of media mode attribute removal from the draft. I'll remove it in the next revision.

I'll give some background why this attribute was removed in the draft as it may be of your interest. Initially open question was how to represent the mixed stream in the metadata. The simplest solution is to indicate whether the stream is mixed or not-mixed as part of Stream XML itself and the attribute was added. While we discussing the relationship between participant and stream using "send" & "recv" attribute, it was clear that there is no need of explicitly mention using attribute like media mode but "send" by multiple participant for the specific stream will represent mixed stream. Of course, the obvious next question is how to know whether the specific participant is sending the stream at the given time or not. It is not possible using simple SDP or metadata XML wherein CSRC information may be used. As discussed in IETF-82, CSRC attribute has lot of controversy. So, RTCP/RTP (CSRC/SSRC) information is the only available information to know about the contributing source for the recorded mixed stream.

Thanks
Partha

>From: [email-masked] [mailto:[email-masked]]
>Sent: Tuesday, March 13, 2012 10:53 PM
>To: Ravindran, Parthasarathi; [email-masked]
>Subject: RE: [siprec] Change Summary & Review request: I-D Action:
>draft-ietf-siprec-metadata-06.txt
>
>Partha
>
>From: [email-masked] [[email-masked]] On Behalf Of
>Ravindran, Parthasarathi [[email-masked]]
>IETF-82 SIPREC meeting consensus and other SIPREC mailing consensus
>after -05 revision of metadata draft are updated in this revision.
>Summary of changes between -05 and -06 are as follows:
>
>6) ParticipantStreamAssoc XML element is introduced for association
>between participant and stream XML element.
>Could you please review the updated metadata draft at
>and provide your valuable comments.
>
>Thanks
>Partha
>
>>From: [email-masked] [mailto:[email-masked]] On
>>Behalf Of [email-masked]