Subject: [siprec] redundancy of session_id in participantsessionassoc/participant

From: Ofir Roth <[email-masked]>
Date: Wed, 17 Oct 2012 12:04:12 +0200

Hi,

I am reviewing draft-ietf-siprec-metadata-07 and observed the follwoing:

"participant" element contains both session_id and participant_id.
"participantsessionassoc" element is used to associate participant within session (also contains participant_id & session_id attributes as a key).

In that case, what is the point of setting/keeping the session_id within the participant element?

Thanks,
Ofir.

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 17 Oct 2012 16:14:55 +0000

> On 17/10/12 3:34 PM, "Ofir Roth" <[email-masked]> wrote:

>"participantsessionassoc" element is used to associate participant within
>session (also contains participant_id & session_id attributes as a key).
>

<participant> element will not have session_id. This is taken care and
will be updated in the next revision.

Regards,
Ram

> 
> 
>Thanks,
>Ofir.
>
>_______________________________________________
>siprec mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/siprec
>