Subject: [siprec] SIPREC captures

From: Dave Higton <[email-masked]>
Date: Tue, 2 Oct 2012 14:12:38 +0100

Can anyone point me at, or send me, some SIPREC captures, please?  PCAP format preferred, but text of the SIPREC commands and responses would do.

Thank you,

Dave

---

From: Leon Portman <[email-masked]>
Date: Tue, 2 Oct 2012 16:14:48 +0300

On Oct 2, 2012 3:12 PM, "Dave Higton" <[email-masked]> wrote:

> Can anyone point me at, or send me, some SIPREC captures, please?  PCAP
> format preferred, but text of the SIPREC commands and responses would do.*
> ***
>
> ** **
>
> Thank you,****
>
> ** **
>
> Dave****
>
> ** **
>
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>
>

---

From: "Simon Farrow" <[email-masked]>
Date: Wed, 3 Oct 2012 09:14:40 -0700

I am just reposting this request as this would very useful to us as well. 
 
Simon

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Leon Portman
Sent: Tuesday, October 02, 2012 6:15 AM
To: Dave Higton
Cc: [email-masked]
Subject: Re: [siprec] SIPREC captures

Can anyone point me at, or send me, some SIPREC captures, please?  PCAP
format preferred, but text of the SIPREC commands and responses would do.

Thank you,

Dave

---

From: "Parthasarathi R" <[email-masked]>
Date: Wed, 3 Oct 2012 22:58:28 +0530

Hi all,

Sec 4.1 of SIPRE callflow document
(http://tools.ietf.org/html/draft-ram-siprec-callflows-00) captures SIPREC
messages with SDP & metadata XML.  We have received the offline review
comments to put RS SIP, SDP and XML message in the callflow document.  We
will update SIPREC callflow document with SIP messages  in the next
revision.

Thanks

Partha

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Simon Farrow
Sent: Wednesday, October 03, 2012 9:45 PM
To: [email-masked]
Subject: Re: [siprec] SIPREC captures

Simon

  _____  

Thank you,

Dave

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 05 Oct 2012 16:09:39 -0400

IMO there is a great need for more examples, done by different people, 
rather than just having ones done by the authors of the schema. It is 
really important to get different interpretations to expose ambiguities, 
etc.

Ideally we would have examples that are done as captures from real 
implementations. But it would also be helpful to have samples 
constructed by hand for interesting cases.

Once we get some of those it's important that they be widely reviewed. 
Two kinds of reviews are both of interest:
- a review from the perspective of an SRS implementer - commenting on
   whether the example looks correct, semantically clear, and
   able to be supported by an implementation.

- a review from the perspective of an SRC implementer - commenting on
   differences from how the reviewer would have represented the same
   case, and whether the differences are both reasonable alternatives,
   which (if any) is preferable, and whether it makes sense to have
   both alternatives.

	Thanks,
	Paul

On 10/3/12 12:14 PM, Simon Farrow wrote:
> ------------------------------------------------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Leon Portman
> *Sent:* Tuesday, October 02, 2012 6:15 AM
> *To:* Dave Higton
> *Cc:* [email-masked]
> *Subject:* Re: [siprec] SIPREC captures
>
> On Oct 2, 2012 3:12 PM, "Dave Higton" <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Can anyone point me at, or send me, some SIPREC captures, please?
>       PCAP format preferred, but text of the SIPREC commands and
>     responses would do.____
>
>     ____
>
>     Thank you,____
>
>     ____
>
>     Dave____
>
>     ____
>
>
>     [email-masked] <mailto:[email-masked]>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 16 Oct 2012 15:20:33 +0000

Hi All,

As Paul pointed out below we really need more review of example usage of Metadata either of real captures of hand generated examples.

Volunteers would be highly appreciated and if we could have discussion before IETF85 (3 weeks time) that would also be great.

Regards
Andy (SIPREC Co-Chair).

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Paul Kyzivat
> Sent: 05 October 2012 21:10
> To: [email-masked]

---

From: Ofir Roth <[email-masked]>
Date: Wed, 17 Oct 2012 15:38:27 +0200

Hello Andrew,

Attached please find are two examples of call flows: 

1. Simple call between Alice & Bob. Alice hang up the call.
2. Simple call between Alice & Bob. Alice hold/resume the call and then hangs up the call.

I am currently working on more complex scenarios which I will post once they are ready. 
I'll be happy to discuss/get comments about them. 

Thanks,
Ofir.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hutton, Andrew
Sent: Tuesday, October 16, 2012 5:21 PM
To: [email-masked]
Subject: [siprec] SIPREC Metadata Reviewers and examples needed.

Hi All,

Regards
Andy (SIPREC Co-Chair).

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 17 Oct 2012 12:12:37 -0400

Hi Ofir,

Welcome! Are you filling in now that Leon has left Nice?

> Attached please find are two examples of call flows:

Are these constructed manually? Or have they been constructed by a 
software implementation of siprec?

(I appreciate both. Some automated ones would be good because we have a 
chance of getting more complete examples than are feasible manually.)

	Thanks,
	Paul

---

From: Ofir Roth <[email-masked]>
Date: Fri, 19 Oct 2012 21:34:21 +0200

Thanks Paul!

The code examples were constructed by a software. I wrote some code that enables to create call flows pretty easily. 
In addition, I am currently working on some more complex scenarios which I plan to post soon. 

BR,
Ofir.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: Wednesday, October 17, 2012 6:13 PM
To: [email-masked]
Subject: Re: [siprec] SIPREC Metadata Reviewers and examples needed.

Hi Ofir,

> Attached please find are two examples of call flows:

Are these constructed manually? Or have they been constructed by a software implementation of siprec?

(I appreciate both. Some automated ones would be good because we have a chance of getting more complete examples than are feasible manually.)

	Thanks,
	Paul

> Behalf Of Hutton, Andrew
>> IMO there is a great need for more examples, done by different 
>> people, rather than just having ones done by the authors of the 
>> schema. It is really important to get different interpretations to 
>> expose ambiguities, etc.
>>
>>> --------------------------------------------------------------------
>>> -
>> ---