Subject: [siprec] draft-ram-siprec-callflows-01

From: Ofir Roth <[email-masked]>
Date: Wed, 17 Oct 2012 13:15:46 +0200

Hello,

I am reviewing the examples provided in draft-ram-siprec-callflows-01 and noticed that it is not aligned according to draft-ietf-siprec-metadata-07.

For example:

1.       Session element does not contain start/stop time

2.       Participant does not include disassociate-time (as in section 4.5)

If those are known issues, I will appreciate if someone can let me know.

Thanks,
Ofir.

---

From: "Parthasarathi R" <[email-masked]>
Date: Wed, 17 Oct 2012 20:57:48 +0530

Hi Ofir,

Thanks for your review. Please read inline.

Thanks

Partha

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Ofir Roth
Sent: Wednesday, October 17, 2012 4:46 PM
To: [email-masked]
Subject: [siprec] draft-ram-siprec-callflows-01

Hello,

I am reviewing the examples provided in draft-ram-siprec-callflows-01 and
noticed that it is not aligned according to draft-ietf-siprec-metadata-07. 

For example: 

<Partha> I guess that you wish to see the example with start/stop time. We
will add in the

 next revision. 

BTW,start/stop time are optional elements in session.  So, the callflow is 

inline with metadata -07 draft. 

</Partha>

<Partha> Sec 4.5 is call disconnect example and so, disassociate-time
exists. Please let me know the exact location where disassociate-time is
missing. </Partha>

Thanks,
Ofir.

---

From: Ofir Roth <[email-masked]>
Date: Fri, 19 Oct 2012 21:05:35 +0200

Hi,

According to the metadata scheme:

<xs:complexType name="participant">
       <xs:sequence>
           <xs:element name="nameID" type="nameID"
             maxOccurs="1"/>
        <xs:any namespace='##other'
                   minOccurs='0'
                   maxOccurs='unbounded'
                   processContents='lax'/>
       </xs:sequence>
       <xs:attribute name="participant_id" type="xs:base64Binary"
            use="required"/>
       <xs:attribute name="session_id" type="xs:base64Binary"
            use="required"/>
   </xs:complexType>
There is no associate/disassociate time as part of the participant definition while it appears in the call flow example of section 4.5.

And session is defined as follow:

<xs:complexType name="session">
       <xs:sequence>
         <xs:element name="reason" type="xs:string"
                minOccurs="0"/>
         <xs:element name="group-ref" type="xs:base64Binary"
                minOccurs="0" maxOccurs="1"/>
           <xs:any namespace='##other'
                   minOccurs='0'
                   maxOccurs='unbounded'
                   processContents='lax'/>
       </xs:sequence>
       <xs:attribute name="session_id" type="xs:base64Binary"
            use="required"/>
   </xs:complexType>

According to the session definition, session does not contain start/stop time while it appears in call flow document.

I am interested which is the up to date version that should be used (call flow or metadata scheme).

Thanks,
Ofir.

From: Parthasarathi R [mailto:[email-masked]]
Sent: Wednesday, October 17, 2012 5:28 PM
To: Ofir Roth; [email-masked]
Subject: RE: [siprec] draft-ram-siprec-callflows-01

Hi Ofir,

Thanks
Partha

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Ofir Roth
Sent: Wednesday, October 17, 2012 4:46 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [siprec] draft-ram-siprec-callflows-01

Hello,

For example:

1.       Session element does not contain start/stop time
<Partha> I guess that you wish to see the example with start/stop time. We will add in the
 next revision.

</Partha>

2.       Participant does not include disassociate-time (as in section 4.5)
<Partha> Sec 4.5 is call disconnect example and so, disassociate-time exists. Please let me know the exact location where disassociate-time is missing. </Partha>

Thanks,
Ofir.

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Sat, 20 Oct 2012 13:03:10 +0000

Ofir,

The schema in the ver 08 is the latest one. The examples in callflows-01
are not yet in sync with that.

We will publish soon the call flows.
As paul mentioned in the other thread, we appreciate if you have any call
flows from the implementation/software that we can use.

Regards,
Ram

> On 20/10/12 12:35 AM, "Ofir Roth" <[email-masked]> wrote:

>There is no associate/disassociate time as part of the participant
>definition while it appears in the call flow example of section 4.5.
> 
>According to the session definition, session does not contain start/stop
>time while it appears in call flow document.
> 
>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of Ofir Roth
>_______________________________________________
>siprec mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/siprec
>

---

From: Ofir Roth <[email-masked]>
Date: Sun, 21 Oct 2012 00:44:50 +0200

Thanks Ram.

I have posted two scenarios which are aligned according to the metadata draft.
Have you had a chance to check them?

BR,
Ofir.

-----Original Message-----
From: Ram Mohan R (rmohanr) [mailto:[email-masked]] 
Sent: Saturday, October 20, 2012 3:03 PM
To: Ofir Roth; Parthasarathi R; [email-masked]
Subject: Re: [siprec] draft-ram-siprec-callflows-01

Ofir,

The schema in the ver 08 is the latest one. The examples in callflows-01 are not yet in sync with that.

We will publish soon the call flows.
As paul mentioned in the other thread, we appreciate if you have any call flows from the implementation/software that we can use.

Regards,
Ram

>According to the session definition, session does not contain 
>start/stop time while it appears in call flow document.
> 
>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of Ofir Roth
>I am reviewing the examples provided in draft-ram-siprec-callflows-01 
>and noticed that it is not aligned according to 
>draft-ietf-siprec-metadata-07.
> 
>For example: 
> 
>BTW,start/stop time are optional elements in session.  So, the callflow 
>is inline with metadata -07 draft.
> 
></Partha>
> 
>exists. Please let me know the exact location where disassociate-time 
>is missing. </Partha>
>

---

From: "Parthasarathi R" <[email-masked]>
Date: Mon, 22 Oct 2012 22:05:57 +0530

Hi Ofir,

Thanks for the review. Please read inline.

Thanks

Partha

From: Ofir Roth [mailto:[email-masked]] 
Sent: Saturday, October 20, 2012 12:36 AM
To: Parthasarathi R; [email-masked]
Subject: RE: [siprec] draft-ram-siprec-callflows-01

Hi,

       <xs:sequence>

             maxOccurs="1"/>

                   minOccurs='0'

                   maxOccurs='unbounded'

                   processContents='lax'/>

       </xs:sequence>

            use="required"/>

            use="required"/>

   </xs:complexType>

<Partha> This is callflow document issue and the actual XML element is
participantsessionassoc. This is updated in -02 callflow draft </Partha>

       <xs:sequence>

                minOccurs="0"/>

                   minOccurs='0'

                   maxOccurs='unbounded'

                   processContents='lax'/>

       </xs:sequence>

            use="required"/>

   </xs:complexType>

<Partha> This issue is related to XML schema in Metadata draft and has to be
fixed in the next revision as 

There was consensus to add start/stop time as part of the session element
</Partha>

I am interested which is the up to date version that should be used (call
flow or metadata scheme).

Thanks,
Ofir.

Hi Ofir,

Thanks

Partha

Hello,

For example: 

 next revision. 

</Partha>

Thanks,
Ofir.