Subject: [siprec] Review of draft-ietf-siprec-metadata-08

From: Ofir Roth <[email-masked]>
Date: Wed, 24 Oct 2012 10:15:28 +0200

Hi,

I have reviewed the updated draft: draft-ietf-siprec-metadata-08 and I have some comments: regarding the metadata schema:

1.       According to the metadata schema, recording element does not contain any association elements:

1.       sessionrecordingassoc

2.       participantsessionassoc

3.       participantstreamassoc
As a result, there is no way to add those elements as child elements of the recording element.

2.       Session element does not contain start/stop time.

Thanks,
Ofir Roth.

---

From: "Parthasarathi R" <[email-masked]>
Date: Wed, 24 Oct 2012 14:38:46 +0530

Hi Ofir,

Thanks a lot for your review comments. Please read inline.

Thanks

Partha

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Ofir Roth
Sent: Wednesday, October 24, 2012 1:45 PM
To: [email-masked]
Subject: [siprec] Review of draft-ietf-siprec-metadata-08

Hi,

I have reviewed the updated draft: draft-ietf-siprec-metadata-08 and I have
some comments: regarding the metadata schema: 

1.       According to the metadata schema, recording element does not
contain any association elements: 

1.       sessionrecordingassoc

As a result, there is no way to add those elements as child elements of the
recording element.

<Partha> Agreed, recording XML element in sec 8 will be updated in the next
revision to accommodate all these three

elements

<xs:element name="sessionrecordingassoc"

               type="sessionrecordingassoc"

               minOccurs="0" maxOccurs="unbounded"/>

          <xs:element name="participantsessionassoc"

               type="participantsessionassoc"

               minOccurs="0" maxOccurs="unbounded"/>

          <xs:element name="participantstreamassoc"

               type="participantstreamassoc"

               minOccurs="0" maxOccurs="unbounded"/>

</Partha>

<Partha>  Agreed.  In Sec 8,  Session XML element will be updated in the
next revision with the following two elements 

       <xs:element name="start-time" type="xs:dateTime"

                minOccurs="0" maxOccurs="1"/>

       <xs:element name="stop-time" type="xs:dateTime"

                minOccurs="0" maxOccurs="1"/>

Hope the above proposed XML schema helps to close your review comments. 

</Partha>

Thanks,
Ofir Roth.

---

From: Ofir Roth <[email-masked]>
Date: Wed, 24 Oct 2012 11:23:30 +0200

Hi Partha,

I will update the schema according to your comments below and will resend the up to date metadata examples.

Thanks,
Ofir.

From: Parthasarathi R [mailto:[email-masked]]
Sent: Wednesday, October 24, 2012 11:09 AM
To: Ofir Roth; [email-masked]
Subject: RE: [siprec] Review of draft-ietf-siprec-metadata-08

Hi Ofir,

Thanks
Partha

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Ofir Roth
Sent: Wednesday, October 24, 2012 1:45 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [siprec] Review of draft-ietf-siprec-metadata-08

Hi,

1.       sessionrecordingassoc

3.       participantstreamassoc
As a result, there is no way to add those elements as child elements of the recording element.
<Partha> Agreed, recording XML element in sec 8 will be updated in the next revision to accommodate all these three
elements

</Partha>

2.       Session element does not contain start/stop time.
<Partha>  Agreed.  In Sec 8,  Session XML element will be updated in the next revision with the following two elements

Thanks,
Ofir Roth.

---

From: Ofir Roth <[email-masked]>
Date: Wed, 24 Oct 2012 14:22:39 +0200

Hi,

Attached please find are the new simple scenarios aligned with the changes below.
I will appreciate any comment.

Thanks,
Ofir Roth.

From: Ofir Roth
Sent: Wednesday, October 24, 2012 11:24 AM
To: 'Parthasarathi R'; [email-masked]
Subject: RE: [siprec] Review of draft-ietf-siprec-metadata-08

Hi Partha,

From: Parthasarathi R [mailto:[email-masked]]
Sent: Wednesday, October 24, 2012 11:09 AM
To: Ofir Roth; [email-masked]<mailto:[email-masked]>
Subject: RE: [siprec] Review of draft-ietf-siprec-metadata-08

Hi Ofir,

Thanks
Partha

Hi,

1.       sessionrecordingassoc

</Partha>

Thanks,
Ofir Roth.

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 24 Oct 2012 12:18:18 -0400

Hi Ofir,

Thanks for the examples!

One question for you: Is there a reason why you have used the <group> 
element when there is only one <session> in it? While this is valid, I 
would have expected that the group would only be introduced when needed.

	Thanks,
	Paul

On 10/24/12 8:22 AM, Ofir Roth wrote:
> *From:*Ofir Roth
> *Sent:* Wednesday, October 24, 2012 11:24 AM
> *To:* 'Parthasarathi R'; [email-masked]
> *Subject:* RE: [siprec] Review of draft-ietf-siprec-metadata-08
>
> Hi Partha,
>
> *From:*Parthasarathi R [mailto:[email-masked]]
> *Sent:* Wednesday, October 24, 2012 11:09 AM
> *To:* Ofir Roth; [email-masked] <mailto:[email-masked]>
> *Subject:* RE: [siprec] Review of draft-ietf-siprec-metadata-08
>
> Hi Ofir,
>
> *From:[email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]] *On Behalf Of *Ofir Roth
> *Sent:* Wednesday, October 24, 2012 1:45 PM
> *To:* [email-masked] <mailto:[email-masked]>
> *Subject:* [siprec] Review of draft-ietf-siprec-metadata-08
>
> Hi,
>
> I have reviewed the updated draft: draft-ietf-siprec-metadata-08 and I
> have some comments: regarding the metadata schema:
>
> 1.According to the metadata schema, *recording* element does not contain
> any association elements:
>
> *1.**sessionrecordingassoc*
>
> *2.**participantsessionassoc*
>
> *3.**participantstreamassoc*
>
> <Partha> Agreed, recording XML element in sec 8 will be updated in the
> next revision to accommodate all these three
>
> elements
>
> 2.*Session* element does not contain start/stop time.
>
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec
>

---

From: Ofir Roth <[email-masked]>
Date: Wed, 24 Oct 2012 20:06:17 +0200

Hi Paul, 

I guess that when SRC creates the first complete metadata update, it does not have the whole picture which might later contain more than one session. 

Thanks.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: Wednesday, October 24, 2012 6:18 PM
To: [email-masked]
Subject: Re: [siprec] Review of draft-ietf-siprec-metadata-08

Hi Ofir,

Thanks for the examples!

One question for you: Is there a reason why you have used the <group> element when there is only one <session> in it? While this is valid, I would have expected that the group would only be introduced when needed.

	Thanks,
	Paul

On 10/24/12 8:22 AM, Ofir Roth wrote:
> 1.According to the metadata schema, *recording* element does not 
> <Partha>  Agreed.  In Sec 8,  Session XML element will be updated in 
> the next revision with the following two elements
>

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 24 Oct 2012 14:30:38 -0400

> I guess that when SRC creates the first complete metadata update, it does not have the whole picture which might later contain more than one session.

Sure. But why not update to include the group then?

Certainly either way can work. By asking I'm trying to ensure that it is 
understood that either is possible - important for the SRS to know that.

	Thanks,
	Paul