Subject: [siprec] IETF 88 - SIPREC Draft Agenda

From: "Hutton, Andrew" <[email-masked]>
Date: Wed, 23 Oct 2013 15:38:41 +0000

Hi All,

I posted a draft agenda which can be found at: https://datatracker.ietf.org/meeting/88/agenda/siprec/.

Please let me have any requests for changes/additions by Sunday 27th of October.

Regards
Andy

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 23 Oct 2013 15:56:10 +0000

The agenda looks great. One thing I would like to hear is -

Discuss on how to progress these two WG drafts:
http://tools.ietf.org/wg/siprec/draft-ietf-siprec-metadata/
http://tools.ietf.org/wg/siprec/draft-ietf-siprec-callflows/

We have not had much progress on either of these drafts  for quite some
time now due to lack of reviews. Can we get some help here ?

Regards,
Ram

-----Original Message-----
From: <Hutton>, Andrew <[email-masked]>
Date: Wednesday, 23 October 2013 9:08 PM
To: "[email-masked]" <[email-masked]>
Subject: [siprec] IETF 88 - SIPREC Draft Agenda

>Hi All,
>
>I posted a draft agenda which can be found at:
>https://datatracker.ietf.org/meeting/88/agenda/siprec/.
>
>_______________________________________________
>siprec mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/siprec

---

From: "Parthasarathi R" <[email-masked]>
Date: Mon, 28 Oct 2013 21:47:12 +0530

Hi Andy/Brian,

I had raised my concern regarding Metadata draft status
(http://www.ietf.org/mail-archive/web/siprec/current/msg03771.html)  as
there is no much progress for 1 years 3 months (from last Vancouver meeting)
without any changes. The multiple SIPREC implementation exists from
different vendors namely ACME, NICE, AudioCodec, ORCx, HP, Broadsoft
(http://www.linkedin.com/groups/Who-is-using-SIPREC-4263898.S.176535181)
already. The comments from ACME & NICE are already incorporated in the
latest draft. This clearly indicates that the metadata draft is matured
enough to implement. AFAIK, each implementation would have gone through the
draft carefully before implementing and it shall be considered as the
review. Could you please let us know when is the plan to start WGLC for the
metadata drafts or any other blocking draft for this draft.

I'm also interested in knowing whether the new charter will have the impact
in metadata draft. IMO, the new use case has to be considered as an
extension to the metadata drafts.

Thanks
Partha
 
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Ram Mohan R (rmohanr)
> Sent: Wednesday, October 23, 2013 9:26 PM
> To: Hutton, Andrew; [email-masked]
> Subject: Re: [siprec] IETF 88 - SIPREC Draft Agenda
> 
> >Please let me have any requests for changes/additions by Sunday 27th
> of
> >October.
> >
> >Regards
> >Andy

---

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 28 Oct 2013 17:28:23 +0000

Hi Partha,

I understand and share your concern on the lack of progress regarding the metadata draft.

However the following is taken from the minutes of the last IETF meeting in Berlin.

>Metadata draft needs more review there is no presentation during this meeting on metadata.
>Companies implementing SIPREC for NENA are expected to be at an interop event for NG911 implementations scheduled for fall (Nov.?>). 3-4 Implementations expected to be there. Brian will ask the implementers for a review. An experienced IETF reviewer is also >needed. Biggest concern is if all necessary semantic are defined.
>Targeting interop events to look for reviewers.
>- Brian Rosen: NENA (Next Generation 911)
>- Charles Eckel: IMTC SIP Parity groups
>ACTION: Need to find reviewers for metadata draft.

The NENA interop event appears to be planned for next week (Same week as IETF88) maybe Brian can update us this.

The IMTC event will not take place until next May and might not test SIPREC stuff so probably we should not wait for that.

I would really like to encourage those that have implemented the metadata draft to provide feedback on the SIPREC mailing list.

Regards
Andy (SIPREC Co-Chair). 

> From: Parthasarathi R [mailto:[email-masked]]
> Sent: 28 October 2013 16:17
> To: Hutton, Andrew; 'Brian Rosen'
> Cc: 'Ram Mohan R (rmohanr)'; [email-masked]
> Subject: RE: [siprec] IETF 88 - SIPREC Draft Agenda
> 
> Hi Andy/Brian,
>

---

From: "Dave Higton" <[email-masked]>
Date: Mon, 28 Oct 2013 17:31:44 +0000

I am in a position to confirm that ICE 8 (the NENA interop event) is scheduled for next week.  All the signs are that it will go ahead as planned.

Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hutton, Andrew
Sent: 28 October 2013 17:28
To: Parthasarathi R; 'Brian Rosen'
Cc: [email-masked]
Subject: Re: [siprec] IETF 88 - SIPREC Draft Agenda

Hi Partha,

Regards
Andy (SIPREC Co-Chair). 

NICE Systems UK Limited ("NICE") is registered in England under company number, 3403044. The registered office of NICE is at Tollbar Way, Hedge End, Southampton, Hampshire SO30 2ZP.

Confidentiality: This communication and any attachments are intended for the above-named persons only and may be confidential and/or legally privileged. Any opinions expressed in this communication are not necessarily those of NICE. If this communication has come to you in error you must take no action based on it, nor must you copy or show it to anyone; please delete/destroy and inform the sender by e-mail immediately.

Monitoring: NICE may monitor incoming and outgoing e-mails.

Viruses: Although we have taken steps toward ensuring that this e-mail and attachments are free from any virus, we advise that in keeping with good computing practice the recipient should ensure they are actually virus free.

---

From: "Michael Smith" <[email-masked]>
Date: Mon, 28 Oct 2013 13:41:15 -0400

About the NENA interop event (ICE 8) - it is indeed next week. We have about
17 companies that have implemented siprec (either SRC or SRS functionality).
We are testing metadata too. I think that those of us who are also on this
list will be more than happy to provide feedback based on our own
experiences with the drafts.

I think we're all swamped right now getting ready for the event, so bear
with us, and I'm sure we'll have some comments once the smoke has cleared.

- Michael Smith, ICE 8 Planning Committee chair

Michael Smith
Chief Technologist, DSS Corp.
Ph: 606.877.2788 | Mobile: 606.231.0243

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Hutton, Andrew
Sent: Monday, October 28, 2013 1:28 PM
To: Parthasarathi R; 'Brian Rosen'
Cc: [email-masked]
Subject: Re: [siprec] IETF 88 - SIPREC Draft Agenda

Hi Partha,

I understand and share your concern on the lack of progress regarding the
metadata draft.

However the following is taken from the minutes of the last IETF meeting in
Berlin.

>Companies implementing SIPREC for NENA are expected to be at an interop
event for NG911 implementations scheduled for fall (Nov.?>). 3-4
Implementations expected to be there. Brian will ask the implementers for a
review. An experienced IETF reviewer is also >needed. Biggest concern is if
all necessary semantic are defined.
>ACTION: Need to find reviewers for metadata draft.

The NENA interop event appears to be planned for next week (Same week as
IETF88) maybe Brian can update us this.

The IMTC event will not take place until next May and might not test SIPREC
stuff so probably we should not wait for that.

I would really like to encourage those that have implemented the metadata
draft to provide feedback on the SIPREC mailing list.

Regards
Andy (SIPREC Co-Chair). 

> (http://www.ietf.org/mail-archive/web/siprec/current/msg03771.html)  
> as there is no much progress for 1 years 3 months (from last Vancouver
> meeting)
> latest draft. This clearly indicates that the metadata draft is 
> matured enough to implement. AFAIK, each implementation would have 
> gone through the draft carefully before implementing and it shall be 
> considered as the review. Could you please let us know when is the 
> plan to start WGLC for the metadata drafts or any other blocking draft 
> for this draft.
> 
> I'm also interested in knowing whether the new charter will have the 
> impact in metadata draft. IMO, the new use case has to be considered 
> as an extension to the metadata drafts.
> 
> Thanks
> Partha
>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 28 Oct 2013 20:52:10 +0000

Hi Michael,

Thanks feedback from this type of event is exactly what we need to move things forward.

Looking forward to hearing how the event goes.

Regards
Andy

---

From: "Parthasarathi R" <[email-masked]>
Date: Tue, 29 Oct 2013 05:48:27 +0530

Hi Andy and Michael,

Thanks for the info. It will be good to see the feedback from ICE 8.

Also, I hope that the new charter will not impact the metadata draft
progress and the new usecase will incorporate its metadata enhancement in
the respective draft itself.

Thanks
Partha

> From: Hutton, Andrew [mailto:[email-masked]]
> Sent: Tuesday, October 29, 2013 2:22 AM
> To: Michael Smith
> Cc: Hutton, Andrew; Parthasarathi R; Brian Rosen; [email-masked]
> Behalf Of
> >> Metadata draft needs more review there is no presentation during
> this
> > meeting on metadata.

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 29 Oct 2013 12:47:13 -0400

This is great news. I look forward to the feedback.

Even better if you can extract some real life examples from it, to 
replace or supplement the synthetic ones we have now.

	Thanks,	
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 29 Oct 2013 12:45:15 -0400

> the respective draft itself.

It has never been our intent to slow down the existing work. We just 
want to prime the pipeline for things to follow that.

IMO it would be fine for the chairs to do whatever they must to ensure 
work is suitably prioritized.

In my own case, having been involved with the metadata from the 
beginning, I view my part as "done" unless reviews by others identify 
things that need fixing.

	Thanks,
	Paul