Subject: [siprec] One question about draft-ietf-siprec-architecture

From: "Yanqiang (Michael)" <[email-masked]>
Date: Wed, 27 Nov 2013 07:50:24 +0000

Hi All,

	In draft-ietf-siprec-architecture-09, 3.1.4 Interaction with MEDIACTRL, talking about the figure 4, should we use the 'source' instead of 'sink' when AS provides metadata to SRS? 

Original text:
	As shown in figure 4, when the SRC is architected according to [RFC5567] the MS acts as a source of recording media and the AS acts as a sink of the metadata and the termination point for RS SIP signaling.

Propose to change as:
	As shown in figure 4, when the SRC is architected according to [RFC5567] the MS acts as a source of recording media and the AS acts as a source of the metadata and the termination point for RS SIP signaling.

Thanks,
Michael

---

From: "Hutton, Andrew" <[email-masked]>
Date: Wed, 27 Nov 2013 18:01:56 +0000

Hi Michael,

I believe you are correct and as I am about to submit a version 10 I will make the change.

Thanks for reporting this.

Regards
Andy

> -----Original Message-----
> From: siprec [mailto:[email-masked]] On Behalf Of Yanqiang
> (Michael)
> Sent: 27 November 2013 07:50
> To: [email-masked]
> Subject: [siprec] One question about draft-ietf-siprec-architecture
> 
> Hi All,
> 
> 	In draft-ietf-siprec-architecture-09, 3.1.4 Interaction with
> MEDIACTRL, talking about the figure 4, should we use the 'source'
> instead of 'sink' when AS provides metadata to SRS?
> 
> Original text:
> 	As shown in figure 4, when the SRC is architected according to
> [RFC5567] the MS acts as a source of recording media and the AS acts as
> a sink of the metadata and the termination point for RS SIP signaling.
> 
> Propose to change as:
> 	As shown in figure 4, when the SRC is architected according to
> [RFC5567] the MS acts as a source of recording media and the AS acts as
> a source of the metadata and the termination point for RS SIP
> signaling.
> 
> Thanks,
> Michael
> _______________________________________________
> siprec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/siprec

---

From: "Yanqiang (Michael)" <[email-masked]>
Date: Thu, 28 Nov 2013 09:04:02 +0000

Hi Andy,

I got three more questions about 09 version.

1. Why remove the word below ' Possible mechanisms for this include using the Require header or a media feature tag as defined in [RFC3840]' for the 3rd action in 3.2.1? It was removed in 09 version and the comparison file of 08/09, while it existed in 08 version and versions before.

2. Should we change 'SRC' to 'SRS' in the word below ' If the Recording Session is to be started immediately then the SRC will include an SDP attribute of "a=recvonly" for each media line or "a=inactive" if it is not ready to receive the media' in 3.2.2 last action?

3. If use SRS to replace all 'Session Recording Server' in 09 version, why not change all 'Session Recording Client' to SRC as well. Anyway, should protocol document and others use SRC/SRS instead of 'Session Recording Server'/'Session Recording Client'?

Thanks,
Michael

> From: Hutton, Andrew [mailto:[email-masked]]
> Sent: Thursday, November 28, 2013 2:02 AM
> To: Yanqiang (Michael); [email-masked]
> Subject: RE: One question about draft-ietf-siprec-architecture
> 
> Hi Michael,
>