Subject: [sixpac] Drafts on SIP-XMPP combined use

From: <[email-masked]>
Date: Thu, 11 Nov 2010 09:05:42 +0100

Thanks Peter for setting up this list!

Just as a reminder, the relevant I-D for this work is 
http://tools.ietf.org/html/draft-veikkolainen-sip-xmpp-coex-reqs-01

We had an earlier draft containing also the protocol extensions, but that one has been expired. However, you can find it at 
http://tools.ietf.org/html/draft-veikkolainen-sip-voip-xmpp-im

For our first target, I think we should concentrate on getting a set of requirements which is agreeable for all.

Regards,
Simo

---

From: Peter Musgrave <[email-masked]>
Date: Thu, 18 Nov 2010 13:01:02 +0800

Hi Simo, 

A question about REQ-1: 
When it says "SIP Contact" information - does this mean literally the value in the SIP Contact: header? 

I think it might need to be the AOR - since that is required to be a FQDN and publicly reachable, whereas a contact header value might not be. However, in the case where the AOR has multiple contacts registered, would we require GRUU to specify which one is to be called?

Is the requirement that the information provided allow for the specific UA instance to be contacted when this identity information is conveyed over XMPP?

REQ-3: Can you elaborate on "real time media contact and status" ? I am not sure what the requirement is asking for. An indication that an audio or video session simply exists - or details down to the port, CODEC etc. ???

Regards, 

Peter Musgrave

On 2010-11-11, at 4:05 PM, <[email-masked]> <[email-masked]> wrote:

> _______________________________________________
> sixpac mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sixpac

---

From: <[email-masked]>
Date: Fri, 19 Nov 2010 09:26:43 +0100

>-----Original Message-----
>From: ext Peter Musgrave [mailto:[email-masked]]
>Sent: 18 November, 2010 07:01
>To: Veikkolainen Simo (Nokia-MS/Helsinki)
>Cc: [email-masked]
>Subject: Re: [sixpac] Drafts on SIP-XMPP combined use
>
>Hi Simo,
>
>A question about REQ-1:

No, what is meant here is the information by which a SIP request can be routed to the endpoint, meaning basically an AOR or GRUU.

>I think it might need to be the AOR - since that is required to be a
>FQDN and publicly reachable, whereas a contact header value might not
>be. However, in the case where the AOR has multiple contacts registered,
>would we require GRUU to specify which one is to be called?
>
>Is the requirement that the information provided allow for the specific
>UA instance to be contacted when this identity information is conveyed
>over XMPP?

Yes.

>REQ-3: Can you elaborate on "real time media contact and status" ? I am
>not sure what the requirement is asking for. An indication that an audio
>or video session simply exists - or details down to the port, CODEC etc.
>???

The wording is indeed a bit confusing. What we would like is to be able to indicate via XMPP presence that I'm available for voice or video calls on SIP, and if you want to contact me, here is my SIP AOR. Also, if I happen to be off-line, on the phone or otherwise not available for SIP calls, that should be indicated in the XMPP presence as well.

Simo

>> We had an earlier draft containing also the protocol extensions, but
>that one has been expired. However, you can find it at
>> For our first target, I think we should concentrate on getting a set
>of requirements which is agreeable for all.
>>
>> Regards,
>> Simo
>>