Subject: Re: [Slim] Question about "asymmetrical language use"

From: Gunnar Hellstrom <[email-masked]>
Date: Wed, 10 Jan 2018 12:39:56 +0100

No, the proposed change is wrong. The reason why it says "one" for the asymmetrical  case is that the rule is stated per media only. In the asymmetrical case you have hlang-send in one media and hlang-recv in another media. 
By the discussion now, I think it is evident that a better explanation is needed. It is easy to forget that the wording is per media. 
(You can of course imagine a case when you want to offer both symmetric and asymmetric  use for selection by the answerer, but then you also need the possibility to set preference between language in different media that we have discussed a lot but not included. )
/Gunnar

Gunnar Hellström  Omnitor [email-masked] +46 708 20 42 88 

-------- Originalmeddelande --------
Från: Randall Gellens <[email-masked]> 
Datum: 2018-01-10  01:54  (GMT+01:00) 
Till: Bernard Aboba <[email-masked]> 
Kopia: [email-masked], Gunnar Hellström <[email-masked]> 
Rubrik: Re: [Slim] Question about "asymmetrical language use" 

It's in -23, which I've held off uploading, to see if any more 
comments come in.

At 4:29 PM -0800 1/9/18, Bernard Aboba wrote:

>  That would help, thanks,
>
>>  On Jan 9, 2018, at 3:50 PM, Randall Gellens 
>> <[email-masked]> wrote:
>>
>>  The wording is intended to permit only one to be specified for 
>> asymmertical use cases, it is not intended to disallow both to be 
>> specified.  This could be clarified by adding "or both":
>>
>>    When placing an emergency call, and in any other case where the
>>    language cannot be inferred from context, in an offer each media
>>    stream primarily intended for human language communication SHOULD
>>    specify both (or for asymmetrical language use, one or both of) the
>>    'hlang-send' and 'hlang-recv' attributes.
>>
>>
>>  At 3:07 PM -0800 1/9/18, Bernard Aboba wrote:
>>
>>>  In Section 5.1 of -22, I noted the following sentence:
>>>
>>>  " When placing an emergency call, and in any other case where the 
>>> language cannot be inferred from context, in an offer each media 
>>> stream primarily intended for human language communication SHOULD 
>>> specify both (or for asymmetrical language use, one of) the 
>>> 'hlang- send' and 'hlang-recv' attributes."
>>>
>>>  [BA] In our previous discussions, we have talked about scenarios 
>>> (e.g. speech impaired, but not hearing impaired) in which it is 
>>> useful to include both 'hlang-send' and 'hlang-recv' so as to 
>>> accommodate user needs.  Wouldn't such a scenario qualify as 
>>> "asymmetrical language use"?  If so, how could the user's needs 
>>> be accommodated with only one of the 'hlang-send' or 'hlang-recv' 
>>> attributes?
>>>
>>>
>>>
>>>  _______________________________________________
>>>  SLIM mailing list
>>>  [email-masked]
>>>  https://www.ietf.org/mailman/listinfo/slim
>>
>>
>>  --
>>  Randall Gellens
>>  Opinions are personal;    facts are suspect;    I speak for myself only
>>  -------------- Randomly selected tag: ---------------
>>  There are two kinds of light--the glow that illuminates,
>>  and the glare that obscures.            --James Thurber
>
>  _______________________________________________
>  SLIM mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/slim

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
Liberals are trusting and optimistic because
they believe other people are much like themselves.
Conservatives are hostile and fearful because they
believe the same thing.

---

From: Randall Gellens <[email-masked]>
Date: Wed, 10 Jan 2018 07:25:50 -0800

The text seems clear to me that it is per media 
stream.  It says "each media stream primarily 
intended for human language communication".

At 12:39 PM +0100 1/10/18, Gunnar Hellstrom wrote:

>  No, the proposed change is wrong.
>  The reason why it says "one" for the 
> asymmetrical  case is that the rule is stated 
> per media only. In the asymmetrical case you 
> have hlang-send in one media and hlang-recv in 
> another media.
>
>  By the discussion now, I think it is evident 
> that a better explanation is needed. It is easy 
> to forget that the wording is per media.
>
>  (You can of course imagine a case when you want 
> to offer both symmetric and asymmetric  use for 
> selection by the answerer, but then you also 
> need the possibility to set preference between 
> language in different media that we have 
> discussed a lot but not included. )
>
>  /Gunnar
>
>
>
>  Gunnar Hellström
>  Omnitor
>  [email-masked]
>  +46 708 20 42 88
>
>
>

-------------- Randomly selected tag: ---------------
Whenever you find that you are on the side of the majority,
it is time to reform.                         --Mark Twain

---

From: Randall Gellens <[email-masked]>
Date: Wed, 10 Jan 2018 08:20:28 -0800

In thinking about the issue, I agree with Gunnar 
that the "or both" is not the correct fix.  I 
have reworded the sentence to read:

    When placing an emergency call, and in any other case where the
    language cannot be inferred from context, in an offer each media
    stream primarily intended for human language communication SHOULD
    specify the 'hlang-send' and/or 'hlang-recv' attributes for the
    direction(s) intended for interactive communication.

I believe this clarifies the usage (which is that 
the attributes are set for the direction(s) in 
which interactive communication is intended).

At 7:25 AM -0800 1/10/18, Randall Gellens wrote:

>> that a better explanation is needed. It is 
>> easy to forget that the wording is per media.
>>
>>   (You can of course imagine a case when you 
>> want to offer both symmetric and asymmetric 
>> use for selection by the answerer, but then 
>> you also need the possibility to set 
>> preference between language in different media 
>> that we have discussed a lot but not included. 
>> )
>>
>>   /Gunnar
>>
>>
>>
>>   Gunnar Hellström
>>   Omnitor

-------------- Randomly selected tag: ---------------
Survivor of Siamese Twins Joins Parents
--Newspaper headline

---

From: Gunnar Hellström <[email-masked]>
Date: Wed, 10 Jan 2018 17:35:41 +0100

Den 2018-01-10 kl. 16:25, skrev Randall Gellens:
> The text seems clear to me that it is per media stream.  It says "each 
> media stream primarily intended for human language communication".
Yes, but still we got a review question about the asymmetric case and 
you proposed a rewording that was not needed.

I suggest that we explain better how the asymmetric case is indicated 
across media instead of just saying that it has only one attribute.

Gunar

>>  The reason why it says "one" for the asymmetrical  case is that the 
>> rule is stated per media only. In the asymmetrical case you have 
>> hlang-send in one media and hlang-recv in another media.
>>
>>  By the discussion now, I think it is evident that a better 
>> explanation is needed. It is easy to forget that the wording is per 
>> media.
>>
>>  (You can of course imagine a case when you want to offer both 
>> symmetric and asymmetric  use for selection by the answerer, but then 
>> you also need the possibility to set preference between language in 
>> different media that we have discussed a lot but not included. )
>>
>>  /Gunnar
>>
>>
>>
>>  Gunnar Hellström
>>  Omnitor

-- 
-----------------------------------------
Gunnar Hellström
Omnitor
[email-masked]
+46 708 204 288

---

From: Gunnar Hellström <[email-masked]>
Date: Wed, 10 Jan 2018 23:20:02 +0100

Den 2018-01-10 kl. 17:20, skrev Randall Gellens:
> In thinking about the issue, I agree with Gunnar that the "or both" is 
> not the correct fix.  I have reworded the sentence to read:
>
> I believe this clarifies the usage (which is that the attributes are 
> set for the direction(s) in which interactive communication is intended).

Yes, I think this can be sufficient.

/Gunnar
>>  The text seems clear to me that it is per media stream.  It says 
>> "each media stream primarily intended for human language communication".
>>
>>>   The reason why it says "one" for the asymmetrical  case is that 
>>> the rule is stated per media only. In the asymmetrical case you have