Subject: [Slim] I-D Action: draft-ietf-slim-negotiating-human-language-20.txt

From: [email-masked]
Date: Mon, 08 Jan 2018 16:29:48 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Selection of Language for Internet Media WG of the IETF.

        Title           : Negotiating Human Language in Real-Time Communications
        Author          : Randall Gellens
	Filename        : draft-ietf-slim-negotiating-human-language-20.txt
	Pages           : 17
	Date            : 2018-01-08

Abstract:
   Users have various human (natural) language needs, abilities, and
   preferences regarding spoken, written, and signed languages.  This
   document adds new SDP media-level attributes so that when
   establishing interactive communication sessions ("calls"), it is
   possible to negotiate (communicate and match) the caller's language
   and media needs with the capabilities of the called party.  This is
   especially important with emergency calls, where a call can be
   handled by a call taker capable of communicating with the user, or a
   translator or relay operator can be bridged into the call during
   setup, but this applies to non-emergency calls as well (as an
   example, when calling a company call center).

   This document describes the need and a solution using new Session
   Description Protocol (SDP) media attributes.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-slim-negotiating-human-language/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-slim-negotiating-human-language-20
https://datatracker.ietf.org/doc/html/draft-ietf-slim-negotiating-human-language-20

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-slim-negotiating-human-language-20

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 8 Jan 2018 19:38:47 -0800

I believe that -20 resolve's Alvaro's comments.

However, there appear to be some dangling items from Mirja and EKR's
reviews:

1. Mirja questioned whether Section 5.1 was redundant, given the material
in the introduction.  Reading that Section over, it seems that it is indeed
redundant and can be removed.

2. EKR's review noted that the hlang send/recv negotiation is  *not*
similar to how SDP negotiates codecs (which is a pure recv/recv
negotiation).  The new text explains the reasoning but still contains the
following sentence:

"This is conceptually similar to the way other aspects of each media stream are
negotiated using SDP (e.g., media type and codecs)."

Since this sentence is incorrect, it probably should be removed.

On Mon, Jan 8, 2018 at 4:29 PM, <[email-masked]> wrote:

> _______________________________________________
> SLIM mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/slim
>

---

From: Randall Gellens <[email-masked]>
Date: Tue, 9 Jan 2018 08:41:37 -0800

I just uploaded -21 that removes both 5.1 and the offending sentence.

--Randall

At 7:38 PM -0800 1/8/18, Bernard Aboba wrote:

>  However, there appear to be some dangling items from Mirja and EKR's reviews:
>
>  1. Mirja questioned whether Section 5.1 was redundant, given the 
> material in the introduction.  Reading that Section over, it seems 
> that it is indeed redundant and can be removed.
>
>  2. EKR's review noted that the hlang send/recv negotiation is 
> *not* similar to how SDP negotiates codecs (which is a pure 
> recv/recv negotiation).  The new text explains the reasoning but 
> still contains the following sentence:
>
>  "This is conceptually similar to the way other aspects of each 
> media stream are negotiated using SDP (e.g., media type and 
> codecs)."
>
>  On Mon, Jan 8, 2018 at 4:29 PM, 
> <<mailto:[email-masked]>[email-masked]> wrote:
>
>
> <https://datatracker.ietf.org/doc/draft-ietf-slim-negotiating-human-language/>https://datatracker.ietf.org/doc/draft-ietf-slim-negotiating-human-language/
>
> <https://tools.ietf.org/html/draft-ietf-slim-negotiating-human-language-20>https://tools.ietf.org/html/draft-ietf-slim-negotiating-human-language-20
> 
> <https://datatracker.ietf.org/doc/html/draft-ietf-slim-negotiating-human-language-20>https://datatracker.ietf.org/doc/html/draft-ietf-slim-negotiating-human-language-20
>
> <https://www.ietf.org/rfcdiff?url2=draft-ietf-slim-negotiating-human-language-20>https://www.ietf.org/rfcdiff?url2=draft-ietf-slim-negotiating-human-language-20
>
>
>  until the htmlized version and diff are available at 
> <http://tools.ietf.org>tools.ietf.org.
>
>  <ftp://ftp.ietf.org/internet-drafts/>ftp://ftp.ietf.org/internet-drafts/
>
>  <mailto:[email-masked]>[email-masked]
> 
> <https://www.ietf.org/mailman/listinfo/slim>https://www.ietf.org/mailman/listinfo/slim
>
>
>

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
If you hit two keys on the keyboard, the one you don't want
will get to the screen first.

---

From: Randall Gellens <[email-masked]>
Date: Tue, 9 Jan 2018 08:58:22 -0800

Oops, I accidently uploaded the wrong file as -21.  Version -22 is 
uploaded with the changes.

-------------- Randomly selected tag: ---------------
Misery loves company, but company does not reciprocate.