Subject: Comments on draft-ietf-smime-key-wrap-00

From: "Jim Schaad" <[email-masked]>
Date: Mon, 17 Sep 2001 19:00:32 -0700

Russ,

Here are the comments that I currently have.

1.  I would like to see the text on how to treat two key 3DES keys from
the introduction to the section on 3DES key wrap so its all together.
(suggest part of section 3 overview)

2.  I would like to see the restriction on RC2 key wrap key sizes moved
from the introduction to the section on RC2 key wrap so  its all
together.  (suggest part of section 4 overview)

3.  Since these algorithms have been designed by us and are not
documented elsewhere, I suggest adding the following sections:

3.4  Triple-DES Key Wrap Example

The following is an example of doing 3DES Key Wrap.  A set of
intermediate values corresponding to the named items in section 3.1 are
given.

CEK: 		2923 bf85 e06d d6ae 5291 49f1 f1ba e9ea b3a7 da3d 860d
3e98
KEK:		255e 0d1c 07b6 46df b313 4cc8 43ba 8aa7 1f02 5b7c 0838
251f
ICV:		181b 7e96 86e0 4a4e
CEKICV:	2923 bf85 e06d d6ae 5291 49f1 f1ba e9ea b3a7 da3d 860d 3e98
		181b 7e96 86e0 4a4e
IV:		5dd4 cbfc 96f5 453b
TEMP1:      cfc1 a789 c675 dd2a b49a 3204 ef92 cc03 5c1f 3b97 7a79 60f6
            a44d cc5f 729d 8449
TEMP2:	5dd4 cbfc 96f5 453b cfc1 a789 c675 dd2a b49a 3204 ef92 cc03
		5c1f 3b97 7a79 60f6 a44d cc5f 729d 8449
TEMP3:      4984 9d72 5fcc 4da4 f660 797a 3b97 1f5c 03cc 92ef 0432 9ab4
		2add 75c6 89a7 c1cf 3b45 f596 fccb d45d
RESULT:	6901 0761 8ef0 92b3 b48c a179 6b23 4ae9 fa33 ebb4 1596 0403
		7db5 d6a8 4eb3 aac2 768c 6327 75a4 67d4

4.4 RC2 Key Wrap Example

The following is an example of doing RC2 Key Wrap.  A set of
intermediate values corresponding to the named items in section 4.1 are
given.

CEK:		b70a 25fb c9d8 6a86 050c e0d7 11ea d4d9
KEK:		fd04 fd08 0607 07fb 0003 feff fd02 fe05
LENGTH:	10
LCEK:		10b7 0a25 fbc9 d86a 8605 0ce0 d711 ead4 d9
PAD		4845 cce7 fd12 50
LCEKPAD:	10b7 0a25 fbc9 d86a 8605 0ce0 d711 ead4
		d948 45cc e7fd 1250
ICV:		0a6f f19f db40 4988
LCEKPADICV: 10b7 0a25 fbc9 d86a 8605 0ce0 d711 ead4
		d948 45cc e7fd 1250 0a6f f19f db40 4988
IV:		c7d9 0059 b29e 97f7
TEMP1:	a01d a259 3793 1260 e48c 55f5 04ce 70b8
            ac8c d79e ffe8 9932 9fa9 8a07 a31f f7a7
TEMP2:	c7d9 0059 b29e 97f7 a01d a259 3793 1260
		e48c 55f5 04ce 70b8 ac8c d79e ffe8 9932
		9fa9 8a07 a31f f7a7
TEMP3:	a7f7 1fa3 078a a99f 3299 8eff 9ed7 8cac
		b870 ce04 f555 8ce4 6012 9337 59a2 1da0
		f797 9eb2 5900 d9c7
RESULT:	70e6 99fb 5701 f783 3330 fb71 e87c 85a4
		20bd c99a f05d 22af 5a0e 48d3 5f31 3898
		6cba afb4 b28d 4f35

Jim

---

From: "Housley, Russ" <[email-masked]>
Date: Tue, 18 Sep 2001 09:01:24 -0400

>(suggest part of section 3 overview)

Agree.  The document does flow better with this change.

>together.  (suggest part of section 4 overview)

Agree.  The document does flow better with this change.

>documented elsewhere, I suggest adding the following sections:

I added the examples.  I would greatly appreciate confirmation that they 
are correct from other implementors.

Russ