Subject: RE: sender-auth and ira

From: [email-masked] (Peter Gutmann)
Date: Fri, 26 Oct 2001 16:58:41 (NZDT)

"Jim Schaad" <[email-masked]> writes:
>[Snip]
>
>I think that this is an interesting accademic problem, until I see a real
>world need for a solution I think it should be ignored.

Unaccustomed as I am to agreeing with Jim :-), I concur with this opinion.
Anything of any importance (eg electronic payment instruction, contract, etc)
which relies on signatures will include more than enough information in the
signed body to resolve any difficulties, and even if there were some pressing
demand for this (there isn't), it's not at all clear what a correct solution
would be.

Speaking of academic exercises, I'm surprised noone's mentioned Serge
Vaudenay's PKCS #5 padding attack yet...

Peter.

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 26 Oct 2001 11:47:35 -0700

Oh yeah the BCC to boss strategy...

To: Fred
BCC: Fred's Boss

Fred,
	I completely understand your situation with the possible loss of the
very big important customer account after your unfortunate presentation.
Please let me know if there is anything I can do to help you rectify the
situation.
		Mallet.

Phillip Hallam-Baker FBCS C.Eng.
Principal Scientist
VeriSign Inc.
[email-masked]
781 245 6996 x227

> -----Original Message-----
> From: Housley, Russ [mailto:[email-masked]]
> Sent: Friday, October 26, 2001 2:21 PM
> To: Peter Sylvester
> Cc: [email-masked]
> Subject: Re: sender-auth and ira
> 
> 
> 
> Peter:
> 
> > > The whole point of BCC recipients is to keep their 
> identities from other
> > > recipients.  If you are going to list them, then they are readily
> > > exposed.  I do not think that we should introduce this leak.
> >
> >Isn't this leak is somewhat similar to the possibility of having
> >one encryption envelope with all addresses in it?
> 
> Yes.  That is why the update to the MSG specification should 
> address BCC in 
> the contect of EnvelopedData.
> 
> Russ
>