Subject: Re: Questions on AuthenticatedData

From: [email-masked] (Peter Gutmann)
Date: Mon, 8 Oct 2001 14:45:15 +1300 (NZDT)

"Jim Schaad" <[email-masked]> writes:

>1.  Should we specify a suggested size for the randomly generated secret to be
>used for HMAC-SHA1?  (The size for HMAC-3DES is fixed at the size of a 3DES
>key.)

The convention seems to be to use a 160-bit value (even if the spec says that
algorithms with variable-length keys use a 128-bit key and you use that and
then spend half a day trying to figure out why your MACs are failing when all
the other side tells you is "Bad MAC").

Peter.

---

From: "Jim Schaad" <[email-masked]>
Date: Sun, 7 Oct 2001 22:01:07 -0700

Peter,

Can you give a few places where this is the convention?  It seems
counter to what would be intuitive looking at the Microsoft APIs.  This
does not mean that you are not correct, I was just wondering.

jim

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Peter Gutmann
> Sent: Sunday, October 07, 2001 6:45 PM
> To: [email-masked]; [email-masked]
> Subject: Re: Questions on AuthenticatedData
> 
> 
>