Subject: snmpconf Upcoming issues mail

From: David Partain <[email-masked]>
Date: Mon, 25 Sep 2000 14:16:45 +0200

Greetings,

We need to get a list of issues on the table for discussion
up to and during the upcoming interim meeting.  These issues will
follow this mail as quickly as I can get them assembled.

With kind regards,

--
David Partain                  [email-masked]
Ericsson Radio Systems AB      Tel: +46 13 28 41 44
Research and Innovation        Fax: +46 13 28 75 67
P.O. Box 1248                  ECN #: 868 4144
SE-581 12  Linköping, Sweden   http://linlab.ericsson.se/~epkpart

---

From: Mike MacFaden <[email-masked]>
Date: Wed, 27 Sep 2000 00:09:54 -0700

>follow this mail as quickly as I can get them assembled.

Things I'm not clear about...

1. General issue of being able to add user defined varbinds
to standard notification varbinds, I'm leaning back towards 
stating this is not good to allow.

2. Issues/costs of implementing helper objects that 
track number of rows in a table in a table when one 
uses subagent technology.

3. Perceived usefulness of having an example low-tech mib in BCP
to illustrate SNMP MIB Policy or should examples be tied to
actual technology specific mib objects.

4. Very large OCTET STRING recommendations (ipsec) BCP 
recommendation needed. Options enumerated on ipsec mailing list.

5. Being able to backup a configuration using IETF standard MIBS remains 
problemmatic. Recommend a new standard mib to provide a means
for extracting "configuration" off a device for backup. (ex: a table
with a list of oids and values that make up the config regardless of mib as Jon 
mentioned)

6. Implementing configuration systems that scale often requires knowing
the volume and rate of change in addition to the varbind list plus any
mechanical RowStatus, RowPointer, etc objects. 

Should there be a standard mib for controlling configuration transactions
to support a style similar to database transactions with commit/rollback two-phase
commits, etc. would be one way to scale up implementations across a
given device or device set.

Regards,
Mike MacFaden
www.riverstonenet.com