Subject: snmpconf Re: TE-MIB readonly or read/write

From: Steve Moulton <[email-masked]>
Date: Mon, 18 Dec 2000 17:18:07 -0500

Forwarding message bounced due to address change.

------- Forwarded Message

Date: Mon, 18 Dec 2000 14:10:53 -0800
Message-Id: <[email-masked]>
From: Mike MacFaden <[email-masked]>
To: [email-masked]
CC: [email-masked], [email-masked], [email-masked],
        [email-masked]
In-reply-to: <[email-masked]> (message from Ben Black on Wed,
	13 Dec 2000 10:18:34 -0800)
Subject: Re: TE-MIB readonly or read/write
Reply-to: [email-masked]

>From: Ben Black <[email-masked]>
>could you give examples of large ISPs who are asking for additional
>SNMP configuration features?  i am not at all a fan of using SNMP for
>router configuration, and i believe that puts me in the majority among
>service provider engineers.

We're putting the cart in front of the horse...

Defining a good read-write MIB module
does not necessarily imply using *all* the 
SNMP framework's modules.

Per RFC 2570:

   The specifications of the Internet Standard Management Framework are
   based on a modular architecture.  This framework is more than just a
   protocol for moving data.  It consists of:

     * a data definition language,
     * definitions of management information (the Management
       Information Base, or MIB),
     * a protocol definition, and
     * security and administration.
[snip]
   To this end, the framework was architected
   with a protocol-independent data definition language and Management
   Information Base along with a MIB-independent protocol.

I believe a good read-write MIB module (and I stress good) would be ideal 
to help define the common mgmt nerd-knobs to be found in a CLI
config/show cmd set or other non-IETF standard mgmt interface as well.

Regards,
Mike MacFaden
www.riverstonenet.com

------- End of Forwarded Message

---

From: Steve Moulton <[email-masked]>
Date: Wed, 20 Dec 2000 12:48:15 -0500

X-Sender: [email-masked]
X-Mailer: QUALCOMM Windows Eudora Version 5.0.1
Date: Wed, 20 Dec 2000 10:14:26 -0500
To: Jon Saperia <[email-masked]>
From: Bob Natale <[email-masked]>
Subject: Re: snmpconf Re: TE-MIB readonly or read/write
Cc: [email-masked], [email-masked], [email-masked]
In-Reply-To: <[email-masked]>
References: <[email-masked]>
 <[email-masked]>
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"

At 12/19/2000:05:25 AM, Jon Saperia wrote:

Hi Jon,

>I think we have a clear consensus among those that have recently
>commented.

I agree...and since, for once, I probably can't be counted among
"the verbose and/or stubborn" on a topic, I'd like to add:

>Define the MIB module completely including configuration/control
>objects.

Definitely.

>There are plenty of standard mechanisms by which vendors and users
>can use less than the full set of capabilities.

Right, and given the rest of the informative messages in this thread,
we would want to be sure that includes (1) spec'ing with SNMPv3
security capabilities in mind, (2) use of the MIN-ACCESS clause, and
(3) use of MODULE-COMPLIANCE macros as may be deemed appropriate by
the WGs involved.

Thanks,

BobN