Subject: RE: snmpconf BCP document

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 18 Mar 2001 17:35:12 +0100

Jeff,
I have many hadnscribble notes on the document which I 
will hand to the authors/editors.

What bothers me most is that it seems premature to do BCP
on policy-based management. Maybe we should try a
BCP for the existing SNMP practices and a separate
guidelines  informational doc with sample MIB for policy
based management. At some later date, when we indeed
have more experience and some current practices,
maybe then we can clean that up and make it a BCP

But I must say that it also bothers me that various erros
and deficiencies in existing MIBs are spelled out and
I find it hard to see what the recommended best practices
are to prevent that in the future.

In the meantime I have also gone through the sample MIB
and have also there lots of comments scribbled in the
document. And I think we would need to add text that
describes how you can define some policies and a
sample set of filters and then show how that then gets
applied.

Bert

> ----------
> From: 	Jeff Case[SMTP:[email-masked]]
> Reply To: 	[email-masked]
> Sent: 	Sunday, March 18, 2001 9:29 AM
> To: 	[email-masked]
> Subject: 	RE: snmpconf BCP document
> 
> 
> bert>I did go through this document and it seems to me
> bert>that it is not really just a BCP, but rather a mix of:
> bert>
> bert>- BCP
> bert>- Requirements
> bert>- Guidance
> bert>
> bert>Specifically BCP stands for best CURRENT practice.
> bert>So I wonder how the policy-based NM can already be
> bert>current practice.
> 
> hi bert, et. al.,
> 
> i agree ... you are right that the document is a mix
> 
> which is bothering you more,
> 	that it is a mixture, as many bcp documents are, or
> 	your second point regarding the dimension of current versus new?
> 
> is there a particular action or solution that you have in mind?
> 
> see you soon
> 
> best regards,
> jdc
>

---

From: Jon Saperia <[email-masked]>
Date: Sun, 18 Mar 2001 19:19:26 -0500

Bert, comments inline.
> will hand to the authors/editors.

Thanks we will do what we can to fix any errors or make things clear.

> maybe then we can clean that up and make it a BCP

The way that we hook-up mechanism and instance specific MIB modules is
something that is relevant and we have learned some of that from the
DiffServ and SNMPCONF effort. While there are probably still bugs in the
BCP example, the idea of showing how this is done is very helpful.

There are products on the market that do configuration with SNMP and some
even do configuration of policy, just not with exactly the PM MIB
Module. This knowledge is in the document along with other general
information. The feedback from the people that have commented so far is
that the document is helpful. Of course will learn a lot more over time
and then we can revise the BCP. Other areas have done this as well.

> 
> But I must say that it also bothers me that various errors

We may be looking at things differently since we have gone to
some length to include examples of what is helpful as well. We have
also attempted to talk about trade offs that engineers should think
about, since that is relevant to such a document. We hope the
consideration of some of these areas will reduce the likihood of errors
in the future, not only for mib modules but for application developers
as well.

> sample set of filters and then show how that then gets

This is an excellent idea, we will add it to the to do list. It had been
suggested in the past, we have not yet gotten to it.

/jo
> Bert

Thanks,
/jon
--

Jon Saperia		     [email-masked]
			     Phone: 617-744-1079
			     Fax:   617-249-0874
			     http://www.jdscons.com/

---

From: "Andrew Smith" <[email-masked]>
Date: Sun, 18 Mar 2001 20:38:30 -0800

My 2c:

I don't think it premature to do a BCP on "policy-based management using the
standards'-track SNMP tools/MIBs that IETF has so far produced". There's
nothing magic about the "P" word - the work of snmpconf WG is evolutionary,
not revolutionary: in my mind it is perfectly possible, if suboptimal, to do
"policy" with current tools/MIBs. The WG is working on some better tools and
mechanisms which, themselves, will need their own BCP later on but it would
be a big service to have a somewhat official-looking document describing the
state of the art right now.

Having said that, if it is really true that the document describes
"requirements", then it ought to be a standards'-track document, not the
traditional informational status of BCPs. Which are we aiming for here? [I
guess I'll have to now read the document in more detail to figure out what
new "requirements" are being placed on implementations].

Andrew

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Wijnen, Bert (Bert)
Sent: Sunday, March 18, 2001 8:35 AM
To: [email-masked]
Subject: RE: snmpconf BCP document

Jeff,

Bert