Subject: snmpconf policy example..

From: "harish " <[email-masked]>
Date: Wed, 4 Apr 2001 08:02:17 -0400

Sir,

The attachment in the mail contains a file in text format, contains a solved example. It is just a attempt to solve it, i want to make sure if that is the way to populate the policy to the MIB.

 Some questions regarding the same are there in the document. Please answer with the concept of populating the MIB with the 2 or more rows.

Pls mail me as soon as possible.

With warm Regards
Harish.

 POLICY = if((Src_Address =192.168.0.131) and (Src_port>1024 and Src_port<10000))
		then dscp_value = 2

   diffPolicyDPCTable 
   +-------+------------------+
   | index | diffPolicy       |
   |       |DPCConfiguration  |
   +-------+------------------+
   | 1     | diffServClfr     |
   |       |ElementSpecific.1 |
   +-------+------------------+

   diffServClfrTable
   +--------------------+
   | diffServClfrId     |
   +--------------------+
   | 1                  |
   +--------------------+

   diffServClfrElementTable
   +----------------+--------------------------+------------------------+--+
   |diffServ        | diffServClfr             |diffServ                |..|
   | ClfrElementId  |ElementNext               |ClfrElementSpecific     |  |
   +----------------+--------------------------+------------------------+--+
   | 1              |diffServActionNext.1      |diffServSixTupleClfrID.1|  |
   +----------------+--------------------------+------------------------+--+

   diffServSixTupleClfrTable
   +---------------+-----------------+----------------+----------------+-----+
   | diffServ      | diffServSixTuple|diffServSixTuple|diffServSixTuple|.... |
   | SixTupleClfrId|ClfrSrcAddr      |ClfrSrcL4PortMin|ClfrDstL4PortMin|     |
   +---------------+-----------------+----------------+----------------+-----+
   | 1             | 192.168.0.131   | 1024           |  10000         |     |
   +---------------+-----------------+----------------+----------------+-----+

   diffServActionTable
   +---------+-----------+----------------------+--------------+-----+
   | diffServ|diffServ   | diffServ             | diffServ     |     |
   | ActionId|ActionNext | ActionSpecific       | ActionType   |.....+
   +---------+-----------+----------------------+--------------+-----+
   | 1       |0.0        |diffServDscpMarkAct.1 | specific     |     |
   +---------+-----------+----------------------+--------------+-----+

   diffServDscpMarkActTable
   +-------------------------+
   | diffServDscpMarkActDscp |
   +-------------------------+
   | 2                       |
   +-------------------------+

The above policy is implemented by applying values to the field to the table as 
above.
 In the if condition above we can apply the "AND" condition to port and with 
ipaddress by getting the values and anding them  using simple SNMP get() and 
set(x) commands.

How to store more complex policies with actions including both PR and PHB actions. 
Then the number of rows in a table, will be increased drastically. I have solved 
the above policy according to the example given in the draft but there are more objects which has to be populated, which are not yet clear. 

My Questions are
 
1) Can the RowPointer contain identical values as given above.

2) Does 
 
   "diffServClfrElementSpecific.1"  and  "diffServClfrElementNext.1"  points 
to the same row of the table.

 The question is yet there as how to store the second row of the table as all 
the Object Identifier's are flat 

Let us think of the senario of A policy, that has been set up by the user it has to 
be applied to the device at that moment for a perticular data. 

 If number of packets of various groups which are applied with various policies 
are to be passed  one after the other,Will it be slow for the device to 
functio0n, every time to update the MIb with the policy and work according to that.

Regards
Harish
Insight Technologies

---

From: Harrie Hazewinkel <[email-masked]>
Date: Wed, 04 Apr 2001 16:46:03 -0700

> The attachment in the mail contains a file in text format, contains a solved example. It is just a attempt to solve it, i want to make sure if that is the way to populate the policy to the MIB.

Thanks for pointing out to some errors I made.
For the update you have to wait until the next
diffserv-mib is released.

Most likely some changes will affect the example
too. So I hope to get that done first.
(as earlier mentioned)

[snip]
> 1) Can the RowPointer contain identical values as given above.

If I understand the question correctly, a rowpointer points to
something and if two different rowpointers point to the same thing
their value is equal.

> to the same row of the table.

No the 'specific' points to more detailed information which is a
classifying filter
and the 'next' points to the next datapath element if the traffic is
conforming
the filter.

Hope this helps,

Harrie