Subject: RE: snmpconf Status of our work

From: "Harrington, David" <[email-masked]>
Date: Fri, 17 Oct 2003 10:52:03 -0400

Hi,

I continue to believe that the scripting language used to specify policies should be separated from the MIBs that coordinate the advertisement and coordination of policies. 

In the MIDCOM WG, we could use many of the features described in snmpconf, such as advertised capabilities, policy groups, precedence, override, etc. Convincing the WG to adopt those features is made much harder by the requirement to be non-conformant to the only defined compliance, which requires support for the snmpconf scripting language. 

It might be possible to simply add lesser compliance levels, but the dependencies on the scripting language in the design of the mib probably need to be reduced to enable easier  reuse of the non-scripting portions of the design possible.

As the representative for a vendor, I can say that I will not go to my engineering department and recommend this protocol because I don't believe the snmpconf scripting is something I believe will solve more problems than it raises. I do not believe a freeform scripted language approach is application friendly; it strikes me about as application-friendly as HTML web pages that manipulate SNMP objects. 

I hate to throw out the baby with the bathwater however. I believe the snmpconf work contains many mib constructs that could be useful if it weren't for the required scripting. If we made these useable with other policy-specification approaches, they could be very useful.

I believe the snmpconf-pm document should be broken up into at least two documents. That would allow vendors and other WGs to adopt some aspects of snmpconf without adopting it all. 

dbh

> -----Original Message-----
> From: David Partain (LI/EAB) [mailto:[email-masked]] 
> Sent: Friday, October 17, 2003 8:27 AM
> To: [email-masked]
> Subject: snmpconf Status of our work
>
> 
> Greetings all,
> 
> The two final SNMPCONF documents have been published, with
> appropriate changelogs published here.
> 
> draft-ietf-snmpconf-diffpolicy-08.txt: There is an ongoing
> IETF last call on this document.
> 
> draft-ietf-snmpconf-pm-14.txt: Published following AD review.
> We believe that this revision covered the remaining outstanding
> issues, but there it may be that Patrik Fältström will have
> additional comments about internationalization.
> 
> If you have comments about these documents, please speak up
> quickly.  Now is the right time...
> 
> David and Jon
> 
>

---

From: "David Partain (LI/EAB)" <[email-masked]>
Date: Tue, 21 Oct 2003 13:07:26 +0200

Hi all,

On Friday 17 October 2003 16.52, Harrington, David wrote:
> I continue to believe that the scripting language used to specify policies
> should be separated from the MIBs that coordinate the advertisement and
> coordination of policies.
[rest deleted]

Thanks for the mail and the comments.

It seems very late in the game to be suggesting a split in
the architecture of the document.  This would definitely be a
very major change at a time when our only remaining milestone
is to close the working group.

While there may be reasons to consider a split of the MIB
constructs and the scripting language, it would require a
significant effort to accomplish this.  Our preference would
be to get the document published as is to allow vendors who are
interested in implementing the work to do so.  Should we indeed
discover wide support for a looser coupling between scripting
and the MIB module, we should clearly address that in future
work in a rejuvenated SNMPCONF or in some other working group.

I hope that seems reasonable...

Cheers,

David Partain