Subject: RE: [Softwires] Re: WG LC Problem Statement (Pekka Savola Comments)

From: "Durand, Alain" <[email-masked]>
Date: Tue, 3 Jan 2006 13:08:41 -0500

>> 3.2.  Network Address Translation (NAT) and Port Address Translation
>>       (PAT)
>> ...
>>    There is no requirement to be able to "autodetect" NAT or PAT
>>    presence during softwire setup.
>>
>> ==> I do not agree with this statement without further qualifiers. The
>> softwire setup needs to work by default through a NAT, and the statement
>> above does not really address that point.  Suggest replacing with:
>>
>>    Establishing a softwire through NAT or PAT must work by default.
>>    However, there is no requirement for explicitly "autodetect"
>>    NAT or PAT presence during softwire setup.
>>
>> I.e., unless the solution provides autodetection, it must be chosen in a
>> manner that can traverse NAT/PAT.  I think that's a hard requirement.
>
>I agree with this change. If others do not agree, please let me know (and we
>can discuss it).

The original intend was to say to the NAT detection mechanism was not needed
and we could simply enable NAT traversal by default.

>>    It should be noted that according to reports the islands do not want
>>    to achieve network connectivity via tunneled Layer 2 mechanisms but,
>>    as distinct Layer 3 or MPLS routers.  This clearly helps scaling and
>>    Layer 2 discovery performance issues.  It also prevents having to
>>    have fully meshed point to point Layer 2 connectivity between the
>>    nodes in differing islands as Layer 2 technology choice must be
>>    preserved.
>>
>> ==> while one network might want to use Layer 3 mechanism, I do not think
>> Layer 2 should be ruled out as it's a more generic solution. We should
>> provide a solution for that as well.
>
>I agree with the thought but am having a hard time reading this into the
>Softwires charter (which seems pretty clearly focused on Layer 3).
>David/Alain, could you express an opinion here?

The question was asked during the interim meeting in Paris. From my notes:

*>Should this be solved at layer 2 or layer 3?
->Crystal ball says both (This belongs to the solution space) 

Still, I believe that the initiaf focus should be at L3.

   - Alain.

_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

---

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 3 Jan 2006 12:30:30 -0600

Thanks, Alain, for the guidance.

I'm suggesting additional text for Pekka's suggestion:

<t>Establishing a softwire through NAT or PAT must work by default.
    However, there is no requirement for explicitly "autodetect"
    NAT or PAT presence during softwire setup - simply enabling NAT 
traversal
    could be sufficient to meet this requirement.</t>

Please "fire at will".

Spencer

----- Original Message ----- 
From: "Durand, Alain" <[email-masked]>
To: "Spencer Dawkins" <[email-masked]>; <[email-masked]>
Sent: Tuesday, January 03, 2006 12:08 PM
Subject: RE: [Softwires] Re: WG LC Problem Statement (Pekka Savola Comments)

>> ==>  Suggest replacing with:
>>

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 03 Jan 2006 20:33:12 +0100

I don't agree with that. Let me explain.

If we use NAT traversal by default, then we are enforcing IPv6/UDP/IPv4
encapsulation, even when IPv6/IPv4 could work. Obviously this will mean
certain lost of performance, which is easily avoidable.

I really think the requirement is to detect if there is a NAT/PAT which can
be traversed with IPv6/IPv4 (for example see proto-41-forwarding draft), and
otherwise use IPv6/UDP/IPv6.

Regards,
Jordi

> De: "Durand, Alain" <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Tue, 3 Jan 2006 13:08:41 -0500
> Para: Spencer Dawkins <[email-masked]>, <[email-masked]>
> Conversación: [Softwires] Re: WG LC Problem Statement (Pekka Savola Comments)
> Asunto: RE: [Softwires] Re:  WG LC Problem Statement (Pekka Savola Comments)
> 

**********************************************
The IPv6 Portal: http://www.ipv6tf.org

Barcelona 2005 Global IPv6 Summit
Slides available at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.