Subject: Re: [Softwires] comments on problem statement (Laurent Toutain)

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 3 Jan 2006 17:40:29 -0600

Just following up on comments - my comments/questions are prefixed by "Spencer:" below.

Thanks,

Spencer
  ----- Original Message ----- 
  From: Laurent Toutain 
  To: [email-masked] 
  Sent: Monday, December 26, 2005 4:33 AM
  Subject: [Softwires] comments on problem statement

  Hi,

  Here are my comments based on the v4.txt document

  Introduction : 3rd § change Hub and Spoke section 4 to section 3
  idem for section 5 => section 4

  Spencer: Yes. Changed.

  Section 3 : Hub and Spoke

   3.4 :
  Last § : Similarly, in the case of an IPv4 softwire, the address could be
     provided by means of DHCP.

  =>Our implementation uses ND, we can also use only link local addresses, Global addresses
  on the tunnel are just given for management reasons (traceroute, or if the provider or others wants
  to access the HGWv6, if it is just for forwarding link local is enough).

  Spencer: Are you asking for text like this: "Similarly, in the case of an IPv4 softwire, the address could be provided by DHCP or neighbor discovery, or could be a link-local address"?

  3.5: 
  may be add after "Nomadicity should be supported.", as well as renumbering of the IPv4 address by
  the provider. 

  I don't know if it is common in other countries, by my provider change my IPv4 address every day, so the 
  Softwire Initiator has to reestablish a tunnel just after the renumbering.

  Spencer: OK... can you describe how the Software Initiator discovers that the IPv4 address has changed? (Is this, for example, a DHCP lease expiring?)

  3.6:

  This is my main concern regarding this draft. It focus to much, in my point of view to the tunnel establishment"

  This section could emphase more on interaction between different protocols (ND, DHCPv6, AAA,...) In our 
  experiences that was the most difficult part. May be we have to recommend the usage of some  options in this
  protocols or ask for new types (for instance delegated prefixes in Radius is a draft). Section 3.11 talks about 
  AAA by in very generic way. In my view AAA is the most important feature for softwire, because it will contains
  a lot of information that will help the provider to manage the network (prefix for the customer, DNS, domains,..)
  that are very useful for a home IPv6 network.
  Spencer: I agree with the comment - this looks like a significant piece of work - can you provide text?

  3.13

  I'm surprised not to see listed IPv4/UDP/L2TP/PPP/IPv6

  Spencer: I believe the problem statement is limited to the set of protocol stacks given in this draft by charter - Dave/Alain, can you confirm this?

  Laurent

_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

---

From: Laurent Toutain <[email-masked]>
Date: Fri, 6 Jan 2006 12:31:36 +0100

> Spencer: Are you asking for text like this: "Similarly, in the case  
> of an IPv4 softwire, the address could be provided by DHCP or  
> neighbor discovery, or could be a link-local address"?
>
yes, or something more specific :

Link local addresses allocated at both ends of the tunnel are enough  
for packets forwarding,
but for management purpose like traceroute, global addresses can be  
allocated using existing
protocols such as Neighbor Discovery or DHCPv6.

> Spencer: OK... can you describe how the Software Initiator  
> discovers that the IPv4 address has changed? (Is this, for example,  
> a DHCP lease expiring?)
" IPv4 provider can also periodically change the IPv4 address  
allocated to the gateway. The softwire initiator
has to discover in a reasonable period of time that the tunnel is  
down and restart tunnel establishment.
This re-establishment should not change the IPv6 prefix and other  
parameters allocated to the site. "

BTW: if you use PPP, the LCP protocol is very useful for this

>
> 3.6:
>
> This is my main concern regarding this draft. It focus to much, in  
> my point of view to the tunnel establishment"
>
> experiences that was the most difficult part. May be we have to  
> recommend the usage of some  options in this
> protocols or ask for new types (for instance delegated prefixes in  
> Radius is a draft). Section 3.11 talks about
> AAA by in very generic way. In my view AAA is the most important  
> feature for softwire, because it will contains
> a lot of information that will help the provider to manage the  
> network (prefix for the customer, DNS, domains,..)

That is not the easiest part :-). I propose this text :

Softwire concentrator will be based on existing standard (for  
tunneling, prefixes and addresses allocation,
management…). The working group must define BCP to define SC  
architecture, interaction between these
protocols and recommends (mandate ?) profiles. These recommendations  
must take into account the
distributed nature of the SC in the provider network and the impact  
on core IPv6 network
(for instance : prefixes aggregation).

Laurent

> Spencer: I believe the problem statement is limited to the set of  
> protocol stacks given in this draft by charter - Dave/Alain, can  
> you confirm this?
>
> Laurent