Subject: RE: [Softwires] IPv4 over IPv6 in Hubs and Spokes?

From: "Durand, Alain" <[email-masked]>
Date: Fri, 13 Jan 2006 09:36:48 -0500

Spencer,
 
This was covered in Paris.
Yes, the softwires wg will address the v4/v6 hub & spoke problem.
However, in the same line that the mesh problem has only one diagram
plus some text that explain the converse problem (v4 only core),
we have diagrams that explain the v6/v4 hub & spoke case and text that
explain the converse problem.
 
Unless somebody can show that there is something more that absolutely need
to be described for the v4/vg6 case, I would suggest we stick to a minimum number of diagrams
to keep things simple.
 
   - Alain.
 
________________________________

From: [email-masked] on behalf of Spencer Dawkins
Sent: Thu 1/12/2006 8:54 PM
To: Softwires Mailing List
Subject: [Softwires] IPv4 over IPv6 in Hubs and Spokes?

One Problem Statement reviewer pointed out that all of the examples in
Figure 1 of the problem statement transit an IPv4 network between softwire
initiator and softwire consolidator, and offered a drawing of a fourth
example that uses IPv4 over IPv6 transit.

Before I add this to the Problem Statement, does anyone actually have this
problem? All of the the IPv4 over IPv6 discussion I've seen has been for the
Mesh application - please let me know if I am missing some background here
(it has happened :-)

Thanks!

Spencer

_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 13 Jan 2006 15:55:04 +0100

Hi Alain,

I disagree, is more clear to have one more figure describing the converse
case.

The alternative is a single figure describing all the cases, as I proposed
initially (and make it), and you indicated that it was too complicate and
difficult to understand.

So you want it easy to understand, then need one more figure, otherwise,
just delete the 3 figures and make a single one.

Alternatively, I don't see why we can't use something so simple as I
suggested:

Case 4: IPv4 connectivity across an IPv6-only access network.
HWG is dual-stack and becomes the Softwire initiator.

                      +-------+   +-------------+  +--------+
                      |       |   | Softwire    |  | IPv4   |
   +-----+  +-----+   | IPv6  |---| concentrator|--| Network|=>Internet
   |Host |--| HGW |---|       |   +-------------+  +--------+
   +-----+  +-----+   |Network|
                      +-------+
                    _ _ _ _ _ _ __
                  ()_ _ _ _ _ _ __()
                      "softwire"
   |--------------||--------------||-------------------------|
      Dual-stack       IPv6-only     IPv4-only or dual-stack

Note: It may be the case, in the future, that the HGW is IPv6-only. This is
similar to cases 2 and 3 above, and softwire also should work in that
situation. These cases aren't depicted here in order to avoid a description
which is already clear looking at Case 4.

Regards,
Jordi

> De: "Durand, Alain" <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Fri, 13 Jan 2006 09:36:48 -0500
> Para: Spencer Dawkins <[email-masked]>, Softwires Mailing List
> <[email-masked]>
> Conversación: [Softwires] IPv4 over IPv6 in Hubs and Spokes?
> Asunto: RE: [Softwires] IPv4 over IPv6 in Hubs and Spokes?
> 
> Spencer,
>  

**********************************************
The IPv6 Portal: http://www.ipv6tf.org

Barcelona 2005 Global IPv6 Summit
Slides available at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Tim Chown <[email-masked]>
Date: Tue, 17 Jan 2006 16:12:54 +0000

> to be described for the v4/vg6 case, I would suggest we stick to a minimum number of diagrams

I think there's a case here to be made for the IPv4 in IPv6 scenario, namely
the IPv6 dominent network deployment.

There are a couple of scenarios.

1) IPv4 connectivity over an IPv6 access network:

                   _ _ _ _ _ _ _ _
                  () _ _ _ _ _ _ _()
      Dual stack      IPv6 only         IPv4 or dual stack
    (Or IPv4 only
        host)

I think this isn't exactly common yet.

2) IPv4 connectivity over an IPv6 site network

This is more 'contentious' because it is a little different to what has
been discussed already.   It's the problem space that DSTM currently
solves and - if people feel DSTM isn't an ideal solution - we should 
cater for a better solution with softwires.

So the scenario would be something like this:

                      +-------+   +-------------+  +--------+
                      |       |   | Softwire    |  | IPv4   |
   +-----+            | IPv6  |---| concentrator|--| Network|=>Internet
   |Host |------------|       |   +-------------+  +--------+
   +-----+            |Network|
                      +-------+
           _ _ _ _ _ _ _ _ _ _ _ _
         ()_ _ _ _ _ _ _ _ _ _ _ _()
                   "softwire"
   |-------||---------------------||-------------------------|
     Dual stack      IPv6 only         IPv6 or dual stack
     
In the DSTM case, the concentrator would be the DSTM tunnel server,
with the host running a DSTM client for address acquisition and tunnel
handling for the IPv4 application running to an external IPv4 target,
i.e. the classic use of DSTM for dual-stack hosts on an IPv6-only network
to talk to IPv4-only nodes on the external Internet.

Or has this been discussed and deemed out of scope?

Tim