Subject: RE: [Softwires] L2TP & NAT traversal

From: "Maria A. Dos Santos \(mariados\)" <[email-masked]>
Date: Wed, 22 Mar 2006 14:47:08 -0800

Alain,

L2TPv2 and L2TPv3 both supports an in-band keepalive 
mechanism (via HELLO messages) that will can be used 
to refresh the NAT/PAT entry.

alice

> -----Original Message-----
> From: BAUDOT Alain RD-CORE-CAE 
> [mailto:[email-masked]] 
> Sent: Wednesday, 22 March, 2006 13:53
> To: [email-masked]
> Subject: [Softwires] L2TP & NAT traversal
> 
> Hi, 
> 
> I have a concern regarding L2TP NAT traversal capability: is 
> there is any need of a keep alive mechanism to make sure the 
> L2TP tunnel will not break down if the NAT time-out the 
> related UDP flow?
> 
> In other terms, can we make sure that L2TP is a NAT traversal 
> solution by itself? 
> 
> Thanks,
> Alain. 
> 
> 

_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

---

From: "Laurent Toutain" <[email-masked]>
Date: Thu, 23 Mar 2006 09:32:18 +0100

In fact there is two level of keep alive. PPP/LCP send periodically a message,
and if there is no traffic (which is not the case due to LCP probing) then
L2TP sends HELLO messages.

Laurent

--
-----------------------
Serveur web du Point6 => http://www.point6.net
Laurent Toutain
ENST Bretagne
tel +33 2 99 12 70 26 - Fax +33 2 99 12 70 30

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 23 Mar 2006 13:59:22 -0800

At the Softwire wg meeting yesterday, I presented a document titled:
"Requirements for IP-in-IP Tunnel MTU Assurance" and was asked by
the chairs to gauge list interest in having it become a wg item.
The abstract and a link to the document appear below; please send
comments/questions to the list.

Fred
[email-masked]

   Abstract
   
   IP-in-IP tunnels present a Maximum Transmission Unit (MTU) to layer 3
   via static prearrangements and/or dynamic MTU determination based on
   layer 2 ICMP messages, but these methods have known operational
   limitations that can fail to enforce an assured MTU resulting in
   degraded performance and communications failures.  A method for
   providing an assured MTU to layer 3 over IP-in-IP tunnels is needed.

  http://www.ietf.org/internet-drafts/draft-templin-mtuassurance-00.txt