Subject: RE: [Softwires] Notes and Consensus from Interim Meeting in Hong Kong

From: "Durand, Alain" <[email-masked]>
Date: Thu, 16 Mar 2006 10:23:42 -0500

Tim,

I used to think that those tunneling methods will go away as soon
as service providers will be able to support native v6.

Now that I work for a service provider, I see things differently.
Maybe I learned something... I also talked to a number of other SP who
share the same concerns.

In the hub & spoke model, scenario 3&4 are here to stay.
Availability of code & product for CPE is one thing, getting them deployed
by the millions in every single place where v6 need to go is another thing.

   - Alain.

> -----Original Message-----
> From: Tim Chown [mailto:[email-masked]] 
> Sent: Thursday, March 16, 2006 5:09 AM
> To: [email-masked]
> Subject: Re: [Softwires] Notes and Consensus from Interim 
> Meeting in Hong Kong
> 
> The 'time to market' aspect is a little muddy, it seems.
> 
> The SOHO deployment problem seems to be a lack of commodity 
> CPE devices that support IPv6.  At least that's what ISPs I 
> talk to say they're
> waiting for, along with OSS support.   They don't say they're held up 
> because they need to tunnel internally on their own infrastructure.
> 
> There are many things coming to market at some point that are 
> relevant,
> including:
> 
> - IPv6 support in commodity CPE devices
> - IPv6 support in ISP routing infrastructure equipment
> - IPv6 support in ISP OSS components
> - Support for L2TP for use with IPv6
> - Support for TSP
> - etc
> 
> It just seems in some cases the transitional (L2TP/TSP/...) 
> support may arrive after the IPv6 support...?
> 
> Or is the WG view that transition is a long game and the 
> tools that will be specified in the next few months and 
> implemented maybe in the next year will be applicable for many years?
> 
> Tim
> 
> On Wed, Mar 15, 2006 at 04:17:45PM -0500, Durand, Alain wrote:
> > What you are describing fits into the mesh case.
> > 
> >    - Alain. 
> > 
> > > -----Original Message-----
> > > From: Fiumano, Michael F [NTK] 
> [mailto:[email-masked]]
> > > Sent: Wednesday, March 15, 2006 4:15 PM
> > > To: Maria A. Dos Santos (mariados); JF Tremblay; 
> [email-masked]
> > > Subject: RE: [Softwires] Notes and Consensus from Interim 
> Meeting in 
> > > Hong Kong
> > > 
> > > What I was describing was definitely NOT from home 
> network to ISP.  
> > > I'm not 100% sure if what I was describing "fits" the "Mesh" 
> > > scenario or not.
> > > 
> > > Michael Fiumano
> > > Senior Network Engineer
> > > IP Core Infrastructure
> > > 703-689-5875 Wk
> > > 703-598-2434 Cel
> > > [email-masked]
> > > 
> > > 
> > > 
> > > 
> > > -----Original Message-----
> > > From: Maria A. Dos Santos (mariados) [mailto:[email-masked]]
> > > Sent: Wednesday, March 15, 2006 3:28 PM
> > > To: Fiumano, Michael F [NTK]; JF Tremblay; [email-masked]
> > > Subject: RE: [Softwires] Notes and Consensus from Interim 
> Meeting in 
> > > Hong Kong
> > > 
> > > Michael,
> > > 
> > > sorry to jump in like this, just trying to understand this better.
> > > What you describe sounds more like the "Mesh" problem in 
> which the 
> > > softwires are setup within the ISP/core network, not from home 
> > > network to ISP.  Is that right?
> > > 
> > > alice
> > >  
> > > 
> > > > -----Original Message-----
> > > > From: Fiumano, Michael F [NTK] 
> > > > [mailto:[email-masked]]
> > > > Sent: Wednesday, 15 March, 2006 11:50
> > > > To: JF Tremblay; [email-masked]
> > > > Subject: RE: [Softwires] Notes and Consensus from Interim
> > > Meeting in
> > > > Hong Kong
> > > > 
> > > > Actually, the CE devices do not terminate the pseudowires.  
> > > > We terminate them on our Edge routers going to the customer.  
> > > > L2 in on one end of the network, L2 out on the other. 
> > > > 
> > > > I would like to see the Edge routers take v4/v6 dualstack,
> > > split off
> > > > v6 and pseudowire it to another router in the network which is 
> > > > connected to the v6 capable parts of the network.
> > > > 
> > > > This would allow us to offer a "native" v4/v6 service and
> > > allow us to
> > > > get around problem routers in the network where deploying
> > > v6 is not an
> > > > option.
> > > > 
> > > > Michael Fiumano
> > > > Senior Network Engineer
> > > > IP Core Infrastructure
> > > > 703-689-5875 Wk
> > > > 703-598-2434 Cel
> > > > [email-masked]
> > > > 
> > > > 
> > > > 
> > > > 
> > > > -----Original Message-----
> > > > From: JF Tremblay [mailto:[email-masked]]
> > > > Sent: Wednesday, March 15, 2006 2:38 PM
> > > > To: Fiumano, Michael F [NTK]; [email-masked]
> > > > Subject: RE: [Softwires] Notes and Consensus from Interim
> > > Meeting in
> > > > Hong Kong
> > > > 
> > > > --On Wednesday, March 15, 2006 1:06 PM -0600 "Fiumano, 
> Michael F 
> > > > [NTK]"
> > > > <[email-masked]> wrote:
> > > > > Hello,
> > > > 
> > > > Hi Michael.
> > > > Thanks for your input. Some comments/questions below.
> > > > 
> > > > > Why do all solutions "require" Windows at all???  I have
> > > > the need to
> > > > > use this standard to enable a port on my network to tunnel
> > > > v6 over my
> > > > > v4 infrastructure to a v6 enabled part of my network.  I
> > > hope that
> > > > > this is being kept in consideration for the solution space.
> > > > 
> > > > According to the problem statement, we have to consider 
> host-based 
> > > > solutions for the hub & spokes problem (scenario
> > > > #2 and #3). Windows XP constitutes a large part of the current 
> > > > dual-stack capable host base.
> > > > 
> > > > > As an operator of a large network, the problems I see
> > > aren't always
> > > > > from a end host.  I would prefer an L2TPv3 solution
> > > > preferably as we
> > > > > use this technology today as a L2 psuedowire transport across 
> > > > > our network.
> > > > 
> > > > Right, a CPE can terminate the softwire (scenario #1). 
> I'm curious 
> > > > about something though. In your current L2 pseudowire
> > > deployment, is
> > > > any of the pseudowires terminated directly on a CPE device
> > > (enterprise
> > > > or end user)? How easily can these be upgraded to IPv6 and
> > > L2TPv3 for
> > > > softwire termination purposes?
> > > > 
> > > > Thanks,
> > > > Jean-Francois Tremblay
> > > > Hexago
> > > > -------------------------------------------------
> > > > http://www.freenet6.net : Free IPv6 Connectivity
> > > > -------------------------------------------------
> > > > 
> > > > > Maybe I am off base, and this is not being given any
> > > > attention because
> > > > > it is assumed that this will work, but please 
> consider this when 
> > > > > talking to your solutions as well.
> > > > >
> > > > > Thanks,
> > > > > Michael Fiumano
> > > > > Senior Network Engineer
> > > > > IP Core Infrastructure
> > > > > 703-689-5875 Wk
> > > > > 703-598-2434 Cel
> > > > > [email-masked]
> > > > >
> > > > >
> > > > >
> > > > >
> > > > >> De: "Bill Storer (bstorer)" <[email-masked]> Responder a: 
> > > > >> <[email-masked]>
> > > > >> Fecha: Wed, 15 Mar 2006 08:54:46 -0800
> > > > >> Para: "Maria A. Dos Santos (mariados)" <[email-masked]>, 
> > > > >> <[email-masked]>, <[email-masked]>
> > > > >> Conversación: [Softwires] Notes and Consensus from Interim
> > > > Meeting in
> > > > >> Hong Kong
> > > > >> Asunto: RE: [Softwires] Notes and Consensus from Interim
> > > > Meeting in
> > > > >> Hong Kong
> > > > >>
> > > > >> To summarize here:
> > > > >>
> > > > >> 1. None of the proposed solutions are supported by
> > > standard issue
> > > > >> "out of the box" Microsoft Windows.  All of the 
> solutions will 
> > > > >> require loading extra software on Windows.
> > > > >
> > > > > I'm not sure if this was a requirement, not in my opinion. 
> > > > It will be
> > > > > ideal, but we know is difficult for old OSs.
> > > > >
> > > > >> 2. L2TP is closest in the above sense as it is supported
> > > > by standard
> > > > >> Windows XP for IPv4/IPv4 tunneling.
> > > > >
> > > > > With a small trick to disable IPsec, but I guess it could be 
> > > > > automated.
> > > > >
> > > > >> 3. GPL code is available for L2TP.
> > > > >
> > > > > Same as other solutions.
> > > > >
> > > > >> 4. L2TP has been implemented in Windows by NTT and SixXs.
> > > > >
> > > > > It will be by SixXS, but agree, within a good timing in
> > > my opinion
> > > > > (actually shorter timing that I will say is the required one, 
> > > > > but that's a different discussion).
> > > > >
> > > > >> 5. Most importantly, L2TP is widely supported by the major 
> > > > >> concentrator vendors.
> > > > >
> > > > > Yes, for two main router/concentrator vendors, should be ok.
> > > > >
> > > > >>
> > > > >
> > > > > Now, if you compare L2TP with TSP (I'm not advocating for
> > > > one or the
> > > > > other, just trying to analyze the situation), TSP 
> seems better 
> > > > > to integrate from the client perspective and no need to play
> > > tricks in
> > > > > any OS. However has less support from the server side.
> > > > >
> > > > > So the question is again, IF we want to have a fair 
> comparison:
> > > > > 1) Technical detailed comparison of different aspects
> > > among both of
> > > > > them, pros and cons (i.e., overhead, prefix delegation,
> > > DNS, etc.).
> > > > >
> > > > > 2) How much time it will take for router/concentrator 
> vendors to 
> > > > > implement TSP, and if it will happen in case we choose it.
> > > > >
> > > > > 3) How much weight we give to the support in routers vs. 
> > > > the support
> > > > > in clients.
> > > > >
> > > > > Not easy ...
> > > > >
> > > > >>
> > > > >> Bill
> > > > >>
> > > > >>> -----Original Message-----
> > > > >>> From: Maria A. Dos Santos (mariados)
> > > > >>> Sent: Saturday, March 11, 2006 12:02 PM
> > > > >>> To: [email-masked]; [email-masked]
> > > > >>> Subject: RE: [Softwires] Notes and Consensus from Interim
> > > > Meeting in
> > > > >>> Hong Kong
> > > > >>>
> > > > >>> Jordi,
> > > > >>>
> > > > >>> We googled "l2tp client" and found SixXs release note 
> > > > >>> mentioned
> > > > >>>
> > > > >>>  "L2TP Support (Yes, even under Windows one can do IPv6
> > > in PPP in
> > > > >>> L2TP :)"
> > > > >>>
> > > > >>> a window client that will have l2tp capability.
> > > > >>>
> > > > >>> Bill queried Jeroen Massar at SixXs and confirmed that the 
> > > > >>> l2tp capability will probably be available in 2 
> months to the public.
> > > > >>>
> > > > >>> http://www.sixxs.net/tools/aiccu/history/
> > > > >>>
> > > > >>> Just one example...
> > > > >>>
> > > > >>> alice
> > > > >>>
> > > > >>>> -----Original Message-----
> > > > >>>> From: JORDI PALET MARTINEZ 
> > > > >>>> [mailto:[email-masked]]
> > > > >>>> Sent: Friday, 10 March, 2006 9:30
> > > > >>>> To: [email-masked]
> > > > >>>> Subject: Re: [Softwires] Notes and Consensus from
> > > > Interim Meeting
> > > > >>>> in Hong Kong
> > > > >>>>
> > > > >>>> Hi David,
> > > > >>>>
> > > > >>>> I think the main discussion here has been related to
> > > the lack of
> > > > >>>> IPv6 support for L2TP in XP (and I guess is the same
> > > in W2003). 
> > > > >>>> Unless I misread the link that you provided, I 
> think doesn't 
> > > > >>>> mention IPv6 support at all.
> > > > >>>>
> > > > >>>> I also recall having checked with Microsoft a couple of
> > > > times and
> > > > >>>> they confirmed that will be only available in Vista. 
> > > Of course,
> > > > >>>> this can change, and that will be great actually !
> > > > >>>>
> > > > >>>> Regards,
> > > > >>>> Jordi
> > > > >>>>
> > > > >>>>
> > > > >>>>
> > > > >>>>
> > > > >>>>> De: David Ward <[email-masked]> Responder a: 
> > > > >>>>> <[email-masked]>
> > > > >>>>> Fecha: Fri, 10 Mar 2006 11:12:36 -0600
> > > > >>>>> Para: David Ward <[email-masked]>, "[email-masked]"
> > > > >>>>> <[email-masked]>, "Durand, Alain"
> > > > >>>> <[email-masked]>
> > > > >>>>> Conversación: [Softwires] Notes and Consensus from Interim
> > > > >>>> Meeting in
> > > > >>>>> Hong Kong
> > > > >>>>> Asunto: Re: [Softwires] Notes and Consensus from Interim
> > > > >>> Meeting in
> > > > >>>>> Hong Kong
> > > > >>>>>
> > > > >>>>> Although I am sitting back allowing folks to discuss
> > > > >>>> various issues, I
> > > > >>>>> had to step in w/ the results of a 5 min google search as
> > > > >>>> there hasn't
> > > > >>>>> been much information presented on the list wrt what is
> > > > actually
> > > > >>>>> available vs
> > > > >>>>> conjecture:
> > > > >>>>>
> > > > >>>>>
> > > > >>>>>> From Microsoft on L2TP clients:
> > > > >>>>>
> > > > >>>>> Explains how to get L2TP on XP and earlier versions of
> > > > >>>> windows (yes, I
> > > > >>>>> wrote "XP").
> > > > >>>>>
> > > > >>>>> 
> http://support.microsoft.com/default.aspx?scid=kb;en-us;8180
> > > > >>>>> 43
> > > > >>>>>
> > > > >>>>> Alice has already sent out how to turn off IPsec.
> > > > >>>>>
> > > > >>>>>
> > > > >>>>> Clients for POSIX OS:
> > > > >>>>>
> > > > >>>>> http://sourceforge.net/projects/rp-l2tp/
> > > > >>>>>
> > > > >>>>>
> > > > >>>>> A quick google gave this information on L2TP as well:
> > > > >>>>>
> > > > >>>>> 0) Cisco support since 2000
> > > > >>>>>
> > > > >>>>> 1) Juniper:
> > > > >>>>>
> > > > >>>>> http://www.juniper.net/products/junose/105016.html
> > > > >>>>>
> > > > >>>>> The ERX now supports IPv6 for BRAS (PPP & L2TP)
> > > > >>>>>
> > > > >>>>> (Since at least September 2003)
> > > > >>>>>
> > > > >>>>> 2) Laurel (now ECI):
> > > > >>>>>
> > > > >>>>>
> > > > >>>>
> > > > >>> 
> > > > 
> http://www.convergedigest.com/PacketSystems/packetsysarticle.asp?I
> > > > D
> > > > >>> =11
> > > > >>>>> 350
> > > > >>>>>
> > > > >>>>> Laurel is also releasing new system software that
> > > adds non-stop
> > > > >>>>> sessions,
> > > > >>>>> IPv6  and LAC (L2TP Access Concentrator) functionality.
> > > > >>>>> http://www.laurelnetworks.com
> > > > >>>>>
> > > > >>>>> Since at least 07-Jun-04
> > > > >>>>>
> > > > >>>>> 3) Nortel:
> > > > >>>>>
> > > > >>>>>
> > > > >>>>
> > > > >>> 
> > > > 
> http://www.nortelnetworks.com/products/library/collateral/66014.25
> > > > -
> > > > >>> 10-
> > > > >>>>> 01.pdf
> > > > >>>>>
> > > > >>>>> "Nortel Networks GGSN acts as an L2TP Access
> > > Concentrator (LAC).
> > > > >>>>> Address allocation, L2TP Network Server (LNS) and ipv6
> > > > >>> routing can
> > > > >>>>> take place within those corporate administrative domains.
> > > > >>>>>
> > > > >>>>> (Posted October 2001)
> > > > >>>>>
> > > > >>>>> It appears that both client and servers are available for
> > > > >>>> desired OS
> > > > >>>>> and interoperability from various commercial vendors.
> > > > >>>>>
> > > > >>>>> -DWard
> > > > >>>>>
> > > > >>>>>
> > > > >>>>>
> > > > >>>>>
> > > > >>>>> _______________________________________________
> > > > >>>>> Softwires mailing list
> > > > >>>>> [email-masked]
> > > > >>>>> https://www1.ietf.org/mailman/listinfo/softwires
> > > > >>>>>
> > > > >>>>
> > > > >>>>
> > > > >>>>
> > > > >>>>
> > > > >>>> **********************************************
> > > > >>>> The IPv6 Portal: http://www.ipv6tf.org
> > > > >>>>
> > > > >>>> Barcelona 2005 Global IPv6 Summit Slides available at:
> > > > >>>> http://www.ipv6-es.com
> > > > >>>>
> > > > >>>> This electronic message contains information which may be 
> > > > >>>> privileged or confidential. The information is intended
> > > > to be for
> > > > >>>> the use of the individual(s) named above. If you 
> are not the 
> > > > >>>> intended recipient be aware that any disclosure, copying, 
> > > > >>>> distribution or use of the contents of this information,
> > > > including
> > > > >>>> attached files, is prohibited.
> > > > >>>>
> > > > >>>>
> > > > >>>>
> > > > >>>>
> > > > >>>>
> > > > >>>> _______________________________________________
> > > > >>>> Softwires mailing list
> > > > >>>> [email-masked]
> > > > >>>> https://www1.ietf.org/mailman/listinfo/softwires
> > > > >>>>
> > > > >>>
> > > > >>> _______________________________________________
> > > > >>> Softwires mailing list
> > > > >>> [email-masked]
> > > > >>> https://www1.ietf.org/mailman/listinfo/softwires
> > > > >>>
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > **********************************************
> > > > > The IPv6 Portal: http://www.ipv6tf.org
> > > > >
> > > > > Barcelona 2005 Global IPv6 Summit Slides available at:
> > > > > http://www.ipv6-es.com
> > > > >
> > > > > This electronic message contains information which may be
> > > > privileged
> > > > > or confidential. The information is intended to be for the
> > > > use of the
> > > > > individual(s) named above. If you are not the intended
> > > recipient be
> > > > > aware that any disclosure, copying, distribution or 
> use of the 
> > > > > contents of this information, including attached files, is
> > > > prohibited.
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > _______________________________________________
> > > > > Softwires mailing list
> > > > > [email-masked]
> > > > > https://www1.ietf.org/mailman/listinfo/softwires
> > > > >
> > > > >
> > > > >
> > > > > _______________________________________________
> > > > > Softwires mailing list
> > > > > [email-masked]
> > > > > https://www1.ietf.org/mailman/listinfo/softwires
> > > > 
> > > > 
> > > > 
> > > > 
> > > > 
> > > > _______________________________________________
> > > > Softwires mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/softwires
> > > > 
> > > 
> > > 
> > > 
> > > _______________________________________________
> > > Softwires mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/softwires
> > > 
> > 
> > _______________________________________________
> > Softwires mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/softwires
> 
> --
> Tim/::1
> 
> 
> 
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/softwires
> 

_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

---

From: Tim Chown <[email-masked]>
Date: Thu, 16 Mar 2006 17:35:30 +0000

Hi Alain,

Fair enough, I thought I'd ask as I'd heard a few comments along these
lines.  It might benice to get some idea of a 'roadmap' (I'm not a huge
fan of that word :) of how the proposed softwires solution(s) can be
used and the timelines of how they'll fit into emerging native IPv6
solutions.   Nothing detailed, just enough to give a flavour.

Tim

-- 
Tim/::1