Subject: [Softwires] About UDP encaps...

From: "Durand, Alain" <[email-masked]>
Date: Mon, 20 Mar 2006 00:47:13 -0500

Jordi,

The point about UDP encaps has been discussed many times. You are the only one considering this as a big issue so far. All others have explained that in real life (the gazilions of L2TP deployments) this has never been an issue.

So unless you have -new- and very strong arguments,  the issue is closed.

   - Alain.
_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 20 Mar 2006 10:32:28 -0600

Hi Alain,

Yes, it was discussed lots of times because the IPv6-in-IPv4 case, but NEVER
in the IPv4-in-IPv6 case, which is quite different.

Again, is one more detail to include in the comparison among protocols,
discussed or not.

As I have already said, this is not an issue in L2TPv3, but the complete
picture need to be contemplated. I'm starting to be convinced that L2TPv2 is
not a good solution, so if we go into that direction, it should be L2TPv3
instead and we need to compare L2TPv3, not L2TPv2.

Anyway, we have the right to disagree I guess, and the freedom to express it
as much as each one like.

Regards,
Jordi

> De: "Durand, Alain" <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Mon, 20 Mar 2006 00:47:13 -0500
> Para: <[email-masked]>, <[email-masked]>
> Conversación: [Softwires] Technical Comparison between L2TPv2 and TSP
> Asunto: About UDP encaps...
> 
> Jordi,
> 
> The point about UDP encaps has been discussed many times. You are the only one
> considering this as a big issue so far. All others have explained that in real
> life (the gazilions of L2TP deployments) this has never been an issue.
> 

**********************************************
The IPv6 Portal: http://www.ipv6tf.org

Barcelona 2005 Global IPv6 Summit
Slides available at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: "Spencer Dawkins" <[email-masked]>
Date: Mon, 20 Mar 2006 19:34:25 -0600

Hi, Jordi,

I am confused. Is the protocol stack you are thinking of

IPv4
UDP
IPv6?

Spencer

----- Original Message ----- 
From: "JORDI PALET MARTINEZ" <[email-masked]>
To: <[email-masked]>
Sent: Monday, March 20, 2006 10:32 AM
Subject: [Softwires] Re: About UDP encaps...

Hi Alain,

Regards,
Jordi

This electronic message contains information which may be privileged or 
confidential. The information is intended to be for the use of the 
individual(s) named above. If you are not the intended recipient be aware 
that any disclosure, copying, distribution or use of the contents of this 
information, including attached files, is prohibited.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 20 Mar 2006 19:50:33 -0600

Hi Spencer,

Yes, that's my concern.

With LT2Pv2, we are forced, I believe, to have IPv4/UDP/IPv6 ... This is not
the case with LT2Pv3.

My understanding is that the requirement was IPv4/IPv6, but I never though
this will be forced to use UDP ... (while it was clear for IPv6/IPv4 that we
may end up forcing IPv6/UDP/IPv4).

Regards,
Jordi

> De: Spencer Dawkins <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Mon, 20 Mar 2006 19:34:25 -0600
> Para: <[email-masked]>
> Asunto: Re: [Softwires] Re: About UDP encaps...
> 
> Hi, Jordi,
>

---

From: Francis Dupont <[email-masked]>
Date: Thu, 23 Mar 2006 21:45:36 +0100

In your previous mail you wrote:

   With LT2Pv2, we are forced, I believe, to have IPv4/UDP/IPv6 ...

=> false, L2TPv2 can run over IP as the protocol 115
   
Regards
   
[email-masked]

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 23 Mar 2006 14:52:33 -0600

Even better, wonderful !

:-)

Regards,
Jordi

> De: Francis Dupont <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Thu, 23 Mar 2006 21:45:36 +0100
> Para: <[email-masked]>
> CC: "[email-masked]" <[email-masked]>