Subject: RE: [Softwires] Notes and Consensus from Interim Meeting in Hong Kong

From: "Bill Storer \(bstorer\)" <[email-masked]>
Date: Wed, 15 Mar 2006 14:32:37 -0800

Hi JF,

You mention that we need to consider the number of vendors supporting L2TP in a Softwires context.  Large numbers of L2TP Softwires users would certainly bolster the L2TP position.  However, those numbers are not necessary to demonstrate support, scalability, and manageability of L2TP for the Softwires service provider.  The reason for this is that L2TP is just transporting PPP packets for Softwires.  This is business as usual for an existing implementation of L2TP.  

Bill

> -----Original Message-----
> From: JF Tremblay [mailto:[email-masked]] 
> Sent: Wednesday, March 15, 2006 10:18 AM
> To: Bill Storer (bstorer); Maria A. Dos Santos (mariados); 
> [email-masked]; [email-masked]
> Subject: RE: [Softwires] Notes and Consensus from Interim 
> Meeting in Hong Kong
> 
> --On Wednesday, March 15, 2006 8:54 AM -0800 "Bill Storer (bstorer)" 
> <[email-masked]> wrote:
> 
> > To summarize here:
> 
> Bill,
> Let me add on this.
> 
> > 1. None of the proposed solutions are supported by standard issue
> > "out of the box" Microsoft Windows.  All of the solutions will
> > require loading extra software on Windows.
> 
> Right. However, we should differentiate between a simple application 
> (like a TSP client) and something that requires integration 
> with the OS 
> such as a new network driver. The level of complexity involved is 
> different.
> 
> TSP uses existing host resources, that makes a huge 
> difference for the 
> time-to-market requirement.
> 
> > 2. L2TP is closest in
> > the above sense as it is supported by standard Windows XP for
> > IPv4/IPv4 tunneling.
> 
> TSP also uses standard tunneling in Windows XP for IPv6 in 
> IPv4. (btw, 
> did you mean IPv6/IPv4 in the above statement?)
> 
> > 3. GPL code is available for L2TP.
> 
> Idem for TSP. There are also plan to license the client under a BSD 
> license.
> 
> > 4. L2TP has been implemented in Windows by NTT and SixXs.
> 
> L2TP is not yet implemented by the SixXS client, from what I 
> understand. TSP has been implemented on a wide range of OS and by CPE 
> manufacturers such as NEC, Draytek and Panasonic. It is also 
> implemented on the SixXS client.
> 
> > 5. Most importantly, L2TP is widely supported by the major
> > concentrator vendors.
> 
> Most importantly, how many vendors actually support L2TP within the 
> softwires context? How many vendors offer L2TP for IPv6 access? How 
> many can support tunneling IPv4 over a native IPv6 network?
> 
> The current deployment of L2TP is indeed a factor to consider. But we 
> have to consider deployment within the softwires context. The current 
> deployment of L2TP specific to IPv6 transition is small.
> 
> And I'd like to add:
> 6. TSP is used and deployed now by several ISPs, reserach 
> networks and 
> US DoD agencies for IPv6 access. How many end customers actually use 
> L2TP for IPv6 access now?
> 
> Based on the above information, it's clear that L2TP and TSP are both 
> very close to the solution we are looking for, with TSP 
> having an edge 
> in actual deployment for IPv6 transition.
> 
> IMHO, the question naturally stemming from this is could we possible 
> consider two protocols to be standardized for softwires? If we don't, 
> then we should debate modifying the existing criteria list 
> (possibly to 
> include a clear reference to time-to-market) and then debate 
> the merits 
> of each protocols in details (i.e. not with wild guesses).
> 
> JF
> 
> >
> > Bill
> >
> >> -----Original Message-----
> >> From: Maria A. Dos Santos (mariados)
> >> Sent: Saturday, March 11, 2006 12:02 PM
> >> To: [email-masked]; [email-masked]
> >> Subject: RE: [Softwires] Notes and Consensus from Interim
> >> Meeting in Hong Kong
> >>
> >> Jordi,
> >>
> >> We googled "l2tp client" and found SixXs release note mentioned
> >>
> >>  "L2TP Support (Yes, even under Windows one can do IPv6 in
> >> PPP in L2TP :)"
> >>
> >> a window client that will have l2tp capability.
> >>
> >> Bill queried Jeroen Massar at SixXs and confirmed that the
> >> l2tp capability
> >> will probably be available in 2 months to the public.
> >>
> >> http://www.sixxs.net/tools/aiccu/history/
> >>
> >> Just one example...
> >>
> >> alice
> >>
> >> > -----Original Message-----
> >> > From: JORDI PALET MARTINEZ [mailto:[email-masked]]
> >> > Sent: Friday, 10 March, 2006 9:30
> >> > To: [email-masked]
> >> > Subject: Re: [Softwires] Notes and Consensus from Interim
> >> > Meeting in Hong Kong
> >> >
> >> > Hi David,
> >> >
> >> > I think the main discussion here has been related to the lack
> >> > of IPv6 support for L2TP in XP (and I guess is the same in
> >> > W2003). Unless I misread the link that you provided, I think
> >> > doesn't mention IPv6 support at all.
> >> >
> >> > I also recall having checked with Microsoft a couple of times
> >> > and they confirmed that will be only available in Vista. Of
> >> > course, this can change, and that will be great actually !
> >> >
> >> > Regards,
> >> > Jordi
> >> >
> >> >
> >> >
> >> >
> >> > > De: David Ward <[email-masked]>
> >> > > Responder a: <[email-masked]>
> >> > > Fecha: Fri, 10 Mar 2006 11:12:36 -0600
> >> > > Para: David Ward <[email-masked]>, "[email-masked]"
> >> > > <[email-masked]>, "Durand, Alain"
> >> > <[email-masked]>
> >> > > Conversación: [Softwires] Notes and Consensus from Interim
> >> > Meeting in
> >> > > Hong Kong
> >> > > Asunto: Re: [Softwires] Notes and Consensus from Interim
> >> Meeting in
> >> > > Hong Kong
> >> > >
> >> > > Although I am sitting back allowing folks to discuss
> >> > various issues, I
> >> > > had to step in w/ the results of a 5 min google search as
> >> > there hasn't
> >> > > been much information presented on the list wrt what 
> is actually
> >> > > available vs
> >> > > conjecture:
> >> > >
> >> > >
> >> > >> From Microsoft on L2TP clients:
> >> > >
> >> > > Explains how to get L2TP on XP and earlier versions of
> >> > windows (yes, I
> >> > > wrote "XP").
> >> > >
> >> > > http://support.microsoft.com/default.aspx?scid=kb;en-us;818043
> >> > >
> >> > > Alice has already sent out how to turn off IPsec.
> >> > >
> >> > >
> >> > > Clients for POSIX OS:
> >> > >
> >> > > http://sourceforge.net/projects/rp-l2tp/
> >> > >
> >> > >
> >> > > A quick google gave this information on L2TP as well:
> >> > >
> >> > > 0) Cisco support since 2000
> >> > >
> >> > > 1) Juniper:
> >> > >
> >> > > http://www.juniper.net/products/junose/105016.html
> >> > >
> >> > > The ERX now supports IPv6 for BRAS (PPP & L2TP)
> >> > >
> >> > > (Since at least September 2003)
> >> > >
> >> > > 2) Laurel (now ECI):
> >> > >
> >> > >
> >> >
> >> 
> http://www.convergedigest.com/PacketSystems/packetsysarticle.asp?ID=
> >> 11
> >> > > 350
> >> > >
> >> > > Laurel is also releasing new system software that adds non-stop
> >> > > sessions,
> >> > > IPv6  and LAC (L2TP Access Concentrator) functionality.
> >> > > http://www.laurelnetworks.com
> >> > >
> >> > > Since at least 07-Jun-04
> >> > >
> >> > > 3) Nortel:
> >> > >
> >> > >
> >> >
> >> 
> http://www.nortelnetworks.com/products/library/collateral/66014.25-1
> >> 0-
> >> > > 01.pdf
> >> > >
> >> > > "Nortel Networks GGSN acts as an L2TP Access 
> Concentrator (LAC).
> >> > > Address allocation, L2TP Network Server (LNS) and ipv6
> >> routing can
> >> > > take place within those corporate administrative domains.
> >> > >
> >> > > (Posted October 2001)
> >> > >
> >> > > It appears that both client and servers are available for
> >> > desired OS
> >> > > and interoperability from various commercial vendors.
> >> > >
> >> > > -DWard
> >> > >
> >> > >
> >> > >
> >> > >
> >> > > _______________________________________________
> >> > > Softwires mailing list
> >> > > [email-masked]
> >> > > https://www1.ietf.org/mailman/listinfo/softwires
> >> > >
> >> >
> >> >
> >> >
> >> >
> >> > **********************************************
> >> > The IPv6 Portal: http://www.ipv6tf.org
> >> >
> >> > Barcelona 2005 Global IPv6 Summit
> >> > Slides available at:
> >> > http://www.ipv6-es.com
> >> >
> >> > This electronic message contains information which may be
> >> > privileged or confidential. The information is intended to be
> >> > for the use of the individual(s) named above. If you are not
> >> > the intended recipient be aware that any disclosure, copying,
> >> > distribution or use of the contents of this information,
> >> > including attached files, is prohibited.
> >> >
> >> >
> >> >
> >> >
> >> >
> >> > _______________________________________________
> >> > Softwires mailing list
> >> > [email-masked]
> >> > https://www1.ietf.org/mailman/listinfo/softwires
> >> >
> >>
> >> _______________________________________________
> >> Softwires mailing list
> >> [email-masked]
> >> https://www1.ietf.org/mailman/listinfo/softwires
> >>
> >
> > _______________________________________________
> > Softwires mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/softwires
> 

_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

---

From: JF Tremblay <[email-masked]>
Date: Wed, 15 Mar 2006 19:13:36 -0500

> Hi JF,

Hi Bill.

> You mention that we need to consider the number of vendors supporting
> L2TP in a Softwires context.  Large numbers of L2TP Softwires users
> would certainly bolster the L2TP position.  However, those numbers
> are not necessary to demonstrate support, scalability, and
> manageability of L2TP for the Softwires service provider. The reason
> for this is that L2TP is just transporting PPP packets for Softwires.
> This is business as usual for an existing implementation of L2TP.

Agreed for scalability and manageability, but for support, I have some 
reserves. Honestly, I'm not a L2TP expert, but let's say for a second I 
am an implementer with an existing L2TP platform (server). If I plan to 
support softwires scenarios, I would expect that some work has to be 
done and it won't come for free.

For example, I would ask myself what has to be changed to support L2TP 
over IPv6 transport for a DSTM-like (v4 in v6) scenario. I would very 
likely need changes to my L2TP implementation to support v6 transport, 
add an IPCPv4 implementation if I don't have one, and a DHCPv4 server 
as well. For IPv6 in IPv4, I would also need an IPCPv6 client and 
server, a DHCPv6 server, etc. Yes, these things do exist now, but I 
need to integrate them to my product and this takes some time.

My point, in brief, is that future vendor support and the possibility 
of a short-term end-user deployment cannot be demonstrated using the 
existing L2TP install base.

JF

>> understand. TSP has been implemented on a wide range of OS and by
>> CPE  manufacturers such as NEC, Draytek and Panasonic. It is also
>> The current deployment of L2TP is indeed a factor to consider. But
>> we  have to consider deployment within the softwires context. The
>> current  deployment of L2TP specific to IPv6 transition is small.
>>
>> And I'd like to add:
>> Based on the above information, it's clear that L2TP and TSP are
>> both  very close to the solution we are looking for, with TSP
>> having an edge
>> consider two protocols to be standardized for softwires? If we
>> don't,  then we should debate modifying the existing criteria list
>> (possibly to
>> >> > > Laurel is also releasing new system software that adds
>> >> > > non-stop sessions,