Subject: RE: [Softwires] Notes and Consensus from Interim Meeting in Hong Kong

From: "Fiumano, Michael F [NTK]" <[email-masked]>
Date: Wed, 15 Mar 2006 13:06:29 -0600

Hello,

Why do all solutions "require" Windows at all???  I have the need to use this standard to enable a port on my network to tunnel v6 over my v4 infrastructure to a v6 enabled part of my network.  I hope that this is being kept in consideration for the solution space.

As an operator of a large network, the problems I see aren't always from a end host.  I would prefer an L2TPv3 solution preferably as we use this technology today as a L2 psuedowire transport across our network. 

Maybe I am off base, and this is not being given any attention because it is assumed that this will work, but please consider this when talking to your solutions as well.

Thanks,
Michael Fiumano
Senior Network Engineer
IP Core Infrastructure
703-689-5875 Wk
703-598-2434 Cel
[email-masked]

> De: "Bill Storer (bstorer)" <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Wed, 15 Mar 2006 08:54:46 -0800
> Para: "Maria A. Dos Santos (mariados)" <[email-masked]>,
> <[email-masked]>, <[email-masked]>
> Conversación: [Softwires] Notes and Consensus from Interim Meeting in Hong
> Kong
> Asunto: RE: [Softwires] Notes and Consensus from Interim Meeting in Hong Kong
> 
> To summarize here:
> 
> 1. None of the proposed solutions are supported by standard issue "out of the
> box" Microsoft Windows.  All of the solutions will require loading extra
> software on Windows.

I'm not sure if this was a requirement, not in my opinion. It will be ideal,
but we know is difficult for old OSs.

> 2. L2TP is closest in the above sense as it is supported by standard Windows
> XP for IPv4/IPv4 tunneling.

With a small trick to disable IPsec, but I guess it could be automated.

> 3. GPL code is available for L2TP.

Same as other solutions.

> 4. L2TP has been implemented in Windows by NTT and SixXs.

It will be by SixXS, but agree, within a good timing in my opinion (actually
shorter timing that I will say is the required one, but that's a different
discussion).

> 5. Most importantly, L2TP is widely supported by the major concentrator
> vendors.

Yes, for two main router/concentrator vendors, should be ok.

Now, if you compare L2TP with TSP (I'm not advocating for one or the other,
just trying to analyze the situation), TSP seems better to integrate from
the client perspective and no need to play tricks in any OS. However has
less support from the server side.

So the question is again, IF we want to have a fair comparison:
1) Technical detailed comparison of different aspects among both of them,
pros and cons (i.e., overhead, prefix delegation, DNS, etc.).

2) How much time it will take for router/concentrator vendors to implement
TSP, and if it will happen in case we choose it.

3) How much weight we give to the support in routers vs. the support in
clients.

Not easy ...

> 
> Bill
> 
>> -----Original Message-----
>> From: Maria A. Dos Santos (mariados)
>> Sent: Saturday, March 11, 2006 12:02 PM
>> To: [email-masked]; [email-masked]
>> Subject: RE: [Softwires] Notes and Consensus from Interim
>> Meeting in Hong Kong
>> 
>> Jordi,
>> 
>> We googled "l2tp client" and found SixXs release note mentioned
>> 
>>  "L2TP Support (Yes, even under Windows one can do IPv6 in
>> PPP in L2TP :)"
>> 
>> a window client that will have l2tp capability.
>> 
>> Bill queried Jeroen Massar at SixXs and confirmed that the
>> l2tp capability 
>> will probably be available in 2 months to the public.
>> 
>> http://www.sixxs.net/tools/aiccu/history/
>> 
>> Just one example...
>> 
>> alice
>> 
>>> -----Original Message-----
>>> From: JORDI PALET MARTINEZ [mailto:[email-masked]]
>>> Sent: Friday, 10 March, 2006 9:30
>>> To: [email-masked]
>>> Subject: Re: [Softwires] Notes and Consensus from Interim
>>> Meeting in Hong Kong
>>> 
>>> Hi David,
>>> 
>>> I think the main discussion here has been related to the lack
>>> of IPv6 support for L2TP in XP (and I guess is the same in
>>> W2003). Unless I misread the link that you provided, I think
>>> doesn't mention IPv6 support at all.
>>> 
>>> I also recall having checked with Microsoft a couple of times
>>> and they confirmed that will be only available in Vista. Of
>>> course, this can change, and that will be great actually !
>>> 
>>> Regards,
>>> Jordi
>>> 
>>> 
>>> 
>>> 
>>>> De: David Ward <[email-masked]>
>>>> Responder a: <[email-masked]>
>>>> Fecha: Fri, 10 Mar 2006 11:12:36 -0600
>>>> Para: David Ward <[email-masked]>, "[email-masked]"
>>>> <[email-masked]>, "Durand, Alain"
>>> <[email-masked]>
>>>> Conversación: [Softwires] Notes and Consensus from Interim
>>> Meeting in 
>>>> Hong Kong
>>>> Asunto: Re: [Softwires] Notes and Consensus from Interim
>> Meeting in 
>>>> Hong Kong
>>>> 
>>>> Although I am sitting back allowing folks to discuss
>>> various issues, I
>>>> had to step in w/ the results of a 5 min google search as
>>> there hasn't 
>>>> been much information presented on the list wrt what is actually
>>>> available vs
>>>> conjecture:
>>>> 
>>>> 
>>>>> From Microsoft on L2TP clients:
>>>> 
>>>> Explains how to get L2TP on XP and earlier versions of
>>> windows (yes, I
>>>> wrote "XP").
>>>> 
>>>> http://support.microsoft.com/default.aspx?scid=kb;en-us;818043
>>>> 
>>>> Alice has already sent out how to turn off IPsec.
>>>> 
>>>> 
>>>> Clients for POSIX OS:
>>>> 
>>>> http://sourceforge.net/projects/rp-l2tp/
>>>> 
>>>> 
>>>> A quick google gave this information on L2TP as well:
>>>> 
>>>> 0) Cisco support since 2000
>>>> 
>>>> 1) Juniper:
>>>> 
>>>> http://www.juniper.net/products/junose/105016.html
>>>> 
>>>> The ERX now supports IPv6 for BRAS (PPP & L2TP)
>>>> 
>>>> (Since at least September 2003)
>>>> 
>>>> 2) Laurel (now ECI):
>>>> 
>>>> 
>>> 
>> http://www.convergedigest.com/PacketSystems/packetsysarticle.asp?ID=11
>>>> 350
>>>> 
>>>> Laurel is also releasing new system software that adds non-stop
>>>> sessions,
>>>> IPv6  and LAC (L2TP Access Concentrator) functionality.
>>>> http://www.laurelnetworks.com
>>>> 
>>>> Since at least 07-Jun-04
>>>> 
>>>> 3) Nortel:
>>>> 
>>>> 
>>> 
>> http://www.nortelnetworks.com/products/library/collateral/66014.25-10-
>>>> 01.pdf
>>>> 
>>>> "Nortel Networks GGSN acts as an L2TP Access Concentrator (LAC).
>>>> Address allocation, L2TP Network Server (LNS) and ipv6
>> routing can 
>>>> take place within those corporate administrative domains.
>>>> 
>>>> (Posted October 2001)
>>>> 
>>>> It appears that both client and servers are available for
>>> desired OS 
>>>> and interoperability from various commercial vendors.
>>>> 
>>>> -DWard
>>>> 
>>>> 
>>>> 
>>>> 
>>>> _______________________________________________
>>>> Softwires mailing list
>>>> [email-masked]
>>>> https://www1.ietf.org/mailman/listinfo/softwires
>>>> 
>>> 
>>> 
>>> 
>>> 
>>> **********************************************
>>> The IPv6 Portal: http://www.ipv6tf.org
>>> 
>>> Barcelona 2005 Global IPv6 Summit
>>> Slides available at:
>>> http://www.ipv6-es.com
>>> 
>>> This electronic message contains information which may be
>>> privileged or confidential. The information is intended to be
>>> for the use of the individual(s) named above. If you are not
>>> the intended recipient be aware that any disclosure, copying,
>>> distribution or use of the contents of this information,
>>> including attached files, is prohibited.
>>> 
>>> 
>>> 
>>> 
>>> 
>>> _______________________________________________
>>> Softwires mailing list
>>> [email-masked]
>>> https://www1.ietf.org/mailman/listinfo/softwires
>>> 
>> 
>> _______________________________________________
>> Softwires mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/softwires
>> 

**********************************************
The IPv6 Portal: http://www.ipv6tf.org

Barcelona 2005 Global IPv6 Summit
Slides available at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 15 Mar 2006 20:26:36 +0100

Hi Michael,

We aren't denying the need for support in others, but we like it or not, XP
is 80-85% of the market, and is an important target for what the WG is
trying to achieve.

How much important is that vs. Router to Router, is why I asked the point 3)
to weight it.

Anyway my understanding is that in a carrier network most probably you will
not be using softwires, unless you're needing just a default route, as it
may be the case if you manage the CPE router.

Regards,
Jordi

> De: "Fiumano, Michael F [NTK]" <[email-masked]>
> Fecha: Wed, 15 Mar 2006 13:06:29 -0600
> Para: <[email-masked]>
> Why do all solutions "require" Windows at all???  I have the need to use this
> standard to enable a port on my network to tunnel v6 over my v4 infrastructure
> to a v6 enabled part of my network.  I hope that this is being kept in
> consideration for the solution space.
> 
> As an operator of a large network, the problems I see aren't always from a end
> host.  I would prefer an L2TPv3 solution preferably as we use this technology
> today as a L2 psuedowire transport across our network.
> 
> Maybe I am off base, and this is not being given any attention because it is
> assumed that this will work, but please consider this when talking to your
> solutions as well.
> 
> Thanks,
> Michael Fiumano
> Senior Network Engineer
> IP Core Infrastructure
> 703-689-5875 Wk
> 703-598-2434 Cel
> This electronic message contains information which may be privileged or
> confidential. The information is intended to be for the use of the
> individual(s) named above. If you are not the intended recipient be aware that
> any disclosure, copying, distribution or use of the contents of this
> information, including attached files, is prohibited.
> 
> 
> 
>

---

From: JF Tremblay <[email-masked]>
Date: Wed, 15 Mar 2006 14:38:20 -0500

> Hello,

Hi Michael.
Thanks for your input. Some comments/questions below.

> Why do all solutions "require" Windows at all???  I have the need to
> use this standard to enable a port on my network to tunnel v6 over my
> v4 infrastructure to a v6 enabled part of my network.  I hope that
> this is being kept in consideration for the solution space.

According to the problem statement, we have to consider host-based 
solutions for the hub & spokes problem (scenario #2 and #3). Windows XP 
constitutes a large part of the current dual-stack capable host base.

> As an operator of a large network, the problems I see aren't always
> from a end host.  I would prefer an L2TPv3 solution preferably as we
> use this technology today as a L2 psuedowire transport across our
> network.

Right, a CPE can terminate the softwire (scenario #1). I'm curious 
about something though. In your current L2 pseudowire deployment, is 
any of the pseudowires terminated directly on a CPE device (enterprise 
or end user)? How easily can these be upgraded to IPv6 and L2TPv3 for 
softwire termination purposes?

Thanks,
Jean-Francois Tremblay
Hexago
-------------------------------------------------
http://www.freenet6.net : Free IPv6 Connectivity
-------------------------------------------------

> Maybe I am off base, and this is not being given any attention
> because it is assumed that this will work, but please consider this
> when talking to your solutions as well.
>
> Thanks,
> Michael Fiumano
> Senior Network Engineer
> IP Core Infrastructure
> 703-689-5875 Wk
> 703-598-2434 Cel
>> Conversación: [Softwires] Notes and Consensus from Interim Meeting
>> in Hong Kong
>> 1. None of the proposed solutions are supported by standard issue
>> "out of the box" Microsoft Windows.  All of the solutions will
>> require loading extra software on Windows.
>
> I'm not sure if this was a requirement, not in my opinion. It will be
> ideal, but we know is difficult for old OSs.
>
>> 2. L2TP is closest in the above sense as it is supported by standard
>> Windows XP for IPv4/IPv4 tunneling.
>
> It will be by SixXS, but agree, within a good timing in my opinion
> (actually shorter timing that I will say is the required one, but
> that's a different discussion).
>
>> 5. Most importantly, L2TP is widely supported by the major
>> concentrator vendors.
>
> Now, if you compare L2TP with TSP (I'm not advocating for one or the
> other, just trying to analyze the situation), TSP seems better to
> integrate from the client perspective and no need to play tricks in
> any OS. However has less support from the server side.
>
> 1) Technical detailed comparison of different aspects among both of
> them, pros and cons (i.e., overhead, prefix delegation, DNS, etc.).
>
> 2) How much time it will take for router/concentrator vendors to
> implement TSP, and if it will happen in case we choose it.
>
> 3) How much weight we give to the support in routers vs. the support
> in clients.
>
> Not easy ...
>
>>
>> Bill
>>
> This electronic message contains information which may be privileged
> or confidential. The information is intended to be for the use of the
> individual(s) named above. If you are not the intended recipient be
> aware that any disclosure, copying, distribution or use of the
> contents of this information, including attached files, is prohibited.
>
>
>
>