Subject: RE: [Softwires] Re: About UDP encaps...

From: "Durand, Alain" <[email-masked]>
Date: Mon, 20 Mar 2006 15:00:58 -0500

Jordi,

FYI,
The L2TP extension wg had in the past been looking at the encapsulation
overhead issue
and published:
http://tools.ietf.org/wg/l2tpext/draft-ietf-l2tpext-l2tphc/draft-ietf-l2
tpext-l2tphc-06.txt

This work has essentially died by lack of practical interest and was
never implemented as far as I've
been told. Given the very large scale of current L2TP deployments, this
is proof that
encapsulation overhead is a red herring.

Now, you may disagree, this is your absolute right, but I'd like to
recommend that you do not
derail this wg efforts by constantly bringing this as a fundamental
issue to be solved.

   - Alain.

_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

---

From: "Bill Storer \(bstorer\)" <[email-masked]>
Date: Thu, 23 Mar 2006 16:59:55 -0800

Yes, there's nothing in RFC 2661 that says UDP/IP is the only transport.

Snip...

8.2 IP

   When operating in IP environments, L2TP MUST offer the UDP
   encapsulation described in 8.1 as its default configuration for IP
   operation. Other configurations (perhaps corresponding to a
   compressed header format) MAY be defined and made available as a
   configurable option.

So, you could use something else.  I was unaware that anyone had ever
done a non UDP IP implementation.

Bill 

> -----Original Message-----
> From: Francis Dupont [mailto:[email-masked]] 
> Sent: Thursday, March 23, 2006 12:46 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Softwires] Re: About UDP encaps... 
> 
>  In your previous mail you wrote:
> 
>    With LT2Pv2, we are forced, I believe, to have IPv4/UDP/IPv6 ...
> 
> => false, L2TPv2 can run over IP as the protocol 115
>    
> Regards
>    
> [email-masked]
>