Subject: [Softwires] Comment about draft-dhankins-softwire-tunnel-option

From: <[email-masked]>
Date: Mon, 16 Nov 2009 14:33:39 +0100

Dear authors, all,

The current version of the draft defines a single option which is used to convey one FQDN pointing to a DS-lite CGN. The use of FQDN may have several advantages compared to a plain IPv6 address such as enabling DNS-based load distribution among a set of CGN devices. Nevertheless, this should not preclude to define an option to convey a (list) of IPv6 address instead of FQDN. It is up to the service providers to decide whether enclosing an IP address or a FQDN in the ds-lite DHCP option is more appropriate in their contexts.

Is there any reason why the draft defines only the FQDN option?

Cheers,
Med
*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************

W0ludGVybmV0U2hvcnRjdXRdDQpVUkw9ZnRwOi8vZnRwLmlldGYub3JnL2ludGVybmV0LWRyYWZ0
cy9kcmFmdC1kaGFua2lucy1zb2Z0d2lyZS10dW5uZWwtb3B0aW9uLTA1LnR4dA0K

---

From: Dave Thaler <[email-masked]>
Date: Mon, 16 Nov 2009 22:53:57 +0000

You can resolve an FQDN to a list of IPv6 addresses, so it seems to
already provide that ability just with an FQDN.

-Dave

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Monday, November 16, 2009 5:34 AM
> To: [email-masked]
> Subject: [Softwires] Comment about draft-dhankins-softwire-tunnel-
> option
> 
> 
> Dear authors, all,
> 
> The current version of the draft defines a single option which is used
> to convey one FQDN pointing to a DS-lite CGN. The use of FQDN may have
> several advantages compared to a plain IPv6 address such as enabling
> DNS-based load distribution among a set of CGN devices. Nevertheless,
> this should not preclude to define an option to convey a (list) of IPv6
> address instead of FQDN. It is up to the service providers to decide
> whether enclosing an IP address or a FQDN in the ds-lite DHCP option is
> more appropriate in their contexts.
>

---

From: <[email-masked]>
Date: Tue, 17 Nov 2009 07:35:30 +0100

Dear Dave, all,

I'm not talking about that, but when I don't want to add any entry to my DNS due to some reasons (avoid extra configuration task of DNS for instance.)

Cheers,
Med

-----Message d'origine-----
De : Dave Thaler [mailto:[email-masked]] 
Envoyé : lundi 16 novembre 2009 23:54
À : BOUCADAIR Mohamed NCPI/NAD/TIP; [email-masked]
Objet : RE: Comment about draft-dhankins-softwire-tunnel-option

-Dave

---

From: Dayong Guo <[email-masked]>
Date: Wed, 18 Nov 2009 15:14:08 +0800

Yes,  it seems that FQDN is NOT better thar IPv6 Address of DSlite CGN.  A
CPE needs two operations (one DHCP, one DNS) to discover CGN too.

DHCP has same  load distribution function as DNS-based.

Dayong Guo

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Tuesday, November 17, 2009 2:36 PM
> To: Dave Thaler; [email-masked]
> Subject: Re: [Softwires] Comment about 
> draft-dhankins-softwire-tunnel-option
> 
> 
> Dear Dave, all,
> 
> I'm not talking about that, but when I don't want to add any 
> entry to my DNS due to some reasons (avoid extra 
> configuration task of DNS for instance.)
> 
> Cheers,
> Med
>  
> 
> De : Dave Thaler [mailto:[email-masked]] Envoyé : 
> lundi 16 novembre 2009 23:54 À : BOUCADAIR Mohamed 
> NCPI/NAD/TIP; [email-masked] Objet : RE: Comment about 
> draft-dhankins-softwire-tunnel-option
> 
> You can resolve an FQDN to a list of IPv6 addresses, so it 
> seems to already provide that ability just with an FQDN.
> 
> -Dave
> 
> > From: [email-masked] 
> [mailto:[email-masked]] 
> > On Behalf Of [email-masked]
> > this should not preclude to define an option to convey a (list) of 
> > IPv6 address instead of FQDN. It is up to the service providers to 
> > decide whether enclosing an IP address or a FQDN in the 
> ds-lite DHCP 
> > option is more appropriate in their contexts.
> >