Subject: [Softwires] Tunnel discovery

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 16 Nov 2009 23:27:54 +0900

Hi,

Looking at the need for discovering a tunnel-endpoint for DSLINE, same as
for other softwires protocols, I wonder if we should revive the work
previously done at

http://tools.ietf.org/id/draft-palet-v6ops-tun-auto-disc-03.txt

I see that a DHCP option is being proposed, however, our previous study was
showing that this is not the best alternative, and similar approaches where
rejected before for softwires hubs&spoke TEP discovery by the DHCP WG.

Regards,
Jordi

**********************************************
The IPv6 Portal: http://www.ipv6tf.org

Bye 6Bone. Hi, IPv6 !
http://www.ipv6day.org

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 16 Nov 2009 23:35:04 +0900

By the way, there is one more document ...

http://tools.ietf.org/id/draft-palet-v6ops-solution-tun-auto-disc-01.txt

Regards,
Jordi

> De: Jordi Palet Martínez <[email-masked]>
> Responder a: Jordi Palet Martínez <[email-masked]>
> Fecha: Mon, 16 Nov 2009 23:27:54 +0900
> Para: <[email-masked]>
> Asunto: [Softwires] Tunnel discovery
> 
> Hi,
> 
> This electronic message contains information which may be privileged or
> confidential. The information is intended to be for the use of the
> individual(s) named above. If you are not the intended recipient be aware that
> any disclosure, copying, distribution or use of the contents of this
> information, including attached files, is prohibited.
> 
> 
> 
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
> 
> 
> This electronic message contains information which may be privileged or
> confidential. The information is intended to be for the use of the
> individual(s) named above. If you are not the intended recipient be aware that
> any disclosure, copying, distribution or use of the contents of this
> information, including attached files, is prohibited.
> 
> 

Bye 6Bone. Hi, IPv6 !
http://www.ipv6day.org

---

From: "Durand, Alain" <[email-masked]>
Date: Tue, 17 Nov 2009 00:15:59 +0900

Jordi,

There is a fundamental difference wrt tunnel end-point discovery between
softwire hub & spoke and dual-stack lite. It is that th dual-stack lite
tunnel is originated by the home gateway itself. As such a DHCPv6 option
will work just fine. It would not have in the more general hub&spoke case,
where a) the tunnel could have been started by an IPv4 node behind the home
gateway and b) the home gateway could have been an unmodified IPv4 gateway,
ie, unaware of such option.

  - Alain