Subject: Re: [Softwires] I-D Action:draft-lee-softwire-6rd-udp-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Fri, 06 Nov 2009 15:18:08 +1300

I like this idea in principle, but I am quite concerned by
two issues that seem to make it unattractive in practice:

1. No defined method for discovering the Subscriber IPv4 Address
(section 3.3) and no universal method of discovering the SP-BR
prefix (requires RADIUS or DIAMETER, section 5.2, but some ISPs
don't use either of them).

2. Does not support IPv6 server ports (section 7.1, no
externally initiated sessions). That's just as bad as traditional
NAT.

One detail in section 4.1:

>    o  this specification does not introduce new requirement to the IPv4
>       UDP Length and Checksum.

Does that mean that the UDP checksum is optional?

    Brian

---

From: "Lee, Yiu" <[email-masked]>
Date: Thu, 5 Nov 2009 21:34:36 -0500

Hi Brian.

I would like to use DHCP to discover the SP-BR. Problem is that the NAT is
the DHCP server for the hosts which won¹t understand the new DHCP option.
Another way to work around this is to define a new light-weight discovery
protocol. Do you have any better idea to share?

For server model, we can define a port-forwarding rule in the NAT. For host
model, things are more tricky. Unfortunately, hosts are behind a NAT and
will suffer from all the NAT limitations.

Thanks,
Yiu

On 11/5/09 9:18 PM, "Brian E Carpenter" <[email-masked]> wrote:

> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>