Subject: [Softwires] Informational RFC 5569 on 6rd now published.

From: Rémi Després <[email-masked]>
Date: Thu, 28 Jan 2010 08:08:12 +0100

Hi, all,

FYI on how 6rd was first deployed in 2007, you can now look at RFC 5569 (tools.ietf.org/rfc/rfc5569.txt)

Cheers,
RD

---

From: Dayong Guo <[email-masked]>
Date: Thu, 28 Jan 2010 18:09:53 +0800

Hi, Rémi 
     Congratulated you for RFC '6rd'   publication.
     But I want to know how a 6rd CPE get default IPv6 DNS server? Manual
configuration?  Because ND or DHCPv6 is not running between CPE and 6rd
relay.

Dayong Guo

Huawei Technologies Co., Ltd.   
Email：[email-masked]
http://www.huawei.com

---

From: Rémi Després <[email-masked]>
Date: Thu, 28 Jan 2010 14:04:22 +0100

Le 28 janv. 2010 à 11:09, Dayong Guo a écrit :
> ... I want to know how a 6rd CPE get default IPv6 DNS server?

Normal hosts, being dual stack (not IPv6-only), query their DNS server in IPv4 as usual.
That is DNS responses that include IPv6 addresses when available.

For example, when browsing to  www.ietf.org, the queried DNS (at 212.27.40.241 in my case) sends back an 2001:1890:1112:1::20 AAAA record. 
The browser then gets the web page in IPv6. 

Regards,

RD