Subject: [Softwires] 6RD prefix delegation without encapsulation?

From: <[email-masked]>
Date: Thu, 21 Jan 2010 23:19:37 +0100

Hi,

draft-ietf-softwire-ipv6-6rd-03 describes how prefixes are automatically delegated.

It also describes IPv6 in IPv4 encapsulation.

However, if CPE has native dual-stack WAN connection, with BR locating at the first hop (say point-to-point connection), what is the problem in CPE obtaining these automatically delegated prefixes as described in 6RD (i.e. based on CPE's IPv4 address), but without need to encapsulate IPv6 packets in IPv4?

Thanks,

	Teemu

---

From: "Lee, Yiu" <[email-masked]>
Date: Thu, 28 Jan 2010 10:26:28 -0500

Hi Teemu,

In 6rd design, we assume that the WAN network is IPv4-only. It is ok that
the CPE WAN port can be dual-stack, but it will never get v6 connectivity
because the network is IPv4-only. So, what is the use case of your question?
Can you explain it in a little more details?

Thanks,
Yiu

On 1/21/10 5:19 PM, "[email-masked]"
<[email-masked]> wrote:

> However, if CPE has native dual-stack WAN connection, with BR locating at the
> first hop (say point-to-point connection), what is the problem in CPE
> obtaining these automatically delegated prefixes as described in 6RD (i.e.
> based on CPE's IPv4 address), but without need to encapsulate IPv6 packets in
> IPv4?
> 
> Thanks,
> 
> Teemu
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: <[email-masked]>
Date: Fri, 29 Jan 2010 11:25:08 +0100

Hi Yiu,

When the WAN is IPv4-only, "CPE" can automatically get prefixes with 6to4 or 6RD to be used locally (just by learning 6RD ISP prefix or using 6to4 WKP).

When the WAN is dual-stack, by current specifications, "CPE" would have to use DHCPv6 for obtaining additional IPv6 prefixes.

Now the "CPE" could use 6to4 or 6RD in the DS WAN case as well, but then it would have to encapsulate.

I am wondering if it would make sense to have automatic prefix delegation, but without need to encapsulate.

In the setups where CPE is behind dual-stack point-to-point link from gateway (GGSN, PDN GW, Home Agent, LMA, ASN GW, BRAS(?)..), the gateway would know where to route as it has assigned the "CPE"'s IPv4 address, which the "CPE" would use in constructing its automatically delegated prefixes.

Best regards,

	Teemu

>-----Original Message-----
>From: ext Lee, Yiu [mailto:[email-masked]]
>Sent: 28 January, 2010 17:26
>To: Savolainen Teemu (Nokia-D-MSW/Tampere); [email-masked]
>Subject: Re: [Softwires] 6RD prefix delegation without encapsulation?
>
>Hi Teemu,
>
>> draft-ietf-softwire-ipv6-6rd-03 describes how prefixes are
>automatically
>> delegated.
>>