Subject: [Softwires] Widening the Port-Control-Protocol scope

From: Rémi Després <[email-masked]>
Date: Fri, 16 Apr 2010 11:04:24 +0200

Dan, Reinaldo, Mohamed,

Following various discussions in Anaheim, here are the two points on which I believe the PCP of draft-wing-softwire-port-control-protocol-01 can advantageously be extended.
(The current scope is:
- DS-lite only
- Only port-control servers that assign ports one by one.)

1.
With the IPv4 address shortage, ISP NATs will be more and more necessary not only in point-to-point configurations, DS-lite in particular, but also in point-to-multipoint configurations, NAT444 in particular. 
PCP should therefore be a *generic port reservation protocol* applicable to both point-to-point and point-to-multipoint access networks*.
If this would be difficult, reasons why limiting to DS-lite would significantly simplify the design should IMHO be discussed.

2.
Allowing PCP servers to assign port ranges, rather than just ports one by one, permits in some scenarios better efficiency and/or extended applications.
In particular: 
- For some gaming applications, current practice includes port-range reservations (see for example the user guide downloaded at http://www.linksysbycisco.com/EU/en/products/WRT120N). A host needing a range for an application, and having received a set of ports in one shot: (1) would be able to reserve consecutive ports; (2) would avoid interacting with the port-control server N times if it needs N ports.
- If a host that needs a port is given in one shot a range of ports, it is easy in this host to avoid new requests to the server until it has consumed its assigned range.

Thoughts?

RD

---

From: Simon Perreault <[email-masked]>
Date: Fri, 16 Apr 2010 08:02:39 -0400

On 2010-04-16 05:04, Rémi Després wrote:
> (The current scope is: - DS-lite only - Only port-control servers
> that assign ports one by one.)
>
> 1. With the IPv4 address shortage, ISP NATs will be more and more
> necessary not only in point-to-point configurations, DS-lite in
> particular, but also in point-to-multipoint configurations, NAT444 in
> particular. PCP should therefore be a *generic port reservation
> protocol* applicable to both point-to-point and point-to-multipoint
> access networks*. If this would be difficult, reasons why limiting to
> DS-lite would significantly simplify the design should IMHO be
> discussed.

I had understood the scope to also include NAT64. See section 2.

Unless the authors foresee specific problems with a larger scope, I
agree it should be expanded to "any NAT44 or NAT64." Let's focus on 
logical functions, not on specific deployments.

The scope should also include multiple layers of NAT.

Simon
-- 
NAT64/DNS64 open-source --> http://ecdysis.viagenie.ca
STUN/TURN server        --> http://numb.viagenie.ca
vCard 4.0               --> http://www.vcarddav.org

---

From: Rémi Després <[email-masked]>
Date: Fri, 16 Apr 2010 14:34:47 +0200

Hi Simon,

> I had understood the scope to also include NAT64. See section 2.

Strictly speaking, you are right, but section 2 starts with 
"PCP has a very focused goal of allowing port reservation in the context of Dual-Stack Lite".
Other configurations should, IMHO, be clearly on the same footing.

> agree it should be expanded to "any NAT44 or NAT64." Let's focus on logical functions, not on specific deployments.
> 

Agreed.
PCP must be a protocol between PCP clients and PCP servers, with enough initial use cases to justify it, but without preventing other use cases to be found useful.

Regards,
RD

> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires