Subject: [Softwires] Softwire agenda for IETF79

From: Alain Durand <[email-masked]>
Date: Wed, 3 Nov 2010 18:03:27 -0700

Dear wg,

Here is the tentative agenda for the softwire meeting at IETF79.
As you see, there is an abundance of items that are neither on the current charter nor on the logical updates
that we chairs have been discussing with our ADs.

  - Alain.

IETF79 Softwire agenda

Items in charter

Multicast Mesh, Mingwei Xu, Chris Metz
draft-dhankins-softwire-tunnel-option, David Hankins

items in agreed evolution of the charter:

draft-lee-softwire-dslite-deployment-00, Yiu Lee
draft-qin-softwire-dslite-multicast-00, Jacni Qin
draft-ietf-softwire-dslite-radius-ext-00, roberta Maglione
draft-ietf-softwire-gateway-init-ds-lite-02, F. Brockners
draft-cui-softwire-host-4over6, Yong Cui

Items not in charter

draft-guo-softwire-sc-discovery, Sheng Jiang
draft-boucadair-softwire-dslite-v6only-00, Mohamed Boucadair
draft-boucadair-softwire-cgn-bypass-03, Mohamed Boucadair
draft-despres-softwire-6a44-01, Remi Despres
draft-cui-softwire-pet<http://datatracker.ietf.org/doc/draft-cui-softwire-pet/>, Peng Wu
draft-templin-iron-13, Fred Templin
draft-templin-intarea-seal-21, Fred Templin
draft-tsou-softwire-gwinit-6rd. Tina Tsou
draft-guo-softwire-6rd-radius-attrib-00, Sheng Jian
draft-despres-softwire-4rd-00<http://tools.ietf.org/id/draft-despres-softwire-4rd-00>, Remi Despres
draft-matsuhira-sa46t-as-00, Naoki Matsuhira

---

From: <[email-masked]>
Date: Thu, 4 Nov 2010 07:33:57 +0100

Dear Alain,

I believe "draft-cui-softwire-host-4over6" and "draft-boucadair-softwire-dslite-v6only" have the same scope: Provide IPv4 connectivity over an IPv6-only network. 

I would expect these I-Ds to be listed under the same category.

Cheers,
Med 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Alain Durand
Envoyé : jeudi 4 novembre 2010 02:03
À : Softwires list
Objet : [Softwires] Softwire agenda for IETF79

Dear wg,

  - Alain.

IETF79 Softwire agenda

Items in charter

Items not in charter

_______________________________________________
Softwires mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/softwires

*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************

---

From: Rémi Després <[email-masked]>
Date: Thu, 4 Nov 2010 10:53:59 +0100

Alain, Dave,

The Softwire charter says:
"The Softwires Working Group is specifying the standardization of discovery, control and encapsulation methods for connecting IPv4 networks across IPv6 networks and IPv6 networks across IPv4 networks in a way that will encourage multiple, inter-operable implementations".

- Draft-despres-softwire-6a44-01 describes an encapsulation method for IPv4 over IPv6.
- It concerns use cases that aren't covered yet (ISP-provided IPv6 addresses across NAT44's).
- In Maastricht, there were 3 presentations for these use cases (not found out of scope then) 
- This draft is the result of a merger effort of two proposals. 

I formally solicit to have this draft re-integrated in the list of "in-scope" items.

RD

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 4 Nov 2010 07:32:54 -0700

Remi, 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Rémi Després
> Sent: Thursday, November 04, 2010 2:54 AM
> To: Alain Durand
> Cc: Softwires
> Subject: Re: [Softwires] Softwire agenda for IETF79
> 
> Alain, Dave,
> 
> "The Softwires Working Group is specifying the 
> standardization of discovery, control and encapsulation 
> methods for connecting IPv4 networks across IPv6 networks and 
> IPv6 networks across IPv4 networks in a way that will 
> encourage multiple, inter-operable implementations".
> 

I have to say that this seems like an unabashed self-promotion.
Your 6a44 is not the only proposal that can satisfy a wide
variety of use cases (see: draft-russert-rangers), nor IMHO
is it the best one.

Thanks - Fred
[email-masked]

> > As you see, there is an abundance of items that are neither 
> on the current charter nor on the logical updates

---

From: Rémi Després <[email-masked]>
Date: Thu, 4 Nov 2010 15:47:54 +0100

Le 4 nov. 2010 à 15:32, Templin, Fred L a écrit :

>> ...
>> ...

It is only a defense of a collective work in which I am implied with Brian and Sheng.
If we don't do it ourselves, who will do it?

> variety of use cases (see: draft-russert-rangers), nor IMHO

I observe a tendency to jump in, with a promotion of YOUR work, each time I defend one in which I am involved.

Please feel free to do what you feel appropriate about your work.
But, preferably, avoid criticizing colleagues when you do so.

Regards,
RD

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 4 Nov 2010 08:06:04 -0700

> If we don't do it ourselves, who will do it?

I used to think that way too, but through hard knocks
came to realize that my time was more appropriately
spent developing the technologies. Widely-applicable
and high-quality technologies will speak for themselves
if the community is being diligent in tracking them,
and I have faith that that is exactly the case here.

Thanks - Fred
[email-masked]