Subject: [Softwires] MAP: Mapping of Addressees and Ports design team

From: Alain Durand <[email-masked]>
Date: Thu, 6 Oct 2011 17:48:05 -0700

During the Softwire interim meeting in Beijing last week, multiple address and port mapping technologies were presented for either encapsulation or double translation.
There was a consensus that those technologies could and should converge. To achieve this, we would like to formally announce the creation of the MAP (Mapping of Addresses and Ports) design team.

This design team is tasked to formulate a unified format is to be used either in an encapsulation or double translation mode, for both hub & spokes and mesh models.

Ole Troan will be leading the effort and will report at the Taipei IETF.

Please send Ole, Yong and Alain a note if you intend to participate.

Alain & Yong, Softwire co-chairs.

---

From: Congxiao Bao <[email-masked]>
Date: Fri, 7 Oct 2011 09:13:26 +0800

Hi Ole,

I am Congxiao Bao, I would like to be in the design team of MAP, I think I
could contribute my design ideas for stateless double transaltion.Since I
have been working on IVI ,dIVI and dIVI-PD for about three years.

Thansk!

Best,

Congxiao

2011/10/7 Alain Durand <[email-masked]>

> During the Softwire interim meeting in Beijing last week, multiple address
> and port mapping technologies were presented for either encapsulation or
> double translation.
> There was a consensus that those technologies could and should converge. To
> achieve this, we would like to formally announce the creation of the MAP
> (Mapping of Addresses and Ports) design team.
>
> This design team is tasked to formulate a unified format is to be used
> either in an encapsulation or double translation mode, for both hub & spokes
> and mesh models.
>
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>

---

From: Maoke Chen <[email-masked]>
Date: Fri, 7 Oct 2011 10:42:02 +0900

hi Ole, Alain and Yong,

this is Maoke Chen of FreeBit.com. i participated the early design and development of IVI and now working in an ISP, doing also ISP service outsourcing to a large number of small administrative domains. i think i may contribute my understanding of stateless transition and  concerns from middle and small operators, into the MAP team.

thanks and regards,
maoke

---

From: Xing Li <[email-masked]>
Date: Fri, 07 Oct 2011 14:01:33 +0800

Hi, Ole and Chairs,

I would like to be in the design team of MAP, since I have design, 
deployment and operation experiences in double translation (dIVI and 
dIVI-PD).

Regards,

xing

于 2011/10/7 8:48, Alain Durand 写道:
> This design team is tasked to formulate a unified format is to be used either in an encapsulation or double translation mode, for both hub&  spokes and mesh models.
>
> Alain&  Yong, Softwire co-chairs.

---

From: Rémi Després <[email-masked]>
Date: Fri, 7 Oct 2011 11:07:14 +0200

Congratulation, Ole, for having deserved this responsibility.

1.
Because I have no financial compensation for my IETF work, I now have to switch to another subject which I had left aside for some time.

As you know, I did volunteer to be coordinator-editor of this unifying effort.
My motivation was that, if given this responsibility, it would have been such an honor, and such a sign of confidence, that I would have been willing to continue unpaid hard work.
The Chairs having decided otherwise, I have complete respect for their decision.  

I hope my past contributions on this subject will substantially help you to succeed, in particular:
 - Draft-despres-softwire-4rd-addmapping-01. 
It is the result of an collaborative work of 4 co-authors having widely different origins, and enthusiastic appreciation of the result. 
Jacni, Simon, and Xiaohong, will be able to comment, and I will also remain available if needed and asked to on specific points.  
 - The "Proposed Unified Address Mapping for encapsulation and double-translation" of www.ietf.org/mail-archive/web/softwires/current/msg02994. 
It is the result of common work between dedicated advocates of Encapsulation and of Double translation. Xing, Wojciech, and Congxiao, will be able to comment, and I will remain available if needed and asked to on specific points.

2.
As a recognition of the value of these past contributions, I would be glad if your design team could keep the 4rd acronym for "IPv4 Residual Deployment". 
With it, you could have, for instance, 4rd-M for the address mapping, 4rd-E for encapsulation, and 4rd-T for double translation.

3.
I recently found what I see as a breakthrough approach for a more complete unification between 4rd-E and 4rd-T (without impact on the address mapping part). 
Within a few days, I should be able to describe this idea on the WG list.
The Softwire WG will then be free to do whatever it likes with it.

4.
FYI, I also have a draft submitted to the RFC editor on "6a44" (stateless IPv6 across NAT44; with as co-authors Brian Carpenter, Dan Wing, and Sheng Jiang). I plan to pursue this project till its conclusion. 

Best wishes,
RD

---

From: GangChen <[email-masked]>
Date: Fri, 7 Oct 2011 23:33:37 +0800

Hello Ole, Alain and Yong,

I'm Gang Chen from China Mobile. I also would like to join the design
team to contribute some ideas from an operator perspective.
Personally, I was working on double translation at very early time. I
hope my past design work could help to advance the work.
draft-ietf-softwire-stateless-4v6-motivation
draft-murakami-softwire-4v6-translation-00
draft-chen-softwire-4v6-pd-00

Many thanks

Gang

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 7 Oct 2011 10:58:34 -0500

I hereby nominate Med into the design team.

Regards,

Behcet

---

From: Leaf yeh <[email-masked]>
Date: Sat, 08 Oct 2011 09:48:04 +0000

Hi, Ole

If you need, I can help to make efforts on the associated jobs with DHCPv6 options.

Best Regards,
Leaf

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of GangChen
Sent: Friday, October 07, 2011 11:34 PM
To: Alain Durand
Cc: [email-masked] list; Ole Troan; Yong Cui; Ralph Droms
Subject: Re: [Softwires] MAP: Mapping of Addressees and Ports design team

Many thanks

Gang

---

From: Jacni Qin <[email-masked]>
Date: Sat, 08 Oct 2011 18:19:13 +0800

hi Ole and chairs,

I'd like to join, thanks.

Cheers,
Jacni

---

From: Tomasz Mrugalski <[email-masked]>
Date: Sat, 08 Oct 2011 14:44:07 +0200

> If you need, I can help to make efforts on the associated jobs with DHCPv6 options.
I would like to join this effort as well, if possible. I have experience
with DHCPv6 (maintaining or developing 3 separate implementations, wrote
several DHCPv6 drafts, one of them published as RFC, others near or
during WGLC).

In fact, I was already discussing DHCPv6 side of things with Med
Boucadair. We are both interested in working on DHCPv6 options.

It is too early to make any decisions, but it seems at least worth
considering to reuse bits and pieces from the following drafts:
draft-boucadair-dhcpv6-shared-address-option-01
draft-mrugalski-dhc-dhcpv6-4rd-00

Of course, the potential for reuse depends on decisions made by the
design team.

Cheers,
Tomek Mrugalski
ISC

---

From: Qiong <[email-masked]>
Date: Sat, 8 Oct 2011 21:11:58 +0800

Hi, Ole and Chairs,

This is Qiong Sun from China Telecom. I have participated the design and
deployment of stateless approach for three years, both with encapsulation
and translation experience. I would like to join in the design group and
contribute my understanding and concerns for Hub & Spoke model from large
scale operators.

Several previous work might be helpful:
draft-sun-softwire-stateless-4over6-00
draft-sunq-v6ops-ivi-sp-02
draft-cui-softwire-b4-translated-ds-lite-02

Thanks in advance.

Qiong

>
> On Fri, Oct 7, 2011 at 8:48 AM, Alain Durand <[email-masked]> wrote:
>
>> There was a consensus that those technologies could and should converge.
>> To achieve this, we would like to formally announce the creation of the MAP