Subject: Re: [Softwires] More changes to revision 03.

From: Ole Trøan <[email-masked]>
Date: Mon, 30 Jan 2012 12:41:25 +0100

Leaf,

OK, I'll get it in the next revision.

cheers,
Ole

On Jan 30, 2012, at 12:38 , Leaf yeh wrote:

> Ole - what's the difference?
>  
> I suggested the following text for the readable .
>  
> Given:
>     End-user IPv6 prefix:   2001:db8:0012:34::/56
>     Basic Mapping Rule:    {2001:db8:00::/40 (Rule IPv6 prefix),
>                         192.0.2.0/24 (Rule IPv4 prefix),
>                         16 (Rule EA-bits length)}
>     PSID offset:           4  (default value as per section 5.1.3)
>  
> We get the IPv4 address, its sharing ratio and port-set:
>  
>     EA bits offset:       40
>     IPv4 suffix bits (p):    Length of IPv4 address (32) - IPv4 prefix length (24) = 8
>     IPv4 address:        192.0.2.18 (0x12)
> 　　
> 　　Sharing ratio:         256 (16 - (32 - 24) = 8. 2^8 = 256)
>  
>  
> Cheers,
> Leaf
>  
>  
> -----Original Message-----
> From: Ole Trøan [mailto:[email-masked]]
> Sent: Monday, January 30, 2012 6:16 PM
> To: Leaf yeh
> Cc: [email-masked]; [email-masked] team
> Subject: Re: More changes to revision 03.
>  
> Leaf,
>  
> > Again C&Qs on the examples in the newly updated candidate of MAP-03:
> > 
> > A.     Section 5.2 - Given:
> >    End-user IPv6 prefix:  2001:db8:0012:34::/56
> >    Basic Mapping Rule:    {2001:db8:00::/40 (Rule IPv6 prefix),
> >                           192.0.2.0/24 (Rule IPv4 prefix),
> >                           16 (Rule EA-bits length)}
> >    Sharing ratio:         256 (16 - (32 - 24) = 8. 2^8 = 256)
> >    PSID offset:           4
> > 
> >   We get IPv4 address and port-set:
> >    EA bits offset:       40
> >    IPv4 suffix bits (p): Length of IPv4 address (32) -
> >                          IPv4 prefix length (24) = 8
> > ….
> > 
> > C1. The ‘End-user IPv6 prefix’ shall be express as ‘2001:db8:0012:3400::/56’ as per the section 2.3 of RFC4291;
>  
> fixed.
>  
> > C2. The sharing ratio sounds a calculated result, not a ‘given’ condition;
>  
> what's the difference?
>  
>  
> > 
> > B.     Section 5.3 - Given:
> >       IPv4 destination address: 192.0.2.18
> >       IPv4 destination port:    9030
> >       Forwarding Mapping Rule:  {2001:db8:00::/40 (Rule IPv6 prefix),
> >                                  192.0.2.0/24 (Rule IPv4 prefix),
> >                                  16 (Rule EA-bits length)}
> > 
> >     We get IPv6 address:
> >       IPv4 suffix bits (p): 32 - 24 = 8 (18 (0x12))
> >       PSID length:          8
> >       PSID:                 0x34 (9030 (0x2346))
> >       EA bits:              0x1234
> >       MAP IPv6 address:     2001:db8:0012:3400:00c0:0002:1200:3400
> > 
> > C3. I suppose the default ‘PSID offset: 4’ seems need to express in the ‘given’ conditions;
>  
> OK
>  
> > Q1. Have the draft stated the ‘u’ bits in the Interface-ID should be 0x00?
>  
> it states that it is based on 6052. I think that should be sufficient.
>  
> cheers,
> Ole
>  
>

---

From: Leaf yeh <[email-masked]>
Date: Mon, 30 Jan 2012 11:38:26 +0000

Given:

    EA bits offset:       40

　　

Cheers,

Leaf

-----Original Message-----

To: Leaf yeh

Leaf,

fixed.

what's the difference?

OK

cheers,

Ole