Subject: [Softwires] MAP documents - next steps

From: Ole Trøan <[email-masked]>
Date: Mon, 30 Jan 2012 12:31:39 +0100

hi,

the MAP (Mapping of address and port) design team has now written and published the following sets of drafts.

the base document (port mapping algorithm):
  http://tools.ietf.org/html/draft-mdt-softwire-mapping-address-and-port-03
  http://tools.ietf.org/rfcdiff?url2=draft-mdt-softwire-mapping-address-and-port-03.txt

the encapsulation document (MAP-E):
  http://tools.ietf.org/html/draft-mdt-softwire-map-encapsulation-00

the translation document (MAP-T):
  http://tools.ietf.org/html/draft-mdt-softwire-map-translation-00

the DHCP option (MAP-DHCP):
  http://tools.ietf.org/html/draft-mdt-softwire-map-dhcp-option-02

there is a MAP deployment document coming soon.

the solution described in this set of documents, are written to satisfy the following from the softwires charter:
   4. Developments for stateless legacy IPv4 carried over IPv6 
      - develop a solution motivation document to be published as an RFC 
      - develop a protocol specification response to the solution 
        motivation document; this work item will not be taken through 

in the design team's view, this set of documents are ready to be adopted as working group documents.

comments?

for the MAP design team,
Ole

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Mon, 30 Jan 2012 12:39:41 +0000

Yes. I support WG adoption (and carry on the discussion further).

Cheers,
Rajiv

Sent from my Phone

On Jan 30, 2012, at 11:31 AM, Ole Trøan <[email-masked]> wrote:

> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: Tomek Mrugalski <[email-masked]>
Date: Mon, 30 Jan 2012 20:15:49 +0100

> Yes. I support WG adoption (and carry on the discussion further).
For what it is worth, I support WG adoption.

Cheers,
Tomek
MAP design team member, map-dhcp editor

---

From: Sheng Jiang <[email-masked]>
Date: Tue, 31 Jan 2012 02:32:00 +0000

I support WG adoption for this series of documents. As a complementarity, we have written a MAP Radius document:

"RADIUS Attribute for MAP"
http://tools.ietf.org/html/draft-jiang-softwire-map-radius-00

This document defines Radius attribute for MAP mechanism. It provides just enough information to form the correspondent DHCPv6 MAP option on BNG.

Best regards,

Sheng

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Ole Tr?an
> Sent: Monday, January 30, 2012 7:32 PM
> To: softwires WG
> Subject: [Softwires] MAP documents - next steps
> 
> hi,
> 
> the solution described in this set of documents, are written to satisfy
> the following from the softwires charter:

---

From: Tina TSOU <[email-masked]>
Date: Tue, 31 Jan 2012 05:54:23 +0000

Tina

> Sent: Monday, January 30, 2012 3:32 AM
> To: softwires WG
Support.
And there is a "port set algorithms analysis" document was discussed and decided targeting for an informational RFC to justify the MAP algorithm. The document was written, just a matter of forming into I-D form now. It is coming soon as well, and requires the same treatment as in the same set.

---

From: Wojciech Dec <[email-masked]>
Date: Tue, 31 Jan 2012 08:13:04 +0100

Support

---

From: Tetsuya Murakami <[email-masked]>
Date: Tue, 31 Jan 2012 00:19:05 -0800

Support. It is worth to adopt these drafts as WG drafts.

Thanks,
Tetsuya

---

From: Rémi Després <[email-masked]>
Date: Tue, 31 Jan 2012 10:15:02 +0100

Le 2012-01-30 à 12:31, Ole Trøan a écrit :
...

> in the design team's view, this set of documents are ready to be adopted as working group documents.

Thanks Ole for the documents.
I will review them and comment.

Some members of the MAP team expressed on the Softwire list, after you, their support for these becoming WG documents now.
This isn't surprising, of course, since you already made it "for the MAP design team".
But there is an important point: it was decided, after the Taipei meeting, to explore in parallel for the next meeting MAP and 4rd-U (ref. Alain's email www.ietf.org/mail-archive/web/softwires/current/msg03296.html).

In this context, promoting MAP documents to WG status NOW would be premature.
Now that both MAP and 4rd-U drafts are available, with a lot of commonality but also with some substantial differences, fair evaluation of the two approaches can start in Softwire.

BTW, among subjects covered in /www.ietf.org/id/draft-despres-softwire-4rd-u-03 and AFAIK not covered in MAP drafts so far, there is:
- How BRs can forward packets of fragmented datagrams on the fly, rather than reassembling them (sec 4.5.2 of 4rd-U-03)
- Avoidance of Identification ambiguities for datagrams from shared-address CEs to the IPv4 Internet.
Comments on these (among others) are welcome.

Other point: due to a typo, the 4rd-U draft is presented as Informational, it is of course intended for the Standards track (will be corrected in the next version).

Regards,
RD

---

From: Satoru Matsushima <[email-masked]>
Date: Tue, 31 Jan 2012 22:28:17 +0900

Hi, I'm in favor of the MAP documents suit. I support to adopt these as WG documents.

cheers,
--satoru