Subject: Re: [Softwires] WT-146 and draft-tsou-softwire-bfd-ds-lite-02

From: Tina TSOU <[email-masked]>
Date: Mon, 7 May 2012 22:23:27 +0000

Thank u for ur reply, Woj.
Then I think draft-tsou-softwire-bfd-ds-lite-02 is in line with WT-146.
Other comments are welcome.

Sent from my iPad

On May 7, 2012, at 8:28 AM, "Wojciech Dec" <[email-masked]<mailto:[email-masked]>> wrote:

Hello,

PING was there, as a SHOULD option.

-Woj.

On 4 May 2012 17:32, Tina TSOU <[email-masked]<mailto:[email-masked]>> wrote:
In WT-146, why is there only BFD, no PING?

Sent from my iPad

---

From: Tina TSOU <[email-masked]>
Date: Tue, 8 May 2012 06:53:53 +0000

In addition, http://tools.ietf.org/html/draft-tsou-softwire-bfd-ds-lite-02 analyses the applicability of some of the keep-alive mechanisms and try to suggest one for DS-Lite scenario.

BFD is a good solution for keep-alive and to trigger failover when a fault is detected. Compared to PING and other solutions, BFD is simple and suitable for implementation by logic (FPGA, ASIC, etc), while usually PING is handled by CPU, which may cause a performance problem if there are too many PING packets. BFD can provide more functionalities besides keep-alive, e.g. delay, jitter and throughput test, etc.

BBF WT-146 also mandate BFD support for IP sessions. Though as Woj said, PING is a SHOULD option.

Sent from my iPad

On May 7, 2012, at 3:35 PM, "Tina TSOU" <[email-masked]<mailto:[email-masked]>> wrote:

Sent from my iPad

Hello,

-Woj.

Sent from my iPad