Subject: [Softwires] Ambiguity in draft-ietf-softwire-map-02.txt algorithm description

From: Tom Taylor <[email-masked]>
Date: Thu, 08 Nov 2012 11:20:38 -0500

Section 5 of draft-ietf-softwire-map-02.txt describes the MAP algorithm. 
The paragraph following bullet 3 reads as follows:

"  A MAP node finds its Basic Mapping Rule by doing a longest match
    between the End-user IPv6 prefix and the Rule IPv6 prefix in the
    Mapping Rules table.  The rule is then used for IPv4 prefix, address
    or shared address assignment."

and, of course, the next paragraph goes on to say that the BMR is used 
to derive the MAP node's IPv6 address for MAP purposes.

I have a feeling the paragraph quoted above applies only to MAP CEs, not 
to all MAP nodes. Can someone confirm this?

Tom Taylor

---

From: Ole Trøan <[email-masked]>
Date: Thu, 8 Nov 2012 13:24:08 -0500

Tom,

> Section 5 of draft-ietf-softwire-map-02.txt describes the MAP algorithm. The paragraph following bullet 3 reads as follows:
> 
> and, of course, the next paragraph goes on to say that the BMR is used to derive the MAP node's IPv6 address for MAP purposes.
> 
> I have a feeling the paragraph quoted above applies only to MAP CEs, not to all MAP nodes. Can someone confirm this?

it isn't restricted to only MAP CEs. a BR could also configure the shared IPv4 address. this overlaps with the issue of, should the BR have an IPv4 address that the CE's IPv4 stack could use as an IPv4 next-hop. I think we ended up with no.

if you think clarifications in order, please propose text.

cheers,
Ole

---

From: Leaf yeh <[email-masked]>
Date: Fri, 9 Nov 2012 02:22:00 +0000

My 2 cents: 'Allocation' might be better than 'Assignment' in the text. The word of 'assignment' makes the reader tend to think only about the CEs.

Best Regards,
Leaf

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ole Tr?an
Sent: Friday, November 09, 2012 2:24 AM
To: Tom Taylor
Cc: [email-masked]
Subject: Re: [Softwires] Ambiguity in draft-ietf-softwire-map-02.txt algorithm description

Tom,

cheers,
Ole
_______________________________________________
Softwires mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/softwires