Subject: [Softwires] Updates to lw4o6 Draft (draft-ietf-softwire-lw4over6)

From: <[email-masked]>
Date: Thu, 11 Jul 2013 08:46:34 +0200

Hi,

I'm currently updating the lw4o6 draft in advance of IETF87. I plan to include the following changes:

- I-D.bfmk-softwire-unified-cpe needs to be changed to I-D.ietf-softwire-unified-cpe throughout

- Section 7 – the reference from I-D.ietf-dhc-dhcpv4-over-ipv6 should be changed to draft-ietf-dhc-dhcpv4-over-dhcpv6 in line with the DHC recommendations

- Section 5.2 does not consider what happens if a packet is received by the lwB4 that isn't addressed to the correct destination v4 address with a valid l4 port (there's a small discussion about this for MAP-E on the list at the moment). Propose that the lw4o6 draft is updated in line with the outcome of this discussions so that MAP-E & lw4o6 CPE behaviour stays aligned.

- I-D.bfmk-softwire-unified-cpe is currently included as a normative reference, this will be moved to informative.

- Add text to section 5.2 saying that any IPv4 fragments received by the lwB4 (CPE) after decapsulation are re-assembled before NAT, so that the whole packet can be translated. This is based on some problems encountered during interop testing.

If you have any comments or objections to the above, please let me know.

Cheers,
Ian

---

From: Qi Sun <[email-masked]>
Date: Thu, 11 Jul 2013 15:34:18 +0800

Hi Ian ,

> - I-D.bfmk-softwire-unified-cpe is currently included as a normative reference, this will be moved to informative.

Does this mean the Unified CPE will be referenced as an informative one? 

Best Regards,
Qi

On 2013-7-11, at 下午2:46, <[email-masked]> <[email-masked]> wrote:

> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: <[email-masked]>
Date: Thu, 11 Jul 2013 10:11:20 +0200

Hi Qi,

Yes. Within the text of the draft, it is only recommended that I-D.bfmk-softwire-unified-cpe is followed so there's no reason for it to be normative.

Cheers,
Ian

From: Qi Sun <[email-masked]<mailto:[email-masked]>>
Date: Thursday, 11 July 2013 09:34
To: Ian Farrer <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Softwires] Updates to lw4o6 Draft (draft-ietf-softwire-lw4over6)

Hi Ian ,

Best Regards,
Qi

On 2013-7-11, at 下午2:46, <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Cheers,
Ian

_______________________________________________
Softwires mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/softwires