Subject: [Softwires] [Technical Errata Reported] RFC5969 (3869)

From: RFC Errata System <[email-masked]>
Date: Mon, 20 Jan 2014 02:23:39 -0800 (PST)

The following errata report has been submitted for RFC5969,
"IPv6 Rapid Deployment on IPv4 Infrastructures (6rd) -- Protocol Specification".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5969&eid=3869

--------------------------------------
Type: Technical
Reported by: Fernando Gont <[email-masked]>

Section: 9.2

Original Text
-------------
In order to prevent spoofing of IPv6 addresses, the 6rd BR and CE
MUST validate the embedded IPv4 source address of the encapsulated
IPv6 packet with the IPv4 source address it is encapsulated by
according to the configured parameters of the 6rd domain.

Corrected Text
--------------
In order to prevent spoofing of IPv6 addresses, the 6rd BR and CE
MUST validate the embedded IPv6 source address of the encapsulated
IPv6 packet with the IPv4 source address it is encapsulated by
according to the configured parameters of the 6rd domain.

Notes
-----

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5969 (draft-ietf-softwire-ipv6-6rd-10)
--------------------------------------
Title               : IPv6 Rapid Deployment on IPv4 Infrastructures (6rd) -- Protocol Specification
Publication Date    : August 2010
Author(s)           : W. Townsley, O. Troan
Category            : PROPOSED STANDARD
Source              : Softwires
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: Ted Lemon <[email-masked]>
Date: Mon, 20 Jan 2014 18:33:53 -0500

Mark, Ole, can you take a look at this erratum?

---

From: Suresh Krishnan <[email-masked]>
Date: Tue, 21 Jan 2014 02:59:38 +0000

Hi Ted/Brian,
  I will let Ole and Mark answer authoritatively but my call is that the existing text is correct and should be left alone. The embedded IPv4 address is a field in the IPv6 address (see format below) that is being compared to the IPv4 address in the encapsulating IPv4 datagram.

   |     n bits    |    o bits    |   m bits  |    128-n-o-m bits      |
   +---------------+--------------+-----------+------------------------+
   |  6rd prefix   | IPv4 address | subnet ID |     interface ID       |
   +---------------+--------------+-----------+------------------------+

Thanks
Suresh

> -----Original Message-----
> From: RFC Errata System [mailto:[email-masked]]
> Sent: January-20-14 5:24 AM
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; Suresh Krishnan; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Technical Errata Reported] RFC5969 (3869)
> 
> In order to prevent spoofing of IPv6 addresses, the 6rd BR and CEMUST
> validate the embedded IPv4 source address of the encapsulatedIPv6 packet
> with the IPv4 source address it is encapsulated byaccording to the configured
> parameters of the 6rd domain.
> 
> Corrected Text
> --------------
> In order to prevent spoofing of IPv6 addresses, the 6rd BR and CEMUST
> validate the embedded IPv6 source address of the encapsulatedIPv6 packet
> with the IPv4 source address it is encapsulated byaccording to the configured
> parameters of the 6rd domain.
> 
> Notes
> -----
> 
> 
> Instructions:
> -------------
> This errata is currently posted as "Reported". If necessary, please use "Reply
> All" to discuss whether it should be verified or rejected. When a decision is
> reached, the verifying party (IESG) can log in to change the status and edit
> the report, if necessary.
>

---

From: Ole Troan <[email-masked]>
Date: Tue, 21 Jan 2014 12:18:35 +0100

>   |     n bits    |    o bits    |   m bits  |    128-n-o-m bits      |

absolutely.
the text says to verify that the embedded IPv4 address and the IPv4 source address are the same.
Fernando, feel free to contact me directly if this is still unclear.

cheers,
Ole

> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires