Subject: Re: [Softwires] Working group last call for draft-ietf-softwire-map-t-05

From: Wojciech Dec <[email-masked]>
Date: Mon, 3 Mar 2014 14:48:14 +0100

Hi Ian,

thanks for the feedback...

On 27 February 2014 20:06, Ian Farrer <[email-masked]> wrote:

> I support this moving forward, with a few small comments:
>
> 1, A few instances where "packets'" should be "packet's" throughout the
> doc (e.g. 8.2, 8.3)
>
> Fixed - I'll reword some of the text to remove the possessive. Also
noticed an inconsistency or two.

> 2, Section 5.1 para 2, line 2 'as' is mis-spelt as "s".
>

Ok.

>
> 3, Section 8.1 "The source address and port of the packet obtained as a
> result of the NAPT44 process
> MUST correspond to the source IPv4 address and source transport port
> number derived
> to belong to the CE by means of the the MAP Basic Mapping Rule (BR)."
>

>
> Reads as if there is only a single transport port allocated to the client.
> Wouldn't something like 'IPv4 address and a valid source transport port...'
> be more accurate?
>

I'll change it to: The source address and source port-range of packets
resulting from the NAPT44 processing MUST correspond to the source IPv4
address and source transport port-range assigned to the CE by means of the
MAP Basic Mapping Rule (BMR).

Cheers,
Wojciech

>
> Cheers,
> Ian
>
> On 14 Feb 2014, at 06:49, Suresh Krishnan <[email-masked]>
> wrote:
>
> > Hi all,
> >  This message starts a two week softwire working group last call on
> advancing the draft about providing Mapping of Address and Port using
> Translation as an Experimental RFC. The authors believe that this version
> has addressed all the issues raised on the document till date. The latest
> version of the draft is available at
> >
> > http://www.ietf.org/id/draft-ietf-softwire-map-t-05.txt
> > http://tools.ietf.org/html/draft-ietf-softwire-map-t-05
> >
> > Substantive comments and statements of support/opposition for advancing
> this document should be directed to the mailing list. Editorial suggestions
> can be sent directly to the authors. This last call will conclude on
> February 28, 2014
> >
> > Regards,
> > Suresh & Yong
> >
> >
> > _______________________________________________
> > Softwires mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/softwires
>
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>

---

From: Ian Farrer <[email-masked]>
Date: Mon, 3 Mar 2014 13:51:36 +0000

> 
> 
> Reads as if there is only a single transport port allocated to the client. Wouldn’t something like ‘IPv4 address and a valid source transport port...’ be more accurate?
> 
> I'll change it to: The source address and source port-range of packets resulting from the NAPT44 processing MUST correspond to the source IPv4 address and source transport port-range assigned to the CE by means of the MAP Basic Mapping Rule (BMR).

Fine.

Cheers,
Ian