Subject: [Softwires] Proposed text that describes lw4o6 and map-e

From: Qi Sun <[email-masked]>
Date: Wed, 12 Mar 2014 15:51:36 +0800

Hi all,

According to the discussion last Friday, there should be some text describing the characteristics of lw4o6 and map-e with cross-referece, and the text should be the same (or almost the same). 

The two points that are requested to be in the text: 
* MAP-E achieves aggregated rules
* MAP-E does mesh

Here is the proposal:

In lw4o6 draft, section of Introduction:
Lightweight 4over6 provides a solution with complete independence of IPv4
and IPv6 addressing (i.e., the IPv6 prefix does not embed an IPv4 address
and/or port set). This is accomplished by maintaining state for each
softwire (per-subscriber state) in the lwAFTR and using a hub-and-spoke
architecture whereby all traffic traverse the lwAFTR. [I-D.ietf-softwire-
map] offers a means for reducing the amount of such state by using
algorithmic IPv4 to IPv6 address mappings to create aggregate rules. This
also gives the option of direct, meshed IPv4 connectivity between
subscribers.

In MAP-E draft, section of Introduction:
MAP-E offers a means for reducing the amount state held in the BR by
using algorithmic IPv4 to IPv6 address mappings to create aggregate rules.
This also gives the option of direct, meshed IPv4 connectivity between
subscribers. Lightweight 4over6 [I-D.ietf-softwire-lw4over6] provides a
solution with complete independence of IPv4 and IPv6 addressing 
(i.e., the IPv6 prefix does not embed an IPv4 address and/or port set). This is
accomplished by maintaining state for each softwire (per-subscriber state)
in the lwAFTR and using a hub-and-spoke architecture whereby all traffic
traverse the lwAFTR. 

The above text has been agreed by the lw4over6 co-authors. 
@Woj, could you please see if the the proposal resolves your concern? Thanks!

Best Regards,
Qi

---

From: Wojciech Dec <[email-masked]>
Date: Wed, 12 Mar 2014 10:25:57 +0100

Hi Qi,

thanks, but I'd rather stick with the text that we proposed and (lengthily)
discussed at the meeting, i.e.:

"Lightweight 4over6 provides a solution for a hub-and-spoke softwire
architecture only, where the lwAFTR maintains (softwire) state for each
subscriber. [I-D.ietf-softwire-map] offers
a means for reducing the amount of such state by using algorithmic IPv4 to
IPv6 address mappings to create aggregate rules. This also gives the option
of direct meshed IPv4 connectivity between subscribers."

Note: Your text is different to the above,  and claims "complete
independence" which is not accurate in view of the fact that lw46 DOES
embed the IPv4 address in the IPv6 address. In terms of embedding stuff in
the "prefix part" (i.e. the top /64), both solutions allow "complete prefix
independence", so that's a null point.

Regards,
Wojciech.

On 12 March 2014 08:51, Qi Sun <[email-masked]> wrote:

>
> Hi all,
>
> According to the discussion last Friday, there should be some text
> describing the characteristics of lw4o6 and map-e with cross-referece, and
> the text should be the same (or almost the same).
>

---

From: <[email-masked]>
Date: Wed, 12 Mar 2014 10:32:33 +0100

Hi Woj,

Just for context, the ‘complete independence’ wording was taken from the map-dhcp draft (section 3). The hope was that this wouldn’t be a contentious phrase because of that.

Cheers,
Ian

From: Wojciech Dec <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, 12 March 2014 10:25
To: Qi Sun <[email-masked]<mailto:[email-masked]>>
Cc: Softwires-wg WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Softwires] Proposed text that describes lw4o6 and map-e

Hi Qi,

thanks, but I'd rather stick with the text that we proposed and (lengthily) discussed at the meeting, i.e.:

"Lightweight 4over6 provides a solution for a hub-and-spoke softwire architecture only, where the lwAFTR maintains (softwire) state for each subscriber. [I-D.ietf-softwire-map] offers
a means for reducing the amount of such state by using algorithmic IPv4 to IPv6 address mappings to create aggregate rules. This also gives the option of direct meshed IPv4 connectivity between subscribers."

Note: Your text is different to the above,  and claims "complete independence" which is not accurate in view of the fact that lw46 DOES embed the IPv4 address in the IPv6 address. In terms of embedding stuff in the "prefix part" (i.e. the top /64), both solutions allow "complete prefix independence", so that's a null point.

Regards,
Wojciech.

On 12 March 2014 08:51, Qi Sun <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Here is the proposal:

Best Regards,
Qi

---

From: Wojciech Dec <[email-masked]>
Date: Wed, 12 Mar 2014 10:50:44 +0100

On 12 March 2014 10:32, <[email-masked]> wrote:

> Hi Woj,
>
> Just for context, the 'complete independence' wording was taken from the
> map-dhcp draft (section 3). The hope was that this wouldn't be a
> contentious phrase because of that.
>

Well, but given that it's not technically accurate it doesn't really matter
where it's taken from.
Can't really say more about this other than what I replied to previously.
If you really want some text in there, I'd be ok with text like: "Both
solutions allow for IPv6 prefix independence, i.e.the IPv6 prefix does not
embed an IPv4 address and/or port set" although it doesn't really add
anything of major relevance,

I think we'd be best served without re-hashing the lengthy discussion we
had at the meeting or having another long email thread here on a few words
and delay the lw46 draft further, i.e. let's stay with the chairs'
conclusion on the matter.

Cheers,
Wojciech.

> Cheers,
> Ian
>
> From: Wojciech Dec <[email-masked]>
> To: Qi Sun <[email-masked]>
> Cc: Softwires-wg WG <[email-masked]>
> thanks, but I'd rather stick with the text that we proposed and
> (lengthily) discussed at the meeting, i.e.:
>
> a means for reducing the amount of such state by using algorithmic IPv4
> to IPv6 address mappings to create aggregate rules. This also gives the
> option of direct meshed IPv4 connectivity between subscribers."
>

---

From: Qi Sun <[email-masked]>
Date: Wed, 12 Mar 2014 18:23:54 +0800

Hi Woj,

Technically, that statement is accurate, for there is no IPv4 address and port set embedded in the IPv6 prefix in lw4over6, no matter what type of provisioning methods (dhcpv6/dhcpv4ov6/pcp) is used. 

Best Regards,
Qi

---

From: <[email-masked]>
Date: Wed, 12 Mar 2014 11:27:12 +0100

Hi Woj,

The text in Qi's proposal is explicit about what is meant by complete independence between IPv4 and IPv6 addressing: "the IPv6 prefix does not embed an IPv4 address and/or port set)". The text is about IPv6 prefix assigned to the CPE; that prefix does not embed an IPv4 address nor a port set.

This is a trivial point IMHO.

Cheers,
Med

De : Softwires [mailto:[email-masked]] De la part de Wojciech Dec
Envoyé : mercredi 12 mars 2014 10:26
À : Qi Sun
Cc : Softwires-wg WG
Objet : Re: [Softwires] Proposed text that describes lw4o6 and map-e

Hi Qi,

Hi all,

Here is the proposal:

Best Regards,
Qi

---

From: Qi Sun <[email-masked]>
Date: Wed, 12 Mar 2014 18:36:13 +0800

Hi Woj,

On 2014-3-12, at 下午5:50, Wojciech Dec wrote:
> Well, but given that it's not technically accurate it doesn't really matter where it's taken from. 
> Can't really say more about this other than what I replied to previously. If you really want some text in there, I'd be ok with text like: "Both solutions allow for IPv6 prefix independence, i.e.the IPv6 prefix does not embed an IPv4 address and/or port set" although it doesn't really add anything of major relevance, 
> 
> I think we'd be best served without re-hashing the lengthy discussion we had at the meeting or having another long email thread here on a few words and delay the lw46 draft further, i.e. let's stay with the chairs' conclusion on the matter.

I also hope to end this discussion asap. As the minutes stated:
"
Summary:
3. Cross-reference: As chair I'll decide that we keep the text with the proposed changes.
   MAP does aggregation and mesh.
"
The text we proposed includes the two points, and takes words from map-dhcp document (which is technically accurate as the prefix embedding thing does not happen in lw4over6). 

Best Regards,
Qi

---

From: Wojciech Dec <[email-masked]>
Date: Wed, 12 Mar 2014 11:48:13 +0100

Hi Qi,

On 12 March 2014 11:23, Qi Sun <[email-masked]> wrote:

>
> Hi Woj,
>
> Technically, that statement is accurate, for there is no IPv4 address and
> port set embedded in the IPv6 prefix in lw4over6, no matter what type of
> provisioning methods (dhcpv6/dhcpv4ov6/pcp) is used.
>

Not on reading section 5.1 of :
http://tools.ietf.org/html/draft-ietf-softwire-lw4over6-07
Where text like "The /128 prefix is then constructed in the same manner as [
I-D.ietf-softwire-map<http://tools.ietf.org/html/draft-ietf-softwire-lw4over6-07#ref-I-D.ietf-softwire-map>]"
is present.

I do agree that there is top level prefix independence.

Regards,
Wojciech.

---

From: Wojciech Dec <[email-masked]>
Date: Wed, 12 Mar 2014 11:49:30 +0100

Well, yeah, so the following text should do:
Both solutions allow for IPv6 prefix independence, i.e.the IPv6 prefix does
not embed an IPv4 address and/or port set

?

Cheers,
Wojciech.

On 12 March 2014 11:27, <[email-masked]> wrote:

> Hi Woj,
>
>
>
> The text in Qi's proposal is explicit about what is meant by complete
> independence between IPv4 and IPv6 addressing: "the IPv6 prefix does not
> embed an IPv4 address and/or port set)". The text is about IPv6 prefix
> assigned to the CPE; that prefix does not embed an IPv4 address nor a port
> set.
>
>
>
> *De :* Softwires [mailto:[email-masked]] *De la part de*Wojciech Dec
> *Envoyé :* mercredi 12 mars 2014 10:26
> *À :* Qi Sun
> *Cc :* Softwires-wg WG
> *Objet :* Re: [Softwires] Proposed text that describes lw4o6 and map-e
>
>
>
> Hi Qi,
>

---

From: "Lee, Yiu" <[email-masked]>
Date: Wed, 12 Mar 2014 11:41:42 +0000

I don¹t understand his point. Let¹s put the 1:1 aside, MAP-E requires IPv4
rule to algorithmically build the CE IPv6 prefix. In lw4o6 Section 5.1, we
simple put the v4 in the IID. Isn¹t it obviously there is no v4/v6
dependency? What Woj tries to argue? I lost. Can somebody explain to me
please?

Date:  Wednesday, March 12, 2014 at 6:48 AM

Not on reading section 5.1 of :
http://tools.ietf.org/html/draft-ietf-softwire-lw4over6-07
Where text like "The /128 prefix is then constructed in the same manner as
[I-D.ietf-softwire-map
<http://tools.ietf.org/html/draft-ietf-softwire-lw4over6-07#ref-I-D.ietf-sof
twire-map> ]" is present.

Regards,
Wojciech.

---

From: Wojciech Dec <[email-masked]>
Date: Wed, 12 Mar 2014 13:00:54 +0100

Let me try again:
Basic fact: IPv6 address is 128 bits.

If you put in the IPv4 address in the IID, then it becomes part of the 128
bit IPv6 address. Claiming that there is complete independence (no linkage)
between the IPv4 addresses and IPv6 address is then not correct. If you see
it another way, then it would be interesting to understand why.
What I think Qi was/is trying to say is that there is prefix independence,
with prefix being the part of the IPv6 address less the IID. That I agree
with. It is the same in lw46 and MAP-E

Side note: The "MAP-E" algorithm derives a PSID and port ranges. That's it.
This PSID, along with trailing bits of the IPv4 address *may* get inserted
in MAP-E into the non IID IPv6 prefix and this is unique to MAP-E.

Hope it helps.

On 12 March 2014 12:41, Lee, Yiu <[email-masked]> wrote:

> I don't understand his point. Let's put the 1:1 aside, MAP-E requires IPv4
> simple put the v4 in the IID. Isn't it obviously there is no v4/v6
> [I-D.ietf-softwire-map<http://tools.ietf.org/html/draft-ietf-softwire-lw4over6-07#ref-I-D.ietf-softwire-map>]"
> is present.
>

---

From: Ian Farrer <[email-masked]>
Date: Thu, 13 Mar 2014 09:00:09 +0100

Hi Woj,

Can we resolve this with the following wording change?

Old:
Lightweight 4over6 provides a solution with complete independence of IPv4 and IPv6 addressing (i.e., the IPv6 prefix does not embed an IPv4 address and/or port set). 

New:
Lightweight 4over6 is a solution designed specifically for complete independence between IPv6 subnet prefix and IPv4 address with/without CPE v4 address sharing.

The complete paragraph with the proposed change would then read:

Lightweight 4over6 is a solution designed specifically for complete independence between IPv6 subnet prefix and IPv4 address with/without CPE v4 address sharing. 
This is accomplished by maintaining state for each softwire (per-subscriber state) in the lwAFTR and using a hub-and-spoke architecture whereby all traffic traverse 
the lwAFTR. [I-D.ietf-softwire-map] offers a means for reducing the amount of such state by using algorithmic IPv4 to IPv6 address mappings to create aggregate rules.
This also gives the option of direct, meshed IPv4 connectivity between subscribers.

If not, please can you suggest an alternative wording?

Cheers,
Ian

On 12 Mar 2014, at 13:00, Wojciech Dec <[email-masked]> wrote:

> If you put in the IPv4 address in the IID, then it becomes part of the 128 bit IPv6 address. Claiming that there is complete independence (no linkage) between the IPv4 addresses and IPv6 address is then not correct. If you see it another way, then it would be interesting to understand why.
> What I think Qi was/is trying to say is that there is prefix independence, with prefix being the part of the IPv6 address less the IID. That I agree with. It is the same in lw46 and MAP-E
> 
> Side note: The "MAP-E" algorithm derives a PSID and port ranges. That's it. This PSID, along with trailing bits of the IPv4 address *may* get inserted in MAP-E into the non IID IPv6 prefix and this is unique to MAP-E.
> 
> Hope it helps.
> 
> 
> I don’t understand his point. Let’s put the 1:1 aside, MAP-E requires IPv4 rule to algorithmically build the CE IPv6 prefix. In lw4o6 Section 5.1, we simple put the v4 in the IID. Isn’t it obviously there is no v4/v6 dependency? What Woj tries to argue? I lost. Can somebody explain to me please?
> 
> Not on reading section 5.1 of : http://tools.ietf.org/html/draft-ietf-softwire-lw4over6-07
> Where text like "The /128 prefix is then constructed in the same manner as [I-D.ietf-softwire-map]" is present.
> 
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: Wojciech Dec <[email-masked]>
Date: Mon, 17 Mar 2014 10:11:55 +0100

Hi Ian,

here's an updated proposal. Besides lining up the text on the prefix
independence, I also edited out some redundant text...

Lightweight 4over6 is a solution designed specifically for complete
independence between IPv6 subnet prefix and IPv4 address with or without
IPv4 address sharing.
This is accomplished by maintaining state for each softwire (per-subscriber
state) in the lwAFTR and a hub-and-spoke forwarding architecture.
[I-D.ietf-softwire-map] offers the same capabilities along with means for
reducing the amount of such state using address mappings rules, which
however introduce a relation between the IPv6 subnet prefix and IPv4
address. This relation also allows optional meshed connectivity between
users.

Cheers,
Wojciech.

On 13 March 2014 09:00, Ian Farrer <[email-masked]> wrote:

> Lightweight 4over6 provides a solution with complete independence of
> IPv4 and IPv6 addressing (i.e., the IPv6 prefix does not embed an IPv4
> address and/or port set).
>
> New:
> Lightweight 4over6 is a solution designed specifically for complete
> independence between IPv6 subnet prefix and IPv4 address with/without CPE
> v4 address sharing.
>
> Lightweight 4over6 is a solution designed specifically for complete
> independence between IPv6 subnet prefix and IPv4 address with/without CPE
> v4 address sharing.
> This is accomplished by maintaining state for each softwire
> (per-subscriber state) in the lwAFTR and using a hub-and-spoke architecture
> whereby all traffic traverse
> the lwAFTR. [I-D.ietf-softwire-map] offers a means for reducing the amount
> of such state by using algorithmic IPv4 to IPv6 address mappings to create
> aggregate rules.
> Side note: The "MAP-E" algorithm derives a PSID and port ranges. That's
> it. This PSID, along with trailing bits of the IPv4 address *may* get
> inserted in MAP-E into the non IID IPv6 prefix and this is unique to MAP-E.
>
> Hope it helps.
>
>
>> I don't understand his point. Let's put the 1:1 aside, MAP-E requires
>> IPv4 rule to algorithmically build the CE IPv6 prefix. In lw4o6 Section
>> 5.1, we simple put the v4 in the IID. Isn't it obviously there is no v4/v6
>> Where text like "The /128 prefix is then constructed in the same manner
>> as [I-D.ietf-softwire-map<http://tools.ietf.org/html/draft-ietf-softwire-lw4over6-07#ref-I-D.ietf-softwire-map>]"
>> is present.
>>

---

From: Qi Sun <[email-masked]>
Date: Tue, 18 Mar 2014 16:52:12 +0800

Hi Woj,

Thanks for the editing! I'm fine with the description for lw4over6. As for the map part, I think it's not that accurate. 

Here is another proposal, based on yours:

Lightweight 4over6 is a solution designed specifically for complete independence between IPv6 subnet prefix and IPv4 address with or without IPv4 address sharing.
This is accomplished by maintaining state for each softwire (per-subscriber state) in the lwAFTR and a hub-and-spoke forwarding architecture. [I-D.ietf-softwire-map] also offers a means for reducing the amount of such state using address mapping rules. However, this introduces a algorithmic relationship between the IPv6 subnet prefix and IPv4 address. This relationship also allows the option of direct meshed connectivity between users.

The reasons are:
1) "same capabilities"
This seems a marketing wording, like "optimizing". lw4over6 architecture is applicable for other provisioning mechanisms, like DHCPv4ov6/PCP, which adds flexibility to lw4over6. Potential flexibility would make them have different capabilities. 
So I think the word should be removed and keep this text purely technical. IMO, this also follows the WG's guidance during the Softwire session.

2) "algorithmic"
It is the designed feature of MAP to use algorithmic v4-v6 mapping to achieve stateless. No matter what mode MAP is running, the algorithm is still there, but with different value of parameters. A vendor has to implement the algorithm if he wants to use MAP. 
So it is accurate to keep the algorithmic there, and it reflects the characteristics of MAP. 

Best Regards,
Qi

On 2014-3-17, at 下午5:11, Wojciech Dec wrote:

> Hi Ian,
> 
> here's an updated proposal. Besides lining up the text on the prefix independence, I also edited out some redundant text...
> 
> Lightweight 4over6 is a solution designed specifically for complete independence between IPv6 subnet prefix and IPv4 address with or without IPv4 address sharing.
> This is accomplished by maintaining state for each softwire (per-subscriber state) in the lwAFTR and a hub-and-spoke forwarding architecture.
> [I-D.ietf-softwire-map] offers the same capabilities along with means for reducing the amount of such state using address mappings rules, which however introduce a relation between the IPv6 subnet prefix and IPv4 address. This relation also allows optional meshed connectivity between users. 
> 
> Cheers,
> Wojciech.
> 
> 
>

---

From: Wojciech Dec <[email-masked]>
Date: Tue, 18 Mar 2014 14:04:59 +0100

Hi Qi,

On 18 March 2014 09:52, Qi Sun <[email-masked]> wrote:

>
> Hi Woj,
>
> Thanks for the editing! I'm fine with the description for lw4over6. As for
> the map part, I think it's not that accurate.
>
> (per-subscriber state) in the lwAFTR and a hub-and-spoke forwarding
> architecture. [I-D.ietf-softwire-map] also offers a means for reducing the
> amount of such state using address mapping rules. However, this introduces
> a algorithmic relationship between the IPv6 subnet prefix and IPv4 address.
> This relationship also allows the option of direct meshed connectivity
> between users.
>
> The reasons are:
> 1) "same capabilities"
> This seems a marketing wording, like "optimizing". lw4over6 architecture
> is applicable for other provisioning mechanisms, like DHCPv4ov6/PCP, which
> adds flexibility to lw4over6. Potential flexibility would make them have
> different capabilities.
> So I think the word should be removed and keep this text purely technical.
> IMO, this also follows the WG's guidance during the Softwire session.
>

Woj> The text read "
Lightweight 4over6 is a solution designed specifically for complete
independence between IPv6 subnet prefix and IPv4 address with or without
IPv4 address sharing.
This is accomplished by maintaining state for each softwire (per-subscriber
state) in the lwAFTR and a hub-and-spoke forwarding architecture.
[I-D.ietf-softwire-map]
*offers the same capabilities..."*
No part of this text referred to DHCPv4oDHCPv6, nor PCP nor how lw46 or MAP
is provisioned. Also, lw46 and MAP drafts are not dependent on any
particular provisioning mechanisms. Lastly, the statement "same
capabilities" is technically true in this context given that as mentioned
earlier, MAP and lw46 are equivalent in terms of prefix independence.
For these rather fundamental reasons your statement appears to
"technically" unjustified.

>
> 2) "algorithmic"
> It is the designed feature of MAP to use algorithmic v4-v6 mapping to
> achieve stateless. No matter what mode MAP is running, the algorithm is
> still there, but with different value of parameters. A vendor has to
> implement the algorithm if he wants to use MAP.
> Woj> Mapping bits, or inserting bits, or shifting bits are all operations
done using an algorithm and a lw46 implementation will use these and a
plethora of other algorithms. Anyway, if it makes you happy we can go with
the following text that mentions "algorithm":

Lightweight 4over6 is a solution designed specifically for complete
independence between IPv6 subnet prefix and IPv4 address with or without
IPv4 address sharing.
This is accomplished by maintaining state for each softwire (per-subscriber
state) in the lwAFTR and a hub-and-spoke forwarding architecture.
[I-D.ietf-softwire-map] offers the same capabilities along with means for
reducing the amount of such state using *algorithmic* address mapping
rules, which however introduce a relation between the IPv6 subnet prefix
and IPv4 address. This relation also allows optional meshed connectivity
between users.

regards,
Wojciech.

> (per-subscriber state) in the lwAFTR and a hub-and-spoke forwarding
> architecture.
>
>> the lwAFTR. [I-D.ietf-softwire-map] offers a means for reducing the
>> amount of such state by using algorithmic IPv4 to IPv6 address mappings to
>> create aggregate rules.
>> If you put in the IPv4 address in the IID, then it becomes part of the
>> 128 bit IPv6 address. Claiming that there is complete independence (no
>> linkage) between the IPv4 addresses and IPv6 address is then not correct.
>> If you see it another way, then it would be interesting to understand why.
>> What I think Qi was/is trying to say is that there is prefix
>> independence, with prefix being the part of the IPv6 address less the IID.
>> That I agree with. It is the same in lw46 and MAP-E
>>
>>> I don’t understand his point. Let’s put the 1:1 aside, MAP-E requires
>>> 5.1, we simple put the v4 in the IID. Isn’t it obviously there is no v4/v6

---

From: Ted Lemon <[email-masked]>
Date: Tue, 18 Mar 2014 09:56:29 -0400

On Mar 18, 2014, at 9:04 AM, Wojciech Dec <[email-masked]> wrote:
> For these rather fundamental reasons your statement appears to "technically" unjustified.

If I understand Qi's point correctly, he is saying that in order to implement MAP, you have to implement the MAP algorithm.   Whereas you don't need this algorithm for lw4over6.  I think this statement is correct, but your proposed rewording removes that distinction for some reason.

---

From: Wojciech Dec <[email-masked]>
Date: Tue, 18 Mar 2014 15:04:33 +0100

Ted,

On 18 March 2014 14:56, Ted Lemon <[email-masked]> wrote:

> If I understand Qi's point correctly, he is saying that in order to
> implement MAP, you have to implement the MAP algorithm.   Whereas you don't
> need this algorithm for lw4over6.  I think this statement is correct, but
> your proposed rewording removes that distinction for some reason.
>
>
You appear to be quoting me out of context. I wrote: "Mapping bits, or
inserting bits, or shifting bits are all operations done using an algorithm
and a lw46 implementation will use these and a plethora of other
algorithms. Anyway, if it makes you happy we can go with the following text
that mentions "algorithm"...."

All that said, and for correctness,
http://tools.ietf.org/html/draft-ietf-softwire-lw4over6-07 states:

"

An lwB4 MUST support dynamic port-restricted IPv4 address
   provisioning.  The port set algorithm for provisioning this is
   described in Section 5.1 of [I-D.ietf-softwire-map
<http://tools.ietf.org/html/draft-ietf-softwire-lw4over6-07#ref-I-D.ietf-softwire-map>].
 For lw4o6, the
   number of a-bits SHOULD be 0.
"

It's rather clear that lw46 also uses "an algorithm", if not THE "algorithm"...
Whatever.

-Wojciech.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 18 Mar 2014 10:08:42 -0400

> It's rather clear that lw46 also uses "an algorithm", if not THE "algorithm"... 

It doesn't use a mapping algorithm to map between IPv4 and IPv6 addresses, which was the point that Qi expressed in the text he sent out this morning.

---

From: Wojciech Dec <[email-masked]>
Date: Tue, 18 Mar 2014 15:19:43 +0100

On 18 March 2014 15:08, Ted Lemon <[email-masked]> wrote:

> It doesn't use a mapping algorithm to map between IPv4 and IPv6 addresses,
> which was the point that Qi expressed in the text he sent out this morning.
>
>
Text I (re)proposed said it all: