Subject: Re: [Softwires] Proposed text that describes lw4o6 and map-e

From: "ian Farrer" <[email-masked]>
Date: Tue, 18 Mar 2014 15:23:10 +0100

Hi Woj,

One thing about your propsed wording is that it reads like addressing independence and state reduction can be realised concurrently. What about the following (with some other slight language cleanups):

Lightweight 4over6 is a solution designed specifically for complete independence between IPv6 subnet prefix and IPv4 address with or without IPv4 address sharing.
This is accomplished by maintaining state for each softwire (per-subscriber state) in the central lwAFTR and a hub-and-spoke forwarding architecture. [I-D.ietf-softwire-map] can offer these capabilities or, alternatively, reduce the amount of centralised state using algorithmic address mappings rules, introducing a relationship between the IPv6 subnet prefix and IPv4 address. This relationship also allows the option of direct, meshed connectivity between users.

Cheers,
Ian
----- Original Message -----
From: Wojciech Dec
Sent: 03/18/14 03:19 PM
To: Ted Lemon
Subject: Re: [Softwires] Proposed text that describes lw4o6 and map-e

On 18 March 2014 15:08, Ted Lemon < [email-masked] > wrote:
On Mar 18, 2014, at 10:04 AM, Wojciech Dec < [email-masked] > wrote:
> It's rather clear that lw46 also uses "an algorithm", if not THE "algorithm"...
It doesn't use a mapping algorithm to map between IPv4 and IPv6 addresses, which was the point that Qi expressed in the text he sent out this morning.

Text I (re)proposed said it all:
Lightweight 4over6 is a solution designed specifically for complete independence between IPv6 subnet prefix and IPv4 address with or without IPv4 address sharing.This is accomplished by maintaining state for each softwire (per-subscriber state) in the lwAFTR and a hub-and-spoke forwarding architecture. [I-D.ietf-softwire-map] offers the same capabilities along with means for reducing the amount of such state using  *algorithmic* address mapping rules, which however introduce a relation between the IPv6 subnet prefix and IPv4 address. This relation also allows optional meshed connectivity between users.

---

From: Wojciech Dec <[email-masked]>
Date: Tue, 18 Mar 2014 15:37:06 +0100

Hi Ian,

indeed. Would however prefer to remove the modal verb however (which leads
to a few changes):

Lightweight 4over6 is a solution designed specifically for complete
independence between IPv6 subnet prefix and IPv4 address with or without
IPv4 address sharing.
This is accomplished by maintaining state for each softwire (per-subscriber
state) in the central lwAFTR and a hub-and-spoke forwarding architecture.
[I-D.ietf-softwire-map] also offers these capabilities or, alternatively,
allows for the reduction of the amount of centralised state by means of
rules expressing an algorithmic address mapping relationship between the
IPv6 subnet prefix and IPv4 address. This relationship also allows the
option of direct, meshed connectivity between users.

Cheers,
Wojciech.

On 18 March 2014 15:23, ian Farrer <[email-masked]> wrote:

> Hi Woj,
>
> One thing about your propsed wording is that it reads like addressing
> independence and state reduction can be realised concurrently. What about
> the following (with some other slight language cleanups):
>
>
> Lightweight 4over6 is a solution designed specifically for complete
> independence between IPv6 subnet prefix and IPv4 address with or without
> IPv4 address sharing.
> This is accomplished by maintaining state for each softwire
> (per-subscriber state) in the central lwAFTR and a hub-and-spoke forwarding
> architecture.  [I-D.ietf-softwire-map] can offer these capabilities or,
> alternatively, reduce the amount of centralised state using algorithmic
> address mappings rules, introducing a relationship between the IPv6 subnet
> prefix and IPv4 address. This relationship also allows the option of
> direct, meshed connectivity between users.
>
> Cheers,
> Ian
>
>
>
> On 18 March 2014 15:08, Ted Lemon <[email-masked]> wrote:
>>
>> On Mar 18, 2014, at 10:04 AM, Wojciech Dec <[email-masked]> wrote:
>> It doesn't use a mapping algorithm to map between IPv4 and IPv6
>> addresses, which was the point that Qi expressed in the text he sent out
>> this morning.
>>
>
>
> Lightweight 4over6 is a solution designed specifically for complete
> independence between IPv6 subnet prefix and IPv4 address with or without
> IPv4 address sharing.
> This is accomplished by maintaining state for each softwire
> (per-subscriber state) in the lwAFTR and a hub-and-spoke forwarding
> architecture. [I-D.ietf-softwire-map] offers the same capabilities along
> with means for reducing the amount of such state using *algorithmic*address mapping rules, which however introduce a relation between the IPv6
> subnet prefix and IPv4 address. This relation also allows optional meshed
> connectivity between users.
>
>
>
>
>

---

From: <[email-masked]>
Date: Tue, 18 Mar 2014 15:59:17 +0100

Hi Woj,

Removing the modal verb has left us with a rather hefty sentence:

…..allows for the reduction of the amount of centralised state by means of rules expressing an algorithmic address mapping relationship between the IPv6 subnet prefix and IPv4 address.

It would be clearer as two:

….allows for a reduction of the amount of centralised state using rules to express IPv4/IPv6 address mappings. This introduces an algorithmic relationship between the IPv6 subnet and IPv4 address.

Cheers,
Ian

From: Wojciech Dec <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 18 March 2014 15:37
To: ian Farrer <[email-masked]<mailto:[email-masked]>>
Cc: Softwires-wg WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Softwires] Proposed text that describes lw4o6 and map-e

Hi Ian,

indeed. Would however prefer to remove the modal verb however (which leads to a few changes):

Lightweight 4over6 is a solution designed specifically for complete independence between IPv6 subnet prefix and IPv4 address with or without IPv4 address sharing.
This is accomplished by maintaining state for each softwire (per-subscriber state) in the central lwAFTR and a hub-and-spoke forwarding architecture.  [I-D.ietf-softwire-map] also offers these capabilities or, alternatively, allows for the reduction of the amount of centralised state by means of rules expressing an algorithmic address mapping relationship between the IPv6 subnet prefix and IPv4 address. This relationship also allows the option of direct, meshed connectivity between users.

Cheers,
Wojciech.

On 18 March 2014 15:23, ian Farrer <[email-masked]<mailto:[email-masked]>> wrote:
Hi Woj,

Cheers,
Ian

----- Original Message -----

From: Wojciech Dec

Sent: 03/18/14 03:19 PM

To: Ted Lemon

On 18 March 2014 15:08, Ted Lemon <[email-masked]<mailto:[email-masked]>> wrote:

Text I (re)proposed said it all:
Lightweight 4over6 is a solution designed specifically for complete independence between IPv6 subnet prefix and IPv4 address with or without IPv4 address sharing.
This is accomplished by maintaining state for each softwire (per-subscriber state) in the lwAFTR and a hub-and-spoke forwarding architecture. [I-D.ietf-softwire-map] offers the same capabilities along with means for reducing the amount of such state using algorithmic address mapping rules, which however introduce a relation between the IPv6 subnet prefix and IPv4 address. This relation also allows optional meshed connectivity between users.

---

From: Wojciech Dec <[email-masked]>
Date: Tue, 18 Mar 2014 16:44:53 +0100

Agreed.

Cheers,
Wojciech.

On 18 March 2014 15:59, <[email-masked]> wrote:

> .....allows for the reduction of the amount of centralised state by means
> of rules expressing an algorithmic address mapping relationship between
> the IPv6 subnet prefix and IPv4 address.
>
> ....allows for a reduction of the amount of centralised state using rules to
> express IPv4/IPv6 address mappings. This introduces an algorithmic
> relationship between the IPv6 subnet and IPv4 address.
>
> Cheers,
> Ian
>
> From: Wojciech Dec <[email-masked]>
> To: ian Farrer <[email-masked]>
> Cc: Softwires-wg WG <[email-masked]>
>
> architecture.  [I-D.ietf-softwire-map] also offers these capabilities or,
> alternatively, allows for the reduction of the amount of centralised state
> by means of rules expressing an algorithmic address mapping relationship
> between the IPv6 subnet prefix and IPv4 address. This relationship also
> allows the option of direct, meshed connectivity between users.
>
> Cheers,
> Wojciech.
>
>