Subject: [Softwires] 答复: Fwd: New Version Notification for draft-fsc-softwire-dhcp4o6-saddr-opt-00.txt

From: [email-masked]
Date: Tue, 5 Aug 2014 15:05:54 +0800

Hi, Qi,

  Suppose the preferred prefix in the OPTION_DHCP4O6_SADDR_HINT doesn't 
match any prefixes configured on the device, 
what IPv6 address would be passed back to the DHCP 4o6 Server?

BRs,
Linda Wang

"Softwires" <[email-masked]> 写于 2014-07-01 19:28:39:

> Qi Sun <[email-masked]> 
> 发件人:  "Softwires" <[email-masked]>
> 
> 2014-07-01 19:28
> 
> 收件人
> 
> Softwires WG <[email-masked]>, 
> 
> 抄送
> 
> 主题
> 
> [Softwires] Fwd: New Version Notification for draft-fsc-softwire-
> dhcp4o6-saddr-opt-00.txt
> 
> Dear all, 
> 
> We have submitted a new draft about using DHCPv4 over DHCPv6 with 
> some IPv4-over-IPv6 softwire mechanisms. This draft follows the 
> essence of the ’Softwire DHCP Options’ document with a new container
> grouping related sub-options. 
> 
> Comments are more than welcome.
> 
> Best Regards,
> Qi
> 
> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-fsc-softwire-dhcp4o6-
> saddr-opt-00.txt
> Date: July 1, 2014 at 7:24:28 PM GMT+8
> To: Yong Cui <[email-masked]>, Ian Farrer <
> [email-masked]>, "Qi Sun" <[email-masked]>, Qi 
Sun <
> [email-masked]>, "Ian Farrer" <[email-masked]
> >, "Yong Cui" <[email-masked]>
> 
> 
> A new version of I-D, draft-fsc-softwire-dhcp4o6-saddr-opt-00.txt
> has been successfully submitted by Qi Sun and posted to the
> IETF repository.
> 
> Name: draft-fsc-softwire-dhcp4o6-saddr-opt
> Revision: 00
> Title: DHCPv4 over DHCPv6 Source Address Option
> Document date: 2014-06-30
> Group: Individual Submission
> Pages: 8
> URL:            http://www.ietf.org/internet-drafts/draft-fsc-
> softwire-dhcp4o6-saddr-opt-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-fsc-softwire-
> dhcp4o6-saddr-opt/
> Htmlized:       http://tools.ietf.org/html/draft-fsc-softwire-
> dhcp4o6-saddr-opt-00
> 
> 
> Abstract:
>   DHCPv4 over DHCPv6 [I-D.ietf-dhc-dhcpv4-over-dhcpv6] describes a
>   mechanism for dynamically configuring IPv4 over an IPv6-only network.
>   For DHCPv4 over DHCPv6 to function with some IPv4-over-IPv6 softwire
>   mechanisms, the operator must obtain information about the IPv4
>   address and Port Set ID allocated to the DHCP 4o6 client, as well as
>   the /128 IPv6 prefix that the client will use as the source of IPv4-
>   in-IPv6 tunnel.  This memo defines a DHCPv6 container option and two
>   DHCPv6 sub-options, to communicate the source tunnel IPv6 address
>   between the DHCP 4o6 client and server.  It is designed to work in
>   conjunction with the IPv4 address allocation process.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of 
submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: Qi Sun <[email-masked]>
Date: Sat, 9 Aug 2014 10:06:13 +0800

Hi Linda,

Thanks for the comment.

If the OPTION_DHCP4O6_SADDR_HINT doesn’t take effect, then the client would pass back to the server the IPv6 address to which it would use to bind IPv4. It depends on the client’s preference/configuration.

There is some text in Section 4:
   The OPTION_DHCP4O6_SADDR_HINT is used by the server to indicate a
   preferred prefix that the client should use to bind IPv4
   configuration to.  If received this sub-option, the client MUST
   perform a longest prefix match between cipv6-prefix-hint and all
   prefixes configured on the device.  The selected prefix MUST then be
   used to bind the received IPv4 configuration to.  Otherwise, the
   client can select any valid /128 IPv6 prefix.

But it seems the _otherwise_ part might cause confusion. We will revise that in the next version.

Thanks,
Qi

On Aug 5, 2014, at 3:05 PM, [email-masked] wrote:

> Hi, Qi, 
> 
>   Suppose the preferred prefix in the OPTION_DHCP4O6_SADDR_HINT doesn't match any prefixes configured on the device, 
> > [email-masked]>, "Qi Sun" <[email-masked]>, Qi Sun <
> > Please note that it may take a couple of minutes from the time of submission

---

From: [email-masked]
Date: Thu, 14 Aug 2014 14:47:14 +0800

Qi，

  That's exactly what I want to express. Now it's addressed. Thanks.

  Here, I have another question: some content in section 1:
   The service provider can then
   use this binding information to provision other functional elements
   in their network accordingly (such as the border router).

What would be provisioned by using this binding information?

And also, I am not very sure that I have gotten the true purpose of this 
solution. If you can elaborate more details, it would be much more better.

Thanks and BRs,
Linda Wang

 Qi Sun <[email-masked]> 写于 2014-08-09 10:06:13:

> 2014-08-09 10:06

> 收件人
> 
> [email-masked], 
> 
> 抄送
> 
> Softwires WG <[email-masked]>
> 
> 主题
> 
> Re: [Softwires] New Version Notification for draft-fsc-softwire-
> dhcp4o6-saddr-opt-00.txt
> 
> Hi Linda,
> 
> Thanks for the comment.
> 
> If the OPTION_DHCP4O6_SADDR_HINT doesn’t take effect, then the 
> client would pass back to the server the IPv6 address to which it 
> would use to bind IPv4. It depends on the client’s 
preference/configuration.
> >   Suppose the preferred prefix in the OPTION_DHCP4O6_SADDR_HINT 
> doesn't match any prefixes configured on the device, 
> > > [email-masked]>, "Qi Sun" 
> <[email-masked]>, Qi Sun <

---

From: <[email-masked]>
Date: Thu, 14 Aug 2014 10:00:18 +0200

Hi Linda,

Please see below.

Thanks,
Ian

Qi，

And also, I am not very sure that I have gotten the true purpose of this solution. If you can elaborate more details, it would be much more better.

[ian] For lw4o6 (and other A+P based softwire mechanisms), the provisioning system for client softwire configuration and the softwire border router (lwAFTR) have to be completely aligned so that traffic can be correctly routed.

If you have dynamic IP address leasing, as is possible with DHCPv4o6, then the border router has to be updated with the current client address leases and also the IPv6 addresses that are being used as tunnel endpoints.

As the DHCPv4o6 server is managing the address leasing, this draft provides a way that it can also store the IPv6 address that it’s clients will use for building their softwire tunnels meaning that there is a single point in the network storing this information. This information will then be used to synchronise the binding table in the border router, although how this is done isn’t in the scope of this draft.

http://datatracker.ietf.org/doc/draft-liu-softwire-lw4over6-dhcp-deployment/ describes the overall architecture in more details.

---

From: [email-masked]
Date: Fri, 15 Aug 2014 15:46:14 +0800

Hi Ian,

  Thanks for your explaination. Now I get the main purpose and I really 
guess it would be better 
understood if you can put your words below in the new version of this 
draft :)

  And now I guess this draft may be the companion draft of a new draft 
about how to synchronise 
the binding table in the border router. Am I right?

  What's more, here are some editorial errors as follow, it would be 
better if they can be revised.
  Section 5.1:  cipv6-hintlen or cipv6-boundlen ? cipv6-prefix-hint or 
cipv6-bound-prefix?
 
  Nothing else.

  Thanks a lot.

BRs,
Linda Wang

<[email-masked]> 写于 2014-08-14 16:00:18:

> <[email-masked]> 
> 2014-08-14 16:00
> 
> 收件人
> 
> <[email-masked]>, <[email-masked]>, 
> 
> 抄送
> 
> <[email-masked]>
> 
> 主题
> 
> And also, I am not very sure that I have gotten the true purpose of 
> this solution. If you can elaborate more details, it would be much 
> more better.
> 
> [ian] For lw4o6 (and other A+P based softwire mechanisms), the 
> provisioning system for client softwire configuration and the 
> softwire border router (lwAFTR) have to be completely aligned so 
> that traffic can be correctly routed.
> 
> If you have dynamic IP address leasing, as is possible with 
> DHCPv4o6, then the border router has to be updated with the current 
> client address leases and also the IPv6 addresses that are being 
> used as tunnel endpoints.
> 
> As the DHCPv4o6 server is managing the address leasing, this draft 
> provides a way that it can also store the IPv6 address that it’s 
> clients will use for building their softwire tunnels meaning that 
> there is a single point in the network storing this information. 
> This information will then be used to synchronise the binding table 
> in the border router, although how this is done isn’t in the scope 
> of this draft.
> 
> 
http://datatracker.ietf.org/doc/draft-liu-softwire-lw4over6-dhcp-deployment

> / describes the overall architecture in more details.

---

From: Qi Sun <[email-masked]>
Date: Mon, 18 Aug 2014 10:47:10 +0800

Hi Linda,

Please see inline.

Thanks,
Qi

On Aug 15, 2014, at 3:46 PM, [email-masked] wrote:

> Hi Ian, 
> 
>   Thanks for your explaination. Now I get the main purpose and I really guess it would be better 
> understood if you can put your words below in the new version of this draft :) 

[Qi] We will do some rewording to make it clearer. 

> 
>   And now I guess this draft may be the companion draft of a new draft about how to synchronise 

[Qi] This draft is scoped for communicating the bound v6 address to the DHCP 4o6 Server. The synchronisation process is handled in http://tools.ietf.org/html/draft-liu-softwire-lw4over6-dhcp-deployment-04#section-4.5 . 

> 
>   What's more, here are some editorial errors as follow, it would be better if they can be revised. 
>   Section 5.1:  cipv6-hintlen or cipv6-boundlen ? cipv6-prefix-hint or cipv6-bound-prefix? 

[Qi] Thanks for pointing it out. Should be: cipv6-hintlen/cipv6-prefix-hint.

Thanks for comments~

---

From: [email-masked]
Date: Tue, 19 Aug 2014 14:46:10 +0800

Hi，all，

  My question has addressed. Thanks!

BRs,
Linda Wang

Qi Sun <[email-masked]> 写于 2014-08-18 10:47:10:

> 2014-08-18 10:47
> "[email-masked]" <[email-masked]>, [email-masked]
> 
> 主题
> 
draft :)
> [Qi] This draft is scoped for communicating the bound v6 address to 
> the DHCP 4o6 Server. The synchronisation process is handled in 
> http://tools.ietf.org/html/draft-liu-softwire-lw4over6-dhcp-
> deployment-04#section-4.5 . 
> 
>