Subject: Re: [Softwires] Fwd: New Version Notification for draft-sun-softwire-yang-02.txt

From: "Lishan Li" <[email-masked]>
Date: Mon, 9 Mar 2015 19:42:44 +0800 (CST)

Dear all, 

Sorry for be lated because of the Chinese Spring Festival vacation.I think that in general, it is a good idea to define a YANG data model for the configuration and management of Softwire mechanisms.

A few comments/suggestions, though:

1. Why lw4over6-aftr and lw4over6-b4 are separated out?
2. I find that config parameters and the state parameters are almost the same. I don't know whether it is necessary to write the same parameters two times?

Thanks a lot!

Best Regards,
Lishan Li

At 2015-02-13 17:24:21, "Qi Sun" <[email-masked]> wrote:
Dear all, 

We have updated the Softwire YANG model. The major changes are:

1) Update the codes and diagram trees to make it clearer
2) Update the descriptions for elements by borrowing text from the standard documents
3) Add notifications for the NETCONF server reporting back to the Client

Please can you review the latest version. Comments are always welcome. Thanks in advance.

Best Regards,
Qi

Begin forwarded message:

From: [email-masked]

Subject: New Version Notification for draft-sun-softwire-yang-02.txt

Date: February 12, 2015 at 5:34:41 PM GMT+1

To: "Hao Wang" <[email-masked]>, "Rajiv Asati" <[email-masked]>, "Yong Cui" <[email-masked]>, "Mohamed Boucadair" <[email-masked]>, "Ian Farrer" <[email-masked]>, "Qi Sun" <[email-masked]>, "Hao Wang" <[email-masked]>, "Qi Sun" <[email-masked]>, "Ian Farrer" <[email-masked]>, "Mohamed Boucadair" <[email-masked]>, "Yong Cui" <[email-masked]>, "Rajiv Asati" <[email-masked]>

A new version of I-D, draft-sun-softwire-yang-02.txt
has been successfully submitted by Qi Sun and posted to the
IETF repository.

Name:draft-sun-softwire-yang
Revision:02
Title:YANG Data Model for IPv4-in-IPv6 Softwire
Document date:2015-02-12
Group:Individual Submission
Pages:34
URL:            http://www.ietf.org/internet-drafts/draft-sun-softwire-yang-02.txt
Status:         https://datatracker.ietf.org/doc/draft-sun-softwire-yang/
Htmlized:       http://tools.ietf.org/html/draft-sun-softwire-yang-02
Diff:           http://www.ietf.org/rfcdiff?url2=draft-sun-softwire-yang-02

Abstract:
  This document defines a YANG data model for the configuration and
  management of IPv4-in-IPv6 Softwire Border Routers and Customer
  Premises Equipment.  It covers Lightweight 4over6, MAP-E and MAP-T
  Softwire mechanisms.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Qi Sun <[email-masked]>
Date: Tue, 10 Mar 2015 13:58:43 +0100

Hi Lishan,

Thanks for comments. Please see inline. 

> 1. Why lw4over6-aftr and lw4over6-b4 are separated out?

[Qi] This is because the YANG model is more “device-based”, so I thought it would be convenient to structure it this way. But it’s also reasonable to have lw4over6-aftr and lw4over6-b4 in one container, but with different features.

> 2. I find that config parameters and the state parameters are almost the same. I don't know whether it is necessary to write the same parameters two times?

[Qi] Some of the parameters in the state tree are not necessary to appear once again, since the GET operation can get both the running configuration and state parameters. 

Thanks!

Qi

>> Name:		draft-sun-softwire-yang
>> Revision:	02
>> Title:		YANG Data Model for IPv4-in-IPv6 Softwire
>> Document date:	2015-02-12
>> Group:		Individual Submission
>> Pages:		34