Subject: [Softwires] Milestone update and closing/rechartering discussion

From: Suresh Krishnan <[email-masked]>
Date: Tue, 13 Oct 2015 23:13:30 +0000

Hi all,
   As we mentioned in the last meeting we are trying to wind down the 
softwire working group in an orderly fashion and trying to make sure 
that no essential documents are left out.

Milestones update
=================

To start off we would like to update the milestones for the open 
deliverables. If you think that the timelines are off or if you think 
any of these deliverables are not needed, please feel to speak up.

Nov 2015    Submit MAP RADIUS attribute document for Proposed Standard
             (decide whether to include lw4o6 or not)

Nov 2015    Submit MAP MIB module document for Proposed Standard

Nov 2015    Adopt MAP-T deployment scenarios as a WG document
             (Already adopted as wg item earlier. Reconfirm)

Dec 2015    Submit Mesh topology multicast document as Proposed Standard

Dec 2015    Submit DS-lite multicast document for Proposed Standard

Jan 2016    Submit multicast prefix option document as Proposed Standard

Jan 2016    Submit MAP deployment document as Informational

Mar 2016    Submit softwire YANG model document for Proposed Standard

Mar 2016    Submit Unified Softwire CPE document for Proposed Standard

Mar 2016    Submit MAP-T deployment scenarios for Informational

Apr 2016    Conclude WG

Potential items for new milestones: Part 1
==========================================

There are also some drafts (or draft ideas) that have seen some support 
at the meetings when they were presented or discussed. We would like to 
gauge the support for these drafts before we add them to the milestones.

Softwire YANG model draft
draft-sun-softwire-yang-04

Dynamic IPv4 Provisioning for Lightweight 4over6
draft-liu-softwire-lw4over6-dynamic-provisioning-00

Lightweight 4over6 operational document
(Idea floated - no current draft)

Potential items for rechartering: Part 2
========================================

There are also a few other drafts that have been presented and the 
authors have requested that they be included in the rechartering process 
(if there is one). Similar to the items in Part 1, we would like to 
gauge the support for these drafts as well before we decide to work on them.

RADIUS Extensions for IPv4-Embedded Multicast and Unicast IPv6 Prefixes
draft-hu-softwire-multicast-radius-ext-08

Multicast Support for Mapping of Address and Port Protocol and Light 
Weight 4over6
draft-sarikaya-softwire-map-multicast-04

There are also a few other drafts floating around that could be of 
potential interest to softwires. If you feel that there are other drafts 
that need to be considered, feel free to propose them here as well. If 
we see a very strong need for a recharter we will work with the ADs to 
decide on the further steps.

Thanks
Suresh

---

From: Linhui Sun <[email-masked]>
Date: Wed, 14 Oct 2015 13:05:41 +0800

Dear Chairs,

I support the softwire YANG model draft (draft-sun-softwire-yang-04) to be
a milestone. I think we need such a unified method to manage/configure the
softwire entities before closing/rechartering the WG.

Best regards,
Linhui

2015-10-14 7:13 GMT+08:00 Suresh Krishnan <[email-masked]>:

> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>

---

From: [email-masked]
Date: Wed, 14 Oct 2015 14:17:12 +0800

Hi all,

    As a co-author of draft-hu-softwire-multicast-radius-ext-08, I support 
this item for rechartering.
It is useful to deploy multicast in transition scenarios.

    BTW, I also support draft-sun-softwire-yang-04 to be a milestone.

Thanks,
Wei

---

From: [email-masked]
Date: Wed, 14 Oct 2015 15:34:00 +0800

Dear Chairs,

  As Mesh topology multicast, DS-lite multicast as well as multicast 
prefix option documents are all going to be proposed as Standard, I think 
the companion document 
http://tools.ietf.org/id/draft-hu-softwire-multicast-radius-ext-08.txt in 
the potential items for rechartering Part 2 is also worthy to be included 
in the rechartering process to form a set of solutions to solve multicast 
in transiton scenarioes.

  Also as a coauthor of draft-hu-softwire-multicast-radius-ext-08, I think 
this draft is mature to advance further :)

  Thanks very much :)

Best Regards,
Linda Wang

"Softwires" <[email-masked]> 写于 2015/10/14 07:13:30:

> Suresh Krishnan <[email-masked]> 
> 发件人:  "Softwires" <[email-masked]>
> 
> 2015/10/14 07:13
> 
> 收件人
> 
> Softwires WG <[email-masked]>, 
> 
> 抄送
> 
> Yong Cui <[email-masked]>
> 
> 主题
> 
> [Softwires] Milestone update and closing/rechartering discussion
> 
> Hi all,

---

From: tianxiang li <[email-masked]>
Date: Wed, 14 Oct 2015 15:47:20 +0800

Hi all,

I support adding draft-liu-softwire-lw4over6-dynamic-provisioning-00 and
draft-sun-softwire-yang-04  to the milestone.

Dynamic IPv4 Provisioning for Lightweight 4over6 is an extension to
Lightweight4over6 technology, which provides an alternative way to
provision lwB4, based on DHCPv4 over DHCPv6.

Softwire YANG model enables the configuration and management of
IPv4-in-IPv6 Softwire Border Routers and Customer Premises Equipment.
(covering lw4o6, MAP-E and MAP-T)

I think both documents are really useful for the wg.

Best regards,
Tianxiang Li

---

From: Tina TSOU <[email-masked]>
Date: Wed, 14 Oct 2015 09:28:10 +0000

Dear all,

I agree with what Wei says, therefore express my support too.

And I also think the softwire WG should recharter to consider the deliverables Suresh mentioned in his email. The deployment just starts, so there are more interoperability needs.

Thank you,
Tina

在 2015年10月14日，下午2:17，"[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> 写道：

Hi all,

    As a co-author of draft-hu-softwire-multicast-radius-ext-08, I support this item for rechartering.
It is useful to deploy multicast in transition scenarios.

Thanks,
Wei

"Softwires" <[email-masked]<mailto:[email-masked]>> 写于 2015/10/14 07:13:30:

> [email-masked]<mailto:[email-masked]>

---

From: <[email-masked]>
Date: Wed, 14 Oct 2015 14:53:37 +0000

Hi Suresh, all,

I'm OK with all the milestones, except the one to conclude the WG. I do think it is safe to schedule it for end 2016. 

I would like to see covered under the YANG data model milestone not only A+P related DMs (i.e., draft-sun-softwire-yang) but also DS-Lite YANG data model (a candidate document is available at: https://datatracker.ietf.org/doc/draft-boucadair-softwire-dslite-yang/).  

I'm also supportive of having an item for "RADIUS Extensions for IPv4-Embedded Multicast and Unicast IPv6 Prefixes".

Cheers,
Med

> -----Message d'origine-----
> De : Softwires [mailto:[email-masked]] De la part de Suresh
> Krishnan
> Envoyé : mercredi 14 octobre 2015 01:14
> À : Softwires WG
> Cc : Yong Cui
> Objet : [Softwires] Milestone update and closing/rechartering discussion
> 
> Hi all,

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 14 Oct 2015 10:55:08 -0500

On Wed, Oct 14, 2015 at 2:34 AM,  <[email-masked]> wrote:
>
> Dear Chairs,
>
>   As Mesh topology multicast, DS-lite multicast as well as multicast prefix
> option documents are all going to be proposed as Standard, I think the
> companion document
> the potential items for rechartering Part 2 is also worthy to be included in
> the rechartering process to form a set of solutions to solve multicast in
> transiton scenarioes.
>

Me too, as a co-author, I would like to see MAP (and lw4over6)
multicast to be taken up as charter item and yes this draft is also
mature to advance.

Regards,

Behcet

---

From: Ted Lemon <[email-masked]>
Date: Wed, 14 Oct 2015 14:02:56 -0400

> multicast to be taken up as charter item and yes this draft is also

Is there any market pressure behind the push to complete the multicast story for DS-lite, MAP and lw40ver6, or would we just be doing this for completeness?

---

From: "[email-masked]" <[email-masked]>
Date: Sat, 17 Oct 2015 06:52:36 +0800

Dear all, 

  I think multicast-radius is an useful solution for IPv6 transition multicast technology and we also have plan of some deployment about it. 

  IMO, multicast-radius should be in new milestone in PART 1 rather than PART2. Because multicast-radius is a companion document of multicast-dhcp(draft-ietf-softwire-multicast-prefix-option-09), just like "map-radius(draft-ietf-softwire-map-radius-04) and map-dhcp(RFC 7598)". Multicast-radius is not a new type of multicast technology. In fact, it tries to assist multicast-dhcp document to support all kinds of multicast transition technology, including Mesh multicast and DS-Lite multicast. 

Thanks 
Chongfeng Xie

[email-masked]
 
发件人： wang.cui1
发送时间： 2015-10-14 15:34
收件人： Suresh Krishnan
抄送： Softwires WG; Softwires; Yong Cui
主题： Re: [Softwires] Milestone update and closing/rechartering discussion

Dear Chairs, 

  As Mesh topology multicast, DS-lite multicast as well as multicast prefix option documents are all going to be proposed as Standard, I think the companion document http://tools.ietf.org/id/draft-hu-softwire-multicast-radius-ext-08.txt in the potential items for rechartering Part 2 is also worthy to be included in the rechartering process to form a set of solutions to solve multicast in transiton scenarioes. 

  Also as a coauthor of draft-hu-softwire-multicast-radius-ext-08, I think this draft is mature to advance further :) 

  Thanks very much :) 

Best Regards, 
Linda Wang

---

From: Qi Sun <[email-masked]>
Date: Mon, 19 Oct 2015 22:31:23 +0800

Dear Chairs,

As a co-author, I support the Softwire YANG model draft (draft-sun-softwire-yang-04) to be added to the milestones. This document is necessary for managing Softwire IPv6 transition mechanisms, and is mature enough for the next step.

Also, I support to add “Dynamic IPv4 Provisioning for Lightweight 4over6”. It’s useful for operators to have more flexibility when configuring and managing the Lightweight 4over6 domain.

Thanks,
Qi

> On Oct 14, 2015, at 07:13, Suresh Krishnan <[email-masked]> wrote:
> 
> Hi all,

---

From: "Liushucheng (Will)" <[email-masked]>
Date: Thu, 22 Oct 2015 09:55:10 +0000

IMHO, Vendors could benefit from such unified method for configuring and managing softwire devices. SUPA could use the models designed here for high level policy related cases. I'd like to see the draft-sun-softwire-yang to be added as a milestone.

Regards,
Will

From: Softwires [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Saturday, October 17, 2015 6:53 AM
To: wang.cui1; Krishnan Suresh
Cc: softwires; softwires-bounces; Yong Cui
Subject: [Softwires] Re Re: Milestone update and closing/rechartering discussion

Dear all,

Thanks
Chongfeng Xie

________________________________
[email-masked]<mailto:[email-masked]>

发件人： wang.cui1<mailto:[email-masked]>
发送时间： 2015-10-14 15:34
收件人： Suresh Krishnan<mailto:[email-masked]>
抄送： Softwires WG<mailto:[email-masked]>; Softwires<mailto:[email-masked]>; Yong Cui<mailto:[email-masked]>
主题： Re: [Softwires] Milestone update and closing/rechartering discussion

Dear Chairs,

  Thanks very much :)

Best Regards,
Linda Wang

"Softwires" <[email-masked]<mailto:[email-masked]>> 写于 2015/10/14 07:13:30:

> Suresh Krishnan <[email-masked]<mailto:[email-masked]>>
> 发件人:  "Softwires" <[email-masked]<mailto:[email-masked]>>
>
> 2015/10/14 07:13
>
> 收件人
>
> Softwires WG <[email-masked]<mailto:[email-masked]>>,
>
> 抄送
>
> Yong Cui <[email-masked]<mailto:[email-masked]>>
>
> 主题
>