Subject: [Softwires] FW: I-D Action: draft-ietf-softwire-map-mib-08.txt

From: "Yu Fu" <[email-masked]>
Date: Thu, 25 May 2017 14:14:53 +0800

Hi Bert,

Thanks for your MIB doctor review.

I have updated the 08 version based on all your comments. Please see whether
it fix all your comments.

I have another question when I do the MIB module validation as the Severity
level is set to 6(most strict). It has warnings as below.

warning: `InetAddress' should be used instead of `InetAddressIPv6'
warning: `InetAddress' should be used instead of `InetAddressIPv4'

It is because we define the mapRuleIPv6Prefix and mapRuleIPv4Prefix as
below:
   mapRuleIPv6Prefix OBJECT-TYPE
       SYNTAX     InetAddressIPv6
       MAX-ACCESS read-only
       STATUS     current
       DESCRIPTION

  mapRuleIPv4Prefix OBJECT-TYPE
       SYNTAX     InetAddressIPv4
       MAX-ACCESS read-only
       STATUS     current
       DESCRIPTION

Shall we ignore these warnings?

Thanks a lot 

Cheers

Yu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of [email-masked]
Sent: Thursday, May 25, 2017 1:46 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Softwires] I-D Action: draft-ietf-softwire-map-mib-08.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Softwires of the IETF.

        Title           : Definitions of Managed Objects for MAP-E
        Authors         : Yu Fu
                          Sheng Jiang
                          Bing Liu
                          Jiang Dong
                          Yuchi Chen
	Filename        : draft-ietf-softwire-map-mib-08.txt
	Pages           : 15
	Date            : 2017-05-24

Abstract:
   This memo defines a portion of the Management Information Base (MIB)
   for using with network management protocols in the Internet
   community.  In particular, it defines managed objects for MAP
   encapsulation (MAP-E) mode.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-softwire-map-mib/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-softwire-map-mib-08
https://datatracker.ietf.org/doc/html/draft-ietf-softwire-map-mib-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-softwire-map-mib-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
Softwires mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/softwires

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 25 May 2017 11:04:25 +0200

Hi,

since these objects seem to be IP version specific, I think it is OK
to ignore the warning. Perhaps consider adding comment such as:

  -- The object mapRuleIPv6Prefix is IPv6 specific and hence it does
  -- not use the version agnostic InetAddress.

This way, it is documented that any warnings related to this can be
ignored. (Otherwise, this question may come up again.)

/js

On Thu, May 25, 2017 at 02:14:53PM +0800, Yu Fu wrote:
> MIB-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mib-doctors

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Yu Fu" <[email-masked]>
Date: Fri, 26 May 2017 10:50:59 +0800

Hi Juergen,

Thank you for your reply.

OK. I will add a note in the MIB.

Cheers
Yu

>From: [email-masked]
>[mailto:[email-masked]]
>Sent: Thursday, May 25, 2017 5:04 PM
>To: Yu Fu
>Cc: [email-masked]; [email-masked]; 'MIB Doctors';
>[email-masked]
>Subject: Re: [MIB-DOCTORS] FW: [Softwires] I-D Action:
>draft-ietf-softwire-map-mib-08.txt
>
>Hi,
>
>since these objects seem to be IP version specific, I think it is OK to
ignore
>the warning. Perhaps consider adding comment such as:
>
ignored.
>(Otherwise, this question may come up again.)
>
>/js
>
>> I have updated the 08 version based on all your comments. Please see
>> whether it fix all your comments.
>>
>> I have another question when I do the MIB module validation as the
>> Severity level is set to 6(most strict). It has warnings as below.
>>
>>>>>>> From: [email-masked] [mailto:[email-masked]]
>>>>>>> On Behalf Of [email-masked]
>>>>>>> Please note that it may take a couple of minutes from the time of
>>>>>>> submission until the htmlized version and diff are available at
>>>>>>tools.ietf.org.
>>>>>>>