Subject: [Softwires] YANG validation issue with draft-ietf-softwire-dslite-yang-05.txt

From: Benoit Claise <[email-masked]>
Date: Fri, 11 Aug 2017 11:00:44 +0200

Dear authors,

I see that you posted a new version, but there are still some errors
See http://www.claise.be/IETFYANGPageCompilation.html
See https://datatracker.ietf.org/doc/draft-ietf-softwire-dslite-yang/ => 
YANG validation

OLD:
augment "/nat:nat-module/nat:nat-instances/nat:nat-instance" {

NEW: I guess this should be
augment "/nat:nat-config/nat:nat-instances/nat:nat-instance" {

OLD:
augment 
"/nat:nat-module/nat:nat-instances/nat:nat-instance/nat:mapping-table/nat:mapping-entry"{

NEW: I guess this should be
augment 
"/nat:nat-state/nat:nat-instances/nat:nat-instance/nat:mapping-table/nat:mapping-entry"{

Attached is the updated YANG module that validates.

Regards, Benoit

---

From: <[email-masked]>
Date: Fri, 11 Aug 2017 09:20:39 +0000

Hi Benoit, 

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : Benoit Claise [mailto:[email-masked]]
> Envoyé : vendredi 11 août 2017 11:01
> À : [email-masked]; [email-masked]
> Objet : YANG validation issue with draft-ietf-softwire-dslite-yang-05.txt
> 
> Dear authors,
> 

[Med] Actually, the OLD one is correct. We changed the NAT module to be aligned with the NDMA recommendation (so, we don't have any more nat-config)

> table/nat:mapping-entry"{

[Med] Idem as above. We don't have anymore a nat-state in the new NAT module. 

> Attached is the updated YANG module that validates.

[Med] Thank you.

---

From: Benoit Claise <[email-masked]>
Date: Fri, 11 Aug 2017 14:50:21 +0200

Hi Med,

That's very good that you are NMDA compliant.

I didn't pay much attention and thought that both 
ietf-dslite-aftr@2017-08-10 and [email-masked] were part of 
draft-ietf-softwire-dslite-yang-05.txt
Actually [email-masked] comes from 
https://datatracker.ietf.org/doc/draft-sivakumar-yang-nat/
Since ietf-dslite-aftr@2017-08-10 imports [email-masked], the 
next step is to modify [email-masked] to be NMDA compliant, right?

Also, how can draft-ietf-softwire-dslite-yang progress without 
progressing this normative reference?

    8.1. Normative references

        [I-D.sivakumar-yang-nat]
                   Sivakumar, S., Boucadair, M., and S. Vinapamula, "YANG
                   Data Model for Network Address Translation (NAT)", draft-
                   sivakumar-yang-nat-07 (work in progress), July 2017.

Regards, Benoit

---

From: <[email-masked]>
Date: Fri, 11 Aug 2017 13:02:15 +0000

Re-,

Please see inline.

Cheers,
Med

De : Benoit Claise [mailto:[email-masked]]
Envoyé : vendredi 11 août 2017 14:50
À : BOUCADAIR Mohamed IMT/OLN; [email-masked]; [email-masked]; [email-masked]
Objet : Re: YANG validation issue with draft-ietf-softwire-dslite-yang-05.txt

Hi Med,

I didn't pay much attention and thought that both ietf-dslite-aftr@2017-08-10 and [email-masked]<mailto:[email-masked]> were part of draft-ietf-softwire-dslite-yang-05.txt

[Med] We used to have both NAT and softwire aspects covered in the same module, but that design is not clean. We need to separate both.

Actually [email-masked]<mailto:[email-masked]> comes from https://datatracker.ietf.org/doc/draft-sivakumar-yang-nat/
Since ietf-dslite-aftr@2017-08-10 imports [email-masked]<mailto:[email-masked]>, the next step is to modify [email-masked]<mailto:[email-masked]> to be NMDA compliant, right?

[Med] Yes, we will publish the new NAT module soon.

Also, how can draft-ietf-softwire-dslite-yang progress without progressing this normative reference?

[Med] There is a call for adoption of the NAT YANG in OPSAWG : https://www.ietf.org/mail-archive/web/opsawg/current/msg04975.html.

   [I-D.sivakumar-yang-nat]

Hi Benoit,

Please see inline.

Cheers,

Med

-----Message d'origine-----

À : [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Dear authors,

YANG validation

OLD:

OLD:

augment

"/nat:nat-module/nat:nat-instances/nat:nat-instance/nat:mapping-

table/nat:mapping-entry"{

augment

"/nat:nat-state/nat:nat-instances/nat:nat-instance/nat:mapping-

table/nat:mapping-entry"{

[Med] Thank you.

Regards, Benoit