Subject: [Softwires] I-D Action: draft-ietf-softwire-map-radius-19.txt

From: [email-masked]
Date: Mon, 11 Feb 2019 00:26:06 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Softwires WG of the IETF.

        Title           : RADIUS Attributes for Address plus Port (A+P) based Softwire Mechanisms
        Authors         : Sheng Jiang
                          Yu Fu
                          Bing Liu
                          Peter Deacon
                          Chongfeng Xie
                          Tianxiang Li
                          Mohamed Boucadair
	Filename        : draft-ietf-softwire-map-radius-19.txt
	Pages           : 39
	Date            : 2019-02-11

Abstract:
   IPv4-over-IPv6 transition mechanisms provide IPv4 connectivity
   services over IPv6 native networks during the IPv4/IPv6 co-existence
   period.  DHCPv6 options have been defined for configuring clients for
   Lightweight 4over6, Mapping of Address and Port with Encapsulation,
   and Mapping of Address and Port using Translation unicast softwire
   mechanisms, and also multicast softwires.  However, in many networks,
   configuration information is stored in an Authentication,
   Authorization, and Accounting server which utilizes the RADIUS
   protocol to provide centralized management for users.  When a new
   transition mechanism is developed, new RADIUS attributes need to be
   defined correspondingly.

   This document defines new RADIUS attributes to carry Address plus
   Port based softwire configuration parameters from an Authentication,
   Authorization, and Accounting server to a Broadband Network Gateway.
   Both unicast and multicast attributes are covered.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-softwire-map-radius/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-softwire-map-radius-19
https://datatracker.ietf.org/doc/html/draft-ietf-softwire-map-radius-19

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-softwire-map-radius-19

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Yu Tianpeng <[email-masked]>
Date: Mon, 11 Feb 2019 11:27:07 +0000

Dear authors,
Thanks for the new version.
I had a quick read on latest version. I find some nits and also some
questions along the way as we meet a scenario when deploying MAP that need
s46 radius attributes.

Nits:
Section 7.1 should be referring section 3.x not 4.x

Question:
1. How is the status of this document? This draft has last called long time
ago, but still not standard yet. What is the reason? Any plans to move
further? As I mentioned we meet requirement when deploying map, we may need
to make a decision if we follow this draft or define a vendor specific one.

2. This draft seems haven't consider conflicts between subscribers. E.g.
EA length conflict between subscribers with in one MAP domain? And EA
length from radius conflict with BNG within same MAP domain?
As this draft enables the capability to maintain MAP rule logic in radius,
conflict mechanisn should be investigated in my POV.

Appreciate your feedback.
Thanks in advance
Tim

On Mon, 11 Feb 2019, 08:26 <[email-masked] wrote:

> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>

---

From: <[email-masked]>
Date: Mon, 11 Feb 2019 12:42:13 +0000

Hi Yu,

Please see inline.

Cheers,
Med

De : Softwires [mailto:[email-masked]] De la part de Yu Tianpeng
Envoyé : lundi 11 février 2019 12:27
À : [email-masked]
Objet : Re: [Softwires] I-D Action: draft-ietf-softwire-map-radius-19.txt

Dear authors,
Thanks for the new version.
I had a quick read on latest version. I find some nits and also some questions along the way as we meet a scenario when deploying MAP that need s46 radius attributes.

Nits:
Section 7.1 should be referring section 3.x not 4.x
[Med] Thank you for catching the bug in Section 7.1.

Question:
1. How is the status of this document? This draft has last called long time ago, but still not standard yet. What is the reason? Any plans to move further? As I mentioned we meet requirement when deploying map, we may need to make a decision if we follow this draft or define a vendor specific one.

[Med] The document passed the WGLC + addressed the reviews from radext wg. We do think that the document is ready to be sent to the IESG.

2. This draft seems haven't consider conflicts between subscribers. E.g.  EA length conflict between subscribers with in one MAP domain? And EA length from radius conflict with BNG within same MAP domain?
As this draft enables the capability to maintain MAP rule logic in radius, conflict mechanisn should be investigated in my POV.

[Med] Which conflict mechanism do you have in mind?

I’m afraid this is deployment and implementation-specific. FWIW, the draft includes the following to warrant that some consistency checks is needed:

   In some deployments, the DHCP server may use the Accounting-Request
   to report to a AAA server the softwire configuration returned to a
   requesting host.  It is the responsibility of the DHCP server to
   ensure the consistency of the configuration provided to requesting
   hosts.

Appreciate your feedback.
Thanks in advance
Tim
On Mon, 11 Feb 2019, 08:26 <[email-masked]<mailto:[email-masked]> wrote:

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
Softwires mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/softwires

---

From: Yu Tianpeng <[email-masked]>
Date: Tue, 12 Feb 2019 13:51:58 +0000

Thanks a lot Mohamed.
It answers my questions.
Inline below.
Regards,
Tim

On Mon, 11 Feb 2019, 12:42 <[email-masked] wrote:

> Hi Yu,
>
>
>
> Please see inline.
>
>
>
> Cheers,
>
> Med
>
>
>
> *De :* Softwires [mailto:[email-masked]] *De la part de* Yu
> Tianpeng
> *Envoyé :* lundi 11 février 2019 12:27
> *À :* [email-masked]
> *Objet :* Re: [Softwires] I-D Action:
> draft-ietf-softwire-map-radius-19.txt
>
>
>
> Dear authors,
>
> 1. How is the status of this document? This draft has last called long
> time ago, but still not standard yet. What is the reason? Any plans to move
> [Med] The document passed the WGLC + addressed the reviews from radext wg.
> We do think that the document is ready to be sent to the IESG.
>
>  [Tim] glad to know. Thanks
>
> I’m afraid this is deployment and implementation-specific. FWIW, the draft
> includes the following to warrant that some consistency checks is needed:
>
>
>
>  [Tim] yes, it solves one of the scenario I mentioned.
>
I believe if dhcp server use access request to get s46 info from AAA, then
> AAA server is response to enrue the consistency I suppose. Am I right?
>

---

From: <[email-masked]>
Date: Tue, 12 Feb 2019 14:07:49 +0000

Hi Yu,

The answer to your question is: Yes.

Cheers,
Med

De : Yu Tianpeng [mailto:[email-masked]]
Envoyé : mardi 12 février 2019 14:52
À : BOUCADAIR Mohamed TGI/OLN
Cc : [email-masked]
Objet : Re: [Softwires] I-D Action: draft-ietf-softwire-map-radius-19.txt

Thanks a lot Mohamed.
It answers my questions.
Inline below.
Regards,
Tim
On Mon, 11 Feb 2019, 12:42 <[email-masked]<mailto:[email-masked]> wrote:
Hi Yu,

Please see inline.

Cheers,
Med

De : Softwires [mailto:[email-masked]<mailto:[email-masked]>] De la part de Yu Tianpeng
Envoyé : lundi 11 février 2019 12:27
À : [email-masked]<mailto:[email-masked]>
Objet : Re: [Softwires] I-D Action: draft-ietf-softwire-map-radius-19.txt

Dear authors,

Nits:

Question:

I believe if dhcp server use access request to get s46 info from AAA, then AAA server is response to enrue the consistency I suppose. Am I right?

Abstract:

---

From: Yu Tianpeng <[email-masked]>
Date: Tue, 12 Feb 2019 14:10:15 +0000

Thanks
Cheers.

On Tue, 12 Feb 2019, 14:07 <[email-masked] wrote:

> *De :* Yu Tianpeng [mailto:[email-masked]]
> *Envoyé :* mardi 12 février 2019 14:52
> *À :* BOUCADAIR Mohamed TGI/OLN
> *Cc :* [email-masked]

---

From: <[email-masked]>
Date: Wed, 13 Feb 2019 08:47:53 +0000

Hi Yu,

Great!

Uploaded -20 which fixes the reference issue you pointed out + includes a mention that configuration consistency check is also the responsibility of the AAA server.

Cheers,
Med

De : Yu Tianpeng [mailto:[email-masked]]
Envoyé : mardi 12 février 2019 15:10
À : BOUCADAIR Mohamed TGI/OLN
Cc : [email-masked]
Objet : Re: [Softwires] I-D Action: draft-ietf-softwire-map-radius-19.txt

Thanks
Cheers.

On Tue, 12 Feb 2019, 14:07 <[email-masked]<mailto:[email-masked]> wrote:
Hi Yu,

Cheers,
Med

De : Yu Tianpeng [mailto:[email-masked]<mailto:[email-masked]>]
Envoyé : mardi 12 février 2019 14:52
À : BOUCADAIR Mohamed TGI/OLN
Cc : [email-masked]<mailto:[email-masked]>
Objet : Re: [Softwires] I-D Action: draft-ietf-softwire-map-radius-19.txt

Thanks a lot Mohamed.
It answers my questions.
Inline below.
Regards,
Tim

Please see inline.

Cheers,
Med

Dear authors,

Nits:

Question:

Abstract:

---

From: Yu Tianpeng <[email-masked]>
Date: Wed, 13 Feb 2019 08:49:31 +0000

Thanks Mohamed,
Cheers
Tim

On Wed, 13 Feb 2019, 08:47 <[email-masked] wrote:

> Hi Yu,
>
>
>
> Great!
>
>
>
> Uploaded -20 which fixes the reference issue you pointed out + includes a
> mention that configuration consistency check is also the responsibility of
> the AAA server.
>
>
>
> Cheers,
>
> Med
>
>
>
> *Envoyé :* mardi 12 février 2019 15:10