Subject: [lamps] I-D Action: draft-ietf-lamps-cms-hash-sig-01.txt

From: [email-masked]
Date: Sun, 23 Sep 2018 14:31:29 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Limited Additional Mechanisms for PKIX and SMIME WG of the IETF.

        Title           : Use of the HSS/LMS Hash-based Signature Algorithm in the Cryptographic Message Syntax (CMS)
        Author          : Russ Housley
	Filename        : draft-ietf-lamps-cms-hash-sig-01.txt
	Pages           : 14
	Date            : 2018-09-23

Abstract:
   This document specifies the conventions for using the the HSS/LMS
   hash-based signature algorithm with the Cryptographic Message Syntax
   (CMS).  The HSS/LMS algorithm is one form of hash-based digital
   signature; it is described in [HASHSIG].

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lamps-cms-hash-sig/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-lamps-cms-hash-sig-01
https://datatracker.ietf.org/doc/html/draft-ietf-lamps-cms-hash-sig-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lamps-cms-hash-sig-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Russ Housley <[email-masked]>
Date: Sun, 23 Sep 2018 17:35:45 -0400

This update does not address the first comment in Daniel's message, but it does address the rest of them.  You can see his comments here:

	https://mailarchive.ietf.org/arch/msg/spasm/tGTrASQXNEK03SL3_Mv3sfg7QYc

I would like to hear from others on this list before I address his first comment.

Russ

> On Sep 23, 2018, at 5:31 PM, [email-masked] wrote:
> 
>

---

From: Daniel Van Geest <[email-masked]>
Date: Mon, 24 Sep 2018 20:41:36 +0000

Hi Russ,

Comments on your recent changes:

	   The public key value is an OCTET STRING.  Like the signature format,	
 	   it is designed for easy parsing.  The value is a length, L, followed	
 	   by the public key itself.

L is the number of levels (in the private key & thus the signature), not a length.

The signature format is still off:

	   The elements of the HSS signature value for a tree with Nspk levels
	   can be summarized as:

In [HASHSIG], L is the number of levels.  Nspk is L - 1.  If you keep the updated indexing of the signed_public_key array in the signature, then the above sentence should be:

	   The elements of the HSS signature value for a tree with Nspk + 1 levels
	   can be summarized as:

Thanks,
Daniel

On 2018-09-23, 11:35 PM, "Spasm on behalf of Russ Housley" <[email-masked] on behalf of [email-masked]> wrote:

    
    
    Russ

    > until the htmlized version and diff are available at tools.ietf.org.
    
    _______________________________________________
    Spasm mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/spasm