Subject: [lamps] I-D Action: draft-ietf-lamps-cmp-algorithms-01.txt

From: [email-masked]
Date: Mon, 02 Nov 2020 07:21:09 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Limited Additional Mechanisms for PKIX and SMIME WG of the IETF.

        Title           : CMP Algorithms
        Author          : Hendrik Brockhaus
	Filename        : draft-ietf-lamps-cmp-algorithms-01.txt
	Pages           : 18
	Date            : 2020-11-02

Abstract:
   This document describes the conventions for using several
   cryptographic algorithms with the Certificate Management Protocol
   (CMP).  CMP is used to enroll and further manage the lifecycle of
   X.509 certificates.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lamps-cmp-algorithms/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-lamps-cmp-algorithms-01
https://datatracker.ietf.org/doc/html/draft-ietf-lamps-cmp-algorithms-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lamps-cmp-algorithms-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Thu, 5 Nov 2020 16:57:25 +0000

This is now the first complete Draft as discussed at IETF 108.
https://datatracker.ietf.org/doc/draft-ietf-lamps-cmp-algorithms/
The content is:
   2.  Message Digest Algorithms . . . . . . . . . . . . . . . . . .   3
     2.1.  SHA2  . . . . . . . . . . . . . . . . . . . . . . . . . .   3
   3.  Signature Algorithms  . . . . . . . . . . . . . . . . . . . .   3
     3.1.  DSA . . . . . . . . . . . . . . . . . . . . . . . . . . .   4
     3.2.  RSA . . . . . . . . . . . . . . . . . . . . . . . . . . .   4
     3.3.  ECDSA . . . . . . . . . . . . . . . . . . . . . . . . . .   5
   4.  Key Management Algorithms . . . . . . . . . . . . . . . . . .   5
     4.1.  Key Agreement Algorithms  . . . . . . . . . . . . . . . .   6
       4.1.1.  Diffie-Hellman  . . . . . . . . . . . . . . . . . . .   6
       4.1.2.  ECDH  . . . . . . . . . . . . . . . . . . . . . . . .   6
     4.2.  Key Transport Algorithms  . . . . . . . . . . . . . . . .   7
       4.2.1.  RSA . . . . . . . . . . . . . . . . . . . . . . . . .   7
     4.3.  Symmetric Key-Encryption Algorithms . . . . . . . . . . .   7
       4.3.1.  AES Key Wrap  . . . . . . . . . . . . . . . . . . . .   8
     4.4.  Key Derivation Algorithms . . . . . . . . . . . . . . . .   8
       4.4.1.  Password-based Key Derivation Function 2  . . . . . .   8
   5.  Content Encryption Algorithms . . . . . . . . . . . . . . . .   9
     5.1.  AES . . . . . . . . . . . . . . . . . . . . . . . . . . .   9
   6.  Message Authentication Code Algorithms  . . . . . . . . . . .  10
     6.1.  Password-based MAC  . . . . . . . . . . . . . . . . . . .  10
     6.2.  Diffie-Hellman-based MAC  . . . . . . . . . . . . . . . .  11
     6.3.  SHA2-based HMAC . . . . . . . . . . . . . . . . . . . . .  11

Any Feedback is welcome

- Hendrik

> Von: Spasm <[email-masked]> Im Auftrag von [email-masked]
> Gesendet: Montag, 2. November 2020 16:21
> 
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatrack
> er.ietf.org%2Fdoc%2Fdraft-ietf-lamps-cmp-
> algorithms%2F&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7
> Caa680ea7b53341729f1b08d87f4331c3%7C38ae3bcd95794fd4addab42e1495d
> 55a%7C1%7C0%7C637399273856702196%7CUnknown%7CTWFpbGZsb3d8eyJW
> IjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C10
> 00&amp;sdata=bNVSx5s%2BZT6vKS0fi61h4wlhilCj93NO7ajRYyaGCgM%3D&am
> p;reserved=0
> 
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.
> org%2Fhtml%2Fdraft-ietf-lamps-cmp-algorithms-
> 01&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7Caa680ea7b
> 53341729f1b08d87f4331c3%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7
> C0%7C637399273856712193%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLj
> AwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;s
> data=%2F223fu7%2F8aAj6067JwcXQRskFS5TZdE1t0nRRiOvF0w%3D&amp;reser
> ved=0
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatrack
> er.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-lamps-cmp-algorithms-
> 01&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7Caa680ea7b
> 53341729f1b08d87f4331c3%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7
> C0%7C637399273856712193%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLj
> AwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;s
> data=aLxIVNyJG%2FzN%2FGQtDKEnxnS6RdBqd%2Fx6Ka9DcIRtAmQ%3D&amp;r
> eserved=0
> 
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.
> org%2Frfcdiff%3Furl2%3Ddraft-ietf-lamps-cmp-algorithms-
> 01&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7Caa680ea7b
> 53341729f1b08d87f4331c3%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7
> C0%7C637399273856712193%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLj
> AwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;s
> data=QI2ugJsqz%2BQAGeGT7PloekyGeM8asTNHL6ovlt24x54%3D&amp;reserve
> d=0
> 
> 
> https://eur01.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%
> 2Finternet-
> drafts%2F&amp;data=04%7C01%7Chendrik.brockhaus%40siemens.com%7Caa6
> 80ea7b53341729f1b08d87f4331c3%7C38ae3bcd95794fd4addab42e1495d55a%
> 7C1%7C0%7C637399273856712193%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiM
> C4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&
> amp;sdata=pls%2F0jMZ76z5LmHARRpB1FA69MkRYT%2F4kuk8BKKJIN4%3D&a
> mp;reserved=0
> 
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.
> org%2Fmailman%2Flistinfo%2Fspasm&amp;data=04%7C01%7Chendrik.brockha
> us%40siemens.com%7Caa680ea7b53341729f1b08d87f4331c3%7C38ae3bcd957
> 94fd4addab42e1495d55a%7C1%7C0%7C637399273856712193%7CUnknown%7
> CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLC
> JXVCI6Mn0%3D%7C1000&amp;sdata=FEDV4Oy9KnvJAJXGbv9sqwoRZdVd7I8fB
> mwtYRuC21k%3D&amp;reserved=0