Subject: [lamps] Call for adoption for draft-dkg-lamps-e2e-mail-guidance

From: Russ Housley <[email-masked]>
Date: Thu, 1 Apr 2021 16:36:43 -0400

A re-charter has been sent to the IESG that includes this new work item:

> 4. Provide concrete guidance for implementers of email user agents
> to promote interoperability of end-to-end cryptographic protection
> of email messages.  This may include guidance about the generation,
> interpretation, and handling of protected messages; management of the
> relevant certificates; documentation of how to avoid common failure
> modes; strategies for deployment in a mixed environment; as well as
> test vectors and examples that can be used by implementers and
> interoperability testing.  The resulting robust consensus among email
> user agent implementers is expected to provide more usable and useful
> cryptographic security for email users.

Assuming that the IESG approves the re-charter text, should the LAMPS WG adopt draft-dkg-lamps-e2e-mail-guidance as the starting point for this work?

Please voice your support or raise concerns by 14 April 2021.

Russ

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 1 Apr 2021 21:25:00 +0000

>    Assuming that the IESG approves the re-charter text, should the LAMPS WG adopt draft-dkg-lamps-e2e-mail-guidance as the starting point for this work?

Yes.  It's a very useful first draft.

---

From: Jonathan Hammell <[email-masked]>
Date: Wed, 7 Apr 2021 09:55:46 -0400

> Assuming that the IESG approves the re-charter text, should the LAMPS WG adopt draft-dkg-lamps-e2e-mail-guidance as the starting point for this work?

I think this draft is useful and I support WG adoption.

Jonathan

On Thu, Apr 1, 2021 at 4:36 PM Russ Housley <[email-masked]> wrote:
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 7 Apr 2021 15:33:20 +0100

> Please voice your support or raise concerns by 14 April 2021.

Yes, I support adoption of this draft as a LAMPS WG document.

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Tue, 13 Apr 2021 16:40:21 -0400

> Please voice your support or raise concerns by 14 April 2021.

In case it wasn't clear, I also support adoption by the WG.  I'm game to
continue as editor, with WG having formal change control.  I welcome
anyone else who wants to join me as editor, and I also would not object
if the WG were to select entirely different editors.  I will contine to
review and propose text in any case.

       --dkg

---

From: Russ Housley <[email-masked]>
Date: Wed, 14 Apr 2021 17:13:50 -0400

> Please voice your support or raise concerns by 14 April 2021.

No one voiced opposition to adopting this document, and several people voiced support.  We expect the IESG to approve a charter that includes this work, and if they do so, this document will be the starting point for that work.

Russ