Subject: [lamps] DRAFT Agenda for LAMPS at IETF 111

From: Russ Housley <[email-masked]>
Date: Thu, 1 Jul 2021 16:11:55 -0400

Please review and comment on the draft agenda below.

Russ

= = = = = = = 

LAMPS WG Agenda at Virtual IETF 111

FIRST SESSION -- Monday, 26 July 2021

0)  Minute Taker, Jabber Scribe, Bluesheets

1)  Agenda Bash

2)  CMP-related Documents
    a)  draft-ietf-lamps-cmp-updates (Hendrik, David)
    b)  draft-ietf-lamps-cmp-algorithms (Hendrik, Hans, Mike, Serge)
    c)  draft-ietf-lamps-lightweight-cmp-profile (Hendrik, Steffen, David)

3)  Wrap Up

SECOND SESSION -- Thursday, 29 July 2021

0)  Minute Taker, Jabber Scribe, Bluesheets

1)  Agenda Bash

2)  S/MIME-related Documents
    a)  draft-ietf-lamps-header-protection (DKG, Alexey, Bernie)
    b)  draft-ietf-lamps-samples  (DKG)

3)  S/MIME-related Documents Pending Recharter (if time permits)
    a)  draft-dkg-lamps-e2e-mail-guidance (DKG)

4)  Wrap Up

---

From: Russ Housley <[email-masked]>
Date: Mon, 5 Jul 2021 16:01:12 -0400

This proposal does not include any time for the discussions of the newly approved post-quantum topics.  I suggest that adding thm would mike for a very tight agenda.  I think that a separate interim session focused on the post-quantum topics after IETF 111 would allow all topics to be given ample time to quality discussion.

What do others think?

Russ

---

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Mon, 5 Jul 2021 20:44:19 +0000

I am OK with having a separate interim session dedicated to PQ topics.

Thanks!
--
Regards,
Uri
 
There are two ways to design a system. One is to make is so simple there are obviously no deficiencies.
The other is to make it so complex there are no obvious deficiencies.
                                                                                                                                     -  C. A. R. Hoare

On 7/5/21, 16:01, "Spasm on behalf of Russ Housley" <[email-masked] on behalf of [email-masked]> wrote:

    What do others think?

    Russ

    > Please review and comment on the draft agenda below.

    _______________________________________________
    Spasm mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/spasm

---

From: Michael Richardson <[email-masked]>
Date: Mon, 05 Jul 2021 16:56:27 -0400

Russ Housley <[email-masked]> wrote:
    > This proposal does not include any time for the discussions of the
    > newly approved post-quantum topics.  I suggest that adding thm would
    > mike for a very tight agenda.  I think that a separate interim session
    > focused on the post-quantum topics after IETF 111 would allow all
    > topics to be given ample time to quality discussion.

I agree. It merits a focused hour.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Mike Ounsworth <[email-masked]>
Date: Mon, 5 Jul 2021 22:08:08 +0000

I also vote for a separate interim on PQ.

Other than our composite stuff, has lamps received any drafts on PQ?

Is it worth 5 or 10 mins at 111 for me to (re-) introduce the composite drafts? We have kept working on them in the background to incorporate feedback and include composite encryption and key exchange mechanisms. Or would that be ok to do on list?

---
Mike Ounsworth
Software Security Architect, Entrust

-----Original Message-----
From: Spasm <[email-masked]> On Behalf Of Blumenthal, Uri - 0553 - MITLL
Sent: July 5, 2021 3:44 PM
To: Russ Housley <[email-masked]>; SPASM <[email-masked]>
Cc: Tim Hollebeek <[email-masked]>
Subject: Re: [lamps] [EXTERNAL] DRAFT Agenda for LAMPS at IETF 111

Thanks!
--
Regards,
Uri

    What do others think?

    Russ

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 5 Jul 2021 22:31:59 +0000

Agreed.

---

From: "Kampanakis, Panos" <[email-masked]>
Date: Tue, 6 Jul 2021 03:33:47 +0000

+1 on a PQ interim. 

-----Original Message-----
From: Spasm <[email-masked]> On Behalf Of Russ Housley
Sent: Monday, July 5, 2021 4:01 PM
To: SPASM <[email-masked]>
Cc: Tim Hollebeek <[email-masked]>
Subject: RE: [EXTERNAL] [lamps] [EXTERNAL] DRAFT Agenda for LAMPS at IETF 111

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you can confirm the sender and know the content is safe.

What do others think?

Russ

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Tue, 6 Jul 2021 06:06:43 +0000

I am fine with the proposed agenda and the PQ interim.

Hendrik

> Von: Spasm <[email-masked]> Im Auftrag von Russ Housley
> Gesendet: Montag, 5. Juli 2021 22:01
> 
> This proposal does not include any time for the discussions of the newly
> approved post-quantum topics.  I suggest that adding thm would mike for a very
> tight agenda.  I think that a separate interim session focused on the post-
> quantum topics after IETF 111 would allow all topics to be given ample time to
> quality discussion.
> 
> What do others think?
> 
> Russ
> 
> 
> https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf
> .org%2Fmailman%2Flistinfo%2Fspasm&amp;data=04%7C01%7Chendrik.brockha
> us%40siemens.com%7C3cb5e2ec86534757e98e08d93fefb172%7C38ae3bcd957
> 94fd4addab42e1495d55a%7C1%7C0%7C637611121004758675%7CUnknown%7
> CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJ
> XVCI6Mn0%3D%7C1000&amp;sdata=%2FY4VY%2F%2Fb8qHfREWJMhs8AiK3R2
> %2B2zK%2FD%2BJCzKK4kk4Y%3D&amp;reserved=0

---

From: Russ Housley <[email-masked]>
Date: Tue, 6 Jul 2021 14:53:30 -0400

Based on the discussion, we will plan for a virtual interim to talk about PQ, and the implementation issue for EST CSRATTRS is added to Thursday (to not conflict with the ANIMA session on Monday).

Russ

= = = = = = = = 

1)  Agenda Bash

2)  CMP-related Documents

3)  Wrap Up

1)  Agenda Bash

2)  EST implementation issue
    a)  Using EST CSRATTRS for SubjectAltName (Eliot)

3)  S/MIME-related Documents
    a)  draft-ietf-lamps-header-protection (DKG, Alexey, Bernie)
    b)  draft-ietf-lamps-samples  (DKG)

4)  S/MIME-related Documents Pending Recharter (if time permits)
    a)  draft-dkg-lamps-e2e-mail-guidance (DKG)

5)  Wrap Up

---

From: Russ Housley <[email-masked]>
Date: Tue, 6 Jul 2021 15:00:30 -0400

Mike:

You and Max Pala are the people that I know are working on this topic.

Not competing, but this document was announced on the CFRG mail list:
https://docs.google.com/document/d/1MbSf7e9NIZ0XCEpJ9Kpdxe04Z5HlvvgOBTUX4uvM1i0/edit

Russ

> On Jul 5, 2021, at 6:08 PM, Mike Ounsworth <Mike.Ounsworth=[email-masked]> wrote:
>

---

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Tue, 6 Jul 2021 19:21:07 +0000

I expect the referred document to be submitted to LAMPS, eventually if not immediately.

--
Regards,
Uri

On 7/6/21, 15:02, "Spasm on behalf of Russ Housley" <[email-masked] on behalf of [email-masked]> wrote:

    Mike:

    Russ

---

From: Ludovic Perret <[email-masked]>
Date: Sat, 31 Jul 2021 19:44:05 +0000

Hi,

------ Message d'origine ------
De: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
À: "Russ Housley" <[email-masked]>; "SPASM" <[email-masked]>
Cc : "Tim Hollebeek" <[email-masked]>
Envoyé : 05/07/2021 22:44:19
Objet : Re: [lamps] [EXTERNAL] DRAFT Agenda for LAMPS at IETF 111

>I am OK with having a separate interim session dedicated to PQ topics.
any date already fixed or envisioned for  the PQ interim meeting ?

Best Regards,

Ludovic,

---

From: Russ Housley <[email-masked]>
Date: Sat, 31 Jul 2021 16:05:35 -0400

I just posted a Doodle poll to find out ...

	https://doodle.com/poll/3m8ca2yyfvttb78w

Russ

> On Jul 31, 2021, at 3:44 PM, Ludovic Perret <[email-masked]> wrote:
> 
> Hi,
>