Subject: Re: [lamps] Call for adoption for draft-ito-documentsigning-eku

From: Russ Housley <[email-masked]>
Date: Wed, 1 Dec 2021 16:22:42 -0500

Tim and I just talked on the phone.  We both agree that there is consensus to adopt this document.  In fact, the discussion about what ought to go into the section on transition and interoperability has started.

Authors, please post draft-ietf-lamps-documentsigning-eku ...

For the LAMPS WG Chairs,
  Russ

> On Nov 10, 2021, at 5:06 PM, Russ Housley <[email-masked]> wrote:
> 
> 
> We have already discussing the assignment of an object identifier for document signing.  An earlier call for document adoption lead to a lot of comments.  We had a presentation at IETF 112, and the authors reported that they have clarified what is meant by document signing, added a section for how to use the public key and certificate, addressed concerns about the extended key usage as a policy identifier, and expanded the security considerations.  Following the IETF 112 presentation, no one spoke against against adoption of this document.  This call is to see if there is rough consensus for the LAMPS WG to proceed with adoption of the revised document.
> 
> Please send your reply about whether you support adopting draft-ito-documentsigning-eku as a WG document.  Please voice your support or raise concerns by 30 November 2021.
> 
> For the LAMPS WG Chairs,
> Russ
>

---

From: Tadahiko Ito <[email-masked]>
Date: Thu, 2 Dec 2021 17:35:16 +0900

Hi Russ and Tim

I am wondering the order of

1) submitting draft-ietf-lamps... and

2) fixing description of Stephan pointed out in his first comment
(“Inclusion of this KeyPurposeId…”).

Which should we do first?

There were some migration and compatibility related comments and
suggestions also, but we will deal with that on the later version of the
draft.

Regards Tadahiko

2021年12月2日(木) 6:23 Russ Housley <[email-masked]>:

> Tim and I just talked on the phone.  We both agree that there is consensus
> to adopt this document.  In fact, the discussion about what ought to go
> into the section on transition and interoperability has started.
>
> > We have already discussing the assignment of an object identifier for
> document signing.  An earlier call for document adoption lead to a lot of
> comments.  We had a presentation at IETF 112, and the authors reported that
> they have clarified what is meant by document signing, added a section for
> how to use the public key and certificate, addressed concerns about the
> extended key usage as a policy identifier, and expanded the security
> considerations.  Following the IETF 112 presentation, no one spoke against
> against adoption of this document.  This call is to see if there is rough
> consensus for the LAMPS WG to proceed with adoption of the revised document.
> >
> > Please send your reply about whether you support adopting
> draft-ito-documentsigning-eku as a WG document.  Please voice your support
> or raise concerns by 30 November 2021.
> >
> > For the LAMPS WG Chairs,
> > Russ
> >
>
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm
>

---

From: Russ Housley <[email-masked]>
Date: Thu, 2 Dec 2021 10:48:18 -0500

Tadahiko:

It is clear that more discussion will take place on the backwards compatibility and interoperability topics, so it it fine to submit the current text, and make changes in future revisions.

Russ

> On Dec 2, 2021, at 3:35 AM, Tadahiko Ito <[email-masked]> wrote:
> 
> Hi Russ and Tim
> 
> 2) fixing description of Stephan pointed out in his first comment (“Inclusion of this KeyPurposeId…”).
> 
> There were some migration and compatibility related comments and suggestions also, but we will deal with that on the later version of the draft.
> 
> Regards Tadahiko 
> 
> 
> 2021年12月2日(木) 6:23 Russ Housley <[email-masked] <mailto:[email-masked]>>:
> > On Nov 10, 2021, at 5:06 PM, Russ Housley <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> > 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/spasm <https://www.ietf.org/mailman/listinfo/spasm>