Subject: [Speechsc] START-OF-SPEECH in DTMF-only mode

From: "Reifenrath, Klaus" <[email-masked]>
Date: Tue, 5 Jul 2005 03:46:31 -0400

The current spec is not clear when START-OF-SPEECH need to be send in the
following scenarios:
A) The client requested a DTMF Recognizer. Is the START-OF-SPEECH event send
to the client also if speech was detected? 
B) The client requested a Speech Recognizer, but only activated DTMF
grammars. Is the START-OF-SPEECH event send to the client also if speech was
detected?
I think in both cases START-OF-SPEECH should only be send after detecting a
DTMF digit (see Figure 12 of VoiceXML 2.0:
http://www.w3.org/TR/voicexml20/#dmlATiming
<http://www.w3.org/TR/voicexml20/> ).

Klaus

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: David R Oran <[email-masked]>
Date: Tue, 5 Jul 2005 08:24:23 -0400

On Jul 5, 2005, at 3:46 AM, Reifenrath, Klaus wrote:

> The current spec is not clear when START-OF-SPEECH need to be send  
> in the following scenarios:
> A) The client requested a DTMF Recognizer. Is the START-OF-SPEECH  
> event send to the client also if speech was detected?
I suspect so, since one of the prime purposes is to enable client- 
mediated barge-in handling. However, if the recognizer is in fact  
only capable of recognizing DTMF then it may in fact not report  
anythin unless it's using some primitive thresholding machinery, like  
a SN threshold.
> B) The client requested a Speech Recognizer, but only activated  
> DTMF grammars. Is the START-OF-SPEECH event send to the client also  
> if speech was detected?
Again, I'd say yes, for the same reason as above.
> I think in both cases START-OF-SPEECH should only be send after  
> detecting a DTMF digit (see Figure 12 of VoiceXML 2.0: http:// 
> www.w3.org/TR/voicexml20/#dmlATiming).
We seem to have reached different conclusions. I'd be interested in  
why you think my analysis above is wrong.

Dave.

---

From: "Dave Burke" <[email-masked]>
Date: Tue, 5 Jul 2005 09:42:37 +0100

START-OF-SPEECH in DTMF-only modeGood catch. 

There has to be a way to select the input mode to dtmf, speech, or both. For example, an application in a noisy environment might fall back to DTMF (but still use its speechrecog resource). If (B) were true, then the fall back would not work due to bargin from noise!

For me, choosing a dtmfrecog implies you only want a DTMF input mode. Choosing a speechrecog is ambigious - there are now 3 choices of input mode. 

Using the mode attribute of the activated grammars to decide the input mode will work but this is NOT what VoiceXML does. For example, I am not sure how MRCP would then let me implement "Grammar activation is not affected by the inputmodes property. For instance, if the inputmodes property restricts input to just voice, DTMF grammars will still be activated, but cannot be matched."

Sounds like a case of YAMHR (yet another MRCP header required).

Dave
  ----- Original Message ----- 
  From: Reifenrath, Klaus 
  To: [email-masked]' 
  Sent: Tuesday, July 05, 2005 8:46 AM
  Subject: [Speechsc] START-OF-SPEECH in DTMF-only mode

  The current spec is not clear when START-OF-SPEECH need to be send in the following scenarios: 
  A) The client requested a DTMF Recognizer. Is the START-OF-SPEECH event send to the client also if speech was detected? 

  B) The client requested a Speech Recognizer, but only activated DTMF grammars. Is the START-OF-SPEECH event send to the client also if speech was detected?

  I think in both cases START-OF-SPEECH should only be send after detecting a DTMF digit (see Figure 12 of VoiceXML 2.0: http://www.w3.org/TR/voicexml20/#dmlATiming).

  Klaus 

------------------------------------------------------------------------------