Subject: RE: [Speechsc] RECOGNIZE completion-cause 003 and 008

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Fri, 15 Jul 2005 16:30:04 -0700

No-Match - means there was no match at all
Recognition-timeout - means there was a partial match but the user
stopped speaking in the middle and a mid speech timeout happenned. 
Too-much-speech-timeout means the user continued to speak for too long
but everything that was spoken until the timeout does match a grammar.

Sarvi

     -----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of Claudia Daboul
     Sent: Friday, July 15, 2005 1:31 PM
     To: David R Oran
     Cc: [email-masked]
     Subject: Re: [Speechsc] RECOGNIZE completion-cause 003 and 008
     
      > I'll take a whack. 003 says that the recognizer didn't 
     see anything  > that matched an active grammar before the 
     timer ran out. 008 says the  > recognizer got an utterance 
     that matched the grammar but the user  kept  > babbling on 
     and didn't stop so the match is probably bogus.
     
     Do you mean that for example when the grammar understands 
     "yes" or "no" 
     and the caller says "yes, but blah blah blah..." I would 
     get 008, but if he just says "blah blah blah..." I would get 003?
     
     I think in both cases it would make more sense to return 
     001 for no-match. More generally if the recognizer has 
     determined that the utterance could not have matched the 
     grammar, even if the recognition-timeout would have been 
     higher, it should return the no-match code.
     Only if this can't be determined, either because the 
     recognizer doesn't process the cut off utterance, or 
     because it determined that the utterance did indeed match 
     the grammar until it was cut off, the 003 (or
     008) should be returned.

     David R Oran wrote:
     > 
     > On Jul 15, 2005, at 7:43 AM, Claudia Daboul wrote:
     > 
     >> The spec defines the following completion-causes for 
     the RECOGNIZE 
     >> request
     >> 003          recognition-timeout
     >>                                    RECOGNIZE completed 
     without a match
     >>                                    due to a 
     recognition-timeout and
     >>
     >> 008           too-much-speech-timeout
     >>                                    RECOGNIZE request 
     terminated  because
     >>                                    speech was too long.
     >>
     >> The recognition timeout parameter is explained as follows:
     >>
     >> Recognition Timeout
     >>
     >>    When recognition is started and there is no match 
     for a certain
     >>    period of time, the recognizer can send a 
     RECOGNITION-COMPLETE  event
     >>    to the client and terminate the recognition 
     operation. It is the
     >>    timer that is started when START-OF-SPEECH event is 
     generated by  the
     >>    resource and specifies the maximum duration of the 
     utterance. When
     >>    this timer expires the recognition request would 
     complete with a
     >>    status code of "008 too-much-speech-timeout". The 
     recognition-
     >>    timeout header field sets this timeout value. The value is in
     >>    milliseconds. The value for this field ranges from 0 
     to MAXTIMEOUT,
     >>    where MAXTIMEOUT is platform specific. The default 
     value is 10
     >>    seconds. This header field MAY occur in RECOGNIZE, 
     SET-PARAMS or
     >>    GET-PARAMS.
     >>
     >>
     >> I am wondering if there is any difference between 
     completion-causes
     >> 003 and 008. Can anybody clarify this?
     >>
     > I'll take a whack. 003 says that the recognizer didn't 
     see anything 
     > that matched an active grammar before the timer ran out. 
     008 says the 
     > recognizer got an utterance that matched the grammar but 
     the user  
     > kept babbling on and didn't stop so the match is probably bogus.
     > 
     >> Claudia
     >>
     >> _______________________________________________
     >> Speechsc mailing list
     >> [email-masked]
     >> https://www1.ietf.org/mailman/listinfo/speechsc
     >>
     
     _______________________________________________
     Speechsc mailing list
     [email-masked]
     https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Claudia Daboul <[email-masked]>
Date: Tue, 19 Jul 2005 12:47:22 +0200

> stopped speaking in the middle and a mid speech timeout happenned.

But in this case it would be the speech-incomplete-timeout that would 
apply and according to the definition of that header-field a nomatch 
event should be returned when it expires and there is only a partial 
(incomplete) match of the grammar.

 > but everything that was spoken until the timeout does match a grammar.
I think this would be what Klaus calls the "success-maxtime" event, 
(which is not yet part of the spec) and which would come together with a 
valid recognition result, or did I get that wrong Klaus?

-- 
Dr. Claudia Daboul
IBP UK (Limited)
Luetkensallee 19
22041 Hamburg
Tel.: +49 (40) 3172541
Fax.: +49 (40) 3172547
E-mail: [email-masked]