Subject: RE: [Speechsc] propose adding "media-type" header fieldinRECOGNIZEorSET-PARAMS/GET-PARAMS methods

From: Baggia Paolo <[email-masked]>
Date: Thu, 28 Jul 2005 11:27:03 +0200

Jenny,
 
As you well explain, these two new fields are essential for implementing VXML 2.1 on top of MRCPv2.
We think to add them is very important for MRCPv2, but there are two considerations we would 
like to add. 
 
These two fields should at least be added to the "recorder-header", because also the recorder 
needs to specify to the VoiceXML interpreter the size and duration of the recorded speech.
 
Another option would be to add them to all the resources, because they may benefit of these fields
related to dump of audio ("save-waveform", "waveform-uri", "waveform-duration",  "waveform-size"):
- recognizer need them for VXML 2.1 support (need media-type, "waveform-duration" & "waveform-size"):
- recorder for both VXML 2.0 and 2.1 support (need"waveform-duration", & "waveform-size"):
- verifier possibly especially if the verification is done independet from recognition (if we think this
  is useful)
- sinthesizer would benefit for dumping the audio in a file, many platform support this feature too
  (need media-type and all the recording field headers)
 
What do you think?
 
Paolo.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Jenny Yao (jyao)
Sent: Thursday, July 28, 2005 12:54 AM
To: [email-masked]
Subject: RE: [Speechsc] propose adding "media-type" header fieldinRECOGNIZEorSET-PARAMS/GET-PARAMS methods

There appears to be no opposition regarding the media-type header field request that we sent earlier. So, can we request this feature be included in the next v2 draft? 
 
In addition, VXML 2.1 needs to have the information about "duration" and "size" of the recorded audio in the field "waveform-uri" in recog-only header. We would like to propose the following fields be added to the recog-only header:
 
        waveform-duration - the duration of the audio file in milliseconds
        waveform-size - the size of the audio file in bytes
 
Thanks.
 
Jenny

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Saravanan Shanmugham (sarvi)
Sent: Wednesday, May 04, 2005 9:27 AM
To: Thomas Gal; Jenny Yao (jyao); [email-masked]
Subject: RE: [Speechsc] propose adding "media-type" header field inRECOGNIZEorSET-PARAMS/GET-PARAMS methods

I don't see why not, considering all this behaviour would apply only if the "Save-Waveform" header is set to true and failure to caoture or save the waveform does not necessarily stop the RECOGNIZE operation itself. 
 
Anyone opposed to doing this. 
 
Thanks,
Sarvi

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Gal
Sent: Friday, April 29, 2005 9:47 AM
To: 'Jenny Yao (jyao)'; [email-masked]
Subject: RE: [Speechsc] propose adding "media-type" header field in RECOGNIZEorSET-PARAMS/GET-PARAMS methods

Though this information could probably be inferred from the filename extension, If we are going to follow/emulate the RECORD methodology than it should also be available as a MIME body to the RECOGNITION COMPLETE/STOP events as well. Otherwise I agree completely.

-Tom

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Jenny Yao (jyao)
Sent: Friday, April 29, 2005 8:58 AM
To: [email-masked]
Subject: [Speechsc] propose adding "media-type" header field in RECOGNIZE orSET-PARAMS/GET-PARAMS methods

VoiceXML 2.1 specifies "recording user utterances while attempting recognition". This can be done through recog-only-header "save-waveform" and "waveform-uri" in MRCP V1 and V2. VoiceXML 2.1 also uses recordutterancetype property to specify the media format of the result recording. However, there is no way in MRCP to pass the required media format to the server. We propose using the "Media-Type" header field, currently defined for the recording resource, in the RECOGNIZE method or the SET-PARAMS/GET-PARAMS methods to specify a media type. The Save-Waveform carries a URI pointing to the audio captured during recognition. The captured audio SHOULD be saved with this media-type.

Thanks.

Jenny

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to 
[email-masked]. Thank you
====================================================================
_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Fri, 29 Jul 2005 08:20:55 -0700

-----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of [email-masked]
     Sent: Thursday, July 28, 2005 9:23 PM
     To: Jenny Yao ((jyao))
     Cc: [email-masked]
     Subject: Re: [Speechsc] propose adding "media-type" header 
     fieldinRECOGNIZEorSET-PARAMS/GET-PARAMS methods

     On Jul 27, 2005, at 6:53 PM, Jenny Yao ((jyao)) wrote:
     
     > There appears to be no opposition regarding the 
     media-type header 
     > field request that we sent earlier. So, can we request 
     this feature be 
     > included in the next v2 draft?
     >
     Sarvi can confirm, but according to our internal 
     author/chair issue tracker, this will appear in -07 (due 
     out shortly).

Yes this covered.     
     >
     > In addition, VXML 2.1 needs to have the information about  
     > "duration" and "size" of the recorded audio in the field 
     "waveform- 
     > uri" in recog-only header. We would like to propose the 
     following  
     > fields be added to the recog-only header:
     >
     The size is obtainable for content in the body through the 
     content- 
     length MIME header. Duration should be easily computable from the  
     encoding type (e.g. coder) and the size.
     
     If you mean input policy from the client to say the 
     maximum size and  
     duration of the returned data, that's another matter, and 
     probably  
     need discussion, since there can be complex interactions 
     with other  
     policy variables, like timeouts and success criteria.
I don't believe this is policy piece sent from the client, but rather
information from the server. After a recognize the recorded
audio/waveform is available as a URI. The request, I believe was for the
server to send these 2 pieces of information in addition to the URI. We
could address this by allowing these fields to be sent in the same
header like the following.

Waveform-URI:<http://mediaserver.acme.com/recordin1234.wav>;size=743672;
duration=2300

Thx,
Sarvi     
     Dave.
     
     >
     > Thanks.
     >
     > Jenny
     >
     > From: [email-masked] 
     [mailto:[email-masked]]  
     > On Behalf Of Saravanan Shanmugham (sarvi)
     > Subject: RE: [Speechsc] propose adding "media-type" 
     header field  
     > inRECOGNIZEorSET-PARAMS/GET-PARAMS methods
     >
     > I don't see why not, considering all this behaviour would apply  
     > only if the "Save-Waveform" header is set to true and 
     failure to  
     > caoture or save the waveform does not necessarily stop the  
     > RECOGNIZE operation itself.
     >
     > From: [email-masked] 
     [mailto:[email-masked]]  
     > On Behalf Of Thomas Gal
     > Subject: RE: [Speechsc] propose adding "media-type" 
     header field in  
     > RECOGNIZEorSET-PARAMS/GET-PARAMS methods
     >
     > Though this information could probably be inferred from the  
     > filename extension, If we are going to follow/emulate 
     the RECORD  
     > methodology than it should also be available as a MIME 
     body to the  
     > RECOGNITION COMPLETE/STOP events as well. Otherwise I agree  
     > completely.
     >
     >
     >
     > -Tom
     >
     >
     >
     > From: [email-masked] 
     [mailto:[email-masked]]  
     > On Behalf Of Jenny Yao (jyao)
     > Subject: [Speechsc] propose adding "media-type" header field in  
     > RECOGNIZE orSET-PARAMS/GET-PARAMS methods
     >
     >
     >
     >
     >
     >
     >
     > VoiceXML 2.1 specifies "recording user utterances while 
     attempting  
     > recognition". This can be done through recog-only-header "save- 
     > waveform" and "waveform-uri" in MRCP V1 and V2. VoiceXML 
     2.1 also  
     > uses recordutterancetype property to specify the media 
     format of  
     > the result recording. However, there is no way in MRCP 
     to pass the  
     > required media format to the server. We propose using 
     the "Media- 
     > Type" header field, currently defined for the recording 
     resource,  
     > in the RECOGNIZE method or the SET-PARAMS/GET-PARAMS methods to  
     > specify a media type. The Save-Waveform carries a URI 
     pointing to  
     > the audio captured during recognition. The captured 
     audio SHOULD be  
     > saved with this media-type.
     >
     >
     >
     > Thanks.
     >
     >
     >
     > Jenny
     >