Subject: RE: [Speechsc] MRCPv2 requirements for VoiceXML "inputmodes" property

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Mon, 22 Aug 2005 10:25:17 -0700

Status in Issue Tracker.
---------------------------
 Addressed this by changing START-OF-SPEECH to START-OF-INPUT.
Added an Input-Type header to all input processing resources, with
values
"speech" and "dtmf"
Add text to explain that what constitutes a barge-in event based on the
resource
type and the grammars that are active.  START-OF-INPUT event is
generated with
this barge-in condition is met.

Sarvi

     -----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of Brett Gavagni
     Sent: Monday, August 22, 2005 7:53 AM
     To: [email-masked]
     Subject: [Speechsc] MRCPv2 requirements for VoiceXML 
     "inputmodes" property
     
     Hi,
     
     What's the status of this request that was made a few 
     months ago, as it doesn't appear to have been addressed in 
     the -07 draft?
     
     Here's the thread on the topic:
     http://www1.ietf.org/mail-archive/web/speechsc/current/msg0
     1234.html
     
     Thanks,
     
     Brett Gavagni
     WebSphere Voice Server Development
     http://www-306.ibm.com/software/pervasive/voice_server/
     [email-masked]

     _______________________________________________
     Speechsc mailing list
     [email-masked]
     https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Brett Gavagni <[email-masked]>
Date: Mon, 22 Aug 2005 17:53:40 -0400

It seems a bit inefficient for a VoiceXML platform utilizing MRCP to rely 
on the START-OF-INPUT to determine if the identified "Input-Type" is 
enabled in the current VoiceXML application execution context. 

I would suggest that a MRCP client be able to specify the input mode 
during the RECOGNIZE request.

Additionally, including the mode that MRCP server's grammar processor 
interpreted for each DEFINE-GRAMMAR request would assist the MRCP client 
with enabling the ideal set of grammars.

Thanks,

Brett Gavagni 

"Shanmugham, Saravanan" <[email-masked]> 
08/22/2005 01:25 PM

To
Brett Gavagni/West Palm Beach/IBM@IBMUS, <[email-masked]>
cc

Subject
RE: [Speechsc] MRCPv2 requirements for VoiceXML "inputmodes" property

Status in Issue Tracker.

Sarvi

     -----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of Brett Gavagni
     Sent: Monday, August 22, 2005 7:53 AM
     To: [email-masked]
     Subject: [Speechsc] MRCPv2 requirements for VoiceXML 
     "inputmodes" property
 
     Hi,

 
     Thanks,
 
     Brett Gavagni

---

From: "Dave Burke" <[email-masked]>
Date: Tue, 23 Aug 2005 06:45:22 +0100

Sarvi,

The changes below look mostly fine to me with the bug noted (point C in
http://www1.ietf.org/mail-archive/web/speechsc/current/msg01485.html).

One concern I do have with it is that -07 says about the speechrecog 
resource:

"This resource generates barge-in events for
   speech.  By analyzing the grammars that are activated by the
   RECOGNIZE method, it also figures out if a barge-in should occur for
   DTMF or not."

whereas I thought it ought to say (based on our discussions):

   "This resource generates barge-in events for
   speech and/or DTMF.  By analyzing the grammar types that are activated
   by the RECOGNIZE method, it determines  if a barge-in should occur for
   speech and/or DTMF"

The concern I have with the current wording is that during a call, it is
common to go from speech+dtmf reco to dtmf-only reco and then back to
speech+dtmf. With current wording, one would need to perform a REINVITE
to change from a speechrecog to a dtmfrecog. To revert to speech+dtmf,
another REINVITEs is needed. So 2 REINVITEs (=6 SIP messages) would be
needed to handle the common use-case for DTMF-only fallback.

Dave

----- Original Message ----- 
From: "Shanmugham, Saravanan" <[email-masked]>
To: "Brett Gavagni" <[email-masked]>; <[email-masked]>
Sent: Monday, August 22, 2005 6:25 PM
Subject: RE: [Speechsc] MRCPv2 requirements for VoiceXML "inputmodes" 
property

Status in Issue Tracker.

Sarvi

     -----Original Message-----
     From: [email-masked]
     [mailto:[email-masked]] On Behalf Of Brett Gavagni
     Sent: Monday, August 22, 2005 7:53 AM
     To: [email-masked]
     Subject: [Speechsc] MRCPv2 requirements for VoiceXML
     "inputmodes" property

     Hi,

     Thanks,

     Brett Gavagni