Subject: RE: [Speechsc] Personal-Grammar-URI clarification

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Wed, 17 Aug 2005 08:52:44 -0700

Don't understand. Could you please clarify and Propose some text.

Sarvi 

     -----Original Message-----
     From: Brett Gavagni [mailto:[email-masked]] 
     Sent: Wednesday, August 17, 2005 8:39 AM
     To: Shanmugham, Saravanan
     Cc: [email-masked]
     Subject: RE: [Speechsc] Personal-Grammar-URI clarification
     
     Thanks for the clarification!
     
     Since SRGS defines syntactical support for both ABNF and 
     XML formats, it may be useful to add some wording or 
     modify the "Personal-Grammar-URI" 
     examples to specify the "Content-Type".
     
     This may assist in facilitating client/server interoperability. 
     
     Thanks,
     
     Brett Gavagni
     WebSphere Voice Server Development
     http://www-306.ibm.com/software/pervasive/voice_server/
     [email-masked]

     
     "Shanmugham, Saravanan" <[email-masked]>
     08/10/2005 04:03 PM
     
     To
     Brett Gavagni/West Palm Beach/IBM@IBMUS, <[email-masked]> cc
     
     Subject
     RE: [Speechsc] Personal-Grammar-URI clarification

     
     I am not sure what you mean by its relationship to Content-Id.
     
     To me Personal-Grammar-URI is just like anyother grammar 
     that has a <one-of> list of items. 
     Except that it is constructed by the user adding 
     individual phrases to that one-of list during enrollment.  
     Once enrolled, the usage of that grammar should be no 
     different from any other grammar.
     
     This could be a HTTP URI in which case the MRCP server 
     uses HTTP GET/PUT to modify that grammar during 
     enrollment. So to answer your question, the MRCP server is 
     not expected to store this personal grammar, but would be 
     create/modified at the URI specified by the personal grammar URI.
     
     Sarvi
     
          -----Original Message-----
          From: [email-masked] 
          [mailto:[email-masked]] On Behalf Of Brett Gavagni
          Sent: Wednesday, August 10, 2005 11:43 AM
          To: [email-masked]
          Subject: Re: [Speechsc] Personal-Grammar-URI clarification
      
          Bump
      
          Thanks,
      
          Brett Gavagni
          WebSphere Voice Server Development
          http://www-306.ibm.com/software/pervasive/voice_server/
          [email-masked]

      
          Brett Gavagni/West Palm Beach/IBM@IBMUS Sent by: 
          [email-masked]
          07/26/2005 11:28 AM
      
          To
          [email-masked]
          cc
      
          Subject
          [Speechsc] Personal-Grammar-URI clarification

      
          Hi,
      
          The wording throughout the current draft specification is 
          a bit confusing w.r.t "Personal-Grammar-URI".
      
          Is the expectation that the "Personal-Grammar-URI" value 
          is merely a client specified handle to an external grammar 
          in lieu of using a "Content-Id" value?
      
          Is the expectation that the server persistently store 
          these references and 
      
          the backing grammars, and when and how would the release 
          of these references occur?
      
          Thanks,
      
          Brett Gavagni
          WebSphere Voice Server Development
          http://www-306.ibm.com/software/pervasive/voice_server/
          [email-masked]

          _______________________________________________
          Speechsc mailing list
          [email-masked]
          https://www1.ietf.org/mailman/listinfo/speechsc

          _______________________________________________
          Speechsc mailing list
          [email-masked]
          https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Brett Gavagni <[email-masked]>
Date: Mon, 22 Aug 2005 11:13:38 -0400

Thanks!

I see the point, the MRCP server's  HTTP PUT request should specify the 
"Content-Type" of "application/srgs" or "application/srgs+xml" as 
described in SRGS to indicate the grammar format.

At the time, I was suggesting to add some wording similar to the following 
to section 9.4.35  Personal-Grammar-URI:
The generated SRGS grammar syntax MAY be implementation specific.

Thanks,

Brett Gavagni 
(561) 862-2097 T/L (975) 
[email-masked]

08/17/2005 11:52 AM

To
Brett Gavagni/West Palm Beach/IBM@IBMUS
cc
<[email-masked]>
Subject
RE: [Speechsc] Personal-Grammar-URI clarification

Sarvi 

     -----Original Message-----
     From: Brett Gavagni [mailto:[email-masked]] 
     Sent: Wednesday, August 17, 2005 8:39 AM
     To: Shanmugham, Saravanan
     Cc: [email-masked]
     Subject: RE: [Speechsc] Personal-Grammar-URI clarification

 
 
     Thanks,
 
     Brett Gavagni

 
 
     To
 
     Subject

 

 
     Sarvi
 
          -----Original Message-----
 
          Bump
 
          Thanks,
 
          Brett Gavagni

 
 
          To
          [email-masked]
          cc
 
          Subject

 
          Hi,

 

          Thanks,
 
          Brett Gavagni