Subject: RE: [Speechsc] MRCPv2 requirements for VoiceXML "inputmodes" property

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Tue, 23 Aug 2005 08:18:27 -0700

The speech syntheisizer barges-in when the it receives the
BARGEIN-OCCURRED method from the client, or if the recognizer on the
same session generated a START-OF-INPUTE event, in the optimized
barge-in case.

The question though, is when does the START-OF-INPUT event get
generated. And based on the current wording , the recognizer should be
smart enough to generate only one START-OF-INPUT event based on the
grammars that are active for that RECOGNIZE method.

Sarvi 

     -----Original Message-----
     From: Dave Burke [mailto:[email-masked]] 
     Sent: Tuesday, August 23, 2005 12:02 AM
     To: Shanmugham, Saravanan; Brett Gavagni; [email-masked]
     Subject: Re: [Speechsc] MRCPv2 requirements for VoiceXML 
     "inputmodes" property
     
     In the -07 version, the wording implies that the 
     speechrecog will always barge-in on speech input 
     regardless of whether a speech grammar was activated in 
     the RECOGNIZE.
     
     So imagine a client has connected to a speechrecog 
     resource. At a certain point, it wants to perform a 
     DTMF-only recognition (because it's noisy). If it performs 
     a RECOGNIZE and activates just a DTMF grammar,  the -07 
     implies that the speechrecog will still barge-in on speech 
     input (in this case the noise). The only way to perform a 
     DTMF-only recognition with the -07 version is to change 
     the resource type from a speechrecog to a dtmfrecog by 
     performing a re-INVITE (altering the SDP by changing the 
     a=resource:speechrecog to a=resource:dtmfrecog).
     
     If we change the wording as suggested below, then it will 
     work with needing a re-INVITE.
     
     Dave
     
     ----- Original Message -----
     From: "Shanmugham, Saravanan" <[email-masked]>
     To: "Dave Burke" <[email-masked]>; "Brett Gavagni" 
     <[email-masked]>; <[email-masked]>
     Sent: Tuesday, August 23, 2005 7:17 AM
     Subject: RE: [Speechsc] MRCPv2 requirements for VoiceXML 
     "inputmodes" 
     property

     The difference, I see between the 2 is or Vs and/or. I can 
     certainly
     make that change.
     But I don't understand your SIP INVITE deal.
     
     This choice of dtmf and/or speech for barge-input is based on a per
     RECOGNIZE method.
     That is where we activate recognition and specify a list 
     of grammars to
     activate. I was thinking that's where this choice would be 
     made based on
     the list of grammars being activated.
     
     I don't see any SIP re-INVITES happenning in this case. Am 
     I missing
     something.
     
     Sarvi

          -----Original Message-----
          From: [email-masked]
          [mailto:[email-masked]] On Behalf Of Dave Burke
          Sent: Monday, August 22, 2005 10:45 PM
          To: Shanmugham, Saravanan; Brett Gavagni; [email-masked]
          Subject: Re: [Speechsc] MRCPv2 requirements for VoiceXML
          "inputmodes" property
     
          Sarvi,
     
          The changes below look mostly fine to me with the bug
          noted (point C in
          http://www1.ietf.org/mail-archive/web/speechsc/current/msg0
          1485.html).
     
          One concern I do have with it is that -07 says about the
          speechrecog
          resource:
     
          "This resource generates barge-in events for
             speech.  By analyzing the grammars that are 
     activated by the
             RECOGNIZE method, it also figures out if a barge-in
          should occur for
             DTMF or not."
     
          whereas I thought it ought to say (based on our discussions):
     
             "This resource generates barge-in events for
             speech and/or DTMF.  By analyzing the grammar types
          that are activated
             by the RECOGNIZE method, it determines  if a barge-in
          should occur for
             speech and/or DTMF"
     
          The concern I have with the current wording is that during
          a call, it is common to go from speech+dtmf reco to
          dtmf-only reco and then back to
          speech+dtmf. With current wording, one would need to
          perform a REINVITE
          to change from a speechrecog to a dtmfrecog. To revert to
          speech+dtmf, another REINVITEs is needed. So 2 REINVITEs
          (=6 SIP messages) would be needed to handle the common
          use-case for DTMF-only fallback.
     
          Dave
     
          ----- Original Message -----
          From: "Shanmugham, Saravanan" <[email-masked]>
          To: "Brett Gavagni" <[email-masked]>; <[email-masked]>
          Sent: Monday, August 22, 2005 6:25 PM
          Subject: RE: [Speechsc] MRCPv2 requirements for VoiceXML
          "inputmodes"
          property

          Status in Issue Tracker.
          ---------------------------
           Addressed this by changing START-OF-SPEECH to START-OF-INPUT.
          Added an Input-Type header to all input processing 
     resources, with
          values
          "speech" and "dtmf"
          Add text to explain that what constitutes a barge-in event
          based on the
          resource
          type and the grammars that are active.  
     START-OF-INPUT event is
          generated with
          this barge-in condition is met.

          Sarvi

               -----Original Message-----
               From: [email-masked]
               [mailto:[email-masked]] On Behalf Of 
     Brett Gavagni
               Sent: Monday, August 22, 2005 7:53 AM
               To: [email-masked]
               Subject: [Speechsc] MRCPv2 requirements for VoiceXML
               "inputmodes" property
     
               Hi,
     
               What's the status of this request that was made a few
               months ago, as it doesn't appear to have been 
     addressed in
               the -07 draft?
     
               Here's the thread on the topic:
               
     http://www1.ietf.org/mail-archive/web/speechsc/current/msg0
               1234.html
     
               Thanks,
     
               Brett Gavagni
               WebSphere Voice Server Development
               http://www-306.ibm.com/software/pervasive/voice_server/
               [email-masked]

               _______________________________________________
               Speechsc mailing list
               [email-masked]
               https://www1.ietf.org/mailman/listinfo/speechsc

          _______________________________________________
          Speechsc mailing list
          [email-masked]
          https://www1.ietf.org/mailman/listinfo/speechsc

          _______________________________________________
          Speechsc mailing list
          [email-masked]
          https://www1.ietf.org/mailman/listinfo/speechsc

     _______________________________________________
     Speechsc mailing list
     [email-masked]
     https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Dave Burke" <[email-masked]>
Date: Tue, 23 Aug 2005 17:19:45 +0100

Right - I was talking about the optimised case. Looks like we both agree on 
the mechanism. My problem is only with the wording "This resource generates 
barge-in events for speech" and "it also figures out if a barge-in should 
occur for DTMF".

This reads to me that the speechrecog *always* generates a START-OF-INPUT 
for any speech/noise heard regardless of what grammar types were activated 
in the RECOGNIZE. The small text change suggested below removes the 
ambiguity. Hope I'm being clear.

Thanks,

Dave

----- Original Message ----- 
From: "Shanmugham, Saravanan" <[email-masked]>
To: "Dave Burke" <[email-masked]>; "Brett Gavagni" 
<[email-masked]>; <[email-masked]>
Sent: Tuesday, August 23, 2005 4:18 PM
Subject: RE: [Speechsc] MRCPv2 requirements for VoiceXML "inputmodes" 
property

Sarvi

     -----Original Message-----
     From: Dave Burke [mailto:[email-masked]]
     Sent: Tuesday, August 23, 2005 12:02 AM
     To: Shanmugham, Saravanan; Brett Gavagni; [email-masked]
     Subject: Re: [Speechsc] MRCPv2 requirements for VoiceXML
     "inputmodes" property

     Dave

     ----- Original Message -----
     From: "Shanmugham, Saravanan" <[email-masked]>
     To: "Dave Burke" <[email-masked]>; "Brett Gavagni"
     <[email-masked]>; <[email-masked]>
     Sent: Tuesday, August 23, 2005 7:17 AM
     Subject: RE: [Speechsc] MRCPv2 requirements for VoiceXML
     "inputmodes"
     property

     Sarvi

          -----Original Message-----

          Sarvi,

          Dave

          ----- Original Message -----

          Status in Issue Tracker.

          Sarvi

               -----Original Message-----

               Hi,

               Thanks,

               Brett Gavagni