Subject: RE: [Speechsc] Personal-Grammar-URI clarification

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Wed, 10 Aug 2005 13:03:41 -0700

I am not sure what you mean by its relationship to Content-Id.

To me Personal-Grammar-URI is just like anyother grammar that has a
<one-of> list of items. 
Except that it is constructed by the user adding individual phrases to
that one-of list during enrollment.  Once enrolled, the usage of that
grammar should be no different from any other grammar.

This could be a HTTP URI in which case the MRCP server uses HTTP GET/PUT
to modify that grammar during enrollment. So to answer your question,
the MRCP server is not expected to store this personal grammar, but
would be create/modified at the URI specified by the personal grammar
URI.

Sarvi

     -----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of Brett Gavagni
     Sent: Wednesday, August 10, 2005 11:43 AM
     To: [email-masked]
     Subject: Re: [Speechsc] Personal-Grammar-URI clarification
     
     Bump
     
     Thanks,
     
     Brett Gavagni
     WebSphere Voice Server Development
     http://www-306.ibm.com/software/pervasive/voice_server/
     [email-masked]

     
     Brett Gavagni/West Palm Beach/IBM@IBMUS Sent by: 
     [email-masked]
     07/26/2005 11:28 AM
     
     To
     [email-masked]
     cc
     
     Subject
     [Speechsc] Personal-Grammar-URI clarification

     
     Hi,
     
     The wording throughout the current draft specification is 
     a bit confusing w.r.t "Personal-Grammar-URI".
     
     Is the expectation that the "Personal-Grammar-URI" value 
     is merely a client specified handle to an external grammar 
     in lieu of using a "Content-Id" value?
     
     Is the expectation that the server persistently store 
     these references and 
     
     the backing grammars, and when and how would the release 
     of these references occur?
     
     Thanks,
     
     Brett Gavagni
     WebSphere Voice Server Development
     http://www-306.ibm.com/software/pervasive/voice_server/
     [email-masked]

     _______________________________________________
     Speechsc mailing list
     [email-masked]
     https://www1.ietf.org/mailman/listinfo/speechsc

     _______________________________________________
     Speechsc mailing list
     [email-masked]
     https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Brett Gavagni <[email-masked]>
Date: Wed, 17 Aug 2005 11:38:43 -0400

Thanks for the clarification!

Since SRGS defines syntactical support for both ABNF and XML formats, it 
may be useful to add some wording or modify the "Personal-Grammar-URI" 
examples to specify the "Content-Type".

This may assist in facilitating client/server interoperability. 

Thanks,

Brett Gavagni 

"Shanmugham, Saravanan" <[email-masked]> 
08/10/2005 04:03 PM

To
Brett Gavagni/West Palm Beach/IBM@IBMUS, <[email-masked]>
cc

Subject
RE: [Speechsc] Personal-Grammar-URI clarification

Sarvi

     -----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of Brett Gavagni
     Sent: Wednesday, August 10, 2005 11:43 AM
     To: [email-masked]
     Subject: Re: [Speechsc] Personal-Grammar-URI clarification
 
     Bump
 
     Thanks,
 
     Brett Gavagni

 
 
     To
     [email-masked]
     cc
 
     Subject

 
     Hi,

 

     Thanks,
 
     Brett Gavagni