Subject: RE: Question on negotiating EMMA (was RE: [Speechsc] EMMA:ExtensibleMultiModalAnnotationmarkuplanguagesupport?)

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Thu, 20 Oct 2005 09:33:24 -0700

Sounds good.
I was going through SIP endpoint capabilities RFC 3840. 
I think we could try to plug into that and add some feature-token values
of our own to meet MRCPv2 needs like feature-types, mime-types
supported, etc.

What do you think.   

Sarvi

     -----Original Message-----
     From: David R Oran [mailto:[email-masked]] 
     Sent: Thursday, October 20, 2005 5:57 AM
     To: Shanmugham, Saravanan
     Cc: Dave Burke; Andrew Wahbe; IETF SPEECHSC (E-mail); Eric Burger
     Subject: Re: Question on negotiating EMMA (was RE: 
     [Speechsc] 
     EMMA:ExtensibleMultiModalAnnotationmarkuplanguagesupport?)

     On Oct 19, 2005, at 3:53 PM, Shanmugham, Saravanan wrote:
     
     [snip]
     >> capabilities through SDP.
     >>    2. It works for routing as such a proxy can take look
     >>
     >      at the SDP to
     >
     >> make this decision.
     >>
     >      Really? What if it's SMIME encrypted. i would council
     >      against putting anythng needed for deciding which server
     >      to contact or how to route the request into the SDP.
     >
     >
     >>    3. A routing proxy would any way have to look at the
     >>
     >      SDP for other
     >
     >> things such as resource type.
     >>
     >      If so, we've probably made a design error and should have
     >      it in SIP caller prefs instead.
     > Today the SDP contains the information as to what resource-type 
     > control channels are to be established. This is need to 
     establish 
     > control channels to specific reources. That seems to be 
     the right 
     > thing to do.
     Of course, for the purposes of end-to-end negotiation of 
     what media streams/channels get enables and how they map 
     to MRCP sessions, that is exactly the job of SDP.
     
     > The question is should we also rely on this piece of 
     information in 
     > the SDP for routing of the INVITE.
     >
     I'm saying no, because that confounds request routing with 
     session parameter negotiation. We have lots of example in 
     SIP, RTSP, and elsewhere of needed slightly different 
     constructs for the two purposes.
     
     Dave.
     
     > Sarvi
     [snip]

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: David R Oran <[email-masked]>
Date: Thu, 20 Oct 2005 13:50:37 -0400

> of our own to meet MRCPv2 needs like feature-types, mime-types
Works for me,
Dave.