Subject: [Speermint] FW: Another proposed LUF vs. LRF terminology

From: Hadriel Kaplan <[email-masked]>
Date: Sun, 23 Nov 2008 19:27:22 -0500

[oops, sent to Drinks but not Speermint]

> -----Original Message-----
>
> How about for LUF first paragraph of 4.3.3:
> "The Look-Up Function (LUF) provides a mechanism for determining for a
>    given request the target URI to which the request should be
>    routed.  An example of the LUF is an ENUM [4] look-up or a SIP INVITE
>    request to a SIP proxy providing redirect responses for peers."
>
> And for LRF, replace the first paragraph of 4.3.4 with:
> "The Location Routing Function (LRF) determines, for the target URI
>    of a given request, the route set to reach the target.
>    An example of the LRF may be applied to either example in
>    Section 4.3.3.  Once the ENUM response or SIP 302 redirect is
>    received with the target SIP URI, the LRF derives the
>    set of next-hops necessary to reach the URI."
>
> -hadriel

_______________________________________________
Speermint mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/speermint

---

From: David Schwartz <[email-masked]>
Date: Mon, 24 Nov 2008 10:42:48 +0200

inline...

>>   request to a SIP proxy providing redirect responses for peers."

DS: Still have the "routed" term indicating that the URI is more than  
just an AOR.
>>   set of next-hops necessary to reach the URI."

DS: I like the focused "route set" instead of SED. The only thing is  
that now we are missing a term for SED (non routing) generation (may  
or may not actually be performed for a call). Should we introduce a  
new logical term LPF (P= profile)?

---

From: "Mike Hammer (hmmr)" <[email-masked]>
Date: Mon, 24 Nov 2008 14:37:05 -0500

That is clear to me.

Mike

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Hadriel Kaplan
> Sent: Sunday, November 23, 2008 7:27 PM
> To: [email-masked]
> Subject: [Speermint] FW: Another proposed LUF vs. LRF terminology
> 
>

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 26 Nov 2008 14:41:29 +0000

Hadriel,

I like this proposal. It seems a good match for the SIP protocol, in the
sense that the LUF can produce a target that goes into the Request-URI
(e.g., retargeting from a tel: URI to a sip: URI) and the LRF will
produce routing information that, among other things, can populate the
Route header field. Also, by sticking to the word "target" rather than
"destination" it covers the case I mentioned where, to get to an
enterprise destination, we may need first to target at a service
provider that has access to that enterprise.

John 

> Sent: 24 November 2008 00:27
> To: [email-masked]