Subject: [Speermint] I-D Action:draft-ietf-speermint-srv-naptr-use-06.txt

From: [email-masked]
Date: Fri, 11 Sep 2009 10:45:02 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session PEERing for Multimedia INTerconnect Working Group of the IETF.

	Title           : Use of DNS SRV and NAPTR Records for SPEERMINT
	Author(s)       : T. Creighton, J. Livingood
	Filename        : draft-ietf-speermint-srv-naptr-use-06.txt
	Pages           : 14
	Date            : 2009-09-11

The objective of this document is to specify the Best Current
Practice (BCP) adopted by a SSP or other organization providing
multimedia communication services such as Voice over Internet
Protocol(VoIP) in order to locate another SSP to peer with in the
context of Session PEERing for Multimedia INTerconnect.  This
document attempts to fill the gaps in information from RFC 3261, RFC
3263, and other documents, in order to more assist SSPs in more
easily performing SIP peering.

[EDITORIAL NOTE: XREF ERROR GENERATED IN ABSTRACT, XREFS REMOVED]

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-speermint-srv-naptr-use-06.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Daryl Malas <[email-masked]>
Date: Mon, 14 Sep 2009 10:16:29 -0600

Jason and Tom,

The more I think about the draft Tom and I submitted to ENUM
(draft-malas-enum-trunk-sip-00), the more I think it could easily fit into
this draft.  The concept is simple and just identifies how trunk groups
should be identified in an ENUM NAPTR response.  I think this will primarily
be used for peering.

Thoughts?

Regards,

Daryl

On 9/11/09 11:45 AM, "[email-masked]" <[email-masked]>
wrote:

> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/speermint

-----------------
Daryl Malas
CableLabs
(o) +1 303 661 3302
(f) +1 303 661 9199
mailto:[email-masked]

---

From: "Richard Shockey" <[email-masked]>
Date: Mon, 14 Sep 2009 14:00:28 -0400

Its entirely up to you how you want to proceed. I certainly have no problem
with this approach though how it fits in with the SPEERMINT charter is
probably a question and I'd poll Cullen to see what he thinks.  In general
he certainly understands the application and the need. I was working on the
assumption that you could submit it as a AD sponsored draft since ENUM is
being shut down.

I'll certainly support whatever you guys want to do. 

>  -----Original Message-----
>  From: [email-masked] [mailto:[email-masked]]
>  On Behalf Of Daryl Malas
>  Sent: Monday, September 14, 2009 12:16 PM
>  To: [email-masked]; Jason Livingood; Tom Creighton
>  Subject: [Speermint] Re: I-D Action:draft-ietf-speermint-srv-naptr-
>  use-06.txt
>  
>  Jason and Tom,
>  
>  > This draft is a work item of the Session PEERing for Multimedia
>  INTerconnect
>  > Working Group of the IETF.
>  >
>  >

---

From: Daryl Malas <[email-masked]>
Date: Tue, 15 Sep 2009 14:11:23 -0600

Richard,

You are correct.  This was the approach I was taking, but then I started to
think about how it relates to peering.  We have the draft currently, and I
thought it might fit best in it.  I can still submit an individual draft.
Are there other thoughts on this from anyone else?

Thanks,

Daryl

-----------------
Daryl Malas
CableLabs
(o) +1 303 661 3302
(f) +1 303 661 9199

---

From: Daryl Malas <[email-masked]>
Date: Tue, 15 Sep 2009 14:19:01 -0600

For the benefit of those who may not want to read the draft, it proposes a
method for including trunk group information in a NAPTR response.  I think
this could be included in this speermint draft.  The alternative approach is
an individual draft target more for ENUM in general.  Richard, correct me if
I am wrong here.

--Daryl

-----------------
Daryl Malas
CableLabs
(o) +1 303 661 3302
(f) +1 303 661 9199