Subject: [ssm] Who uses SSM?

From: "Marc Barisch" <[email-masked]>
Date: Wed, 17 Nov 2004 14:30:16 +0100 (MET)

Hi

I have read about the advantages of PIM-SSM over PIM-SM from a technical
point of view.
For a seminar paper at my university, I would like to provide some figures
concerning the deployment of the different PIM modes, especially regarding
TV broadcast over packet networks.

Does anybody know of providers using PIM-SSM or are using all PIM-SM?
Are there any commercial deployments regarding PIM-SSM and IPv6.

Thanks in advance

Marc

-- 
Geschenkt: 3 Monate GMX ProMail + 3 Top-Spielfilme auf DVD
++ Jetzt kostenlos testen http://www.gmx.net/de/go/mail ++

_______________________________________________
ssm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ssm

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 17 Nov 2004 09:28:06 -0500

As far as I know, the users of SSM are a set of measure zero.

However, from time to time there are tests.

Compare
http://netflow.internet2.edu/weekly/longit/ssm-octets.png
with 
http://netflow.internet2.edu/weekly/longit/multicast-octets.png

Pay attention to the scales on the Y axes.

I would love to hear of assertions that disprove the above.

Regards
Marshall Eubanks

---

From: Tim Chown <[email-masked]>
Date: Wed, 17 Nov 2004 14:47:15 +0000

> I would love to hear of assertions that disprove the above.

We're using IPv6 SSM, as are a number of academic sites in Europe, currently
with the Mad-Flute reliable multicast file transfer protocol, but also
for some streaming.

This is not commercial, but we have commercial interest in pilots.

Tim

---

From: Hoerdt Mickael <[email-masked]>
Date: Wed, 17 Nov 2004 15:58:40 +0100

>>As far as I know, the users of SSM are a set of measure zero.
That's quite logical : SSM is 5 years old (counting from the first 1999 
Express SIGCOMM paper) compared with ASM which is almost 20 years old 
(counting from the first SIGCOMM
host group model definition from Deering in 1985). But SSM could grow 
faster, as it rely on the same routing routing architecture than ASM ;)

For information, at the time of writing, linux is the only operating 
system supporting IPv4/IPv6 SSM
natively (first patch starting from 21 may 2003 are now included in the 
main kernel).

Hoerdt Mickaël

---

From: Beau Williamson <[email-masked]>
Date: Wed, 17 Nov 2004 09:21:08 -0600

>Are there any commercial deployments regarding PIM-SSM and IPv6.

Marc,

This is a classic case of "The spirit is willing but the flesh (hardware) 
is weak."

The advantages are certainly well known and there is a growing push to 
build networks that support SSM.  Unfortunately, the support for IGMPv3 is 
still not pervasive enough in end-stations and (in some cases) edge routers 
and switches to actually deploy SSM.  This is slowly changing and I expect 
(I hope) that we will soon see greater deployments of SSM for one-to-many 
multicast applications.

Beau Williamson

---

From: Tim Chown <[email-masked]>
Date: Wed, 17 Nov 2004 19:01:08 +0000

PS. See http://support.bbc.co.uk/multicast/streams.html

Signs of v4 SSM activity (pre-commercial, as much as the BBC is commercial)

Tim

-- 
Tim

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 17 Nov 2004 17:48:58 -0500

Yes, indeed. The routers are the easy part. To adopt to SSM an
application developer will need

- An OS that supports IGMPv3
- An API that supports IGMPv3
- Code to obtain Source IP address information in addition to group addresses

To implement it, typically a network architect will need

- minor changes to "core" routers
- IGMPv3 support from "edge" routers (may be expensive if these are old)
- IGMP v3 support from IGMP snooping switches (an unexpected  gotcha
for the multicast
community, I think it is fair to say)

It will come, but it's a slow train indeed.

Regards
Marshall Eubanks