Subject: [Stackevo] A SPUD design team; nominating two new members of the Stack Evolution Program

From: Brian Trammell <[email-masked]>
Date: Wed, 20 May 2015 11:21:59 +0200

Greetings, all,

As discussed briefly during the retreat in London, in moving forward after the SPUD BoF, we've had a couple of calls of a subset of the program (myself, Mirja, Joe, Ted, Jana, and David Black) along with two external participants (Eric Rescorla and Ken Calvert) who have an interest in the SPUD work at the architecture level. We've been referring to this internally as a "SPUD design team", the intention of which is to produce a set of requirements which could be the input to an effort to standardize a UDP-based "minimal subtransport" encapsulation approach for middlebox cooperation. The point of doing the initial work on this in a smaller subcommittee is largely to make sure we get a coherent initial proposal, which can be discussed both within the whole program as well as with the community on the [email-masked] list.

After our last call, I'd like to propose the following arrangement moving forward:

(1) The requirements document will be a product of the IP Stack Evolution program. For now, it is not clear whether we'd want this to eventually be published as an IAB stream RFC or an IETF stream RFC as a product of an eventual (and by "eventual" I mean "not before 2016") WG, but we'd like to keep working on it as an I-D.

(2) Discussion of the requirements document will happen on [email-masked] until -00 is published, after which discussion will move to [email-masked]. Editorial control will remain with the smaller group, especially until we get a first coherent document at which arrows can be thrown.

(3) To fix the problem of having what is in effect a subcommittee of the Program which is not a subset of the Program, I'd like to propose adding Eric Rescorla and Ken Calvert as new members.

Thanks, cheers,

Brian

---

From: Aaron Falk <[email-masked]>
Date: Wed, 20 May 2015 09:40:02 -0400

Thanks for the update, Brian.  I think adding Ken and Eric is a great
idea.  Looking forward to seeing what you guys are cooking up.

--aaron

On Wed, May 20, 2015 at 5:21 AM, Brian Trammell <[email-masked]> wrote:

> Greetings, all,
>
> As discussed briefly during the retreat in London, in moving forward after
> the SPUD BoF, we've had a couple of calls of a subset of the program
> (myself, Mirja, Joe, Ted, Jana, and David Black) along with two external
> participants (Eric Rescorla and Ken Calvert) who have an interest in the
> SPUD work at the architecture level. We've been referring to this
> internally as a "SPUD design team", the intention of which is to produce a
> set of requirements which could be the input to an effort to standardize a
> UDP-based "minimal subtransport" encapsulation approach for middlebox
> cooperation. The point of doing the initial work on this in a smaller
> subcommittee is largely to make sure we get a coherent initial proposal,
> which can be discussed both within the whole program as well as with the
> community on the [email-masked] list.
>
> (1) The requirements document will be a product of the IP Stack Evolution
> program. For now, it is not clear whether we'd want this to eventually be
> published as an IAB stream RFC or an IETF stream RFC as a product of an
> eventual (and by "eventual" I mean "not before 2016") WG, but we'd like to
> keep working on it as an I-D.
>
> (2) Discussion of the requirements document will happen on
> [email-masked] until -00 is published, after which discussion will move
> to [email-masked]. Editorial control will remain with the smaller group,
> especially until we get a first coherent document at which arrows can be
> thrown.
>
> (3) To fix the problem of having what is in effect a subcommittee of the
> Program which is not a subset of the Program, I'd like to propose adding
> Eric Rescorla and Ken Calvert as new members.
>
> Thanks, cheers,
>
> Brian
>
>
> _______________________________________________
> Stackevo mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/stackevo
>
>