Subject: [Stackevo] Second IAB Workshop on Stack Evolution in a Middlebox Internet

From: Brian Trammell <[email-masked]>
Date: Wed, 11 Nov 2015 08:20:28 +0100

Greetings, all,

As briefly discussed during the Thursday IAB meeting in Yokohama, we (Mirja and I) as general chairs of the IAB SEMI Workshop in Zurich last January would like to organize a second edition of the workshop colocated with SIGCOMM 2016 in Salvador, Brazil, in August 2016. The deadline for workshop proposals is 23 November; we'll need a complete CFP as well as a list of candidate TPC members by then.

Below is the motivation text from the proposal; the topic areas will be broadly the same as those for the first SEMI workshop. We're splitting the workshop into two tracks, academic (standard sigcomm six pages, come give a talk and answer a couple of questions) and industrial (two page position papers, lightning talks followed by discussion, more like the first SEMI workshop and RAIM).

If you'd like to serve on the TPC, please let me know. Our aim is that each TPC member will have to do two to three reviews.

Thanks, cheers,

Brian

The Internet’s transport layer has ossified, squeezed between narrow interfaces and increasing in-network modification of traffic by middleboxes that make assumptions about the protocols running through them. This ossification makes it difficult to innovate in the transport layer, through the deployment of new protocols or the extension of existing ones. At the same time, emerging applications require functionality that existing protocols can provide only inefficiently, if at all. The acceleration of deployment of encryption in the Internet shows promise in breaking this logjam, replacing it with another: while encryption can be used to protect new transport protocols from meddling, it also breaks in-network functionality that can be crucial for network management and performance. A more balanced approach is therefore necessary.

In January 2015, The Internet Architecture Board (IAB) together with the Internet Society and Communication Systems Group at ETH Zurich, organized a workshop to discuss this tussle. This successful workshop (documented in RFC 7663) led to ongoing work on middlebox measurement within the Internet Research Task Force (IRTF) — developing a more quantitative understanding of the extent of transport layer ossification — as well as work within the IAB’s IP Stack Evolution Program to develop an architecture to replace traffic classification and hard-coded assumptions about application and transport semantics with explicit cooperation between endpoints and middleboxes in the Internet.

This second edition of the Workshop on Stack Evolution in an Middlebox Internet (SEMI) will focus on research into approaches to support this explicit cooperation, soliciting early-stage work addressing transport layer evolution, signaling across layers in the Internet protocol stack, driving the incremental deployment of new protocols in the Internet, and related topics. Through colocation at SIGCOMM, this second edition will also serve to build bridges between research and industrial communities on this topic, with both a research track (six page research papers) and an industrial track (two-page position papers or problem statements).

---

From: Natasha Rooney <[email-masked]>
Date: Wed, 11 Nov 2015 07:32:57 +0000

Hey!

> As briefly discussed during the Thursday IAB meeting in Yokohama, we (Mirja and I) as general chairs of the IAB SEMI Workshop in Zurich last January would like to organize a second edition of the workshop colocated with SIGCOMM 2016 in Salvador, Brazil, in August 2016.

You’re in Europe so it’s pointless me saying it - but we do see some "Yay it’s August let’s take a month off!" here, but everyone is on holiday at some point…. so, I guess they can put up with it.

> If you'd like to serve on the TPC, please let me know. Our aim is that each TPC member will have to do two to three reviews.

I volunteer!

> This second edition of the Workshop on Stack Evolution in an Middlebox Internet (SEMI) will focus on research into approaches to support this explicit cooperation, soliciting early-stage work addressing transport layer evolution,[*] signaling across layers in the Internet protocol stack, driving the incremental deployment of new protocols in the Internet, and related topics. Through colocation at SIGCOMM, this second edition will also serve to build bridges between research and industrial communities on this topic, with both a research track (six page research papers) and an industrial track (two-page position papers or problem statements).
>

Sounds great! I was wondering whether to add something on "across network types" at [*] but not sure it needs it. Thanks for this Brian!

Natasha
This email and its attachments are intended for the above named only and may be confidential. If they have come to you in error you must take no action based on them, nor must you copy or show them to anyone; please reply to this email or call +44 207 356 0600 and highlight the error.

---

From: Michael Welzl <[email-masked]>
Date: Wed, 11 Nov 2015 10:02:31 +0100

> On 11 Nov 2015, at 08:32, Natasha Rooney <[email-masked]> wrote:
> 
> Hey!
> 

Me too

>> This second edition of the Workshop on Stack Evolution in an Middlebox Internet (SEMI) will focus on research into approaches to support this explicit cooperation, soliciting early-stage work addr…

+1 on that this is a great initiative!  Good luck with it

Cheers,
Michael

> _______________________________________________
> Stackevo mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/stackevo

---

From: Aaron Falk <[email-masked]>
Date: Wed, 11 Nov 2015 13:48:16 -0500

Count me in.  (When Mirja approached me in Japan I didn't realize it was in
August.)

---aaron

On Wed, Nov 11, 2015 at 4:02 AM, Michael Welzl <[email-masked]> wrote:

> >> As briefly discussed during the Thursday IAB meeting in Yokohama, we
> (Mirja and I) as general chairs of the IAB SEMI Workshop in Zurich last
> January would like to organize a second edition of the workshop colocated
> with SIGCOMM 2016 in Salvador, Brazil, in August 2016.
> >
> > You’re in Europe so it’s pointless me saying it - but we do see some
> "Yay it’s August let’s take a month off!" here, but everyone is on holiday
> at some point…. so, I guess they can put up with it.
> >
> >> If you'd like to serve on the TPC, please let me know. Our aim is that
> each TPC member will have to do two to three reviews.
> >
> > I volunteer!
>
> Me too
>
>
> >> The Internet’s transport layer has ossified, squeezed between narrow
> interfaces and increasing in-network modification of traffic by middleboxes
> that make assumptions about the protocols running through them. This
> ossification makes it difficult to innovate in the transport layer, through
> the deployment of new protocols or the extension of existing ones. At the
> same time, emerging applications require functionality that existing
> protocols can provide only inefficiently, if at all. The acceleration of
> deployment of encryption in the Internet shows promise in breaking this
> logjam, replacing it with another: while encryption can be used to protect
> new transport protocols from meddling, it also breaks in-network
> functionality that can be crucial for network management and performance. A
> more balanced approach is therefore necessary.
> >>
> >> In January 2015, The Internet Architecture Board (IAB) together with
> the Internet Society and Communication Systems Group at ETH Zurich,
> organized a workshop to discuss this tussle. This successful workshop
> (documented in RFC 7663) led to ongoing work on middlebox measurement
> within the Internet Research Task Force (IRTF) — developing a more
> quantitative understanding of the extent of transport layer ossification —
> as well as work within the IAB’s IP Stack Evolution Program to develop an
> architecture to replace traffic classification and hard-coded assumptions
> about application and transport semantics with explicit cooperation between
> endpoints and middleboxes in the Internet.
> >>
> >> This second edition of the Workshop on Stack Evolution in an Middlebox
> Internet (SEMI) will focus on research into approaches to support this
> explicit cooperation, soliciting early-stage work addressing transport
> layer evolution,[*] signaling across layers in the Internet protocol stack,
> driving the incremental deployment of new protocols in the Internet, and
> related topics. Through colocation at SIGCOMM, this second edition will
> also serve to build bridges between research and industrial communities on
> this topic, with both a research track (six page research papers) and an
> industrial track (two-page position papers or problem statements).
> >>
>
> > Sounds great! I was wondering whether to add something on "across
> network types" at [*] but not sure it needs it. Thanks for this Brian!
> >
> > Natasha
> > This email and its attachments are intended for the above named only and
> may be confidential. If they have come to you in error you must take no
> action based on them, nor must you copy or show them to anyone; please
> reply to this email or call +44 207 356 0600 and highlight the error.

---

From: Brian Trammell <[email-masked]>
Date: Thu, 12 Nov 2015 09:13:13 +0100

> You’re in Europe so it’s pointless me saying it - but we do see some "Yay it’s August let’s take a month off!" here, but everyone is on holiday at some point…. so, I guess they can put up with it.

The traditional date of the SIGCOMM conference is certainly correlated with the relatively low participation from Europe-based researchers...

> Sounds great! I was wondering whether to add something on "across network types" at [*] but not sure it needs it. Thanks for this Brian!

Thanks, good point, added.

I've also got in the topics "Approaches for transport evolution optimized for mobile and wireless access networks" and "Network management techniques that function in the presence of ubiquitous encryption"...

I'll post the workshop proposal to the stackevo list for review shortly...

Cheers,

Brian

---

From: Brian Trammell <[email-masked]>
Date: Thu, 12 Nov 2015 09:28:24 +0100

Greetings, all,

The workshop proposal is now essentially complete and available for comment in Google Docs:

https://docs.google.com/document/d/1t-4ZhQ_YTdN9zCnZUartqxZuaiGzdkSifhmL9X-t_f8/edit?usp=sharing

Please raise any comments you place in the document on the list for discussion. Deadline is Monday 23 but planning on submitting Thursday 19 evening CET...

Cheers,

Brian

> On 11 Nov 2015, at 08:20, Brian Trammell <[email-masked]> wrote:
> 
> Greetings, all,
>

---

From: Eliot Lear <[email-masked]>
Date: Thu, 12 Nov 2015 09:46:55 +0100

And me.  But I may not attend.

Eliot

On 11/11/15 7:48 PM, Aaron Falk wrote:
> Count me in.  (When Mirja approached me in Japan I didn't realize it
> was in August.)
>
> ---aaron
>
> On Wed, Nov 11, 2015 at 4:02 AM, Michael Welzl <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>
>     > On 11 Nov 2015, at 08:32, Natasha Rooney <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     >
>     > Hey!
>     >
>     >> As briefly discussed during the Thursday IAB meeting in
>     Yokohama, we (Mirja and I) as general chairs of the IAB SEMI
>     Workshop in Zurich last January would like to organize a second
>     edition of the workshop colocated with SIGCOMM 2016 in Salvador,
>     Brazil, in August 2016.
>     >
>     > You’re in Europe so it’s pointless me saying it - but we do see
>     some "Yay it’s August let’s take a month off!" here, but everyone
>     is on holiday at some point…. so, I guess they can put up with it.
>     >
>     >> If you'd like to serve on the TPC, please let me know. Our aim
>     is that each TPC member will have to do two to three reviews.
>     >
>     > I volunteer!
>
>     Me too
>
>
>     >> The Internet’s transport layer has ossified, squeezed between
>     narrow interfaces and increasing in-network modification of
>     traffic by middleboxes that make assumptions about the protocols
>     running through them. This ossification makes it difficult to
>     innovate in the transport layer, through the deployment of new
>     protocols or the extension of existing ones. At the same time,
>     emerging applications require functionality that existing
>     protocols can provide only inefficiently, if at all. The
>     acceleration of deployment of encryption in the Internet shows
>     promise in breaking this logjam, replacing it with another: while
>     encryption can be used to protect new transport protocols from
>     meddling, it also breaks in-network functionality that can be
>     crucial for network management and performance. A more balanced
>     approach is therefore necessary.
>     >>
>     >> In January 2015, The Internet Architecture Board (IAB) together
>     with the Internet Society and Communication Systems Group at ETH
>     Zurich, organized a workshop to discuss this tussle. This
>     successful workshop (documented in RFC 7663) led to ongoing work
>     on middlebox measurement within the Internet Research Task Force
>     (IRTF) — developing a more quantitative understanding of the
>     extent of transport layer ossification — as well as work within
>     the IAB’s IP Stack Evolution Program to develop an architecture to
>     replace traffic classification and hard-coded assumptions about
>     application and transport semantics with explicit cooperation
>     between endpoints and middleboxes in the Internet.
>     >>
>     >> This second edition of the Workshop on Stack Evolution in an
>     Middlebox Internet (SEMI) will focus on research into approaches
>     to support this explicit cooperation, soliciting early-stage work
>     addressing transport layer evolution,[*] signaling across layers
>     in the Internet protocol stack, driving the incremental deployment
>     of new protocols in the Internet, and related topics. Through
>     colocation at SIGCOMM, this second edition will also serve to
>     build bridges between research and industrial communities on this
>     topic, with both a research track (six page research papers) and
>     an industrial track (two-page position papers or problem statements).
>     >>
>
>     > Sounds great! I was wondering whether to add something on
>     "across network types" at [*] but not sure it needs it. Thanks for
>     this Brian!
>     >
>     > Natasha
>     > This email and its attachments are intended for the above named
>     only and may be confidential. If they have come to you in error
>     you must take no action based on them, nor must you copy or show
>     them to anyone; please reply to this email or call +44 207 356
>     0600 <tel:%2B44%20207%20356%200600> and highlight the error.
>     > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: "Black, David" <[email-masked]>
Date: Fri, 13 Nov 2015 02:57:55 +0000

I've put a bunch of editorial suggestions and comments in the Google Doc.

The only one that has any technical content is that I wonder why this bullet
is in the scope of the workshop:

o Traffic management techniques that function in the presence of ubiquitous encryption

What does traffic management have to do with Transport protocols?

Thanks,
--David

> -----Original Message-----
> From: Stackevo [mailto:[email-masked]] On Behalf Of Brian Trammell
> Sent: Thursday, November 12, 2015 3:28 AM
> To: Brian Trammell
> Cc: Stackevo
> Subject: Re: [Stackevo] Second IAB Workshop on Stack Evolution in a Middlebox
> Internet
> 
> Greetings, all,
> 
> Please raise any comments you place in the document on the list for
> discussion. Deadline is Monday 23 but planning on submitting Thursday 19
> evening CET...
> 
> Cheers,
> 
> Brian
> 
> 
> > As briefly discussed during the Thursday IAB meeting in Yokohama, we (Mirja
> and I) as general chairs of the IAB SEMI Workshop in Zurich last January would
> like to organize a second edition of the workshop colocated with SIGCOMM 2016
> in Salvador, Brazil, in August 2016. The deadline for workshop proposals is 23
> November; we'll need a complete CFP as well as a list of candidate TPC members
> by then.
> >
> > Below is the motivation text from the proposal; the topic areas will be
> broadly the same as those for the first SEMI workshop. We're splitting the
> workshop into two tracks, academic (standard sigcomm six pages, come give a
> talk and answer a couple of questions) and industrial (two page position
> papers, lightning talks followed by discussion, more like the first SEMI
> workshop and RAIM).
> >
> > If you'd like to serve on the TPC, please let me know. Our aim is that each
> TPC member will have to do two to three reviews.
> >
> > Thanks, cheers,
> >
> > Brian
> >
> >
> >
> the deployment of new protocols or the extension of existing ones. At the same
> time, emerging applications require functionality that existing protocols can
> provide only inefficiently, if at all. The acceleration of deployment of
> encryption in the Internet shows promise in breaking this logjam, replacing it
> with another: while encryption can be used to protect new transport protocols
> from meddling, it also breaks in-network functionality that can be crucial for
> network management and performance. A more balanced approach is therefore
> necessary.
> >
> > In January 2015, The Internet Architecture Board (IAB) together with the
> Internet Society and Communication Systems Group at ETH Zurich, organized a
> workshop to discuss this tussle. This successful workshop (documented in RFC
> 7663) led to ongoing work on middlebox measurement within the Internet
> Research Task Force (IRTF) — developing a more quantitative understanding of
> the extent of transport layer ossification — as well as work within the IAB’s
> IP Stack Evolution Program to develop an architecture to replace traffic
> classification and hard-coded assumptions about application and transport
> semantics with explicit cooperation between endpoints and middleboxes in the
> Internet.
> >
> explicit cooperation, soliciting early-stage work addressing transport layer
> evolution, signaling across layers in the Internet protocol stack, driving the
> incremental deployment of new protocols in the Internet, and related topics.
> Through colocation at SIGCOMM, this second edition will also serve to build
> bridges between research and industrial communities on this topic, with both a
> research track (six page research papers) and an industrial track (two-page
> position papers or problem statements).
> >
> >
> >

---

From: Brian Trammell <[email-masked]>
Date: Fri, 13 Nov 2015 14:56:18 +0100

> On 13 Nov 2015, at 03:57, Black, David <[email-masked]> wrote:
> 

Thanks! Will have a look shortly...

> What does traffic management have to do with Transport protocols?

In the brave new explicitly cooperative world (that we may never get to) there will need to be some interaction between the application/transport layer and traffic management primitives at the network and link layer to replace all the DPI ubiquitous encryption will make useless. I'm not super happy with how this one bullet is phrased, though, so suggestions are welcome...

Cheers,

Brian

---

From: Eliot Lear <[email-masked]>
Date: Fri, 13 Nov 2015 16:11:25 +0100

Hi David and friends,

Is there any chance to simplify the bureaucratese about " This proposal
has been discussed with the Internet Architecture Board, which supports
holding the is willing for the second edition of this IAB workshop to be
held in conjunction..."?  How about...

"The Internet Architecture Board proposes to hold this workshop in
conjunction..."

Does the IAB in fact propose this?

Eliot

---

From: "Black, David" <[email-masked]>
Date: Fri, 13 Nov 2015 19:38:42 +0000

> In the brave new explicitly cooperative world (that we may never get to) there
> will need to be some interaction between the application/transport layer and
> traffic management primitives at the network and link layer to replace all the
> DPI ubiquitous encryption will make useless. I'm not super happy with how this
> one bullet is phrased, though, so suggestions are welcome...

Traffic classification approaches for encrypted traffic (including cooperative
approaches based on exposing specific transport and application protocol information
to networks).

My concern is that "traffic management" feels like it's in OPS space, not TSV, and
invites submissions on completely unrelated things like OAM for encrypted traffic.

Thanks,
--David

> From: Brian Trammell [mailto:[email-masked]]
> Sent: Friday, November 13, 2015 8:56 AM
> To: Black, David
> Cc: Stackevo
> In the brave new explicitly cooperative world (that we may never get to) there
> will need to be some interaction between the application/transport layer and
> traffic management primitives at the network and link layer to replace all the
> DPI ubiquitous encryption will make useless. I'm not super happy with how this
> one bullet is phrased, though, so suggestions are welcome...
> 
> Cheers,
> 
> Brian
> 
> > Thanks,
> > --David
> >
> >
> >> The workshop proposal is now essentially complete and available for comment
> in
> >> Google Docs:
> >>
> (Mirja
> each
> same
> layer

---

From: Brian Trammell <[email-masked]>
Date: Mon, 16 Nov 2015 17:02:09 +0200

> On 13 Nov 2015, at 21:38, Black, David <[email-masked]> wrote:
> 

Yep, this is much closer to what I meant here. Thanks!

Cheers,

Brian

---

From: Brian Trammell <[email-masked]>
Date: Mon, 16 Nov 2015 17:02:49 +0200

> On 13 Nov 2015, at 17:11, Eliot Lear <[email-masked]> wrote:
> 
> Hi David and friends,
> 
> Is there any chance to simplify the bureaucratese about " This proposal has been discussed with the Internet Architecture Board, which supports holding the is willing for the second edition of this IAB workshop to be held in conjunction..."?  How about...
> 
> "The Internet Architecture Board proposes to hold this workshop in conjunction..."
> 

Hm. Yes, this is (1) the case and (2) a better way to put this.

Thanks, cheers,

Brian

>>> From: Stackevo [
>>> mailto:[email-masked]
>>> ] On Behalf Of Brian Trammell
>>> https://docs.google.com/document/d/1t-4ZhQ_YTdN9zCnZUartqxZuaiGzdkSifhmL9X
>>> -
>>> t_f8/edit?usp=sharing
>>>

---

From: Ted Hardie <[email-masked]>
Date: Mon, 16 Nov 2015 10:21:58 -0800

Friendly amendment:

> > approaches based on exposing specific transport and application protocol
"​Traffic classification approaches for encrypted traffic, including
cooperative approaches based on exposing specific transport or application
requirements to the network.​"

(Rationale: We're trying to shift from exposing information about the
application to exposing what's needed instead)

​Ted​

> >>> o Traffic management techniques that function in the presence of
> ubiquitous
> >> encryption
> >>>
> >>>> and I) as general chairs of the IAB SEMI Workshop in Zurich last
> January
> >> would
> >>>> like to organize a second edition of the workshop colocated with
> SIGCOMM
> >> 2016
> >>>> in Salvador, Brazil, in August 2016. The deadline for workshop
> proposals is
> >> 23
> >>>> time, emerging applications require functionality that existing
> protocols
> >> can
> >>>> encryption in the Internet shows promise in breaking this logjam,
> replacing
> >> it
> >>>> from meddling, it also breaks in-network functionality that can be
> crucial
> >> for
> the
> >>>> workshop to discuss this tussle. This successful workshop (documented
> in
> >> RFC
> >>>> Research Task Force (IRTF) — developing a more quantitative
> understanding
> >> of
> >>>> the extent of transport layer ossification — as well as work within
> the
> >> IAB’s
> >>>> semantics with explicit cooperation between endpoints and middleboxes
> in
> >> the
> >>>> Internet.
> >>>>>
> Middlebox
> >>>> evolution, signaling across layers in the Internet protocol stack,
> driving
> >> the
> >>>> bridges between research and industrial communities on this topic,
> with
> >> both a

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 16 Nov 2015 14:25:35 -0600

> application to exposing what's needed instead)

Agreed, and we're going to have to keep hitting ourselves in the head with
a hammer to remind ourselves of that. We've been doing it the other way for
a very long time.

>> >>>> November; we'll need a complete CFP as well as a list of candidate
>> TPC
>> >> members
>> >>>> by then.
>> >>>>>
>> with the
>> >>>> workshop to discuss this tussle. This successful workshop
>> (documented in
>> >> RFC
>> >>>> semantics with explicit cooperation between endpoints and
>> middleboxes in
>> >> the
>> >>>> Internet.
>> >>>>>

---

From: Eliot Lear <[email-masked]>
Date: Mon, 16 Nov 2015 22:35:46 +0100

I'd make one further amendment.  It could be that the information flows
in the other direction, so...

On 11/16/15 9:25 PM, Spencer Dawkins at IETF wrote:
>
>
> On Mon, Nov 16, 2015 at 12:21 PM, Ted Hardie <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Friendly amendment:
>
>
>     On Mon, Nov 16, 2015 at 7:02 AM, Brian Trammell
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>
>     " ​Traffic classification approaches for encrypted traffic,
>     including cooperative approaches based on exposing specific
>     transport or application requirements to the network.​"
>

Traffic classification approaches for encrypted traffic, including
cooperative approaches based on exposing specific transport or
application requirements to the network or network information to the
application.

Eliot

---

From: Brian Trammell <[email-masked]>
Date: Tue, 17 Nov 2015 15:26:20 +0200

hi Eliot,

Yep, applied...

Many thanks, all, for the comments... if I don't hear any other comments here in the next 24h, I'll go ahead and submit the workshop proposal.

Cheers,

Brian

> On 16 Nov 2015, at 23:35, Eliot Lear <[email-masked]> wrote:
> 
> I'd make one further amendment.  It could be that the information flows in the other direction, so...
> 
>> On Mon, Nov 16, 2015 at 7:02 AM, Brian Trammell <[email-masked]> wrote:
>> 
>> " ​Traffic classification approaches for encrypted traffic, including cooperative approaches based on exposing specific transport or application requirements to the network.​"
> 
> Traffic classification approaches for encrypted traffic, including cooperative approaches based on exposing specific transport or application requirements to the network or network information to the application.
> 
> Eliot
>