Subject: [Stackevo] Scope of stackevo and ossification in DC

From: Tom Herbert <[email-masked]>
Date: Mon, 16 Nov 2015 21:56:35 -0800

Hello,

Similar to the use of protocols on the Internet we are hitting the
transport protocol ossification problem in the data center.
Specifically, performance optimizations in networking devices only
support TCP or UDP, and without these optimizations this negatively
impacts our use of other protocols. One example of this is the need
for fine grained ECMP which has become driver behind many of the
foo-over-UDP proposals (e.g. MPLS/UDP, GRE/UDP, ...).

This problem is likely a proper subset of the general problem, but
might be more amenable to some "simpler" solutions. Is this within
scope of stackevo?

Thanks,
Tom

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 17 Nov 2015 11:17:23 -0600

As a non-IAB program member, I offer this possible answer ...

> might be more amenable to some "simpler" solutions. Is this within

Please say "yes".

Given MaRNEW, the more often we have people from different communities
talking about "the network" at the same time in the same place, the better.

We're already having some conversations about how much LTE-specific
optimization to do in TCP. I got into the IETF when there was a TCPSAT
working group, and I came to propose a "TCP over cellular" working group,
but that got generalized into PILC, which was the Right Thing To Do.

Having people who say, "but we're not running LTE, at least at one end of
our connections" involved in the conversation will be helpful.

Spencer, as TSV AD

---

From: Eliot Lear <[email-masked]>
Date: Wed, 18 Nov 2015 14:20:31 +0100

Hi,

On 11/17/15 6:17 PM, Spencer Dawkins at IETF wrote:
> On Mon, Nov 16, 2015 at 11:56 PM, Tom Herbert <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Hello,
>

+1000.

> working group, and I came to propose a "TCP over cellular" working
> group, but that got generalized into PILC, which was the Right Thing
> To Do.

YES.
>
> Having people who say, "but we're not running LTE, at least at one end
> of our connections" involved in the conversation will be helpful.
>
YES.

---

From: Natasha Rooney <[email-masked]>
Date: Fri, 27 Nov 2015 09:46:42 +0000

Quick note to say I can help here if needs be. Getting LTE people to talk seems to be my specialty, although I cannot guarantee the quality of their comments!

Natasha

Natasha Rooney | Technologist, Web and Internet, W3C & IETF | GSMA | [email-masked]<mailto:[email-masked]> | +44 (0) 7730 219 765 | @thisNatasha | Skype: [email-masked]<mailto:[email-masked]>
Tokyo, Japan

On Nov 18, 2015, at 10:20 PM, Eliot Lear <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

On Mon, Nov 16, 2015 at 11:56 PM, Tom Herbert <[email-masked]<mailto:[email-masked]>> wrote:
Hello,

Please say "yes".

Given MaRNEW, the more often we have people from different communities talking about "the network" at the same time in the same place, the better.

+1000.

We're already having some conversations about how much LTE-specific optimization to do in TCP. I got into the IETF when there was a TCPSAT working group, and I came to propose a "TCP over cellular" working group, but that got generalized into PILC, which was the Right Thing To Do.

YES.

Having people who say, "but we're not running LTE, at least at one end of our connections" involved in the conversation will be helpful.

YES.
_______________________________________________
Stackevo mailing list
[email-masked]<mailto:[email-masked]>
https://www.iab.org/mailman/listinfo/stackevo

This email and its attachments are intended for the above named only and may be confidential. If they have come to you in error you must take no action based on them, nor must you copy or show them to anyone; please reply to this email or call +44 207 356 0600 and highlight the error.